]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm.macros
- don't omit ldconfig in postun on upgrades - it's needed on downgrades and maybe...
[packages/rpm-build-macros.git] / rpm.macros
index 352d041c9a7cc90a6435e9b9903925a462189728..ff50d047ccdec0783a8b0e949ec54577fe8f8015 100644 (file)
@@ -21,7 +21,8 @@
 %debugcflags   -O0 -g -Wall
 %rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
 %rpmcxxflags   %{rpmcflags} -fvisibility-inlines-hidden
-%rpmldflags    %{nil}
+%rpmldflags %{nil}
+# %rpmldflags  -Wl,--as-needed
 
 # kernel compiler
 %kgcc          gcc
 
 # Build system path macros.
 #
-%__libtoolize           libtoolize --copy --force
+%__autoconf                    autoconf %{?debug:-Wall}
+%__automake                    automake -a -c -f --foreign
+%__autopoint           autopoint --force
+
 %__gettextize { \
     if ! gettextize --version | grep -q '0\.10\.' ; then \
        if grep -qs 'AM_GNU_GETTEXT.*external' configure.{ac,in} ; then \
        gettextize --copy --force; \
     fi; \
 }
-%__autopoint            autopoint --force
-%__automake             automake -a -c -f --foreign
-%__autoconf             autoconf %{?debug:-Wall}
+
+%__glib_gettextize     glib-gettextize --copy --force
+%__gnome_doc_common    gnome-doc-common --copy
+%__gtkdocize           gtkdocize --copy
+%__intltoolize         intltoolize --copy --force
+%__libtoolize          libtoolize --copy --force
 
 %dependencytracking    %{nil}
 #-----------------------------------------------------------------
 LANG=C\
 export LANG\
 unset DISPLAY ||:\
+unset LINGUAS ||:\
 %{nil}
 
 %build %%build\
 LANG=C\
 export LANG\
 unset DISPLAY ||:\
+unset LINGUAS ||:\
 %{nil}
 
 %install %{?_enable_debug_packages:%{?buildsubdir:%{debug_package}}}\
@@ -125,6 +134,7 @@ unset DISPLAY ||:\
 LANG=C\
 export LANG\
 unset DISPLAY ||:\
+unset LINGUAS ||:\
 %{nil}
 
 # ------------------------------------------------------------------------
@@ -179,11 +189,9 @@ unset DISPLAY ||:\
 # Location of pkgconfig files
 %_pkgconfigdir /usr/%{_lib}/pkgconfig
 
-# Location of top applink dir
-%_applnkdir    /usr/X11R6/share/applnk
-
 # Location of desktop files
 %_desktopdir   /usr/share/applications
+%_applnkdir    ERROR:_applnkdir_is_obsolete_use_desktopdir_instead
 
 # Location of pixmaps for applnk/desktop files
 %_pixmapsdir   /usr/share/pixmaps
@@ -231,19 +239,19 @@ unset DISPLAY ||:\
 %apache_modules_api %(awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' /usr/include/apache/ap_mmn.h 2>/dev/null || echo ERROR)
 
 # kernel version-release handling
-%__kernel_ver   %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | head -n 1 | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } /^EXTRAVERSION/ { ever = $0; gsub(/EXTRAVERSION.*=/, NIL, ever); gsub(/ /, NIL, ever); } END { printf("%d.%d.%d%s", ver, plev, slev, ever); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
+%__kernel_ver    %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | head -n 1 | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } /^EXTRAVERSION/ { ever = $0; gsub(/EXTRAVERSION.*=/, NIL, ever); gsub(/ /, NIL, ever); } END { printf("%d.%d.%d%s", ver, plev, slev, ever); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
 %__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h --queryformat "%{RELEASE}" | grep -v "is not")
 %__kernel_rpmvr  %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h --queryformat "%{VERSION}-%{RELEASE}" | grep -v "is not")
 %_kernel_ver     %{__kernel_ver}%{?with_dist_kernel:%(echo %{__kernel_ver} | grep -q -e - || echo -%{__kernel_rel})}
-%_kernel_ver_str %(echo %{!?_without_dist_kernel:%{__kernel_rpmvr}}%{?_without_dist_kernel:%{__kernel_ver}} | sed -e 's/-/_/')
+%_kernel_ver_str %(echo %{!?_without_dist_kernel:%{__kernel_rpmvr}}%{?_without_dist_kernel:%{__kernel_ver}} | sed -e 's/-/_/g')
 
 # sgml macros
-%xmlcat_add()            /usr/bin/xmlcatalog --noout --add nextCatalog \"\" %1 /etc/xml/catalog
-%xmlcat_del()            /usr/bin/xmlcatalog --noout --del %1 /etc/xml/catalog
+%xmlcat_add()            /usr/bin/xmlcatalog --noout --add nextCatalog \"\" %1 /etc/xml/catalog ;
+%xmlcat_del()            /usr/bin/xmlcatalog --noout --del %1 /etc/xml/catalog ;
 %xmlcat_add_rewrite      /usr/bin/xmlcatalog --noout --add rewriteSystem
-%xmlcat_create()          /usr/bin/xmlcatalog --noout --create %1
-%sgmlcat_add()           /usr/bin/install-catalog --add %1 %2 > /dev/null
-%sgmlcat_del()           /usr/bin/install-catalog --remove %1 %2 > /dev/null
+%xmlcat_create()          /usr/bin/xmlcatalog --noout --create %1 ;
+%sgmlcat_add()           /usr/bin/install-catalog --add %1 %2 > /dev/null ;
+%sgmlcat_del()           /usr/bin/install-catalog --remove %1 %2 > /dev/null ;
 %docbook_sgmlcat_fix() { for l in \
 '' \
 '  -- default decl --' \
@@ -314,7 +322,7 @@ unset DISPLAY ||:\
        %{?verbose:set -x;} \
 if [ -d "$RPM_BUILD_ROOT" ]; then \
 echo "Remove RPATH from executable binaries and shared object files."; \
-find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautochrpath:! -regex "%{_noautochrpath}"} | xargs -r file | \
+find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" ! -regex ".*/usr/lib[0-9]*/debug/.*" %{?_noautochrpath:! -regex "%{_noautochrpath}"} | xargs -r file | \
        awk '/ELF.*(executable.*dynamically linked|shared object)/ {print $1}' | cut -d: -f1 | \
 while read file ; do \
        rpath= ; \
@@ -360,15 +368,62 @@ echo "Compress kernel modules if any."; \
 %_binary_payload        w9.bzdio
 
 #-----------------------------------------------------------------
-# Update all GConf2 schemas
+# Update GConf2 schemas
 #
 # Requires: GConf2
 #
-%gconf_schema_install { umask 022; \
-    GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" \
-    /usr/bin/gconftool-2 --makefile-install-rule \
-    /etc/gconf/schemas/*.schemas > /dev/null \
-}
+%gconf_schema_install() \
+    umask 022; \
+    GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/%{?1}%{!?1:*.schemas} > /dev/null \
+    %{nil}
+
+%gconf_schema_uninstall() \
+if [ $1 = 0 ]; then \
+    umask 022; \
+    GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/%{?1} > /dev/null \
+fi \
+%{nil}
+
+#-----------------------------------------------------------------
+# Update desktop MIME database
+# requries: desktop-file-utils
+#
+%update_desktop_database_post() \
+       umask 022; \
+       /usr/bin/update-desktop-database; \
+       %{nil}
+
+%update_desktop_database_postun() \
+if [ $1 = 0 ]; then \
+       umask 022; \
+       /usr/bin/update-desktop-database; \
+fi \
+%{nil}
+
+#-----------------------------------------------------------------
+# Update scrollkeeper database
+# requires: scrollkeeper
+#
+%scrollkeeper_update_post() \
+       /usr/bin/scrollkeeper-update -q; \
+       %{nil}
+
+%scrollkeeper_update_postun() \
+if [ $1 = 0 ]; then \
+       /usr/bin/scrollkeeper-update -q; \
+fi \
+%{nil}
+
+#-----------------------------------------------------------------
+# Run ldconfig after installing/deinstalling libraries
+#
+%ldconfig_post() \
+       /sbin/ldconfig; \
+       %{nil}
+
+%ldconfig_postun() \
+       /sbin/ldconfig; \
+       %{nil}
 
 #-----------------------------------------------------------------
 # post %install sequence:
@@ -429,11 +484,32 @@ echo "Compress kernel modules if any."; \
 %py_ocomp       python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
 
 # Software written in Python language require Python with main version
-# unchanged
-%pyrequires_eq() Requires:       %1 >= 1:%py_ver %1 < 1:%(echo `python -c "import sys; import string; ver=sys.version[:3].split('.'); ver[1]=str(int(ver[1])+1); print string.join(ver, '.')"`)
+%pyrequires_eq() Requires:     %1
+
+
+# Hardlink binary identical .pyc and .pyo files
+# (idea by glen <at> pld-linux <dot> org)
+%__spec_install_post_py_hardlink {\
+%{!?no_install_post_py_hardlink: \
+[ ! -d "$RPM_BUILD_ROOT" ] || find "$RPM_BUILD_ROOT" -name '*.pyc' | while read a; do \
+       b="$(echo $a|sed -e 's/.pyc$/.pyo/')"; \
+       if cmp -s "$a" "$b"; then \
+               ln -f "$a" "$b"; \
+       fi; \
+done \
+} }
+
+# remove python sources, so that check-files won't complain                                                                
+# (idea by glen <at> pld-linux <dot> org)
+%py_postclean() \
+for d in %{py_sitescriptdir} %{py_sitedir}; do \
+ [ ! -d "$RPM_BUILD_ROOT$d" ] || find "$RPM_BUILD_ROOT$d" -name '*.py' -exec rm {} \; ;\
+done \
+%{nil}
 
 # depmod macro
 %depmod() { \
+umask 022; \
 if [ -e /boot/System.map-%1 ]; then \
         /sbin/depmod -a -F /boot/System.map-%1 %1; \
 else \
@@ -487,15 +563,89 @@ fi; \
 # banner support (useful in {pre,post}{,un} and triggers)
 #
 # Usage:
-#      %banner name [-a] [-n] [-tn]
+#      %banner name [-a] [-e] [-n] [-tn] <<EOF
 # the banner text, the banner text
-# the banner text, and following line HAVE TO BE:
-# EOF
+# the banner text, and following line
+#EOF
+# You can use any form of here-document, <<'EOF' <<-EOT will do.
+# NOTE: if your use "<<-EOF", then You can actually indent inside here-document.
+#
 # -a   - append to the banner
-# -n   - no show banner (overriden by -t)
-# -t   - show only, if RPM_SCRIPTVERBOSITY >= n
-%banner(a:n:t:)        \
-       [ -r /etc/sysconfig/rpm ] && . /etc/sysconfig/rpm || RPM_SCRIPTVERBOSITY=5; \
-       %{_bindir}/banner.sh %{!-t:%{!-n:-s}} %{-t:`[ $RPM_SCRIPTVERBOSITY -ge %{-t*} ] && echo "-s"`} %{!-a:-m}%{-a:-M} %1 << EOF\
+# -e   - send to stderr instead of stdout
+# -n   - no show banner (overrides -t)
+# -t   - show only, if RPM_SCRIPTVERBOSITY >= n; default n=5
+%banner(aent:) \
+RPM_SCRIPTVERBOSITY=5 \
+[ -r /etc/sysconfig/rpm ] && . /etc/sysconfig/rpm \
+if [ -x /usr/bin/banner.sh ]; then \
+       CMD="/usr/bin/banner.sh %{-e:--stderr} %{!-n:$([ $RPM_SCRIPTVERBOSITY -ge %{-t:%{-t*}}%{!-t:5} ] && echo -s)} %{!-a:-m}%{-a:-M} %1" \
+else \
+       CMD="cat%{-e: >&2}" \
+fi \
+$CMD %2%{?3: %3} \
 %nil
 
+# fatal macro. produces recursion and therefore stops rpm build.
+# until there's no legal way of stopping rpmbuild from macros, this is used by
+# %useradd/%groupadd to notify user of wrong usage. glen@pld-linux.org
+%fatal() { %{*} %fatal }
+
+# useradd/groupadd macros written by glen@pld-linux.org.
+# All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
+#
+# Usage:
+#   %useradd [-P package] [-u uid] [-d home_dir] [-s shell] [-c comment]
+#   [-g initial_group] [-G group[,...]] login
+#
+#  -u uid. REQUIRED
+#  -g gid/group. REQUIRED
+#  -s defaults to /bin/false
+#  -d defaults to /usr/share/empty
+#  -c No default
+#  -r is accepted but ignored (it's always set)
+# rpm specific flags
+#  -P package name. defaults to %{name}
+#
+%useradd(c:d:e:f:g:G:Mmk:op:s:u:rP:) \
+%{!-u:%fatal -- useradd: Required argument -u missing} \
+%{!-g:%fatal -- useradd: Required argument -g missing} \
+%{!?1:%fatal -- useradd: Required parameter login missing} \
+if [ -n "`/bin/id -u %{expand:%{%{#}}} 2>/dev/null`" ]; then \
+       if [ "`/bin/id -u %{expand:%{%{#}}}`" != "%{-u*}" ]; then \
+               echo "Error: user %{expand:%{%{#}}} doesn't have uid=%{-u*}. Correct this before installing %{-P*}%{!?-P:%{name}}." 1>&2 \
+               exit 1 \
+       fi \
+else \
+       echo "Adding user %{expand:%{%{#}}} UID=%{-u*}." \
+       /usr/sbin/useradd \\\
+               -u %{-u*} \\\
+               -r \\\
+               -d %{-d*}%{!-d:/usr/share/empty} \\\
+               -s %{-s*}%{!-s:/bin/false} \\\
+               %{-c:-c "%(set -- %{-c*} %{*}; echo $1)"}\\\
+               -g %{-g*} \\\
+               %{-M} \\\
+               %{-G:-G %{-G*}} \\\
+               %{expand:%{%{#}}} 1>&2 \
+fi;
+
+# Usage:
+#   %groupadd [-P package] [-g gid] group
+#
+# -g gid. REQUIRED
+#
+# Sample:
+#   %groupadd -P %{name}-base -g %{gid} %{name}
+
+%groupadd(g:P:rfo)     \
+%{!-g:%fatal -- groupadd: Required argument -g missing} \
+%{!?1:%fatal -- groupadd: Required parameter group missing} \
+if [ -n "`/usr/bin/getgid %{1}`" ]; then \
+       if [ "`/usr/bin/getgid %{1}`" != "%{-g*}" ]; then \
+               echo "Error: group %{1} doesn't have gid=%{-g*}. Correct this before installing %{-P*}%{!?-P:%{name}}." 1>&2 \
+               exit 1 \
+       fi \
+else \
+       echo "Adding group %{1} GID=%{-g*}." \
+       /usr/sbin/groupadd -g %{-g*} -r %{1} 1>&2 \
+fi;
This page took 0.095281 seconds and 4 git commands to generate.