]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm.macros
- %%releq_kernel_up/smp added (for proper use with requires(...)).
[packages/rpm-build-macros.git] / rpm.macros
index 9ecd00884bf48b5eef38acf53f3424b3e9f4b4ce..b777dbaebe01dd1936cbec963caa4f03b8bcb05e 100644 (file)
@@ -1,5 +1,8 @@
 # PLD rpm macros
 
+# other macros
+%_enable_debug_packages 1
+
 %__id          @__ID@
 %__id_u                %{__id} -u 
 %__chown_Rhf           @__CHOWN_RHF@
 #-----------------------------------------------------------------
 # CFLAGS and LDFLAGS used to build
 
+%debuginfocflags       %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -ggdb}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
+
 %debugcflags   -O0 -g -Wall
-%rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}
-%rpmldflags    %{!?debug:-s}
+%rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
+%rpmcxxflags   %{rpmcflags} -fvisibility-inlines-hidden
+%rpmldflags    %{nil}
 
 # kernel compiler
 %kgcc          gcc
 %__automake             automake -a -c -f --foreign
 %__autoconf             autoconf %{?debug:-Wall}
 
+%dependencytracking    %{nil}
 #-----------------------------------------------------------------
 %configure2_13 { \
  if [ -n "$LINGUAS" ]; then unset LINGUAS; fi; \
  LDFLAGS="${LDFLAGS:-%rpmldflags}" ; export LDFLAGS ; \
  CFLAGS="${CFLAGS:-%rpmcflags}" ; export CFLAGS ; \
- CXXFLAGS="${CXXFLAGS:-%rpmcflags}" ; export CXXFLAGS ; \
+ CXXFLAGS="${CXXFLAGS:-%rpmcxxflags}" ; export CXXFLAGS ; \
  FFLAGS="${FFLAGS:-%rpmcflags}" ; export FFLAGS ; \
  CPPFLAGS="${CPPFLAGS:-}" ; export CPPFLAGS ; \
- %{?__cc:CC=%{__cc} ; export CC ; } \
- %{?__cxx:CXX=%{__cxx} ; export CXX ; } \
+ %{?__cc:CC="%{__cc}" ; export CC ; } \
+ %{?__cxx:CXX="%{__cxx}" ; export CXX ; } \
  %{?configuredir:%{configuredir}}%{!?configuredir:.}/configure \
        --host=%{_target_platform} \
        --prefix=%{_prefix} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
        --x-libraries=/usr/X11R6/%{_lib} \
+       %{dependencytracking} \
 }
 
 #----------------------------------------------------------------
 %configure {./configure \
        LDFLAGS="${LDFLAGS:-%rpmldflags}" \
        CFLAGS="${CFLAGS:-%rpmcflags}" \
-       CXXFLAGS="${CXXFLAGS:-%rpmcflags}" \
+       CXXFLAGS="${CXXFLAGS:-%rpmcxxflags}" \
        FFLAGS="${FFLAGS:-%rpmcflags}" \
        CPPFLAGS="${CPPFLAGS:-}" \
-       %{?__cc:CC=%{__cc}} \
-       %{?__cxx:CXX=%{__cxx}} \
+       %{?__cc:CC="%{__cc}"} \
+       %{?__cxx:CXX="%{__cxx}"} \
        --build=%{_target_platform} \
        --prefix=%{_prefix} \
        --exec-prefix=%{_exec_prefix} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
        --x-libraries=/usr/X11R6/%{_lib} \
+       %{dependencytracking} \
 }
 
+# ------------------------------------------------------------------------
+# Overloading of some basic macros
+%prep \
+%%prep\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
+%build %%build\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
+%install %{?_enable_debug_packages:%{?buildsubdir:%{debug_package}}}\
+%%install\
+LANG=C\
+export LANG\
+unset DISPLAY ||:\
+%{nil}
+
 # ------------------------------------------------------------------------
 # Conditional build stuff.
 
 
 # Requires name = version-release
 %requires_releq()              %(LC_ALL="C" echo '%*' | xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}-%%{release}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
+
+%releq_kernel_up()             %(LC_ALL="C" rpm -qf --qf 'kernel-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
+%releq_kernel_smp()            %(LC_ALL="C" rpm -qf --qf 'kernel-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
 %requires_releq_kernel_up()    %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
 %requires_releq_kernel_smp()   %(LC_ALL="C" rpm -qf --qf 'Prereq: kernel-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -vE "(is not|no such)")
-%requires_eq_to %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
+
+%requires_eq_to() %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
 
 %apache_modules_api %(awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' /usr/include/apache/ap_mmn.h 2>/dev/null || echo ERROR)
 
 # kernel version-release handling
-%__kernel_ver    %(grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2)
-%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/version.h --queryformat "%{RELEASE}" | grep -v "is not")
+%__kernel_ver   %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } END { printf("%d.%d.%d", ver, plev, slev); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
+%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h --queryformat "%{RELEASE}" | grep -v "is not")
 %_kernel_ver     %(echo %{__kernel_ver}%{!?_without_dist_kernel:-%{__kernel_rel}})
 %_kernel_ver_str %(echo %{_kernel_ver} | sed s/-/_/g)
 
 #
 #%no_install_post_compress_docs        1
 %__spec_install_post_compress_docs { \
-echo "Compress man and info pages."; \
 %{!?no_install_post_compress_docs: \
+       echo "Compress man and info pages."; \
        %{?verbose:set -x;} \
        for i in /usr/share/man /usr/X11R6/man /usr/share/info; do \
                if [ -d "$RPM_BUILD_ROOT$i" ]; then \
@@ -242,7 +277,8 @@ echo "Compress man and info pages."; \
 #%no_install_post_strip        1
 %__spec_install_post_strip {%{!?debug: \
 %{!?no_install_post_strip: \
-       %{?verbose:set -x;} \
+    %{?verbose:set -x;} \
+    if [ -d "$RPM_BUILD_ROOT" ]; then \
        echo "Strip executable binaries, archives and shared object files."; \
        filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautostrip:! -regex "%{_noautostrip}"}`; \
        elfexelist=`echo $filelist | xargs -r file | \
@@ -259,7 +295,8 @@ echo "Compress man and info pages."; \
        fi; \
        if [ -n "$elfarchiveslist" ]; then \
                %{__strip} --strip-debug --remove-section=.note  --remove-section=.comment $elfarchiveslist; \
-       fi; } \
+       fi; \
+    fi; } \
 } }
 #-----------------------------------------------------------------
 # remove all RPATH from executable binaries and shared object files
@@ -270,9 +307,10 @@ echo "Compress man and info pages."; \
 %__spec_install_post_chrpath {%{!?debug: \
 %{!?no_install_post_chrpath: \
        %{?verbose:set -x;} \
+if [ -d "$RPM_BUILD_ROOT" ]; then \
 echo "Remove RPATH from executable binaries and shared object files."; \
 find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautochrpath:! -regex "%{_noautochrpath}"} | xargs -r file | \
-       awk '/ELF.*(executable|shared object)/ {print $1}' | cut -d: -f1 | \
+       awk '/ELF.*(executable.*dynamically linked|shared object)/ {print $1}' | cut -d: -f1 | \
 while read file ; do \
        rpath= ; \
        chmod u+w "$file"; \
@@ -290,7 +328,8 @@ while read file ; do \
        done ; \
        if [ "$rpath" = "" ] ; then chrpath -d "$file" > /dev/null ; \
        else chrpath -r "$rpath" "$file" > /dev/null ; fi ; \
-done; } \
+done; \
+fi; } \
 } }
 #-----------------------------------------------------------------
 # Find and gzip all kernel modules
@@ -300,14 +339,16 @@ done; } \
 #%no_install_post_compress_modules  1
 %__spec_install_post_compress_modules { \
 %{!?no_install_post_compress_modules: \
-echo "Compress kernel modules if any."; \
     %{?verbose:set -x;} \
+    if [ -d "$RPM_BUILD_ROOT" ]; then \
+echo "Compress kernel modules if any."; \
     if test -d $RPM_BUILD_ROOT/lib/modules ; then \
        find $RPM_BUILD_ROOT/lib/modules -name \*o -type f -print | \
        xargs -r %{__gzip} -9nf; \
           find $RPM_BUILD_ROOT/lib/modules -name \*o -type l -printf "%p %l\n" | \
           while read a b; do ln -sf $b.gz $a.gz; rm -f $a; done; \
     fi; \
+    fi; \
 } }
 
 %_source_payload        w9.gzdio
@@ -335,11 +376,11 @@ echo "Compress kernel modules if any."; \
 # Requires/Provides automation
 # exceptions system by Jacek Konieczny <jajcus@pld.org.pl>
 #
-%_noautoreqfiles       %(sed -e s'/#.*//' /etc/rpm/noautoreqfiles)
-%_noautoprovfiles      %(sed -e s'/#.*//' /etc/rpm/noautoprovfiles)
-%_noautoreq            %(sed -e s'/#.*//' /etc/rpm/noautoreq)
-%_noautoreqdep         %(sed -e s'/#.*//' /etc/rpm/noautoreqdep)
-%_noautoprov           %(sed -e s'/#.*//' /etc/rpm/noautoprov)
+%__noautoreqfiles      %(sed -e s'/#.*//' /etc/rpm/noautoreqfiles)%{?_noautoreqfiles: %{_noautoreqfiles}}
+%__noautoprovfiles     %(sed -e s'/#.*//' /etc/rpm/noautoprovfiles)%{?_noautoprovfiles: %{_noautoprovfiles}}
+%__noautoreq           %(sed -e s'/#.*//' /etc/rpm/noautoreq)%{?_noautoreq: %{_noautoreq}}
+%__noautoreqdep                %(sed -e s'/#.*//' /etc/rpm/noautoreqdep)%{?_noautoreqdep: %{_noautoreqdep}}
+%__noautoprov          %(sed -e s'/#.*//' /etc/rpm/noautoprov)%{?_noautoprov: %{_noautoprov}}
 #%_noautocompressdoc   %{nil}
 #
 %_missing_doc_files_terminate_build    1%{nil}
@@ -411,3 +452,29 @@ fi; \
 %xmms_effect_plugindir        %(xmms-config --effect-plugin-dir)
 %xmms_general_plugindir       %(xmms-config --general-plugin-dir)
 
+%_target_base_arch     %(echo %{_target_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/pentium./i386/;s/amd64/x86_64/')
+
+# user/group checking macros
+#
+# Usage:
+#      %userremove myuser
+#
+%userremove    /usr/lib/rpm/user_group.sh user del
+%groupremove   /usr/lib/rpm/user_group.sh group del
+#
+# Usage:
+#      if %usertestrm myuser; then
+#              /usr/sbin/userdel -r myuser
+# Note:
+#      use these macros only if you need to call userdel/groupdel with
+#      a non-standard option or take an extra action; otherwise use the
+#      %userremove/%groupremove macros
+#
+%usertestrm    /usr/lib/rpm/user_group.sh user testrm
+%grouptestrm   /usr/lib/rpm/user_group.sh group testrm
+# user group membership management macros
+#
+# Usage:
+#      %addusertogroup myuser agroup
+#
+%addusertogroup        /usr/lib/rpm/user_group.sh user addtogroup
This page took 0.039263 seconds and 4 git commands to generate.