]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm.macros
v1.717: %py_install_opts, %py3_install_opts
[packages/rpm-build-macros.git] / rpm.macros
index 452ca977ba85f7265c7e6b79d69ccc1c800f832b..aeb242c2e0f8bb96568419ba49168e01f4ef84d6 100644 (file)
@@ -31,7 +31,7 @@
 # expands to -jN if %__jobs has a value
 %_smp_mflags   %{expand:%%global _smp_mflags %(jobs=%{__jobs}; echo ${jobs:+-j$jobs}%%{nil})}%_smp_mflags
 
-%__make                /usr/bin/make %{?_smp_mflags}
+%__make                /usr/bin/make %{?_make_opts} %{?_smp_mflags}
 %__scons       /usr/bin/scons %{?_smp_mflags}
 %__waf         /usr/bin/waf %{?_smp_mflags}
 %__cmake       /usr/bin/cmake
@@ -264,7 +264,21 @@ CPPFLAGS="${CPPFLAGS:-%{rpmcppflags}}" \\\
 %{__cmake} \\\
        -DCMAKE_VERBOSE_MAKEFILE=ON \\\
        -DCMAKE_BUILD_TYPE=%{!?debug:PLD}%{?debug:Debug} \\\
+       -DCMAKE_INSTALL_BINDIR:PATH=%{_bindir} \\\
+       -DCMAKE_INSTALL_SBINDIR:PATH=%{_sbindir} \\\
+       -DCMAKE_INSTALL_LIBEXECDIR:PATH=%{_libexecdir} \\\
+       -DCMAKE_INSTALL_SYSCONFDIR:PATH=%{_sysconfdir} \\\
+       -DCMAKE_INSTALL_SHAREDSTATEDIRPATH:PATH=%{_sharedstatedir} \\\
+       -DCMAKE_INSTALL_LOCALSTATEDIRPATH:PATH=%{_localstatedir} \\\
        -DCMAKE_INSTALL_LIBDIR:PATH=%{_libdir} \\\
+       -DCMAKE_INSTALL_INCLUDEDIR:PATH=%{_includedir} \\\
+       -DCMAKE_INSTALL_OLDINCLUDEDIR:PATH=%{_includedir} \\\
+       -DCMAKE_INSTALL_DATAROOTDIR:PATH=%{_datadir} \\\
+       -DCMAKE_INSTALL_DATADIR:PATH=%{_datadir} \\\
+       -DCMAKE_INSTALL_INFODIR:PATH=%{_infodir} \\\
+       -DCMAKE_INSTALL_LOCALEDIR:PATH=%{_localedir} \\\
+       -DCMAKE_INSTALL_MANDIR:PATH=%{_mandir} \\\
+       -DCMAKE_INSTALL_DOCDIR:PATH=%{_docdir} \\\
        -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \\\
        -DSYSCONF_INSTALL_DIR:PATH=%{_sysconfdir} \\\
        -DCMAKE_CXX_FLAGS_PLD="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \\\
@@ -275,6 +289,9 @@ CPPFLAGS="${CPPFLAGS:-%{rpmcppflags}}" \\\
        -DCMAKE_MODULE_LINKER_FLAGS_PLD="${LDFLAGS:-%{rpmldflags}}" \\\
 %if "%{_lib}" == "lib64" \
        -DLIB_SUFFIX=64 \\\
+%endif \
+%if "%{_lib}" == "libx32" \
+       -DLIB_SUFFIX=x32 \\\
 %endif \
        -DBUILD_SHARED_LIBS:BOOL=ON \\\
 %{nil}
@@ -436,48 +453,6 @@ LINKFLAGS="%{rpmldflags}" \
 # and release 0.zzz.bootstrap if built with bootstrap
 %bootstrap_release() %{!?with_bootstrap:%{1}%{?2:.%{2}}}%{?with_bootstrap:%{!?2:%(expr %{1} - 1)}%{?2:%{1}.%(expr %{2} - 1)}.zzz.bootstrap}
 
-# Alternative kernel type/version
-%_alt_kernel   %{nil}%{?alt_kernel:-%{?alt_kernel}}
-
-# The directory holding Linux kernel sources
-%_kernelsrcdir /usr/src/linux%{_alt_kernel}
-
-# rpm -qf on kernel version.h file
-%__kernel_qf()         %(R=$(cd %{_kernelsrcdir} 2>/dev/null && LC_ALL=C rpm -q --qf '%*' -f include/linux/version.h 2>/dev/null | grep -v 'is not'); echo ${R:-ERROR})
-
-# kernel %{name} and kernel %{epoch}:%{version}-%{release} macro respecing alt_kernel
-%kernel_name   %(N=%{__kernel_qf %{N}}; echo ${N%%-headers})
-%kernel_version        %{__kernel_qf %|E?{%{E}:}|%{V}-%{R}}
-
-# -n drm to generate kernel%{_alt_kernel}-drm dependency
-%releq_kernel(n:)              %{kernel_name}%{?-n:-%{-n*}} = %{kernel_version}
-%releq_kernel_up(n:)   %{kernel_name}-up%{?-n:-%{-n*}} = %{kernel_version}
-%releq_kernel_smp(n:)  %{kernel_name}-smp%{?-n:-%{-n*}} = %{kernel_version}
-
-# -s post to generate Requires(post) dependency
-%requires_releq_kernel(s:n:)           Requires%{-s:(%{-s*})}: %releq_kernel
-%requires_releq_kernel_up(s:n:)                Requires%{-s:(%{-s*})}: %releq_kernel_up
-%requires_releq_kernel_smp(s:n:)       Requires%{-s:(%{-s*})}: %releq_kernel_smp
-
-# kernel version-release handling
-%__kernel_ver   %( \\
-       Z=$([ -f '%{_kernelsrcdir}/include/generated/utsrelease.h' ] && awk -F'"' '/UTS_RELEASE/{print $2}' %{_kernelsrcdir}/include/{linux/version,generated/utsrelease}.h 2>/dev/null || awk -F'"' '/UTS_RELEASE/{print $2}' %{_kernelsrcdir}/include/linux/{version,utsrelease}.h 2>/dev/null); \\
-       Z=${Z:-$(awk -F' = ' '/^VERSION/{v=$2} /^PATCHLEVEL/{p=$2} /^SUBLEVEL/{s=$2} /^EXTRAVERSION/{e=$2} END {printf("%d.%d.%d%s", v, p, s, e)}' %{_kernelsrcdir}/Makefile 2>/dev/null)}; \\
-       echo ${Z:-ERROR}; \\
-)
-
-%_kernel_version_code   %( \\
-       Z=$(awk '/LINUX_VERSION_CODE/{print $3}' %{_kernelsrcdir}/include/linux/version.h 2>/dev/null); \\
-       echo ${Z:-ERROR}; \\
-)
-
-%_kernel_version_magic()        %(echo $((%{1} * 65536 + %{2} * 256 + %{3})))
-
-# `uname -r` used for building/installing kernel modules
-%_kernel_ver   %{__kernel_ver}%{!?_without_dist_kernel:%(echo %{__kernel_ver} | grep -q -e - || echo -%{__kernel_qf %{R}})}
-# package version OR `uname -r` for non-dist kernel to be used in @release field
-%_kernel_ver_str %(echo %{!?_without_dist_kernel:%{__kernel_qf %{V}-%{R}}}%{?_without_dist_kernel:%{__kernel_ver}} | tr '-' '_')
-
 # Requires name = version-release
 %requires_releq()      %{!?1:ERROR}%{?2:ERROR}%{?1:%{!?2:%{expand:%%requires_eq_to -r %1 %1}}}
 # Requires: name = version
@@ -753,25 +728,38 @@ __spec_install_post_check_tmpfiles() { \
 }; __spec_install_post_check_tmpfiles }}
 
 #-----------------------------------------------------------------
-# Find and gzip all kernel modules
+# Verify that scripts have reasonable shebangs
+# Test spec: see "test/spec_install_post_check_shebangs" branch on packages/test.spec
 #
-# Requires: find
+#%no_install_post_check_shebangs 1
 #
-#%no_install_post_compress_modules     1
-%__spec_install_post_compress_modules { \
-%{!?no_install_post_compress_modules: __spec_install_post_compress_modules() { \
+%__spec_install_post_check_shebangs { \
+__spec_install_post_check_shebangs() { \
 %{!?debug:set +x;} \
-       if [ -d $RPM_BUILD_ROOT/lib/modules ]; then \
-               q=$(find $RPM_BUILD_ROOT/lib/modules -name '*o' -type f -print); \
-               if [ "$q" ]; then \
-                       printf "Compress %d kernel modules..." $(echo "$q" | wc -l); \
-                       echo "$q" | xargs -r %{__gzip} -9nf; \
-                       echo "DONE"; \
-                       find $RPM_BUILD_ROOT/lib/modules -name '*o' -type l -printf "%p %l\n" | \
-                       while read a b; do ln -sf $b.gz $a.gz; rm -f $a; done; \
-               fi; \
-       fi; \
-}; __spec_install_post_compress_modules } }
+       fail=0; \
+       echo "Checking script shebangs..."; \
+       find $RPM_BUILD_ROOT -type f -perm -500 -print | \
+       while read f ; do \
+               shebang="$(sed -e'1s/#! *\(.*\)/\1/;t;d;q' "$f")" ; \
+               f="${f##$RPM_BUILD_ROOT}"; \
+               case "$shebang" in \
+                       "%{__python}"|"%{__python3}"|"%{__python} "*|"%{__python3} "* \
+                       |"/usr/bin/python%{py_ver}"|"/usr/bin/python%{py_ver} "* \
+                       |"/usr/bin/python%{py3_ver}"|"/usr/bin/python%{py3_ver} "*) \
+                               ;; \
+                       "/usr/bin/env python"*|"/usr/bin/python"|"/usr/bin/python "*) \
+                               echo "$f starts with '#!$shebang', should be '#!%{__python}' or '#!%{__python3}'" >&2;\
+                               fail=1 ; \
+                               ;; \
+                       "/usr/bin/env "*) \
+                               echo "$f starts with '#!$shebang', should be explicit interpreter path" >&2;\
+                               fail=1 ; \
+                               ;; \
+                       *) ;;\
+               esac ; \
+       done ; \
+       echo " DONE" ; \
+}; %{!?no_install_post_check_shebangs:__spec_install_post_check_shebangs} }
 
 # Remove common Perl files we don't package
 %__spec_install_post_perl_clean {\
@@ -885,6 +873,8 @@ fi; \
        %{?_noautoreq_pear: %{__noauto_regexp_helper -p pear %{_noautoreq_pear}}} \
        %{?_noautoreq_perl: %{__noauto_regexp_helper -p perl %{_noautoreq_perl}}} \
        %{?_noautoreq_java: %{__noauto_regexp_helper -p java %{_noautoreq_java}}} \
+       %{?_noautoreq_pyegg: %{__noauto_regexp_helper -p pythonegg %{_noautoreq_pyegg}}} \
+       %{?_noautoreq_py3egg: %{__noauto_regexp_helper -p python3egg %{_noautoreq_py3egg}}} \
        %{nil}
 
 # helper for wrapping _noautoreq between perl() or pear()
@@ -929,6 +919,10 @@ fi; \
 # Ruby
 %__ruby                                /usr/bin/ruby
 
+# Ruby ABI version
+# NOTE: %ruby_version may be empty, depending how Ruby was built
+%ruby_abi                      %{expand:%%global ruby_abi %(%{__ruby} -r rbconfig -e 'print [RbConfig::CONFIG["MAJOR"], RbConfig::CONFIG["MINOR"]].join(".")' 2>/dev/null || echo ERROR)}%ruby_abi
+
 # get rbconfig parameter
 %__ruby_rbconfig()     %(%{__ruby} -r rbconfig -e 'print RbConfig::CONFIG["%1"]' 2>/dev/null || echo ERROR)
 %__ruby_rbconfig_path()        %(%{__ruby} -r rbconfig -r pathname -e 'print Pathname(RbConfig::CONFIG["%1"]).cleanpath' 2>/dev/null || echo ERROR)
@@ -984,7 +978,7 @@ fi; \
 %__php                                 /usr/bin/php%{php_versuffix}
 
 # helper macro
-%__php_api_requires(v:) Requires: %{php_name}(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
+%__php_api_requires() Requires: %{php_name}(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
 
 # macros for public use
 # for php extensions (php-pecl)
@@ -1102,11 +1096,10 @@ fi \
 
 # directories
 %py3_prefix            %{expand:%%global py3_prefix %(%{__python3} -c "import sys; print(sys.prefix)" 2>/dev/null || echo ERROR)}%py3_prefix
-%py3_libdir            %{expand:%%global py3_libdir %(%{__python3} -c "import sysconfig; print(sysconfig.get_path('platstdlib'))" 2>/dev/null || echo ERROR)}%py3_libdir
 %py3_incdir            %{expand:%%global py3_incdir %(%{__python3} -c "import sysconfig; print(sysconfig.get_path('include'))" 2>/dev/null || echo ERROR)}%py3_incdir
-%py3_sitedir           %{expand:%%global py3_sitedir %(%{__python3} -c "import sysconfig; print(sysconfig.get_path('platlib'))" 2>/dev/null || echo ERROR)}%py3_sitedir
-%py3_sitescriptdir             %{expand:%%global py3_sitescriptdir %(%{__python3} -c "import sysconfig; print(sysconfig.get_path('purelib'))" 2>/dev/null || echo ERROR)}%py3_sitescriptdir
-%py3_scriptdir %{py3_prefix}/share/python%{py3_ver}
+%py3_libdir            %{py3_prefix}/%{_lib}/python%{py3_ver}
+%py3_sitedir   %{py3_libdir}/site-packages
+%py3_sitescriptdir %{py3_prefix}/share/python%{py3_ver}/site-packages
 %py3_dyndir            %{py3_libdir}/lib-dynload
 
 # pure python modules compilation
@@ -1114,6 +1107,69 @@ fi \
 
 %py3_ocomp             %{__python3} -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
 
+%py_build { \
+       LDFLAGS="${LDFLAGS:-%rpmldflags}"; export LDFLAGS; \
+       CFLAGS="${CFLAGS:-%rpmcppflags %rpmcflags}"; export CFLAGS; \
+       CXXFLAGS="${CXXFLAGS:-%rpmcppflags %rpmcxxflags}"; export CXXFLAGS; \
+       %{?__cc:CC="%{__cc}"; export CC;} \
+       %{?__cxx:CXX="%{__cxx}"; export CXX;} \
+       %{__python} setup.py \
+                               build --build-base=build-2 \
+}
+
+# "shrink" filter to keep this macro without newlines,
+# so it could be used as make arguments
+%py_install_opts() %{shrink: \
+       --prefix=%{_prefix} \
+       --install-purelib=%{py_sitescriptdir} \
+       --install-platlib=%{py_sitedir} \
+       --optimize=2 \
+}
+
+%py_install { \
+       LDFLAGS="${LDFLAGS:-%rpmldflags}"; export LDFLAGS; \
+       CFLAGS="${CFLAGS:-%rpmcppflags %rpmcflags}"; export CFLAGS; \
+       CXXFLAGS="${CXXFLAGS:-%rpmcppflags %rpmcxxflags}"; export CXXFLAGS; \
+       %{?__cc:CC="%{__cc}"; export CC;} \
+       %{?__cxx:CXX="%{__cxx}"; export CXX;} \
+       %{__python} setup.py \
+                               build --build-base=build-2 \
+                               install --skip-build \
+                               %{py_install_opts} \
+                               --root=$RPM_BUILD_ROOT \
+}
+
+%py3_build { \
+       LDFLAGS="${LDFLAGS:-%rpmldflags}"; export LDFLAGS; \
+       CFLAGS="${CFLAGS:-%rpmcppflags %rpmcflags}"; export CFLAGS; \
+       CXXFLAGS="${CXXFLAGS:-%rpmcppflags %rpmcxxflags}"; export CXXFLAGS; \
+       %{?__cc:CC="%{__cc}"; export CC;} \
+       %{?__cxx:CXX="%{__cxx}"; export CXX;} \
+       %{__python3} setup.py build --build-base=build-3 \
+}
+
+# "shrink" filter to keep this macro without newlines,
+# so it could be used as make arguments
+%py3_install_opts() %{shrink: \
+       --prefix=%{_prefix} \
+       --install-purelib=%{py3_sitescriptdir} \
+       --install-platlib=%{py3_sitedir} \
+       --optimize=2 \
+}
+
+%py3_install { \
+       LDFLAGS="${LDFLAGS:-%rpmldflags}"; export LDFLAGS; \
+       CFLAGS="${CFLAGS:-%rpmcppflags %rpmcflags}"; export CFLAGS; \
+       CXXFLAGS="${CXXFLAGS:-%rpmcppflags %rpmcxxflags}"; export CXXFLAGS; \
+       %{?__cc:CC="%{__cc}"; export CC;} \
+       %{?__cxx:CXX="%{__cxx}"; export CXX;} \
+       %{__python3} setup.py \
+                               build --build-base=build-3 \
+                               install --skip-build \
+                               %{py3_install_opts} \
+                               --root=$RPM_BUILD_ROOT \
+}
+
 # node.js libdir
 # Requirements:
 # BuildRequires: rpmbuild(macros) >= 1.634
@@ -1189,9 +1245,6 @@ fi; \
 %xmms_effect_plugindir         %{expand:%%global xmms_effect_plugindir %(xmms-config --effect-plugin-dir 2>/dev/null || echo ERROR)}%xmms_effect_plugindir
 %xmms_general_plugindir                %{expand:%%global xmms_general_plugindir %(xmms-config --general-plugin-dir 2>/dev/null || echo ERROR)}%xmms_general_plugindir
 
-%_host_base_arch       %{expand:%%global _host_base_arch %(echo %{_host_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/pentium./i386/;s/amd64/x86_64/;s/ia32e/x86_64/;s/sparcv./sparc/;s/arm.*/arm/')}%_host_base_arch
-%_target_base_arch     %{expand:%%global _target_base_arch %(echo %{_target_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/pentium./i386/;s/amd64/x86_64/;s/ia32e/x86_64/;s/sparcv./sparc/;s/arm.*/arm/')}%_target_base_arch
-
 # user/group checking macros
 #
 # Usage:
@@ -1700,243 +1753,6 @@ done \
 
 %env_update [ ! -x /sbin/env-update ] || /sbin/env-update -u || :
 
-
-# Build modules for kernels 2.6
-# Author: Przemyslaw Iskra <sparky@pld-linux.org>
-#
-# Usage:
-#      %build_kernel_modules -m <modules> -C <directory>
-#
-#  remember that proper Makefile is still required
-# Options:
-#  -m <modules> (required) -- comma-separated list of modules to save,
-#              without .ko extension, may be placed in subdirectory
-#  -C <directory> -- change to <directory> before doing anything
-#  -p <arg>, -P <arg> -- arguments passeed to make scripts
-#  -c -- do not execute make clean
-#  <additional arguments> -- all additional arguments will be passed to
-#              make modules
-#
-# Additional patching supported via here document. Try:
-#      %build_kernel_modules -m module <<'EOF'
-#      your patch script here
-#      EOF
-# Don't use it unless patching depends on config options.
-
-# Developer note: don't touch it unless you know how to handle '\'.
-# - \ in script expands to nothing
-# - \\\ in script expands to \
-# - \\\ inside definition expands to nothing
-# - \\\\\\\ inside definition expands to \
-# - in last line \ has to touch arguments so arguments passing
-#   in new lines (using \) will be supported
-
-%build_kernel_modules(p:P:m:C:c)                                                                       \
-%{!?-m:%{error:%{0}: Required module name/list missing} exit 1}                \
-                                                                                                                                       \
-%define Opts                                                                                                           \\\\\\\
-%if "%{_target_base_arch}" != "%{_host_base_arch}"                                     \\\
-       %if "%{_host_base_arch}" == "x86_64" && "%{_target_base_arch}" == "i386" \\\
-       CC="%{__cc}" ARCH=%{_target_base_arch}                                                  \\\
-       %else                                                                                                                   \\\
-       ARCH=%{_target_base_arch} CROSS_COMPILE=%{_target_cpu}-pld-linux- \\\
-       %endif                                                                                                                  \\\
-%else                                                                                                                          \\\
-       CC="%{__cc}"                                                                                                    \\\
-%endif                                                                                                                         \
-%define        MakeOpts HOSTCC="%{__cc}" SYSSRC=%{_kernelsrcdir} SYSOUT=$PWD/o \\\\\\\
-               O=$PWD/o %{?with_verbose:V=1} %{Opts}                                           \
-                                                                                                                                       \
-%{?-C:cd %{-C*}}                                                                                                       \
-compile() {                                                                                                                    \
-       local L="<" PATCH_SH;                                                                                   \
-       [[ '%{*}' != *$L$L* ]] || PATCH_SH="set -x -e;$(cat)"                   \
-       set -e -x                                                                                                               \
-                                                                                                                                       \
-       [ -r "%{_kernelsrcdir}/.config" ] || exit 1                                             \
-       rm -rf o                                                                                                                \
-       install -d o/include/linux o/include/generated o/arch/x86/include o/arch/powerpc/lib    \
-       ln -sf %{_kernelsrcdir}/.config o/.config                                               \
-       ln -sf %{_kernelsrcdir}/Module.symvers o/Module.symvers                 \
-       if [ -f %{_kernelsrcdir}/include/generated/autoconf.h ]; then   \
-               ln -sf %{_kernelsrcdir}/include/generated/autoconf.h o/include/generated/autoconf.h \
-               ln -s ../generated/autoconf.h o/include/linux/autoconf.h        \
-       else                                                                                                                    \
-               ln -sf %{_kernelsrcdir}/include/linux/autoconf.h o/include/linux/autoconf.h \
-       fi                                                                                                                              \
-       if [ -d %{_kernelsrcdir}/arch/x86/include/generated ]; then             \
-               ln -s %{_kernelsrcdir}/arch/x86/include/generated o/arch/x86/include    \
-       fi                                                                                                                              \
-                                                                                                                                       \
-       set +x                                                                                                                  \
-       [ -z "$PATCH_SH" ] || echo "$PATCH_SH" | %__spec_build_shell    \
-       set -x                                                                                                                  \
-                                                                                                                                       \
-       install -d o/include/config                                                                             \
-       touch o/include/config/MARKER                                                                   \
-       ln -sf %{_kernelsrcdir}/include/config/auto.conf o/include/config/auto.conf     \
-       ln -sf %{_kernelsrcdir}/scripts o/scripts                                               \
-                                                                                                                                       \
-       %{!?-c:%{__make} -C %{_kernelsrcdir} clean                                              \\\
-               RCS_FIND_IGNORE="-name '*.[ks]o' -o"                                            \\\
-               ${1+"$@"}                                                                                                       \\\
-               M=$PWD %{MakeOpts}}                                                                                     \
-                                                                                                                                       \
-       %{__make} -C %{_kernelsrcdir} modules                                                   \\\
-               ${1+"$@"}                                                                                                       \\\
-               M=$PWD CONSTIFY_PLUGIN="" %{MakeOpts}                                           \
-%{?-C:cd -}                                                                                                                    \
-}                                                                                                                                      \
-compile %{*}                                                                                                           \
-%{nil}
-
-%build_kernel_modules_compat(p:P:m:C:c)                                                                \
-%{!?-m:%{error:%{0}: Required module name/list missing} exit 1}                \
-                                                                                                                                       \
-%define Opts                                                                                                           \\\\\\\
-%if "%{_target_base_arch}" != "%{_host_base_arch}"                                     \\\
-       %if "%{_host_base_arch}" == "x86_64" && "%{_target_base_arch}" == "i386" \\\
-       CC="%{__cc}" ARCH=%{_target_base_arch}                                                  \\\
-       %else                                                                                                                   \\\
-       ARCH=%{_target_base_arch} CROSS_COMPILE=%{_target_cpu}-pld-linux- \\\
-       %endif                                                                                                                  \\\
-%else                                                                                                                          \\\
-       CC="%{__cc}"                                                                                                    \\\
-%endif                                                                                                                         \
-%define        MakeOpts HOSTCC="%{__cc}" SYSSRC=%{_kernelsrcdir} SYSOUT=$PWD/o \\\\\\\
-               O=$PWD/o %{?with_verbose:V=1} %{Opts}                                           \
-                                                                                                                                       \
-%{?-C:cd %{-C*}}                                                                                                       \
-compile() {                                                                                                                    \
-       local L="<" PATCH_SH;                                                                                   \
-       [[ '%{*}' != *$L$L* ]] || PATCH_SH="set -x -e;$(cat)"                   \
-       set -e -x                                                                                                               \
-       local cfgs='%{?with_dist_kernel:%{?with_smp: smp}%{?with_up: up}}%{!?with_dist_kernel: nondist}' \
-                                                                                                                                       \
-for cfg in ${cfgs:-dist}; do                                        \
-       [ -r "%{_kernelsrcdir}/config-$cfg" ] || exit 1                                 \
-                                                                                                                                       \
-       rm -rf o                                                                                                                \
-       install -d o/include/linux o/include/generated o/arch/powerpc/lib       \
-       ln -sf %{_kernelsrcdir}/config-$cfg o/.config                                   \
-       ln -sf %{_kernelsrcdir}/Module.symvers-$cfg o/Module.symvers    \
-       if [ -f %{_kernelsrcdir}/include/generated/autoconf-$cfg.h ]; then      \
-               ln -sf %{_kernelsrcdir}/include/generated/autoconf-$cfg.h o/include/generated/autoconf.h \
-               ln -s ../generated/autoconf.h o/include/linux/autoconf.h        \
-       else                                                                                                                    \
-               ln -sf %{_kernelsrcdir}/include/linux/autoconf-$cfg.h o/include/linux/autoconf.h \
-       fi                                                                                                                              \
-                                                                                                                                       \
-       set +x                                                                                                                  \
-       [ -z "$PATCH_SH" ] || echo "$PATCH_SH" | %__spec_build_shell    \
-       set -x                                                                                                                  \
-                                                                                                                                       \
-       %if %{with dist_kernel} || %(test -f %{_kernelsrcdir}/scripts/bin2c ; echo $?)  \
-               %{__make} -j1 -C %{_kernelsrcdir} prepare scripts                       \\\
-                       %{-p*} %{-P*}                                                                                   \\\
-                       %{MakeOpts}                                                                                             \
-       %else                                                                                                                   \
-               install -d o/include/config                                                                     \
-               touch o/include/config/MARKER                                                           \
-               ln -sf %{_kernelsrcdir}/include/config/auto-$cfg.conf o/include/config/auto.conf        \
-               ln -sf %{_kernelsrcdir}/scripts o/scripts                                       \
-       %endif                                                                                                                  \
-                                                                                                                                       \
-       %{!?-c:%{__make} -C %{_kernelsrcdir} clean                                              \\\
-               RCS_FIND_IGNORE="-name '*.[ks]o' -o"                                            \\\
-               ${1+"$@"}                                                                                                       \\\
-               M=$PWD %{MakeOpts}}                                                                                     \
-                                                                                                                                       \
-       %{__make} -C %{_kernelsrcdir} modules                                                   \\\
-               ${1+"$@"}                                                                                                       \\\
-               M=$PWD CONSTIFY_PLUGIN="" %{MakeOpts}                                           \
-                                                                                                                                       \
-       for MODULE in {%{-m*},}; do                                                                             \
-               [ -z "${MODULE}" ] || mv ${MODULE}{,-$cfg}.ko                           \
-       done                                                                                                                    \
-done                                                                                                                           \
-%{?-C:cd -}                                                                                                                    \
-}                                                                                                                                      \
-compile %{*}                                                                                                           \
-%{nil}
-
-
-# Install kernel modules built by %build_kernel_modules
-# Author: Przemyslaw Iskra <sparky@pld-linux.org>
-#
-# Usage:
-#      %install_kernel_modules -m <modules> -d <directory>
-#
-# Options:
-#  -m <modules> (required) -- comma-separated list of modules to install,
-#              without .ko extension, may be placed in subdirectory
-#  -d <directory> (required) -- in what subdirectory modules should be
-#              installed (eg. misc, kernel/drivers/net)
-#  -s <suffix> -- suffix to use when installing modules, useful when module
-#              with same name exists in kernel already
-#  -n <file> -- name of modprobe config file to use (without .conf extension)
-#              for defining aliases, only useful with -s
-#  -D <directory> -- DESTDIR, base directory for installed files,
-#              defaults to RPM_BUILD_ROOT
-
-%install_kernel_modules(m:d:s:n:D:)                                                                    \
-%{!?-m:%{error:%{0}: Required module name (-m) missing}exit 1}         \
-%{!?-d:%{error:%{0}: Required module directory missing}exit 1}         \
-%{?-n:%{!?-s:%{error:%{0}: Modprobe .conf file requires module suffix}exit 1}} \
-                                                                                                                                       \
-INSTALLROOT=%{-D*}                                                                                                     \
-[ -n "$INSTALLROOT" ] || INSTALLROOT=$RPM_BUILD_ROOT                           \
-                                                                                                                                       \
-%define KernelD $INSTALLROOT/lib/modules/%{_kernel_ver}                                \
-%define ModprobeD $INSTALLROOT%{_sysconfdir}/modprobe.d/%{_kernel_ver} \
-                                                                                                                                       \
-__install_kernel_modules() {                                                                           \
-%{!?debug:set +x;}                                                                                                     \
-                                                                                                                                       \
-for MODULE in {%{-m*},}; do                                                                                    \
-       [ -n "${MODULE}" ] || continue                                                                  \
-       MNAME=${MODULE##*/}                                                                                             \
-       install -m 644 -D ${MODULE}.ko %{KernelD}/%{-d*}/${MNAME}%{-s:-%{-s*}}.ko       \
-       %{?-s:install -d %{ModprobeD}                                                                   \
-               echo "alias ${MNAME} ${MNAME}-%{-s*}" >> %{ModprobeD}/%{-n*}.conf}      \
-done                                                                                                                           \
-}                                                                                                                                      \
-__install_kernel_modules                                                                                       \
-unset INSTALLROOT                                                                                                      \
-%{nil}
-
-%install_kernel_modules_compat(m:d:s:n:D:)                                                     \
-%{!?-m:%{error:%{0}: Required module name (-m) missing}exit 1}         \
-%{!?-d:%{error:%{0}: Required module directory missing}exit 1}         \
-%{?-n:%{!?-s:%{error:%{0}: Modprobe .conf file requires module suffix}exit 1}} \
-                                                                                                                                       \
-INSTALLROOT=%{-D*}                                                                                                     \
-[ -n "$INSTALLROOT" ] || INSTALLROOT=$RPM_BUILD_ROOT                           \
-                                                                                                                                       \
-%define KernelD $INSTALLROOT/lib/modules/%{_kernel_ver}                                \
-%define ModprobeD $INSTALLROOT%{_sysconfdir}/modprobe.d/%{_kernel_ver} \
-                                                                                                                                       \
-__install_kernel_modules() {                                                                           \
-%{!?debug:set +x;}                                                                                                     \
-local cfgs='%{?with_dist_kernel:%{?with_smp: smp}%{?with_up: up}}%{!?with_dist_kernel: nondist}' \
-                                                                                                                                       \
-for MODULE in {%{-m*},}; do                                                                                    \
-       [ -n "${MODULE}" ] || continue                                                                  \
-       for cfg in ${cfgs:-dist}; do                                    \
-               [ "$cfg" = smp ] && suf=smp || suf=                                                     \
-               MNAME=${MODULE##*/}                                                                                     \
-               install -m 644 -D ${MODULE}-$cfg.ko                                                     \\\
-                       %{KernelD}$suf/%{-d*}/${MNAME}%{-s:-%{-s*}}.ko                  \
-               %{?-s:install -d %{ModprobeD}$suf                                                       \
-                       echo "alias ${MNAME} ${MNAME}-%{-s*}"                                   \\\
-                       >> %{ModprobeD}$suf/%{-n*}.conf}                                                \
-       done                                                                                                                    \
-done                                                                                                                           \
-}                                                                                                                                      \
-__install_kernel_modules                                                                                       \
-unset INSTALLROOT                                                                                                      \
-%{nil}
-
 # patchset macros
 # generate SourceX urls from range START STOP
 # Format can be SINGLE format char of %e, %f, %g, see seq(1)
This page took 0.104183 seconds and 4 git commands to generate.