]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm.macros
- 1.293: added %cmake macro
[packages/rpm-build-macros.git] / rpm.macros
index c9d19d0abcaebb04d9818636ad57535208b1e190..90728615f4ff6ed43a50789c23b349e40bb8d788 100644 (file)
@@ -1,33 +1,16 @@
+# $Revision$, $Date$
 # PLD rpm macros
 
-# other macros
 %epoch         0
-%_enable_debug_packages 1
-
-%__id          @__ID@
-%__id_u                %{__id} -u 
-%__chown_Rhf           @__CHOWN_RHF@
-%__chgrp_Rhf           @__CHGRP_RHF@
-
-%_fixowner       [ `%{__id_u}` = '0' ] && %{__chown_Rhf} root:@ROOT_GROUP@
-%_fixgroup       true
-%_fixperms       %{__chmod} -Rf @FIXPERMS@
-%_topdir         %(echo $HOME)/rpm
-#-----------------------------------------------------------------
-# CFLAGS and LDFLAGS used to build
-
-%debuginfocflags       %{expand:%%define __dic_%{?_enable_debug_packages} 1}%{?__dic_1: -ggdb}%{expand:%%undefine __dic_%{?_enable_debug_packages}}
-
-%debugcflags   -O0 -g -Wall
-%rpmcflags     %{?debug:%debugcflags}%{!?debug:%optflags}%{?debuginfocflags}
-%rpmcxxflags   %{rpmcflags}
-%rpmldflags    %{nil}
-# %rpmldflags  -Wl,--as-needed
+%x8664         x86_64 amd64 ia32e
 
 # kernel compiler
-%kgcc          gcc
+%kgcc          %{__cc}
 %kgcc_package  gcc
 
+%_source_payload       w9.gzdio
+%_binary_payload       w9.bzdio
+
 # Build system path macros.
 #
 %__autoconf            autoconf %{?debug:-Wall}
 %__autopoint           autopoint --force
 
 %__gettextize { \
-    if ! gettextize --version | grep -q '0\.10\.' ; then \
+if ! gettextize --version | grep -q '0\.10\.' ; then \
        if grep -qs 'AM_GNU_GETTEXT.*external' configure.{ac,in} ; then \
-           gettextize --copy --force --no-changelog; \
+               gettextize --copy --force --no-changelog; \
        else \
-           gettextize --copy --force --no-changelog --intl; \
+               gettextize --copy --force --no-changelog --intl; \
        fi; \
        if [ ! -f po/Makevars ]; then \
-           cp -f po/Makevars{.template,}; \
+               cp -f po/Makevars{.template,}; \
        fi; \
-    else \
+else \
        gettextize --copy --force; \
-    fi; \
+fi; \
 }
 
 %__glib_gettextize     glib-gettextize --copy --force
 %__intltoolize         intltoolize --copy --force
 %__libtoolize          libtoolize --copy --force
 
+#      The number of cvs changelog entries kept when building package.
+%_buildchangelogtruncate 20
+
 %dependencytracking    %{nil}
+
+#      Relations between package names that cause dependency loops
+#      with legacy packages that cannot be fixed. Relations are
+#      specified as
+#              p>q
+#      where package p has a Requires: on something that package q Provides:
+#
+# XXX  Note: that there cannot be any whitespace within the string "p>q",
+#      and that both p and q are package names (i.e. no version/release).
+%_dependency_whiteout  %{nil}
+
 #-----------------------------------------------------------------
 %configure2_13 { \
  if [ -n "$LINGUAS" ]; then unset LINGUAS; fi; \
        --sharedstatedir=%{_sharedstatedir} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
-       --x-libraries=/usr/X11R6/%{_lib} \
+       --x-libraries=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
        %{dependencytracking} \
 }
 
+%cmake { \
+CC="%{__cc}" \
+CXX="%{__cxx}" \
+CFLAGS="%{rpmcflags}" \
+CXXFLAGS="%{rpmcxxflags}" \
+cmake \
+}
+
 #----------------------------------------------------------------
 %global configure_cache 0
 %configure_cache_file   %{buildroot}.configure.cache
        --sharedstatedir=%{_sharedstatedir} \
        --mandir=%{_mandir} \
        --infodir=%{_infodir} \
-       --x-libraries=/usr/X11R6/%{_lib} \
+       --x-libraries=%{?_x_libraries}%{!?_x_libraries:%{_libdir}} \
        %{dependencytracking} \
        %{?configure_cache:--cache-file=%{configure_cache_file:-%{buildroot}.configure.cache}} \
 }
@@ -134,7 +139,10 @@ unset DISPLAY ||:\
 unset LINGUAS ||:\
 %{nil}
 
-%install %{?_enable_debug_packages:%{?buildsubdir:%{debug_package}}}\
+%install \
+%if 0%{?_enable_debug_packages}\
+%{?buildsubdir:%{debug_package}}\
+%endif\
 %%install\
 LANG=C\
 export LANG\
@@ -142,49 +150,6 @@ unset DISPLAY ||:\
 unset LINGUAS ||:\
 %{nil}
 
-# ------------------------------------------------------------------------
-# Conditional build stuff.
-
-# Check if symbol is defined.
-# Example usage: %if %{defined with_foo} && %{undefined with_bar} ...
-%defined()     %{expand:%%{?%{1}:1}%%{!?%{1}:0}}
-%undefined()   %{expand:%%{?%{1}:0}%%{!?%{1}:1}}
-
-# Shorthand for %{defined with_...}
-%with()                %{expand:%%{?with_%{1}:1}%%{!?with_%{1}:0}}
-%without()     %{expand:%%{?with_%{1}:0}%%{!?with_%{1}:1}}
-
-# Handle conditional builds. %bcond_with is for case when feature is
-# default off and needs to be activated with --with ... command line 
-# switch. %bcond_without is for the dual case.
-#
-# %bcond_with foo defines symbol with_foo if --with foo was specified on
-# command line.
-# %bcond_without foo defines symbol with_foo if --without foo was *not* 
-# specified on command line.
-#
-# For example:
-#
-# %bcond_with extra_fonts
-# %bcond_without static
-# %if %{with extra_fonts}
-# ...
-# %endif
-# %ifdef %{with static}
-# ...
-# %endif
-# %{?with_static: ... }
-# %{!?with_static: ... }
-# %{?with_extra_fonts: ... }
-# %{!?with_extra_fonts: ... }
-# 
-# The bottom line: never use without_foo, _with_foo nor _without_foo, only
-# with_foo. This way changing default set of bconds for given spec is just
-# a matter of changing single line in it and syntax is more readable.
-%bcond_with()          %{expand:%%{?_with_%{1}:%%global with_%{1} 1}}
-%bcond_without()       %{expand:%%{!?_without_%{1}:%%global with_%{1} 1}}
-# ------------------------------------------------------------------------
-
 # Location of autoconf macros
 %_aclocaldir   %(aclocal --print-ac-dir)
 
@@ -225,8 +190,11 @@ unset LINGUAS ||:\
 # Example files, programs, scripts...
 %_examplesdir  /usr/src/examples
 
+# Alternative kernel type/version
+%alt_kernel    %{nil}%{?_alt_kernel:-%{?_alt_kernel}}
+
 # The directory holding Linux kernel sources
-%_kernelsrcdir /usr/src/linux
+%_kernelsrcdir /usr/src/linux%{alt_kernel}
 
 # If non-empty "debug" macro defined, add "dbg" suffix to release number
 %_rpmfilename          %%{NAME}-%%{VERSION}-%%{RELEASE}%{?debug:dbg}.%%{ARCH}.rpm
@@ -234,29 +202,30 @@ unset LINGUAS ||:\
 # Requires name = version-release
 %requires_releq()              %(echo '%*' | LC_ALL="C" xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}-%%{release}\\n' | sed -e 's/ (none):/ /' | grep -v "is not")
 
-%releq_kernel_up()             %(LC_ALL="C" rpm -qf --qf '%%{name}-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
-%releq_kernel_smp()            %(LC_ALL="C" rpm -qf --qf '%%{name}-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
-%requires_releq_kernel_up()    %(LC_ALL="C" rpm -qf --qf 'PreReq: %%{name}-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
-%requires_releq_kernel_smp()   %(LC_ALL="C" rpm -qf --qf 'PreReq: %%{name}-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%releq_kernel_up()             %((LC_ALL="C" rpm -qf --qf '%%{name}-up = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h 2>/dev/null || echo ERROR) | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%releq_kernel_smp()            %((LC_ALL="C" rpm -qf --qf '%%{name}-smp = %%{epoch}:%%{version}-%%{release}\\n' %{_kernelsrcdir}/include/linux/version.h 2>/dev/null || echo ERROR) | sed -e 's/ (none):/ /' | sed -e 's:-headers::' | grep -vE "(is not|no such)")
+%requires_releq_kernel_up(s:)          Requires%{-s:(%{-s*})}: %releq_kernel_up
+%requires_releq_kernel_smp(s:)         Requires%{-s:(%{-s*})}: %releq_kernel_smp
 
+%requires_eq()         %(echo '%*' | LC_ALL="C" xargs -r rpm -q --qf 'Requires: %%{name} = %%{epoch}:%%{version}\\n' | sed -e 's/ (none):/ /' -e 's/ 0:/ /' | grep -v "is not")
 %requires_eq_to() %(LC_ALL="C" rpm -q --qf 'Requires: %1 = %%{epoch}:%%{version}\\n' %2 | sed -e 's/ (none):/ /' | grep -v "is not")
 
 %apache_modules_api %(awk '/#define MODULE_MAGIC_NUMBER_MAJOR/ {print $3}' /usr/include/apache/ap_mmn.h 2>/dev/null || echo ERROR)
 
 # kernel version-release handling
-%__kernel_ver    %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | head -n 1 | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } /^EXTRAVERSION/ { ever = $0; gsub(/EXTRAVERSION.*=/, NIL, ever); gsub(/ /, NIL, ever); } END { printf("%d.%d.%d%s", ver, plev, slev, ever); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
-%__kernel_rel    %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h 2>/dev/null --qf "%{RELEASE}" | grep -v "is not")
+%__kernel_ver  %([ -f %{_kernelsrcdir}/include/linux/version.h ] && (grep UTS_RELEASE %{_kernelsrcdir}/include/linux/version.h 2>/dev/null | head -n 1 | cut -d'"' -f2) || (awk '/^VERSION/ { ver = $0; gsub(/VERSION.*=/, NIL, ver); } /^PATCHLEVEL/ { plev = $0; gsub(/PATCHLEVEL.*=/, NIL, plev); } /^SUBLEVEL/ { slev = $0; gsub(/SUBLEVEL.*=/, NIL, slev); } /^EXTRAVERSION/ { ever = $0; gsub(/EXTRAVERSION.*=/, NIL, ever); gsub(/ /, NIL, ever); } END { printf("%d.%d.%d%s", ver, plev, slev, ever); }' %{_kernelsrcdir}/Makefile 2> /dev/null))
+%__kernel_rel  %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h 2>/dev/null --qf "%{RELEASE}" | grep -v "is not")
 %__kernel_rpmvr  %(LC_ALL="C" rpm -qf %{_kernelsrcdir}/include/linux/fs.h 2>/dev/null --qf "%{VERSION}-%{RELEASE}" | grep -v "is not")
-%_kernel_ver     %{__kernel_ver}%{?with_dist_kernel:%(echo %{__kernel_ver} | grep -q -e - || echo -%{__kernel_rel})}
+%_kernel_ver   %{__kernel_ver}%{?with_dist_kernel:%(echo %{__kernel_ver} | grep -q -e - || echo -%{__kernel_rel})}
 %_kernel_ver_str %(echo %{!?_without_dist_kernel:%{__kernel_rpmvr}}%{?_without_dist_kernel:%{__kernel_ver}} | sed -e 's/-/_/g')
 
 # sgml macros
-%xmlcat_add()            /usr/bin/xmlcatalog --noout --add nextCatalog \"\" %1 /etc/xml/catalog ;
-%xmlcat_del()            /usr/bin/xmlcatalog --noout --del %1 /etc/xml/catalog ;
-%xmlcat_add_rewrite      /usr/bin/xmlcatalog --noout --add rewriteSystem
-%xmlcat_create()          /usr/bin/xmlcatalog --noout --create %1 ;
-%sgmlcat_add()           /usr/bin/install-catalog --add %1 %2 > /dev/null ;
-%sgmlcat_del()           /usr/bin/install-catalog --remove %1 %2 > /dev/null ;
+%xmlcat_add()          /usr/bin/xmlcatalog --noout --add nextCatalog \"\" %1 /etc/xml/catalog ;
+%xmlcat_del()          /usr/bin/xmlcatalog --noout --del %1 /etc/xml/catalog ;
+%xmlcat_add_rewrite    /usr/bin/xmlcatalog --noout --add rewriteSystem
+%xmlcat_create()       /usr/bin/xmlcatalog --noout --create %1 ;
+%sgmlcat_add()         /usr/bin/install-catalog --add %1 %2 > /dev/null ;
+%sgmlcat_del()         /usr/bin/install-catalog --remove %1 %2 > /dev/null ;
 %docbook_sgmlcat_fix() { for l in \
 '' \
 '  -- default decl --' \
@@ -275,9 +244,8 @@ unset LINGUAS ||:\
 #
 #%no_install_post_compress_docs        1
 %__spec_install_post_compress_docs { \
-%{!?no_install_post_compress_docs: \
+%{!?no_install_post_compress_docs:__spec_install_post_compress_docs() { \
        echo "Compress man and info pages."; \
-       %{?verbose:set -x;} \
        for i in /usr/share/man /usr/X11R6/man /usr/share/info; do \
                if [ -d "$RPM_BUILD_ROOT$i" ]; then \
                        find "$RPM_BUILD_ROOT$i" -name \*.bz2 -print | xargs -r %{__bzip2} -df; \
@@ -285,7 +253,7 @@ unset LINGUAS ||:\
                        find "$RPM_BUILD_ROOT$i" -type f -print | xargs -r %{__gzip} -9nf; \
                fi; \
        done; \
-} }
+}; __spec_install_post_compress_docs } }
 
 #-----------------------------------------------------------------
 # Strip executable binaries and shared object files
@@ -294,11 +262,10 @@ unset LINGUAS ||:\
 #
 #%no_install_post_strip        1
 %__spec_install_post_strip {%{!?debug: \
-%{!?no_install_post_strip: \
-    %{?verbose:set -x;} \
-    if [ -d "$RPM_BUILD_ROOT" ]; then \
+%{!?no_install_post_strip:__spec_install_post_strip() { \
+       if [ -d "$RPM_BUILD_ROOT" ]; then \
        echo "Strip executable binaries, archives and shared object files."; \
-       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" %{?_noautostrip:! -regex "%{_noautostrip}"}`; \
+       filelist=`find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" ! -regex ".*/usr/lib[0-9]*/debug/.*\.debug" %{?_noautostrip:! -regex "%{_noautostrip}"}`; \
        elfexelist=`echo $filelist | xargs -r file | \
                awk '/ELF.*executable/ {print $1}' | cut -d: -f1`; \
        elfsharedlist=`echo $filelist | xargs -r file | \
@@ -314,8 +281,8 @@ unset LINGUAS ||:\
        if [ -n "$elfarchiveslist" ]; then \
                %{__strip} --strip-debug --remove-section=.note  --remove-section=.comment $elfarchiveslist; \
        fi; \
-    fi; } \
-} }
+fi; }; __spec_install_post_strip } } }
+
 #-----------------------------------------------------------------
 # remove all RPATH from executable binaries and shared object files
 #
@@ -323,8 +290,7 @@ unset LINGUAS ||:\
 #
 #%no_install_post_chrpath      1
 %__spec_install_post_chrpath {%{!?debug: \
-%{!?no_install_post_chrpath: \
-       %{?verbose:set -x;} \
+%{!?no_install_post_chrpath: __spec_install_post_chrpath() { \
 if [ -d "$RPM_BUILD_ROOT" ]; then \
 echo "Remove RPATH from executable binaries and shared object files."; \
 find $RPM_BUILD_ROOT -type f ! -regex ".*ld-[0-9.]*so.*" ! -regex ".*/usr/lib[0-9]*/debug/.*" %{?_noautochrpath:! -regex "%{_noautochrpath}"} | xargs -r file | \
@@ -333,7 +299,7 @@ while read file ; do \
        rpath= ; \
        chmod u+w "$file"; \
        for dir in `chrpath -l "$file" | \
-                   awk '/RPATH=/ { gsub(/.*RPATH=/,""); gsub(/:/," "); print $0 }'` ; do \
+                       awk '/RPATH=/ { gsub(/.*RPATH=/,""); gsub(/:/," "); print $0 }'` ; do \
                        case $dir in \
                        /home/* | /tmp/* | /usr/lib | /usr/lib64 | /lib | /lib64 | /usr/local/lib | /usr/local/lib64 | /usr/X11R6/lib | /usr/X11R6/lib64 ) \
                                echo "remove-rpath: $dir in $file"; \
@@ -347,8 +313,8 @@ while read file ; do \
        if [ "$rpath" = "" ] ; then chrpath -d "$file" > /dev/null ; \
        else chrpath -r "$rpath" "$file" > /dev/null ; fi ; \
 done; \
-fi; } \
-} }
+fi; }; __spec_install_post_chrpath } } }
+
 #-----------------------------------------------------------------
 # Find and gzip all kernel modules
 #
@@ -356,21 +322,23 @@ fi; } \
 #
 #%no_install_post_compress_modules  1
 %__spec_install_post_compress_modules { \
-%{!?no_install_post_compress_modules: \
-    %{?verbose:set -x;} \
-    if [ -d "$RPM_BUILD_ROOT" ]; then \
-echo "Compress kernel modules if any."; \
-    if test -d $RPM_BUILD_ROOT/lib/modules ; then \
-       find $RPM_BUILD_ROOT/lib/modules -name \*o -type f -print | \
-       xargs -r %{__gzip} -9nf; \
-          find $RPM_BUILD_ROOT/lib/modules -name \*o -type l -printf "%p %l\n" | \
-          while read a b; do ln -sf $b.gz $a.gz; rm -f $a; done; \
-    fi; \
-    fi; \
-} }
+%{!?no_install_post_compress_modules: __spec_install_post_compress_modules() { \
+       if [ -d "$RPM_BUILD_ROOT" ]; then \
+               echo "Compress kernel modules if any."; \
+               if test -d $RPM_BUILD_ROOT/lib/modules ; then \
+                       find $RPM_BUILD_ROOT/lib/modules -name \*o -type f -print | \
+                       xargs -r %{__gzip} -9nf; \
+                          find $RPM_BUILD_ROOT/lib/modules -name \*o -type l -printf "%p %l\n" | \
+                          while read a b; do ln -sf $b.gz $a.gz; rm -f $a; done; \
+               fi; \
+       fi; \
+}; __spec_install_post_compress_modules } }
 
-%_source_payload        w9.gzdio
-%_binary_payload        w9.bzdio
+# Remove common Perl files we don't package
+%__spec_install_post_perl_clean {\
+%{!?no_install_post_perl_clean: \
+%{?pdir:rm -f $RPM_BUILD_ROOT{%{perl_archlib}/perllocal.pod,%{perl_vendorarch}/auto/%{pdir}%{?pnam:/%(echo %{pnam} | tr - /)}/.packlist}} \
+} }
 
 #-----------------------------------------------------------------
 # Update GConf2 schemas
@@ -378,14 +346,14 @@ echo "Compress kernel modules if any."; \
 # Requires: GConf2
 #
 %gconf_schema_install() \
-    umask 022; \
-    GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/%{?1}%{!?1:*.schemas} > /dev/null \
-    %{nil}
+       umask 022; \
+       GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" /usr/bin/gconftool-2 --makefile-install-rule /etc/gconf/schemas/%{?1}%{!?1:*.schemas} > /dev/null \
+       %{nil}
 
 %gconf_schema_uninstall() \
 if [ $1 = 0 ]; then \
-    umask 022; \
-    GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/%{?1} > /dev/null \
+       umask 022; \
+       GCONF_CONFIG_SOURCE="xml:readwrite:/etc/gconf/gconf.xml.defaults" /usr/bin/gconftool-2 --makefile-uninstall-rule /etc/gconf/schemas/%{?1} > /dev/null \
 fi \
 %{nil}
 
@@ -463,69 +431,86 @@ fi \
 %__mono_requires %{nil}
 
 # Perl specific macro definitions.
-%perl_privlib  %(eval "`%{__perl} -V:installprivlib`"; echo $installprivlib)
-%perl_archlib  %(eval "`%{__perl} -V:installarchlib`"; echo $installarchlib)
-%perl_vendorlib        %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
+%perl_privlib          %(eval "`%{__perl} -V:installprivlib`"; echo $installprivlib)
+%perl_archlib          %(eval "`%{__perl} -V:installarchlib`"; echo $installarchlib)
+%perl_vendorlib                %(eval "`%{__perl} -V:installvendorlib`"; echo $installvendorlib)
 %perl_vendorarch       %(eval "`%{__perl} -V:installvendorarch`"; echo $installvendorarch)
-%perl_sitelib  %(eval "`%{__perl} -V:installsitelib`"; echo $installsitelib)
-%perl_sitearch %(eval "`%{__perl} -V:installsitearch`"; echo $installsitearch)
+%perl_sitelib          %(eval "`%{__perl} -V:installsitelib`"; echo $installsitelib)
+%perl_sitearch         %(eval "`%{__perl} -V:installsitearch`"; echo $installsitearch)
+
+# Ruby
+%ruby_archdir          %(ruby -r rbconfig -e 'print Config::CONFIG["archdir"]' 2>/dev/null || echo ERROR)
+%ruby_ridir            %(ruby -r rbconfig -e 'include Config; print File.join(CONFIG["datadir"], "ri", CONFIG["ruby_version"], "system")' 2>/dev/null || echo ERROR)
+%ruby_rubylibdir       %(ruby -r rbconfig -e 'print Config::CONFIG["rubylibdir"]' 2>/dev/null || echo ERROR)
+%ruby_sitearchdir      %(ruby -r rbconfig -e 'print Config::CONFIG["sitearchdir"]' 2>/dev/null || echo ERROR)
+%ruby_sitelibdir       %(ruby -r rbconfig -e 'print Config::CONFIG["sitelibdir"]' 2>/dev/null || echo ERROR)
+%ruby_version          %(ruby -r rbconfig -e 'print Config::CONFIG["ruby_version"]' 2>/dev/null || echo ERROR)
+%ruby_ver_requires_eq  Requires:       ruby(ver) = %ruby_version
+%ruby_mod_ver_requires_eq      Requires:       ruby-modules(ver) = %ruby_version
 
 %php_pear_dir  %{_datadir}/pear
 
-# extract php/zend api versions
-%php_api_version %(awk '/#define PHP_API_VERSION/{print $3}' /usr/include/php/main/php.h)
-%zend_module_api %(awk '/#define ZEND_MODULE_API_NO/{print $3}' /usr/include/php/Zend/zend_modules.h)
-%zend_extension_api %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' /usr/include/php/Zend/zend_extensions.h)
-
 # directory where php includes are installed on system.
 %__php_includedir              /usr/include/php
+# extract php/zend api versions
+%php_major_version             %(awk '/#define PHP_MAJOR_VERSION/{print $3}' %{__php_includedir}/main/php_version.h 2>/dev/null || echo ERROR)
 %php_api_version               %(awk '/#define PHP_API_VERSION/{print $3}' %{__php_includedir}/main/php.h 2>/dev/null || echo ERROR)
+%php_pdo_api_version   %(awk '/#define PDO_DRIVER_API/{print $3}' %{__php_includedir}/ext/pdo/php_pdo_driver.h 2>/dev/null || echo ERROR)
+%php_debug                             %(awk '/#define ZEND_DEBUG/{print $3}' %{__php_includedir}/main/php_config.h 2>/dev/null || echo ERROR)
 %zend_module_api               %(awk '/#define ZEND_MODULE_API_NO/{print $3}' %{__php_includedir}/Zend/zend_modules.h 2>/dev/null || echo ERROR)
 %zend_extension_api            %(awk '/#define ZEND_EXTENSION_API_NO/{print $3}' %{__php_includedir}/Zend/zend_extensions.h 2>/dev/null || echo ERROR)
+%zend_zts                              %(Z=$(grep -sc '^#define ZTS 1' %{__php_includedir}/main/php_config.h); echo ${Z:-ERROR})
 
 # helper macro
-%__php_api_requires() Requires: php(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
+%__php_api_requires(v:) Requires: php%{-v*}(%{expand:%1}) = %{expand:%{%{!?2:%{1}}%{?2}}}
 
 # macros for public use
 # for php extensions (php-pecl)
-%requires_php_extension %{__php_api_requires modules_api php_api_version}
+%requires_php_extension %{__php_api_requires modules_api php_api_version} \
+%{__php_api_requires -v %php_major_version debug php_debug} \
+%{__php_api_requires -v %php_major_version thread-safety zend_zts}
+
 # for zend extensions
 %requires_zend_extension %{__php_api_requires zend_module_api} \
-%{__php_api_requires zend_extension_api}
+%{__php_api_requires zend_extension_api} \
+%{__php_api_requires -v %php_major_version debug php_debug} \
+%{__php_api_requires -v %php_major_version thread-safety zend_zts}
+
+# for php pdo modules (php-pecl-PDO_*)
+%requires_php_pdo_module %{__php_api_requires PDO_API php_pdo_api_version}
 
 # Python specific macro definitions.
 # python main version
-%py_ver         %(echo `python -c "import sys; print sys.version[:3]"`)
+%py_ver                %(python -c "import sys; print sys.version[:3]")
 
 # directories
-%py_prefix      %(echo `python -c "import sys; print sys.prefix"`)
-%py_libdir      %{py_prefix}/%{_lib}/python%{py_ver}
+%py_prefix             %(python -c "import sys; print sys.prefix")
+%py_libdir             %{py_prefix}/%{_lib}/python%{py_ver}
 %py_scriptdir  %{py_prefix}/share/python%{py_ver}
-%py_incdir      /usr/include/python%{py_ver}
+%py_incdir             /usr/include/python%{py_ver}
 %py_sitedir    %{py_libdir}/site-packages
 %py_sitescriptdir %{py_scriptdir}/site-packages
-%py_dyndir      %{py_libdir}/lib-dynload
+%py_dyndir             %{py_libdir}/lib-dynload
 
 # pure python modules compilation
-%py_comp        python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
+%py_comp               python -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
 
-%py_ocomp       python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
+%py_ocomp              python -O -c "import compileall; import sys; compileall.compile_dir(sys.argv[1], ddir=sys.argv[1][len('$RPM_BUILD_ROOT'):])"
 
 # Software written in Python language require Python with main version
 %pyrequires_eq() Requires:     %1
 
-
 # Hardlink binary identical .pyc and .pyo files
 # (idea by glen <at> pld-linux <dot> org)
 %__spec_install_post_py_hardlink {\
-%{!?no_install_post_py_hardlink: \
+%{!?no_install_post_py_hardlink: __spec_install_post_py_hardlink() { \
 [ ! -d "$RPM_BUILD_ROOT" ] || find "$RPM_BUILD_ROOT" -name '*.pyc' | while read a; do \
        b="$(echo $a|sed -e 's/.pyc$/.pyo/')"; \
        if cmp -s "$a" "$b"; then \
                ln -f "$a" "$b"; \
        fi; \
 done \
-} }
+}; __spec_install_post_py_hardlink } }
 
 # remove python sources, so that check-files won't complain
 # (idea by glen <at> pld-linux <dot> org)
@@ -539,32 +524,30 @@ done \
 %depmod() { \
 umask 022; \
 if [ -e /boot/System.map-%1 ]; then \
-        /sbin/depmod -a -F /boot/System.map-%1 %1; \
+       /sbin/depmod -a -F /boot/System.map-%1 %1; \
 else \
-        if [ -e /boot/System.map ]; then \
-                /sbin/depmod -a -F /boot/System.map %1; \
-        else \
-                /sbin/depmod -a %1; \
-        fi \
+       if [ -e /boot/System.map ]; then \
+               /sbin/depmod -a -F /boot/System.map %1; \
+       else \
+               /sbin/depmod -a %1; \
+       fi \
 fi; \
 }
 
 # XMMS specific macros
-%xmms_prefix                  %(xmms-config --prefix 2>/dev/null)
-%xmms_exec_prefix             %(xmms-config --exec-prefix 2>/dev/null)
-%xmms_version                 %(xmms-config --version 2>/dev/null)
-%xmms_datadir                 %(xmms-config --data-dir 2>/dev/null)
-%xmms_plugindir               %(xmms-config --plugin-dir 2>/dev/null)
-%xmms_visualization_plugindir %(xmms-config --visualization-plugin-dir 2>/dev/null)
-%xmms_input_plugindir         %(xmms-config --input-plugin-dir 2>/dev/null)
-%xmms_output_plugindir        %(xmms-config --output-plugin-dir 2>/dev/null)
-%xmms_effect_plugindir        %(xmms-config --effect-plugin-dir 2>/dev/null)
-%xmms_general_plugindir       %(xmms-config --general-plugin-dir 2>/dev/null)
+%xmms_prefix                   %(xmms-config --prefix 2>/dev/null)
+%xmms_exec_prefix              %(xmms-config --exec-prefix 2>/dev/null)
+%xmms_version                  %(xmms-config --version 2>/dev/null)
+%xmms_datadir                  %(xmms-config --data-dir 2>/dev/null)
+%xmms_plugindir                        %(xmms-config --plugin-dir 2>/dev/null)
+%xmms_visualization_plugindir  %(xmms-config --visualization-plugin-dir 2>/dev/null)
+%xmms_input_plugindir          %(xmms-config --input-plugin-dir 2>/dev/null)
+%xmms_output_plugindir         %(xmms-config --output-plugin-dir 2>/dev/null)
+%xmms_effect_plugindir         %(xmms-config --effect-plugin-dir 2>/dev/null)
+%xmms_general_plugindir                %(xmms-config --general-plugin-dir 2>/dev/null)
 
 %_target_base_arch     %(echo %{_target_cpu} | sed 's/i.86/i386/;s/athlon/i386/;s/pentium./i386/;s/amd64/x86_64/;s/ia32e/x86_64/')
 
-%x8664                 x86_64 amd64 ia32e
-
 # user/group checking macros
 #
 # Usage:
@@ -628,7 +611,6 @@ eval $CMD %2%{?3: %3} \
 #  -d defaults to /usr/share/empty
 #  -c No default
 #  -r is accepted but ignored (it's always set)
-#  -m IGNORED. always set.
 #  -k skeleton dir. defaults to /usr/share/empty
 # rpm specific flags
 #  -P package name. defaults to %{name}
@@ -645,8 +627,7 @@ if [ -n "`/bin/id -u %{expand:%{%{#}}} 2>/dev/null`" ]; then \
 else \
        echo "Adding user %{expand:%{%{#}}} UID=%{-u*}." \
        /usr/sbin/useradd \\\
-               -m \\\
-               -k %{-k*}%{!-k:/usr/share/empty} \\\
+               %{-m:-m -k %{-k*}%{!-k:/usr/share/empty}} \\\
                -u %{-u*} \\\
                -r \\\
                -d %{-d*}%{!-d:/usr/share/empty} \\\
@@ -655,7 +636,8 @@ else \
                -g %{-g*} \\\
                %{-M} \\\
                %{-G:-G %{-G*}} \\\
-               %{expand:%{%{#}}} 1>&2 \
+               %{expand:%{%{#}}} 1>&2 || exit $? \
+       [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i passwd \
 fi;
 
 # Usage:
@@ -676,12 +658,15 @@ if [ -n "`/usr/bin/getgid %{1}`" ]; then \
        fi \
 else \
        echo "Adding group %{1} GID=%{-g*}." \
-       /usr/sbin/groupadd -g %{-g*} -r %{1} 1>&2 \
+       /usr/sbin/groupadd -g %{-g*} -r %{1} 1>&2 || exit $? \
+       [ ! -x /usr/sbin/nscd ] || /usr/sbin/nscd -i group \
 fi;
 
 # apache_config_{install/uninstall} macros written by glen@pld-linux.org.
 # All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
 #
+# You should use webapp macros instead. these are here until single piece of them is gone from specs ;)
+#
 # The config is installed/removed inside trigger, this means that you can any
 # time install apache1 or apache package and the configuration file is updated.
 # if you don't need the config for various reason for specific apache, just
@@ -701,6 +686,7 @@ fi;
 #  -v REQUIRED: specify apache version. can be 1 or 2.
 #  -c OPTIONAL: specify full path to PACKAGE's config. Defaults to %{_sysconfdir}/apache-%{name}.conf.
 #  -n OPTIONAL: specify config "slot". defaults to 99
+#  -f OPTIONAL: force symlink creation regardless if package was upraded. useful in triggers
 #
 # Internal macros. don't use ;).
 # expands apache config dir by apache version at build time.
@@ -708,10 +694,10 @@ fi;
 # expands apache service name by apache version at build time.
 %__apache_svcname() %(if [ %{1} = 1 ]; then echo apache; elif [ %{1} = 2 ]; then echo httpd; else echo >&2 Unknown apache version specified; fi)
 
-%apache_config_install(v:c:n:) \
+%apache_config_install(fv:c:n:) \
 %{!-v:%{error:apache_config_install: Required argument -v missing}} \
 %{?debug:set -x; echo "apache_config_install:%{-v*} %{name}-%{version}-%{release} 1:[$1]; 2:[$2]"} \
-if [ "$1" = "1" ] && [ "$2" = "1" ] && [ -d %{__apache_confdir %{-v*}} ]; then\
+if [ -n "%{-f:1}" ] || ([ "$1" = "1" ] && [ "$2" = "1" ]) && [ -d %{__apache_confdir %{-v*}} ]; then\
        ln -sf %{-c*}%{!-c:%{_sysconfdir}/apache-%{name}.conf} %{__apache_confdir %{-v*}}/%{-n*}%{!-n:99}_%{name}.conf\
 fi\
 # reload apache if the config symlink is there\
@@ -744,6 +730,43 @@ if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
 fi \
 %{nil}
 
+# webapp macros
+#
+# The config is installed/removed inside trigger, this means that you can any
+# time install apache1/apache/lighttpd package and the configuration file is
+# updated.  if you don't need the config for various reason for specific
+# webserver, just remove the symlink from config directory using webapp
+# program. the trigger will not recreate the symlink on upgrades. In other
+# words the config is linked to webserver config directory on first install of
+# PACKAGE or WEBSERVER.
+#
+# Add package's webserver config to webserver webapps dir.
+# Usage:
+#   %webapp_register WEBSERVER WEBAPP
+#
+%webapp_register() \
+%{?debug:set -x; echo "webapp_register: %{name}-%{version}-%{release} 1:[$1]; 2:[$2]"} \
+if [ "$1" = "1" ] && [ "$2" = "1" ]; then\
+       /usr/sbin/webapp register %1 %2\
+fi\
+# reload webserver if the config symlink is there and skip reload if webserver is upgraded\
+if [ -L /etc/%1/webapps.d/%2.conf ] && [ "$2" -lt "2" ]; then\
+       %{expand:%service -q %%1 reload}\
+fi\
+%{nil}
+
+# Remove package's config from webserver webapps dir.
+# Usage:
+#   %webapp_register [-f] WEBSERVER WEBAPP
+%webapp_unregister(f) \
+%{?debug:set -x; echo "webapp_unregister: %{name}-%{version}-%{release}: 1:[$1]; 2:[$2]"} \
+# remove link if either of the packages are gone \
+if [ -n "%{-f:1}" ] || [ "$1" = "0" ] || [ "$2" = "0" ] && [ -L /etc/%1/webapps.d/%2.conf ]; then \
+       /usr/sbin/webapp unregister %1 %2\
+       %{expand:%service -q %%1 reload}\
+fi \
+%{nil}
+
 # see browser-plugins.spec / template-browser-plugin.spec
 # written by glen@pld-linux.org.
 %nsplugin_install(d:f) { \
@@ -780,25 +803,8 @@ if [ "$1" = "0" ] || [ "$2" = "0" ]; then \
 # All rights reserved. Permission to copy is hereby granted.. yada, yada, yada
 #
 # Usage:
-#   %service [-q] SERVICE ACTION
-#
-#  -q be silent when service isn't started (for postun scriplets)
-#
-%service(q) {{ \
-# we use function, not to globber namespace with useless variables \
-skip_auto_restart() { \
-       . /etc/sysconfig/rpm; # global setting \
-       [ -f /etc/sysconfig/%1 ] && . /etc/sysconfig/%1; # per service setting \
-       echo ${RPM_SKIP_AUTO_RESTART:-no}; \
-}; \
-if [ -f /var/lock/subsys/%1 ]; then \
-       if [ $(skip_auto_restart) = no ]; then \
-               /etc/rc.d/init.d/%1 %2 1>&2; \
-       else \
-               echo 'Run "/etc/rc.d/init.d/%1 %2" to %2 %1 service.'; \
-       fi \
-else \
-       %{!-q:echo 'Run "/etc/rc.d/init.d/%1 start" to start %1 service.';} \
-       %{-q::;} \
-fi }; }
-
+#   %service [-q] SERVICE ACTION ["SERVICE NICE DESCRIPTION"]
+#
+#  -q be silent when service isn't started (for scriplets restaring other package's services)
+#
+%service(q) {{%(export quiet=%{-q:1}; /usr/lib/rpm/service_generator.sh %{*}) };}
This page took 0.089436 seconds and 4 git commands to generate.