]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm.macros
typo
[packages/rpm-build-macros.git] / rpm.macros
index 43b8cd2b77b6c2f472bf6ee04e44283254f0c16e..3f034b5d33f449bbad613db03d0b272d0ac28a85 100644 (file)
@@ -1,5 +1,102 @@
-%requires_eq() %(LC_ALL="C" rpm -q --queryformat 'Requires: %%{NAME} = %%{VERSION}' %1|grep -v "is not")
-%perl_sitearch  %(eval "`perl -V:installsitearch`"; echo $installsitearch)
-%perl_archlib  %(eval "`perl -V:installarchlib`"; echo $installarchlib)
-# %%requires_pkg macro is obsoletes. Use %%requires_eq instead
-#%requires_pkg() %(LC_ALL="C" rpm -q --queryformat 'Requires: %%{NAME} = %%{VERSION}' %1|grep -v "is not")
+# arch macro for Intel i?86 compatibile processors
+%ix86  i386 i486 i586 i686 i786 i886 i986
+
+#------------------------------------------------------------------------------
+# The GNUconfigure macro does the following:
+#       update config.guess and config.sub.
+#       regenerate all autoconf/automake files
+#       optionally change to a directory (make the directory if requested).
+#       run configure with correct prefix, platform, and CFLAGS.
+#       optionally restore current directory.
+#
+# Based on autogen.sh from GNOME and orginal GNUconfigure
+#
+%GNUconfigure(MCs:)      \
+  CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS; \
+  LDFLAGS="${LDFLAGS:-'%{-s:-s}'}"  ; export LDFLAGS; \
+  %{-C:_mydir="`pwd`"; %{-M: %{__mkdir} -p %{-C*};} cd %{-C*}} \
+  dirs="`find ${_mydir} -name configure.in -print`"; export dirs; \
+    for coin in `echo ${dirs}` \
+do \
+  dr=`dirname ${coin}`; \
+if test -f ${dr}/NO-AUTO-GEN; then \
+ : \
+else \
+     macrodirs=`sed -n -e 's,AM_ACLOCAL_INCLUDE(\(.*\)),\1,gp' < ${coin}`; \
+    ( cd ${dr}; \
+      aclocalinclude="${ACLOCAL_FLAGS}"; \
+      for k in ${macrodirs}; do \
+        if test -d ${k}; then \
+          aclocalinclude="${aclocalinclude} -I ${k}"; \
+        ##else \
+        ##  echo "**Warning**: No such directory \`${k}'.  Ignored." \
+        fi \
+      done \
+      if grep "^AM_GNU_GETTEXT" configure.in >/dev/null; then \
+        if grep "sed.*POTFILES" configure.in >/dev/null; then \
+          : do nothing -- we still have an old unmodified configure.in \
+        else \
+          test -r ${dr}/aclocal.m4 || touch ${dr}/aclocal.m4; \
+          echo "no" | gettextize --force --copy; \
+          test -r ${dr}/aclocal.m4 && %{__chmod} u+w ${dr}/aclocal.m4; \
+        fi \
+      fi \
+      if grep "^AM_PROG_LIBTOOL" configure.in >/dev/null; then \
+        %{__libtoolize} --force --copy; \
+      fi \
+      aclocal ${aclocalinclude}; \
+      if grep "^AM_CONFIG_HEADER" configure.in >/dev/null; then \
+        %{__autoheader}; \
+      fi \
+      echo "Running automake --gnu ${am_opt} ..."; \
+      %{__automake} --add-missing --gnu ${am_opt}; \
+      %{__autoconf}; \
+    ); \
+  fi \
+done \
+  %{-C:${_mydir}}%{!-C:.}/configure %{_target_platform} --prefix=%{_prefix} --exec-prefix=%{_exec_prefix} --bindir=%{_bindir} --sbindir=%{_sbindir} --sysconfdir=%{_sysconfdir} --datadir=%{_datadir} --includedir=%{_includedir} --libdir=%{_libdir} --libexecdir=%{_libexecdir} --localstatedir=%{_localstatedir} --sharedstatedir=%{_sharedstatedir} --mandir=%{_mandir} --infodir=%{_infodir} %* ; \
+  %{-C:cd ${_mydir}; unset _mydir}
+
+#-----------------------------------------------------------------
+%configure { CFLAGS="${CFLAGS:-%optflags}" ; export CFLAGS ; \
+ CXXFLAGS="${CXXFLAGS:-%optflags}" ; export CXXFLAGS ; \
+ FFLAGS="${FFLAGS:-%optflags}" ; export FFLAGS ; \
+ unset LINGUAS || : ; \
+ ./configure %{_target_platform} \
+       --prefix=%{_prefix} \
+       --exec-prefix=%{_exec_prefix} \
+       --bindir=%{_bindir} \
+       --sbindir=%{_sbindir} \
+       --sysconfdir=%{_sysconfdir} \
+       --datadir=%{_datadir} \
+       --includedir=%{_includedir} \
+       --libdir=%{_libdir} \
+       --libexecdir=%{_libexecdir} \
+       --localstatedir=%{_localstatedir} \
+       --sharedstatedir=%{_sharedstatedir} \
+       --mandir=%{_mandir} \
+       --infodir=%{_infodir} }
+
+# Location of autoconf macros
+%_aclocaldir   %(aclocal --print-ac-dir)
+
+# Fixed location of top applink dir
+%_applnkdir      /usr/X11R6/share/applnk
+
+# Current date
+%date          %(LC_ALL="C" date +"%a %b %d %Y")
+
+# tmp directory
+%tmpdir                %(echo "${TMPDIR:-/tmp}")
+
+# Example files, programs, scripts...
+%_examplesdir  /usr/src/examples
+
+# Find-requires and directories excluded from auto-req
+%_noautoreqdir         %{_defaultdocdir} %{_examplesdir}
+%_noautoreqdep         %{nil}
+#%__find_requires_pre  /usr/lib/rpm/find-requires-pre %{_noautoreqdir}
+#%__find_requires_core /usr/lib/rpm/find-requires
+#%__find_requires_post /usr/lib/rpm/find-requires-post
+#%__find_requires      %{__find_requires_pre} | %{__find_requires_core} | %{__find_requires_post}
+
This page took 0.030676 seconds and 4 git commands to generate.