]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm-build.sh
fetch tags before figuring out last tag
[packages/rpm-build-macros.git] / rpm-build.sh
old mode 100644 (file)
new mode 100755 (executable)
index ab0cc10..a04dc94
@@ -1,5 +1,4 @@
 # shell aliases and functions for PLD Developer
-# $Id$
 
 # set $dist, used by functions below
 [ -n "$dist" ] || dist=$(awk '/PLD Linux/ {print tolower($NF)}' /etc/pld-release 2>/dev/null | tr -d '()')
@@ -87,10 +86,22 @@ dist-verify() {
                ignore="$ignore kadu-module-xmms"
                # obsoleted by kadu 0.6.0
                ignore="$ignore kadu-theme-icons-crystal16 kadu-theme-icons-crystal22 kadu-theme-icons-nuvola16 kadu-theme-icons-nuvola22 kadu-module-iwait4u"
+               # obsoleted pear test packages
+               ignore="$ignore php-*-tests"
                # obsoleted
-               ignore="$ignore php-pear-Net_Ping-tests"
+               ignore="$ignore nmap-X11"
+               # mksd dependency not distributale
+               ignore="$ignore samba-vfs-vscan-mks"
+               # ibbackup is not distributale
+               ignore="$ignore innobackup"
+               # use ac-updates
+               ignore="$ignore ntp-client ntp"
+               # php4 only(php-pecl-tidy), for php<5.2(php-pecl-filter)
+               ignore="$ignore php-pecl-tidy php-pecl-filter"
+
                # renamed to vim-syntax-txt2tags
                ignore="$ignore txt2tags-vim"
+
                for a in $ignore; do
                        args="$args --ignore=$a"
                done
@@ -103,10 +114,15 @@ dist-verify() {
 
 # displays latest used tag for a specfile
 autotag() {
-       local out
-       for a in "$@"; do
-               s=${a%.spec}.spec
-               out=$(cvs status -v $s | awk "!/Sticky/&&/auto-$dist-/{if (!a++) print \$1}")
+       local out s
+       for s in "$@"; do
+               # strip branches
+               s=${s%:*}
+               # ensure package ends with .spec
+               s=${s%.spec}.spec
+               git fetch --tags
+               out=$(git for-each-ref --count=1 --sort=-authordate refs/tags/auto/$dist \
+                       --format='%(refname:short)')
                echo "$s:$out"
        done
 }
@@ -120,26 +136,31 @@ get-buildlog() {
                return
        fi
 
-       local al
+       local archlist
        case "$dist" in
        ac)
-               al='i686,i586,i386,athlon,alpha,sparc,amd64,ppc'
+               archlist='i686 i586 i386 athlon alpha sparc amd64 ppc'
                ;;
        th)
-               al='x86_64,athlon,i486,i686,ppc'
+               archlist='x86_64 i486 i686'
                ;;
        *)
                echo >&2 "get-buildlog: $dist buildlogs are /dev/null"
                return
        esac
 
-       local u a s=ftp://buildlogs.pld-linux.org
-       for u in `eval echo $s/$dist/{$al}/{OK,FAIL}/$p.bz2`; do
-               a=${u#$s/$dist/}; a=${a%%/*}
-               echo -n "Fetching $u... "
-               if wget -q $u -O .$p~; then
+       local url arch path ftp=ftp://buildlogs.pld-linux.org
+       for arch in $archlist; do
+               [ "$arch" ] || continue
+               path=${url#$ftp}
+               echo -n "Checking $p.$arch... "
+               url=$(lftp -c "debug 0;open $ftp; cls --sort=date -r /$dist/$arch/OK/$p,*.bz2 /$dist/$arch/FAIL/$p,*.bz2 | tail -n1")
+               url=$ftp$url
+
+               echo -n "$url... "
+               if wget -q $url -O .$p~; then
                        echo "OK"
-                       mv -f .$p~ $p.$a.bz2
+                       mv -f .$p~ $p.$arch.bz2
                else
                        echo "SKIP"
                        rm -f .$p~
@@ -186,7 +207,7 @@ urldiff() {
 # makes diff from kde svn path
 # requires: wget, tee
 kdediff() {
-       local url="$1"
+       local url="$1" r1 r2
        # --- branches/KDE/3.5/kdepim/kpilot/conduits/vcalconduit/vcalRecord.cc #624744:624745
        url=${url#*--- }
        echo >&2 "Process $url"
@@ -229,9 +250,9 @@ sfget() {
 
 dif() {
        if [ -t 1 ]; then
-               diff -ur "$@" | diffcol | less -R
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@" | diffcol | less -R
        else
-               diff -ur "$@"
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@"
        fi
 }
 
@@ -243,8 +264,7 @@ sed -e '
        s,^@@ ,\e[33m&,;
        s,^-,\e[35m&,;
        s,^+,\e[36m&,;
-       s,
-,\e[44m^M\e[49m,g;
+       s,\r,\e[44m^M\e[49m,g;
        s,      ,    ,g;
        s,\([^[:space:]]\)\([[:space:]]\+\)$,\1\e[41m\2\e[49m,g;
        s,$,\e[0m,
@@ -259,11 +279,11 @@ cvslog() {
        (builtin cd $d && cvs log ${f##*/})
 }
 
-# does diff between FILE and FILE~
+# does diff between FILE~ and FILE
 # the diff can be applied with patch -p1
 d() {
        local file="$1"
-       local dir
+       local dir diff
        if [[ "$file" = /* ]]; then
                # full path -- no idea where to strip
                dir=.
@@ -276,3 +296,15 @@ d() {
 
        (builtin cd "$dir"; dif $diff{~,})
 }
+
+rpmb() {
+       local SPEC SPECDIR arg
+       for arg in "$@"; do
+               case "$arg" in
+                       *.spec) SPEC="$arg"
+                               ;;
+               esac
+       done
+       SPECDIR=$(dirname "$(pwd)/${SPEC:-.}")
+       command rpmbuild --define "_specdir $SPECDIR" --define "_sourcedir $SPECDIR" "$@"
+}
This page took 0.057074 seconds and 4 git commands to generate.