]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm-build.sh
- added qt .qm support
[packages/rpm-build-macros.git] / rpm-build.sh
index 036c3c9275e80e08146d3a2769f91736f80db0d2..97a110d8facdf9ec39692870496064be12738349 100644 (file)
@@ -1,11 +1,10 @@
 # shell aliases and functions for PLD Developer
-# $Id$
 
 # set $dist, used by functions below
 [ -n "$dist" ] || dist=$(awk '/PLD Linux/ {print tolower($NF)}' /etc/pld-release 2>/dev/null | tr -d '()')
 
 case "$dist" in
-ac|th)
+ac|th|ti)
        ;;
 *)
        # invalid one ;)
@@ -15,14 +14,100 @@ esac
 if [ "$dist" ]; then
 
 alias ipoldek-$dist="poldek -q --sn $dist --cmd"
-alias $dist-requires="ipoldek-$dist what-requires"
 alias $dist-provides="ipoldek-$dist what-provides"
 alias $dist-tag="./builder -cf -T $(echo $dist | tr '[a-z]' '[A-Z]')-branch -r HEAD"
 alias $dist-verify=dist-verify
+alias $dist-requires=dist-requires
+
+# undo spec utf8
+# note: it will do it blindly, so any lang other than -pl is most likely broken
+specutfundo() {
+       local spec="$1"
+       iconv -futf8 -tlatin2 "$spec" > m
+       sed -e 's/\.UTF-8//' m > "$spec"
+       rm -f m
+}
+
+dist-requires() {
+       local opts deps
+       while [ $# -gt 0 ]; do
+               case "$1" in
+               --sn)
+                       opts="$opts $1 $2"
+                       shift
+                       ;;
+               -*)
+                       opts="$opts $1"
+                       ;;
+               *)
+                       deps="$deps $1"
+                       ;;
+               esac
+               shift
+       done
+
+       case "$dist" in
+       ac)
+               opts="$opts --sn=$dist-updates"
+               ;;
+       esac
+
+       poldek -q -Q --sn $dist $opts --cmd what-requires $deps
+}
 
 dist-verify() {
-       poldek --sn $dist --sn $dist-ready --up
-       poldek --sn $dist --sn $dist-ready --noignore --verify=deps "$@"
+       local args sn
+       sn="--sn $dist"
+
+       case "$dist" in
+       ac)
+               sn="$sn --sn $dist-updates"
+
+               local a ignore
+               # typo
+               ignore="$ignore kdenetwork-kopete-tool-conectionstatus"
+               # obsoleted
+               ignore="$ignore gimp-plugin-swfdec wine-drv-arts ntp-ntptrace"
+               # quake2@MAIN is now quake2forge, original quake2 restored to quake2
+               ignore="$ignore quake2-3dfx quake2-sdl quake2-sgl quake2-snd-alsa quake2-snd-ao quake2-snd-oss quake2-snd-sdl quake2-static"
+               # obsoleted
+               ignore="$ignore mozilla-firefox-lang-en apache1-mod_perl-devel libyasm-static"
+               # renamed (courier-authlib.spec, r1.54)
+               ignore="$ignore courier-authlib-userdb courier-authlib-pipe"
+               # obsoleted, squid 2.6
+               ignore="$ignore squid-winbind_acl squid-winbind_auth"
+               # obsoleted with 1.0.4
+               ignore="$ignore python-numpy-FFT python-numpy-MA python-numpy-RNG"
+               # subpkgs renamed
+               ignore="$ignore apache1-doc apache1-index"
+               # obsoleted by kadu-module-mediaplayer-amarok
+               ignore="$ignore kadu-module-amarok"
+               # obsoleted by kadu-module-mediaplayer-xmms
+               ignore="$ignore kadu-module-xmms"
+               # obsoleted by kadu 0.6.0
+               ignore="$ignore kadu-theme-icons-crystal16 kadu-theme-icons-crystal22 kadu-theme-icons-nuvola16 kadu-theme-icons-nuvola22 kadu-module-iwait4u"
+               # obsoleted pear test packages
+               ignore="$ignore php-*-tests"
+               # obsoleted
+               ignore="$ignore nmap-X11"
+               # mksd dependency not distributale
+               ignore="$ignore samba-vfs-vscan-mks"
+               # ibbackup is not distributale
+               ignore="$ignore innobackup"
+               # use ac-updates
+               ignore="$ignore ntp-client ntp"
+
+               # renamed to vim-syntax-txt2tags
+               ignore="$ignore txt2tags-vim"
+
+               for a in $ignore; do
+                       args="$args --ignore=$a"
+               done
+               ;;
+       esac
+
+       poldek $sn --up --upa -q "$@"
+       poldek $sn --uniq --noignore --verify=deps $args "$@"
 }
 
 # displays latest used tag for a specfile
@@ -30,11 +115,52 @@ autotag() {
        local out
        for a in "$@"; do
                s=${a%.spec}.spec
-               out=$(cvs status -v $s | awk "/auto-$dist-/{if (!a++) print \$1}")
+               out=$(cvs status -v $s | awk "!/Sticky/&&/auto-$dist-/{if (!a++) print \$1}")
                echo "$s:$out"
        done
 }
 
+get-buildlog() {
+       local p=$1
+       if [ -z "$p" ]; then
+               echo >&2 "Usage: get-buildlog PACKAGE"
+               echo >&2 ""
+               echo >&2 "Grabs buildlogs from pld builder for all arch."
+               return
+       fi
+
+       local archlist
+       case "$dist" in
+       ac)
+               archlist='i686 i586 i386 athlon alpha sparc amd64 ppc'
+               ;;
+       th)
+               archlist='x86_64 i486 i686'
+               ;;
+       *)
+               echo >&2 "get-buildlog: $dist buildlogs are /dev/null"
+               return
+       esac
+
+       local url arch ftp=ftp://buildlogs.pld-linux.org
+       for arch in $archlist; do
+               [ "$arch" ] || continue
+               path=${url#$ftp}
+               echo -n "Checking $p.$arch... "
+               url=$(lftp -c "debug 0;open $ftp; cls --sort=date -r /$dist/$arch/OK/$p,*.bz2 /$dist/$arch/FAIL/$p,*.bz2 | tail -n1")
+               url=$ftp$url
+
+               echo -n "$url... "
+               if wget -q $url -O .$p~; then
+                       echo "OK"
+                       mv -f .$p~ $p.$arch.bz2
+               else
+                       echo "SKIP"
+                       rm -f .$p~
+               fi
+       done
+}
+
 fi # no $dist set
 
 alias cv='cvs status -v'
@@ -83,8 +209,9 @@ kdediff() {
        r1=${r1%:*}
 
        #  http://websvn.kde.org/branches/KDE/3.5/kdepim/kpilot/conduits/vcalconduit/vcalRecord.cc?rev=624745&r1=612579&r2=624745&makepatch=1&diff_format=u
+       #  http://websvn.kde.org/branches/KDE/3.5/kdenetwork/kopete/protocols/oscar/aim/aimcontact.cpp?r1=609808&r2=673027&view=patch
        url=http://websvn.kde.org/${url% *}
-       url="$url?r1=$r1&r2=$r2&makepatch=1&diff_format=u"
+       url="$url?r1=$r1&r2=$r2&view=patch"
 
        if [ -t 1 ]; then
                wget "$url" -O -| tee m.patch | diffcol
@@ -105,6 +232,8 @@ pmerge() {
 sfget() {
        local url="$1"
        url="${url%?download}"
+       url="${url%?use_mirror=*}"
+       url="${url#http://downloads.}"
        url="http://dl.${url#http://prdownloads.}"
        # use mirror
        local mirror="http://nchc.dl.sourceforge.net"
@@ -114,9 +243,9 @@ sfget() {
 
 dif() {
        if [ -t 1 ]; then
-               diff -ur "$@" | diffcol | less -R
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@" | diffcol | less -R
        else
-               diff -ur "$@"
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@"
        fi
 }
 
@@ -128,11 +257,11 @@ sed -e '
        s,^@@ ,\e[33m&,;
        s,^-,\e[35m&,;
        s,^+,\e[36m&,;
-       s,\r,\e[44m^M\e[49m,g;
+       s,\r,\e[44m^M\e[49m,g;
        s,      ,    ,g;
        s,\([^[:space:]]\)\([[:space:]]\+\)$,\1\e[41m\2\e[49m,g;
        s,$,\e[0m,
-' "$@"
+' ${1:+"$@"}
 }
 
 # chdir to file location and do 'cvs log'
@@ -143,11 +272,11 @@ cvslog() {
        (builtin cd $d && cvs log ${f##*/})
 }
 
-# does diff between FILE and FILE~
+# does diff between FILE~ and FILE
 # the diff can be applied with patch -p1
 d() {
        local file="$1"
-       local dir=${file%/*}
+       local dir
        if [[ "$file" = /* ]]; then
                # full path -- no idea where to strip
                dir=.
@@ -160,3 +289,14 @@ d() {
 
        (builtin cd "$dir"; dif $diff{~,})
 }
+rpmb() {
+       local SPEC SPECDIR
+       for arg in "$@"; do
+               case "$arg" in
+                       *.spec) SPEC="$arg"
+                               ;;
+               esac
+       done
+       SPECDIR=$(dirname "$(pwd)/${SPEC:-.}")
+       command rpmbuild --define "_specdir $SPECDIR" --define "_sourcedir $SPECDIR" "$@"
+}
This page took 0.038554 seconds and 4 git commands to generate.