]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm-build.sh
- add %nagios_nrpe
[packages/rpm-build-macros.git] / rpm-build.sh
index 238672f90b801ac149e7a07456f4cc1797767304..937ea63df267808121db3c8a3e4367fd46a0a0fa 100644 (file)
@@ -88,8 +88,18 @@ dist-verify() {
                ignore="$ignore kadu-theme-icons-crystal16 kadu-theme-icons-crystal22 kadu-theme-icons-nuvola16 kadu-theme-icons-nuvola22 kadu-module-iwait4u"
                # obsoleted
                ignore="$ignore php-pear-Net_Ping-tests"
+               # obsoleted
+               ignore="$ignore nmap-X11"
+               # mksd dependency not distributale
+               ignore="$ignore samba-vfs-vscan-mks"
+               # ibbackup is not distributale
+               ignore="$ignore innobackup"
+               # use ac-updates
+               ignore="$ignore ntp-client ntp"
+
                # renamed to vim-syntax-txt2tags
                ignore="$ignore txt2tags-vim"
+
                for a in $ignore; do
                        args="$args --ignore=$a"
                done
@@ -119,26 +129,31 @@ get-buildlog() {
                return
        fi
 
-       local al
+       local archlist
        case "$dist" in
        ac)
-               al='i686,i586,i386,athlon,alpha,sparc,amd64,ppc'
+               archlist='i686 i586 i386 athlon alpha sparc amd64 ppc'
                ;;
        th)
-               al='x86_64,athlon,i486,i686,ppc'
+               archlist='x86_64 i486 i686'
                ;;
        *)
                echo >&2 "get-buildlog: $dist buildlogs are /dev/null"
                return
        esac
 
-       local u a s=ftp://buildlogs.pld-linux.org
-       for u in `eval echo $s/$dist/{$al}/{OK,FAIL}/$p.bz2`; do
-               a=${u#$s/$dist/}; a=${a%%/*}
-               echo -n "Fetching $u... "
-               if wget -q $u -O .$p~; then
+       local url arch ftp=ftp://buildlogs.pld-linux.org
+       for arch in $archlist; do
+               [ "$arch" ] || continue
+               path=${url#$ftp}
+               echo -n "Checking $p.$arch... "
+               url=$(lftp -c "debug 0;open $ftp; cls --sort=date -r /$dist/$arch/OK/$p,*.bz2 /$dist/$arch/FAIL/$p,*.bz2 | tail -n1")
+               url=$ftp$url
+
+               echo -n "$url... "
+               if wget -q $url -O .$p~; then
                        echo "OK"
-                       mv -f .$p~ $p.$a.bz2
+                       mv -f .$p~ $p.$arch.bz2
                else
                        echo "SKIP"
                        rm -f .$p~
@@ -228,9 +243,9 @@ sfget() {
 
 dif() {
        if [ -t 1 ]; then
-               diff -ur "$@" | diffcol | less -R
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@" | diffcol | less -R
        else
-               diff -ur "$@"
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@"
        fi
 }
 
@@ -242,7 +257,7 @@ sed -e '
        s,^@@ ,\e[33m&,;
        s,^-,\e[35m&,;
        s,^+,\e[36m&,;
-       s,\r,\e[44m^M\e[49m,g;
+       s,\r,\e[44m^M\e[49m,g;
        s,      ,    ,g;
        s,\([^[:space:]]\)\([[:space:]]\+\)$,\1\e[41m\2\e[49m,g;
        s,$,\e[0m,
@@ -274,3 +289,14 @@ d() {
 
        (builtin cd "$dir"; dif $diff{~,})
 }
+rpmb() {
+       local SPEC SPECDIR
+       for arg in "$@"; do
+               case "$arg" in
+                       *.spec) SPEC="$arg"
+                               ;;
+               esac
+       done
+       SPECDIR=$(dirname "$(pwd)/${SPEC:-.}")
+       command rpmbuild --define "_specdir $SPECDIR" --define "_sourcedir $SPECDIR" "$@"
+}
This page took 0.112436 seconds and 4 git commands to generate.