]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm-build.sh
- added %systemdunitdir macro
[packages/rpm-build-macros.git] / rpm-build.sh
index e3db8b9423537f17e52f69eff104774129c309c6..472d6c1d97afa51bc174d274340a2f61936fc759 100644 (file)
@@ -86,8 +86,8 @@ dist-verify() {
                ignore="$ignore kadu-module-xmms"
                # obsoleted by kadu 0.6.0
                ignore="$ignore kadu-theme-icons-crystal16 kadu-theme-icons-crystal22 kadu-theme-icons-nuvola16 kadu-theme-icons-nuvola22 kadu-module-iwait4u"
-               # obsoleted
-               ignore="$ignore php-pear-Net_Ping-tests"
+               # obsoleted pear test packages
+               ignore="$ignore php-*-tests"
                # obsoleted
                ignore="$ignore nmap-X11"
                # mksd dependency not distributale
@@ -112,9 +112,12 @@ dist-verify() {
 
 # displays latest used tag for a specfile
 autotag() {
-       local out
-       for a in "$@"; do
-               s=${a%.spec}.spec
+       local out s
+       for s in "$@"; do
+               # strip branches
+               s=${s%:*}
+               # ensure package ends with .spec
+               s=${s%.spec}.spec
                out=$(cvs status -v $s | awk "!/Sticky/&&/auto-$dist-/{if (!a++) print \$1}")
                echo "$s:$out"
        done
@@ -129,26 +132,31 @@ get-buildlog() {
                return
        fi
 
-       local al
+       local archlist
        case "$dist" in
        ac)
-               al='i686,i586,i386,athlon,alpha,sparc,amd64,ppc'
+               archlist='i686 i586 i386 athlon alpha sparc amd64 ppc'
                ;;
        th)
-               al='x86_64,athlon,i486,i686,ppc'
+               archlist='x86_64 i486 i686'
                ;;
        *)
                echo >&2 "get-buildlog: $dist buildlogs are /dev/null"
                return
        esac
 
-       local u a s=ftp://buildlogs.pld-linux.org
-       for u in `eval echo $s/$dist/{$al}/{OK,FAIL}/$p.bz2`; do
-               a=${u#$s/$dist/}; a=${a%%/*}
-               echo -n "Fetching $u... "
-               if wget -q $u -O .$p~; then
+       local url arch ftp=ftp://buildlogs.pld-linux.org
+       for arch in $archlist; do
+               [ "$arch" ] || continue
+               path=${url#$ftp}
+               echo -n "Checking $p.$arch... "
+               url=$(lftp -c "debug 0;open $ftp; cls --sort=date -r /$dist/$arch/OK/$p,*.bz2 /$dist/$arch/FAIL/$p,*.bz2 | tail -n1")
+               url=$ftp$url
+
+               echo -n "$url... "
+               if wget -q $url -O .$p~; then
                        echo "OK"
-                       mv -f .$p~ $p.$a.bz2
+                       mv -f .$p~ $p.$arch.bz2
                else
                        echo "SKIP"
                        rm -f .$p~
@@ -238,9 +246,9 @@ sfget() {
 
 dif() {
        if [ -t 1 ]; then
-               diff -ur "$@" | diffcol | less -R
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@" | diffcol | less -R
        else
-               diff -ur "$@"
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@"
        fi
 }
 
@@ -267,7 +275,7 @@ cvslog() {
        (builtin cd $d && cvs log ${f##*/})
 }
 
-# does diff between FILE and FILE~
+# does diff between FILE~ and FILE
 # the diff can be applied with patch -p1
 d() {
        local file="$1"
This page took 0.028341 seconds and 4 git commands to generate.