]> git.pld-linux.org Git - packages/rpm-build-macros.git/blobdiff - rpm-build.sh
- compress docs: if man link is in other section than current, we need to preserve...
[packages/rpm-build-macros.git] / rpm-build.sh
index 194cb5264917813a663321ad0c76b0f5d15b1cd0..472d6c1d97afa51bc174d274340a2f61936fc759 100644 (file)
@@ -1,5 +1,4 @@
 # shell aliases and functions for PLD Developer
-# $Id$
 
 # set $dist, used by functions below
 [ -n "$dist" ] || dist=$(awk '/PLD Linux/ {print tolower($NF)}' /etc/pld-release 2>/dev/null | tr -d '()')
@@ -59,6 +58,7 @@ dist-requires() {
 dist-verify() {
        local args sn
        sn="--sn $dist"
+
        case "$dist" in
        ac)
                sn="$sn --sn $dist-updates"
@@ -86,8 +86,20 @@ dist-verify() {
                ignore="$ignore kadu-module-xmms"
                # obsoleted by kadu 0.6.0
                ignore="$ignore kadu-theme-icons-crystal16 kadu-theme-icons-crystal22 kadu-theme-icons-nuvola16 kadu-theme-icons-nuvola22 kadu-module-iwait4u"
+               # obsoleted pear test packages
+               ignore="$ignore php-*-tests"
                # obsoleted
-               ignore="$ignore php-pear-Net_Ping-tests"
+               ignore="$ignore nmap-X11"
+               # mksd dependency not distributale
+               ignore="$ignore samba-vfs-vscan-mks"
+               # ibbackup is not distributale
+               ignore="$ignore innobackup"
+               # use ac-updates
+               ignore="$ignore ntp-client ntp"
+
+               # renamed to vim-syntax-txt2tags
+               ignore="$ignore txt2tags-vim"
+
                for a in $ignore; do
                        args="$args --ignore=$a"
                done
@@ -100,14 +112,58 @@ dist-verify() {
 
 # displays latest used tag for a specfile
 autotag() {
-       local out
-       for a in "$@"; do
-               s=${a%.spec}.spec
+       local out s
+       for s in "$@"; do
+               # strip branches
+               s=${s%:*}
+               # ensure package ends with .spec
+               s=${s%.spec}.spec
                out=$(cvs status -v $s | awk "!/Sticky/&&/auto-$dist-/{if (!a++) print \$1}")
                echo "$s:$out"
        done
 }
 
+get-buildlog() {
+       local p=$1
+       if [ -z "$p" ]; then
+               echo >&2 "Usage: get-buildlog PACKAGE"
+               echo >&2 ""
+               echo >&2 "Grabs buildlogs from pld builder for all arch."
+               return
+       fi
+
+       local archlist
+       case "$dist" in
+       ac)
+               archlist='i686 i586 i386 athlon alpha sparc amd64 ppc'
+               ;;
+       th)
+               archlist='x86_64 i486 i686'
+               ;;
+       *)
+               echo >&2 "get-buildlog: $dist buildlogs are /dev/null"
+               return
+       esac
+
+       local url arch ftp=ftp://buildlogs.pld-linux.org
+       for arch in $archlist; do
+               [ "$arch" ] || continue
+               path=${url#$ftp}
+               echo -n "Checking $p.$arch... "
+               url=$(lftp -c "debug 0;open $ftp; cls --sort=date -r /$dist/$arch/OK/$p,*.bz2 /$dist/$arch/FAIL/$p,*.bz2 | tail -n1")
+               url=$ftp$url
+
+               echo -n "$url... "
+               if wget -q $url -O .$p~; then
+                       echo "OK"
+                       mv -f .$p~ $p.$arch.bz2
+               else
+                       echo "SKIP"
+                       rm -f .$p~
+               fi
+       done
+}
+
 fi # no $dist set
 
 alias cv='cvs status -v'
@@ -190,9 +246,9 @@ sfget() {
 
 dif() {
        if [ -t 1 ]; then
-               diff -ur "$@" | diffcol | less -R
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@" | diffcol | less -R
        else
-               diff -ur "$@"
+               diff -ur -x .svn -x .git -x .bzr -x CVS "$@"
        fi
 }
 
@@ -204,11 +260,11 @@ sed -e '
        s,^@@ ,\e[33m&,;
        s,^-,\e[35m&,;
        s,^+,\e[36m&,;
-       s,\r,\e[44m^M\e[49m,g;
+       s,\r,\e[44m^M\e[49m,g;
        s,      ,    ,g;
        s,\([^[:space:]]\)\([[:space:]]\+\)$,\1\e[41m\2\e[49m,g;
        s,$,\e[0m,
-' "$@"
+' ${1:+"$@"}
 }
 
 # chdir to file location and do 'cvs log'
@@ -219,7 +275,7 @@ cvslog() {
        (builtin cd $d && cvs log ${f##*/})
 }
 
-# does diff between FILE and FILE~
+# does diff between FILE~ and FILE
 # the diff can be applied with patch -p1
 d() {
        local file="$1"
@@ -236,3 +292,14 @@ d() {
 
        (builtin cd "$dir"; dif $diff{~,})
 }
+rpmb() {
+       local SPEC SPECDIR
+       for arg in "$@"; do
+               case "$arg" in
+                       *.spec) SPEC="$arg"
+                               ;;
+               esac
+       done
+       SPECDIR=$(dirname "$(pwd)/${SPEC:-.}")
+       command rpmbuild --define "_specdir $SPECDIR" --define "_sourcedir $SPECDIR" "$@"
+}
This page took 0.655534 seconds and 4 git commands to generate.