]> git.pld-linux.org Git - packages/rpm-build-macros.git/blob - rpm-build-macros.spec
- we're looking for fixed srtings here
[packages/rpm-build-macros.git] / rpm-build-macros.spec
1 %define         rpm_macros_rev  1.637
2 %define         find_lang_rev   1.35
3 Summary:        PLD Linux RPM build macros
4 Summary(pl.UTF-8):      Makra do budowania pakietów RPM dla Linuksa PLD
5 Name:           rpm-build-macros
6 Version:        %{rpm_macros_rev}
7 Release:        1
8 License:        GPL
9 Group:          Development/Building
10 Source0:        rpm.macros
11 Source1:        service_generator.sh
12 Source2:        rpm-build.sh
13 Source3:        rpm-find-lang
14 Source4:        dokuwiki-find-lang.sh
15 #Patch0:                %{name}-pydebuginfo.patch
16 BuildRequires:  rpm >= 4.4.9-56
17 Requires:       findutils >= 1:4.2.26
18 Provides:       rpmbuild(find_lang) = %{find_lang_rev}
19 Provides:       rpmbuild(macros) = %{rpm_macros_rev}
20 Obsoletes:      rpm-macros
21 # rm: option `--interactive' doesn't allow an argument
22 Conflicts:      coreutils < 6.9
23 Conflicts:      gettext-devel < 0.11
24 # tmpdir/_tmppath macros problems; optcppflags missing
25 Conflicts:      rpm < 4.4.9-72
26 # php-config --sysconfdir
27 Conflicts:      php-devel < 4:5.2.0-3
28 Conflicts:      php4-devel < 3:4.4.4-10
29 # sysconfig module with proper 'purelib' path
30 Conflicts:      python3 < 1:3.2.1-3
31 %if "%{pld_release}" != "ac"
32 # libtool --install
33 Conflicts:      libtool < 2:2.2
34 %endif
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 # redefine to bootstrap
39 %define         _usrlibrpm %{_prefix}/lib/rpm
40
41 %description
42 This package contains rpm build macros for PLD Linux.
43
44 %description -l pl.UTF-8
45 Ten pakiet zawiera makra rpm-a do budowania pakietów dla Linuksa PLD.
46
47 %prep
48 %setup -qcT
49 cp %{SOURCE0} .
50 #%patch0 -p1
51
52 %if "%{pld_release}" == "ac"
53 %{__sed} -i -e '/libtoolize --copy --force --install/s/ --install//' rpm.macros
54 %endif
55
56 %build
57 rev=$(awk '/^#.*Revision:.*Date/{print $3}' rpm.macros)
58 if [ "$rev" != "%rpm_macros_rev" ]; then
59         : Update rpm_macros_rev define to $rev, and retry
60         exit 1
61 fi
62 rev=$(awk '/^#.*Id:.*/{print $4}' %{SOURCE3})
63 if [ "$rev" != "%find_lang_rev" ]; then
64         : Update find_lang_rev define to $rev, and retry
65         exit 1
66 fi
67
68 %install
69 rm -rf $RPM_BUILD_ROOT
70 install -d $RPM_BUILD_ROOT{%{_usrlibrpm},/etc/shrc.d}
71 cp -a rpm.macros $RPM_BUILD_ROOT%{_usrlibrpm}/macros.build
72 install -p %{SOURCE1} $RPM_BUILD_ROOT%{_usrlibrpm}/service_generator.sh
73 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/shrc.d/rpm-build.sh
74 install -p %{SOURCE3} $RPM_BUILD_ROOT%{_usrlibrpm}/find-lang.sh
75 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_usrlibrpm}
76
77 %clean
78 rm -rf $RPM_BUILD_ROOT
79
80 %files
81 %defattr(644,root,root,755)
82 %{_usrlibrpm}/macros.build
83 %attr(755,root,root) %{_usrlibrpm}/service_generator.sh
84 %attr(755,root,root) %{_usrlibrpm}/find-lang.sh
85 %attr(755,root,root) %{_usrlibrpm}/dokuwiki-find-lang.sh
86 /etc/shrc.d/rpm-build.sh
This page took 0.08593 seconds and 4 git commands to generate.