]> git.pld-linux.org Git - packages/rocksdb.git/blame - rocksdb.spec
- updated to 4.4.1 (note: new soname)
[packages/rocksdb.git] / rocksdb.spec
CommitLineData
d120039a 1# TODO: hdfs/java
b427c498
ER
2#
3# Conditional build:
4%bcond_with tests # build with tests
5%bcond_without static_libs # don't build static libraries
6
c4a98ad2
JB
7Summary: RocksDB: A Persistent Key-Value Store for Flash and RAM Storage
8Summary(pl.UTF-8): RocksDB - trwała baza danych klucz-wartość dla pamięci Flash i RAM
9Name: rocksdb
d120039a 10Version: 4.4.1
c4a98ad2
JB
11Release: 1
12License: BSD
13Group: Libraries
d120039a 14#Source0Download: https://github.com/facebook/rocksdb/releases
c4a98ad2 15Source0: https://github.com/facebook/rocksdb/archive/%{name}-%{version}.tar.gz
d120039a 16# Source0-md5: ad38c27c09cea873296bfba68594335c
c4a98ad2 17Patch0: %{name}-libdir.patch
b427c498 18Patch1: make-programs.patch
d120039a 19Patch2: %{name}-numa.patch
c4a98ad2
JB
20URL: http://rocksdb.org/
21BuildRequires: bzip2-devel
22BuildRequires: gflags-devel
d120039a
JB
23# libtcmalloc also supported, but jemalloc is preferred
24BuildRequires: jemalloc-devel
1225ec57
JB
25%ifarch i386 i486
26BuildRequires: libatomic-devel
27%endif
c4a98ad2 28BuildRequires: libstdc++-devel >= 6:4.7
c4a98ad2 29BuildRequires: lz4-devel
d120039a 30BuildRequires: numactl-devel
c4a98ad2
JB
31BuildRequires: snappy-devel
32BuildRequires: zlib-devel
d120039a 33BuildRequires: zstd-devel
c4a98ad2
JB
34BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
b136638d
JB
36# std::__once_call, std::__once_callable non-function symbols
37%define skip_post_check_so librocksdb.so.*
38
c4a98ad2
JB
39%description
40RocksDB is a Persistent Key-Value Store for Flash and RAM Storage.
41
42%description -l pl.UTF-8
43RocksDB to trwała baza danych klucz-wartość dla pamięci Flash i RAM.
44
45%package devel
46Summary: Header files for RocksDB library
47Summary(pl.UTF-8): Pliki nagłówkowe biblioteki RocksDB
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50Requires: libstdc++-devel >= 6:4.7
51
52%description devel
53Header files for RocksDB library.
54
55%description devel -l pl.UTF-8
56Pliki nagłówkowe biblioteki RocksDB.
57
58%package static
59Summary: Static RocksDB library
60Summary(pl.UTF-8): Statyczna biblioteka RocksDB
61Group: Development/Libraries
62Requires: %{name}-devel = %{version}-%{release}
63
64%description static
65Static RocksDB library.
66
67%description static -l pl.UTF-8
68Statyczna biblioteka RocksDB.
69
70%prep
71%setup -q -n %{name}-%{name}-%{version}
72%patch0 -p1
b427c498 73%patch1 -p1
d120039a 74%patch2 -p1
c4a98ad2
JB
75
76%build
1225ec57
JB
77%ifarch i386 i486
78PLATFORM_LDFLAGS="-latomic" \
79%endif
b427c498 80%{__make} shared_lib %{?with_static_libs:static_lib} programs %{?with_tests:check} \
83ab867a 81 AM_DEFAULT_VERBOSITY=1 \
c4a98ad2
JB
82 CC="%{__cc}" \
83 CXX="%{__cxx}" \
84 OPT="%{rpmcflags} %{!?debug:-DNDEBUG}" \
d120039a
JB
85 PORTABLE=1 \
86 %{!?with_debug:DEBUG_LEVEL=0}
c4a98ad2
JB
87 WARNING_FLAGS="%{rpmcppflags} -Wall"
88
89%install
90rm -rf $RPM_BUILD_ROOT
d120039a 91
c4a98ad2 92%{__make} install \
d120039a 93 %{!?with_debug:DEBUG_LEVEL=0} \
c4a98ad2 94 INSTALL_PATH=$RPM_BUILD_ROOT%{_prefix} \
b136638d
JB
95 INSTALL_LIBDIR=$RPM_BUILD_ROOT%{_libdir}
96
97# reduntant symlink
d120039a 98%{__rm} $RPM_BUILD_ROOT%{_libdir}/librocksdb.so.4
c4a98ad2
JB
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post -p /sbin/ldconfig
104%postun -p /sbin/ldconfig
105
106%files
107%defattr(644,root,root,755)
108%doc HISTORY.md LICENSE PATENTS README.md ROCKSDB_LITE.md
b136638d 109%attr(755,root,root) %{_libdir}/librocksdb.so.*.*.*
d120039a 110%attr(755,root,root) %ghost %{_libdir}/librocksdb.so.4.4
c4a98ad2
JB
111
112%files devel
113%defattr(644,root,root,755)
114%doc doc/*
b136638d 115%attr(755,root,root) %{_libdir}/librocksdb.so
c4a98ad2
JB
116%{_includedir}/rocksdb
117
b427c498 118%if %{with static_libs}
c4a98ad2
JB
119%files static
120%defattr(644,root,root,755)
121%{_libdir}/librocksdb.a
b427c498 122%endif
This page took 0.111852 seconds and 4 git commands to generate.