]> git.pld-linux.org Git - packages/ristretto.git/commitdiff
- obsolete
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 21 Jan 2012 20:58:46 +0000 (20:58 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    ristretto-nodebug.patch -> 1.2
    ristretto-scale-state.patch -> 1.2
    ristretto-ui.patch -> 1.2

ristretto-nodebug.patch [deleted file]
ristretto-scale-state.patch [deleted file]
ristretto-ui.patch [deleted file]

diff --git a/ristretto-nodebug.patch b/ristretto-nodebug.patch
deleted file mode 100644 (file)
index 64bf1cd..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-commit 565519daa73bc7a737739b3ea618d076b159c7be
-Author: Stephan Arts <stephan@xfce.org>
-Date:   Mon Nov 15 20:07:29 2010 +0100
-
-    Remove debug output
-
-diff --git a/src/image.c b/src/image.c
-index 2e45a98..9b3c2ce 100644
---- a/src/image.c
-+++ b/src/image.c
-@@ -314,7 +314,7 @@ rstto_image_new (GFile *file)
- gboolean
- rstto_image_load (RsttoImage *image, gboolean empty_cache, gdouble scale, gboolean preload, GError **error)
- {
--    g_debug("%s: %f", __FUNCTION__, scale);
-+    /* g_debug("%s: %f", __FUNCTION__, scale); */
-     RsttoImageCache *cache;
-     g_return_val_if_fail (image != NULL, FALSE);
diff --git a/ristretto-scale-state.patch b/ristretto-scale-state.patch
deleted file mode 100644 (file)
index e8307ff..0000000
+++ /dev/null
@@ -1,346 +0,0 @@
-commit 048812613c8e8a77d1afb9b9cceb9fc8ed864572
-Author: Stephan Arts <stephan@xfce.org>
-Date:   Wed Sep 22 04:40:34 2010 +0200
-
-    - Fix saving of scale-state on images
-    - Set 'local_only' property to false on filechooser
-
-diff --git a/src/image.c b/src/image.c
-index f0344cc..2e45a98 100644
---- a/src/image.c
-+++ b/src/image.c
-@@ -34,6 +34,8 @@
- #define RSTTO_IMAGE_BUFFER_SIZE 131072
- #endif
-+#define STD_IMAGE_SIZE 1024
-+
- enum
- {
-     RSTTO_IMAGE_SIGNAL_UPDATED= 0,
-@@ -114,7 +116,7 @@ struct _RsttoImagePriv
-     GdkPixbuf *pixbuf;
-     gint       width;
-     gint       height;
--    guint      max_size;
-+    gdouble    scale;
-     /* Animation data for animated images (like .gif/.mng) */
-     /*******************************************************/
-@@ -310,8 +312,9 @@ rstto_image_new (GFile *file)
-  * Return value: TRUE on success.
-  */
- gboolean
--rstto_image_load (RsttoImage *image, gboolean empty_cache, guint max_size, gboolean preload, GError **error)
-+rstto_image_load (RsttoImage *image, gboolean empty_cache, gdouble scale, gboolean preload, GError **error)
- {
-+    g_debug("%s: %f", __FUNCTION__, scale);
-     RsttoImageCache *cache;
-     g_return_val_if_fail (image != NULL, FALSE);
-@@ -320,8 +323,8 @@ rstto_image_load (RsttoImage *image, gboolean empty_cache, guint max_size, gbool
-     g_cancellable_reset (image->priv->cancellable);
--    /* NEW */
--    image->priv->max_size = max_size;
-+    /* Image scale */
-+    image->priv->scale = scale;
-     /* Check if a GIOChannel is present, if so... the load is already in progress */
-     /* The image needs to be loaded if:
-@@ -680,11 +682,27 @@ cb_rstto_image_size_prepared (GdkPixbufLoader *loader, gint width, gint height,
-     image->priv->width = width;
-     image->priv->height = height;
--    if (image->priv->max_size > 0)
-+    if (image->priv->scale > 0.0)
-+    {
-+      gdk_pixbuf_loader_set_size (loader, (gint)((gdouble)width*image->priv->scale), (gint)((gdouble)height*image->priv->scale));
-+    }
-+    else
-     {
--        gdouble ratio = (gdouble)(image->priv->max_size)/(gdouble)(width * height);
--        if (ratio < 1)
--          gdk_pixbuf_loader_set_size (loader, width*ratio, height*ratio);
-+        if (width > height)
-+        {
-+            if (width > STD_IMAGE_SIZE)
-+            {
-+              gdk_pixbuf_loader_set_size (loader, STD_IMAGE_SIZE, (height*STD_IMAGE_SIZE)/width);
-+            }
-+        }
-+        else
-+        {
-+            if (height > STD_IMAGE_SIZE)
-+            {
-+              gdk_pixbuf_loader_set_size (loader, (width*STD_IMAGE_SIZE)/height, STD_IMAGE_SIZE);
-+            }
-+
-+        }
-     }
-     g_signal_emit(G_OBJECT(image), rstto_image_signals[RSTTO_IMAGE_SIGNAL_PREPARED], 0, image, NULL);
-diff --git a/src/image.h b/src/image.h
-index 1e17346..a36659b 100644
---- a/src/image.h
-+++ b/src/image.h
-@@ -81,7 +81,7 @@ gint rstto_image_get_height (RsttoImage *image);
- GFile *rstto_image_get_file (RsttoImage *image);
- void rstto_image_unload (RsttoImage *image);
--gboolean rstto_image_load (RsttoImage *image, gboolean empty_cache, guint max_size, gboolean preload, GError **error);
-+gboolean rstto_image_load (RsttoImage *image, gboolean empty_cache, gdouble scale, gboolean preload, GError **error);
- guint64 rstto_image_get_size (RsttoImage *image);
-diff --git a/src/main.c b/src/main.c
-index cc51e6c..a69c683 100644
---- a/src/main.c
-+++ b/src/main.c
-@@ -84,6 +84,9 @@ main(int argc, char **argv)
-     textdomain (GETTEXT_PACKAGE);
-     #endif
-+    g_thread_init(NULL);
-+    gdk_threads_init();
-+
-     if(!gtk_init_with_args(&argc, &argv, "", entries, PACKAGE, &cli_error))
-     {
-         if (cli_error != NULL)
-@@ -126,7 +129,9 @@ main(int argc, char **argv)
-     g_signal_connect(G_OBJECT(window), "destroy", G_CALLBACK(gtk_main_quit), NULL);
-     gtk_widget_show_all (window);
-+    GDK_THREADS_ENTER();
-     gtk_main();
-+    GDK_THREADS_LEAVE();
-     g_object_unref (settings);
-diff --git a/src/main_window.c b/src/main_window.c
-index a96e94f..747496f 100644
---- a/src/main_window.c
-+++ b/src/main_window.c
-@@ -1680,10 +1680,10 @@ cb_rstto_main_window_image_list_new_image (RsttoImageList *image_list, RsttoImag
-     else
-     {
-         rstto_image_list_iter_find_image (window->priv->iter, image);
-+        rstto_main_window_image_list_iter_changed (window);
-     }
-     window->priv->open_image_timer_id = g_timeout_add (
-             1000, rstto_window_open_image_timer, window);
--    rstto_main_window_image_list_iter_changed (window);
- }
- static gboolean
-@@ -1946,6 +1946,8 @@ cb_rstto_main_window_open_image (GtkWidget *widget, RsttoMainWindow *window)
-                                          NULL);
-     gtk_file_chooser_set_select_multiple (GTK_FILE_CHOOSER (dialog), TRUE);
-+    gtk_file_chooser_set_local_only (GTK_FILE_CHOOSER (dialog), FALSE);
-+
-     if (g_value_get_string (&current_uri_val))
-         gtk_file_chooser_set_current_folder_uri (GTK_FILE_CHOOSER (dialog), g_value_get_string (&current_uri_val));
-@@ -1957,6 +1959,7 @@ cb_rstto_main_window_open_image (GtkWidget *widget, RsttoMainWindow *window)
-     gtk_file_filter_add_mime_type (filter, "image/jpeg");
-     gtk_file_filter_set_name (filter, _(".jp(e)g"));
-     gtk_file_chooser_add_filter (GTK_FILE_CHOOSER (dialog), filter);
-+    gtk_file_chooser_set_local_only (GTK_FILE_CHOOSER(dialog), FALSE);
-     response = gtk_dialog_run(GTK_DIALOG(dialog));
-diff --git a/src/picture_viewer.c b/src/picture_viewer.c
-index 5c23703..b171a39 100644
---- a/src/picture_viewer.c
-+++ b/src/picture_viewer.c
-@@ -771,6 +771,9 @@ rstto_picture_viewer_set_scale (RsttoPictureViewer *viewer, gdouble scale)
-              * since the old and new values are required in the above code
-              */
-             *img_scale = scale;
-+            g_object_set_data (G_OBJECT (viewer->priv->image), "viewer-scale", img_scale);
-+
-+            rstto_image_load (viewer->priv->image, TRUE, scale, FALSE, NULL);
-             rstto_picture_viewer_queued_repaint (viewer, TRUE);
-         }
-@@ -896,6 +899,8 @@ cb_rstto_picture_viewer_scroll_event (RsttoPictureViewer *viewer, GdkEventScroll
-                     break;
-             }
-+
-+            rstto_picture_viewer_set_scale (viewer, *p_scale);
-             gtk_adjustment_value_changed(viewer->hadjustment);
-             gtk_adjustment_value_changed(viewer->vadjustment);
-             viewer->priv->repaint.idle_id = g_idle_add((GSourceFunc)cb_rstto_picture_viewer_queued_repaint, viewer);
-@@ -1479,6 +1484,7 @@ cb_rstto_picture_viewer_button_release_event (RsttoPictureViewer *viewer, GdkEve
-                             }
-                             g_object_set_data (G_OBJECT(viewer->priv->image), "viewer-scale", scale);
-+                            rstto_picture_viewer_set_scale(viewer, *scale);
-                             if(viewer->hadjustment)
-                             {
-@@ -1594,8 +1600,7 @@ rstto_picture_viewer_set_zoom_mode(RsttoPictureViewer *viewer, RsttoZoomMode mod
-                 g_object_set_data (G_OBJECT (viewer->priv->image), "viewer-fit-to-screen", p_fit_to_screen);
-             }
-             scale = rstto_picture_viewer_calculate_scale (viewer);
--            if (scale != -1.0)
--                rstto_picture_viewer_set_scale (viewer, scale);
-+            rstto_picture_viewer_set_scale (viewer, scale);
-             break;
-         case RSTTO_ZOOM_MODE_100:
-             if (viewer->priv->image)
-@@ -1658,7 +1663,7 @@ rstto_picture_viewer_set_image (RsttoPictureViewer *viewer, RsttoImage *image)
-             g_object_set_data (G_OBJECT (viewer->priv->image), "viewer-fit-to-screen", fit_to_screen);
-         }
--        rstto_image_load (viewer->priv->image, FALSE, g_value_get_uint (&max_size), FALSE, NULL);
-+        rstto_image_load (viewer->priv->image, FALSE, *scale, FALSE, NULL);
-     }
-     else
-     {
-diff --git a/src/preferences_dialog.c b/src/preferences_dialog.c
-index d18c6f6..8455e20 100644
---- a/src/preferences_dialog.c
-+++ b/src/preferences_dialog.c
-@@ -50,8 +50,6 @@ cb_rstto_preferences_dialog_cache_preload_check_button_toggled (GtkToggleButton
- static void
- cb_rstto_preferences_dialog_cache_spin_button_value_changed (GtkSpinButton *, gpointer);
- static void
--cb_rstto_preferences_dialog_image_quality_combo_box_changed (GtkComboBox *, gpointer);
--static void
- cb_rstto_preferences_dialog_image_preview_toggled (GtkToggleButton *button, 
-                                                       gpointer user_data);
- static void
-@@ -90,12 +88,6 @@ struct _RsttoPreferencesDialogPriv
-         GtkWidget *bgcolor_color_button;
-         GtkWidget *bgcolor_override_check_button;
--
--        GtkWidget *image_quality_frame;
--        GtkWidget *image_quality_vbox;
--        GtkWidget *image_quality_hbox;
--        GtkWidget *image_quality_label;
--        GtkWidget *image_quality_combo;
-         GtkWidget *image_preview_check_button;
-     } display_tab;
-@@ -176,7 +168,6 @@ rstto_preferences_dialog_get_type (void)
- static void
- rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
- {
--    guint uint_image_quality;
-     guint uint_cache_size;
-     gboolean bool_preload_images;
-     gboolean bool_enable_cache;
-@@ -208,7 +199,6 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     dialog->priv->settings = rstto_settings_new ();
-     g_object_get (G_OBJECT (dialog->priv->settings),
--                  "image-quality", &uint_image_quality,
-                   "cache-size", &uint_cache_size,
-                   "show-preview", &bool_show_preview,
-                   "preload-images", &bool_preload_images,
-@@ -261,15 +251,6 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     g_signal_connect (G_OBJECT (dialog->priv->display_tab.bgcolor_color_button), 
-                       "color-set", G_CALLBACK (cb_rstto_preferences_dialog_bgcolor_color_set), dialog);
--/** Image-quality frame */
--    dialog->priv->display_tab.image_quality_vbox = gtk_vbox_new(FALSE, 0);
--    dialog->priv->display_tab.image_quality_frame = xfce_create_framebox_with_content (_("Quality"),
--                                                                                 dialog->priv->display_tab.image_quality_vbox);
--    gtk_box_pack_start (GTK_BOX (display_main_vbox), dialog->priv->display_tab.image_quality_frame, FALSE, FALSE, 0);
--
--    dialog->priv->display_tab.image_quality_label = gtk_label_new (_("Maximum render quality:"));
--    dialog->priv->display_tab.image_quality_hbox= gtk_hbox_new (FALSE, 4);
--    dialog->priv->display_tab.image_quality_combo= gtk_combo_box_new_text ();
-     dialog->priv->display_tab.image_preview_check_button = gtk_check_button_new_with_label (_("Show preview when loading image"));
-     gtk_toggle_button_set_active (GTK_TOGGLE_BUTTON (dialog->priv->display_tab.image_preview_check_button),
-@@ -277,45 +258,6 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     g_signal_connect (G_OBJECT (dialog->priv->display_tab.image_preview_check_button), 
-                       "toggled", (GCallback)cb_rstto_preferences_dialog_image_preview_toggled, dialog);
--    gtk_combo_box_append_text (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), _("Best"));
--    gtk_combo_box_append_text (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), _("High"));
--    gtk_combo_box_append_text (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), _("Medium"));
--    gtk_combo_box_append_text (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), _("Low"));
--
--    gtk_box_pack_start (GTK_BOX (dialog->priv->display_tab.image_quality_vbox), 
--                                 dialog->priv->display_tab.image_quality_hbox, FALSE, FALSE, 0);
--    gtk_box_pack_start (GTK_BOX (dialog->priv->display_tab.image_quality_vbox), 
--                                 dialog->priv->display_tab.image_preview_check_button, FALSE, FALSE, 0);
--
--    gtk_box_pack_start (GTK_BOX (dialog->priv->display_tab.image_quality_hbox), 
--                                 dialog->priv->display_tab.image_quality_label, FALSE, FALSE, 0);
--    gtk_box_pack_start (GTK_BOX (dialog->priv->display_tab.image_quality_hbox), 
--                                 dialog->priv->display_tab.image_quality_combo, FALSE, FALSE, 0);
--    /* set current value */
--    switch (uint_image_quality-(uint_image_quality%1000000))
--    {
--        case 0:
--            gtk_combo_box_set_active (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), 0);
--            break;
--        case 8000000:
--            gtk_combo_box_set_active (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), 1);
--            break;
--        case 4000000:
--            gtk_combo_box_set_active (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), 2);
--            break;
--        case 2000000:
--            gtk_combo_box_set_active (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), 3);
--            break;
--        default:
--            gtk_combo_box_set_active (GTK_COMBO_BOX (dialog->priv->display_tab.image_quality_combo), 2);
--            break;
--    }
--
--    /* connect signals */
--    g_signal_connect (G_OBJECT (dialog->priv->display_tab.image_quality_combo), 
--                      "changed", (GCallback)cb_rstto_preferences_dialog_image_quality_combo_box_changed, dialog);
--    
--
- /*******************/
- /** Slideshow tab **/
- /*******************/
-@@ -642,38 +584,6 @@ cb_rstto_preferences_dialog_cache_spin_button_value_changed (GtkSpinButton *butt
- }
- static void
--cb_rstto_preferences_dialog_image_quality_combo_box_changed (GtkComboBox *combo_box,
--                                                             gpointer user_data)
--
--{
--    /* FIXME */
--    RsttoPreferencesDialog *dialog = RSTTO_PREFERENCES_DIALOG (user_data);
--    switch (gtk_combo_box_get_active (combo_box))
--    {
--        case 0: /* unlimited */
--            g_object_set (G_OBJECT (dialog->priv->settings),
--                          "image-quality", 0,
--                          NULL);
--            break;
--        case 1: /* 1 MegaPixel */
--            g_object_set (G_OBJECT (dialog->priv->settings),
--                          "image-quality", 8000000,
--                          NULL);
--            break;
--        case 2: /* 2 MegaPixel */
--            g_object_set (G_OBJECT (dialog->priv->settings),
--                          "image-quality", 4000000,
--                          NULL);
--            break;
--        case 3: /* 4 MegaPixel */
--            g_object_set (G_OBJECT (dialog->priv->settings),
--                          "image-quality", 2000000,
--                          NULL);
--            break;
--    }
--}
--
--static void
- cb_rstto_preferences_dialog_image_preview_toggled (GtkToggleButton *button, 
-                                                       gpointer user_data)
- {
diff --git a/ristretto-ui.patch b/ristretto-ui.patch
deleted file mode 100644 (file)
index 8df1ba8..0000000
+++ /dev/null
@@ -1,171 +0,0 @@
-commit b0ee303cca52a86292602d60eaa7efdf1b6df436
-Author: Stephan Arts <stephan@xfce.org>
-Date:   Mon Nov 15 07:10:43 2010 +0100
-
-    Migrate ristretto to libxfce4ui.
-     - Thanks to Romain Bouvier <skunnyk@archlinux.fr>, who provided a patch.
-
-diff --git a/configure.in b/configure.in
-index 5d59252..ceb59a4 100644
---- a/configure.in
-+++ b/configure.in
-@@ -52,16 +52,16 @@ dnl Check for i18n support
- XDT_I18N([@LINGUAS@])
- XDT_CHECK_PACKAGE([LIBEXIF], [libexif], [0.6.0])
--XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.12.0])
--XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.16.0])
--XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.16.0])
--XDT_CHECK_PACKAGE([GOBJECT], [gobject-2.0], [2.16.0])
--XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.16.0])
-+XDT_CHECK_PACKAGE([GTK], [gtk+-2.0], [2.14.0])
-+XDT_CHECK_PACKAGE([GLIB], [glib-2.0], [2.18.0])
-+XDT_CHECK_PACKAGE([GTHREAD], [gthread-2.0], [2.18.0])
-+XDT_CHECK_PACKAGE([GOBJECT], [gobject-2.0], [2.18.0])
-+XDT_CHECK_PACKAGE([GIO], [gio-2.0], [2.18.0])
- XDT_CHECK_PACKAGE([DBUS_GLIB], [dbus-glib-1], [0.34])
--XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.6.0])
--XDT_CHECK_PACKAGE([LIBXFCEGUI4], [libxfcegui4-1.0], [4.6.0])
-+XDT_CHECK_PACKAGE([LIBXFCE4UTIL], [libxfce4util-1.0], [4.7.0])
-+XDT_CHECK_PACKAGE([LIBXFCE4UI], [libxfce4ui-1], [4.7.0])
--XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [4.6.0])
-+XDT_CHECK_PACKAGE([XFCONF], [libxfconf-0], [4.7.0])
- XDT_CHECK_PACKAGE([CAIRO], [cairo], [1.8.0])
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 82c6bf7..dd1fc5a 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -29,7 +29,7 @@ ristretto_CFLAGS = \
-       $(XFCONF_CFLAGS) \
-       $(CAIRO_CFLAGS) \
-       $(LIBXFCE4UTIL_CFLAGS) \
--      $(LIBXFCEGUI4_CFLAGS) \
-+      $(LIBXFCE4UI_CFLAGS) \
-       -DDATADIR=\"$(datadir)\" \
-       -DSRCDIR=\"$(top_srcdir)\" \
-       -DLOCALEDIR=\"$(localedir)\"
-@@ -43,7 +43,7 @@ ristretto_LDADD = \
-       $(CAIRO_LIBS) \
-       $(XFCONF_LIBS) \
-       $(LIBXFCE4UTIL_LIBS) \
--      $(LIBXFCEGUI4_LIBS)
-+      $(LIBXFCE4UI_LIBS) -lX11
- INCLUDES = \
-       -I${top_srcdir}
-diff --git a/src/main_window.c b/src/main_window.c
-index 2e61084..029ca7c 100644
---- a/src/main_window.c
-+++ b/src/main_window.c
-@@ -12,9 +12,7 @@
-  *  GNU Library General Public License for more details.
-  *
-  *  You should have received a copy of the GNU General Public License
-- *  along with this program; if not, write to the Free Software
-- *  Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
-- */
-+ *  along with this program; if not, write to the Free Software *  Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.  */ 
- #include <config.h>
- #include <gtk/gtk.h>
-@@ -24,7 +22,7 @@
- #include <gio/gio.h>
--#include <libxfcegui4/libxfcegui4.h>
-+#include <libxfce4ui/libxfce4ui.h>
- #include <libexif/exif-data.h>
- #include <cairo/cairo.h>
-diff --git a/src/preferences_dialog.c b/src/preferences_dialog.c
-index fde5635..738f005 100644
---- a/src/preferences_dialog.c
-+++ b/src/preferences_dialog.c
-@@ -18,7 +18,7 @@
- #include <config.h>
- #include <gtk/gtk.h>
--#include <libxfcegui4/libxfcegui4.h>
-+#include <libxfce4ui/libxfce4ui.h>
- #include <libxfce4util/libxfce4util.h>
- #include "settings.h"
-@@ -224,7 +224,7 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
- /** Bg-color frame */
-     dialog->priv->display_tab.bgcolor_vbox = gtk_vbox_new (FALSE, 0);
--    dialog->priv->display_tab.bgcolor_frame = xfce_create_framebox_with_content (_("Background color"),
-+    dialog->priv->display_tab.bgcolor_frame = xfce_gtk_frame_box_new_with_content(_("Background color"),
-                                                                                  dialog->priv->display_tab.bgcolor_vbox);
-     gtk_box_pack_start (GTK_BOX (display_main_vbox), dialog->priv->display_tab.bgcolor_frame, FALSE, FALSE, 0);
-@@ -269,7 +269,7 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     gtk_notebook_append_page(GTK_NOTEBOOK(notebook), slideshow_main_vbox, slideshow_main_lbl);
-     dialog->priv->slideshow_tab.timeout_vbox = gtk_vbox_new(FALSE, 0);
--    dialog->priv->slideshow_tab.timeout_frame = xfce_create_framebox_with_content (_("Timeout"), dialog->priv->slideshow_tab.timeout_vbox);
-+    dialog->priv->slideshow_tab.timeout_frame = xfce_gtk_frame_box_new_with_content(_("Timeout"), dialog->priv->slideshow_tab.timeout_vbox);
-     gtk_box_pack_start (GTK_BOX (slideshow_main_vbox), dialog->priv->slideshow_tab.timeout_frame, FALSE, FALSE, 0);
-     timeout_lbl = gtk_label_new(_("The time period an individual image is displayed during a slideshow\n(in seconds)"));
-@@ -287,7 +287,7 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     
-     dialog->priv->slideshow_tab.thumbnail_vbox = gtk_vbox_new(FALSE, 0);
--    dialog->priv->slideshow_tab.thumbnail_frame = xfce_create_framebox_with_content (_("Thumbnails"), dialog->priv->slideshow_tab.thumbnail_vbox);
-+    dialog->priv->slideshow_tab.thumbnail_frame = xfce_gtk_frame_box_new_with_content(_("Thumbnails"), dialog->priv->slideshow_tab.thumbnail_vbox);
-     gtk_box_pack_start (GTK_BOX (slideshow_main_vbox), dialog->priv->slideshow_tab.thumbnail_frame, FALSE, FALSE, 0);
-     dialog->priv->slideshow_tab.hide_thumbnails_fullscreen_lbl = gtk_label_new(_("The thumbnailbar can be automatically hidden \nwhen the image-viewer is fullscreen."));
-@@ -309,7 +309,7 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     gtk_notebook_append_page(GTK_NOTEBOOK(notebook), control_main_vbox, control_main_lbl);
-     dialog->priv->control_tab.scroll_vbox = gtk_vbox_new(FALSE, 0);
--    dialog->priv->control_tab.scroll_frame = xfce_create_framebox_with_content (_("Scrollwheel"), dialog->priv->control_tab.scroll_vbox);
-+    dialog->priv->control_tab.scroll_frame = xfce_gtk_frame_box_new_with_content(_("Scrollwheel"), dialog->priv->control_tab.scroll_vbox);
-     gtk_box_pack_start (GTK_BOX (control_main_vbox), dialog->priv->control_tab.scroll_frame, FALSE, FALSE, 0);
-     dialog->priv->control_tab.no_scrollwheel_action_radio_button = gtk_radio_button_new_with_label (NULL, _("No action"));
-@@ -358,7 +358,7 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     /********************************************/
-     dialog->priv->behaviour_tab.scaling_vbox = gtk_vbox_new(FALSE, 0);
--    dialog->priv->behaviour_tab.scaling_frame = xfce_create_framebox_with_content (_("Scaling"), dialog->priv->behaviour_tab.scaling_vbox);
-+    dialog->priv->behaviour_tab.scaling_frame = xfce_gtk_frame_box_new_with_content(_("Scaling"), dialog->priv->behaviour_tab.scaling_vbox);
-     gtk_box_pack_start (GTK_BOX (behaviour_main_vbox), dialog->priv->behaviour_tab.scaling_frame, FALSE, FALSE, 0);
-     /* not used */
-     gtk_widget_set_sensitive (dialog->priv->behaviour_tab.scaling_vbox, FALSE);
-@@ -367,7 +367,7 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
-     gtk_container_add (GTK_CONTAINER (dialog->priv->behaviour_tab.scaling_vbox), dialog->priv->behaviour_tab.resize_image_on_maximize);
-     dialog->priv->behaviour_tab.startup_vbox = gtk_vbox_new(FALSE, 0);
--    dialog->priv->behaviour_tab.startup_frame = xfce_create_framebox_with_content (_("Startup"), dialog->priv->behaviour_tab.startup_vbox);
-+    dialog->priv->behaviour_tab.startup_frame = xfce_gtk_frame_box_new_with_content(_("Startup"), dialog->priv->behaviour_tab.startup_vbox);
-     gtk_box_pack_start (GTK_BOX (behaviour_main_vbox), dialog->priv->behaviour_tab.startup_frame, FALSE, FALSE, 0);
-     dialog->priv->behaviour_tab.resize_window_on_startup_check_button = gtk_check_button_new_with_label (_("Resize window to image on startup"));
-     gtk_container_add (GTK_CONTAINER (dialog->priv->behaviour_tab.startup_vbox), dialog->priv->behaviour_tab.resize_window_on_startup_check_button);
-@@ -400,7 +400,7 @@ rstto_preferences_dialog_init(RsttoPreferencesDialog *dialog)
- /** Image-cache frame */
-     dialog->priv->cache_tab.cache_vbox = gtk_vbox_new(FALSE, 0);
--    dialog->priv->cache_tab.cache_frame = xfce_create_framebox_with_content (_("Image cache"),
-+    dialog->priv->cache_tab.cache_frame = xfce_gtk_frame_box_new_with_content(_("Image cache"),
-                                                                                  dialog->priv->cache_tab.cache_vbox);
-     gtk_box_pack_start (GTK_BOX (cache_main_vbox), dialog->priv->cache_tab.cache_frame, FALSE, FALSE, 0);
-diff --git a/src/thumbnail_bar.c b/src/thumbnail_bar.c
-index 282db14..e2bc892 100644
---- a/src/thumbnail_bar.c
-+++ b/src/thumbnail_bar.c
-@@ -21,7 +21,7 @@
- #include <gio/gio.h>
--#include <libxfcegui4/libxfcegui4.h>
-+#include <libxfce4ui/libxfce4ui.h>
- #include <libexif/exif-data.h>
- #include "image.h"
This page took 0.201838 seconds and 4 git commands to generate.