]> git.pld-linux.org Git - packages/remmina.git/blame - remmina.spec
- fixed conditional build of NX plugin
[packages/remmina.git] / remmina.spec
CommitLineData
7c4bd58c 1#
ec36c311
AG
2# note: disabling plugins will still build them if deps are met
3#
7c4bd58c
AG
4# Conditional build:
5%bcond_without exec # do not build exec plugin
b57cab6d 6%bcond_with nx # build nx plugin
7c4bd58c
AG
7%bcond_without rdp # do not build rdp plugin
8%bcond_without secret # do not build secret plugin
9%bcond_without spice # do not build spice plugin
d66ee200 10%bcond_with telepathy # do not build telepathy plugin
7c4bd58c 11%bcond_without vnc # do not build vnc plugin
6236602e 12%bcond_without vte # do not build vte plugin
2cd7a1fc 13%bcond_without www # do not build www plugin
7c4bd58c
AG
14%bcond_without xdmcp # do not build xdmcp plugin
15#
bff36d36
AG
16Summary: Remote Desktop Client
17Name: remmina
2cd7a1fc
KM
18Version: 1.4.7
19Release: 1
bff36d36
AG
20License: GPLv2+ and MIT
21Group: X11/Applications
d66ee200 22Source0: https://gitlab.com/Remmina/Remmina/-/archive/v%{version}/Remmina-v%{version}.tar.bz2
2cd7a1fc 23# Source0-md5: 17c9f9530b9863365e9acf18183c69eb
bff36d36
AG
24# Cmake helper file to easy build plugins outside remmina source tree
25# See http://www.muflone.com/remmina-plugin-rdesktop/english/install.html which
26# use http://www.muflone.com/remmina-plugin-builder/ with remmina bundled source.
27# So we can't use it directly only as instructions.
28Source1: pluginBuild-CMakeLists.txt
2cd7a1fc 29Patch0: fix-shebangs.patch
bff36d36
AG
30URL: http://remmina.org
31BuildRequires: appstream-glib
32BuildRequires: avahi-ui-gtk3-devel >= 0.6.30
33BuildRequires: cmake >= 2.8
34BuildRequires: desktop-file-utils
7c4bd58c 35%{?with_rdp:BuildRequires: freerdp2-devel >= 2.0.0-0.20190320}
bff36d36
AG
36BuildRequires: gettext
37BuildRequires: gtk+3-devel
2cd7a1fc 38%{?with_www:BuildRequires: gtk-webkit4-devel}
bff36d36
AG
39BuildRequires: intltool
40BuildRequires: json-glib-devel
41BuildRequires: libappindicator-gtk3-devel
42BuildRequires: libgcrypt-devel
7c4bd58c 43%{?with_secret:BuildRequires: libsecret-devel}
bff36d36 44BuildRequires: libsoup-devel
7fc1103f 45%{?with_nx:BuildRequires: libssh-devel >= 0.6}
7c4bd58c 46%{?with_vnc:BuildRequires: libvncserver-devel}
7c4bd58c
AG
47BuildRequires: rpmbuild(macros) >= 1.742
48%{?with_spice:BuildRequires: spice-gtk-devel}
6f8d7930 49%{?with_telepathy:BuildRequires: telepathy-glib-devel}
2cd7a1fc 50%{?with_vte:BuildRequires: vte-devel}
bff36d36 51BuildRequires: xorg-lib-libxkbfile-devel
791ee4d2 52Requires(post,postun): gtk-update-icon-cache
d8865dbe 53Requires: avahi-ui-gtk3 >= 0.6.30
791ee4d2 54Requires: hicolor-icon-theme
d8865dbe 55Requires: libssh >= 0.6
c2acb0d6 56BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
bff36d36
AG
57
58%description
59Remmina is a remote desktop client written in GTK+, aiming to be
60useful for system administrators and travelers, who need to work with
61lots of remote computers in front of either large monitors or tiny
62net-books.
63
64Remmina supports multiple network protocols in an integrated and
65consistent user interface. Currently RDP, VNC, XDMCP and SSH are
66supported.
67
68Please don't forget to install the plugins for the protocols you want
69to use.
70
71%package devel
72Summary: Development files for %{name}
73Requires: %{name} = %{version}-%{release}
74Requires: pkgconfig
75
76%description devel
77The %{name}-devel package contains header files for developing plugins
78for %{name}.
79
80%package plugins-exec
81Summary: External execution plugin for Remmina Remote Desktop Client
82Requires: %{name} = %{version}-%{release}
83
84%description plugins-exec
85Remmina is a remote desktop client written in GTK+, aiming to be
86useful for system administrators and travelers, who need to work with
87lots of remote computers in front of either large monitors or tiny
88net-books.
89
90This package contains the plugin to execute external processes
91(commands or applications) from the Remmina window.
92
bff36d36
AG
93%package plugins-nx
94Summary: NX plugin for Remmina Remote Desktop Client
95Requires: %{name} = %{version}-%{release}
96Requires: nxproxy
97
98%description plugins-nx
99Remmina is a remote desktop client written in GTK+, aiming to be
100useful for system administrators and travelers, who need to work with
101lots of remote computers in front of either large monitors or tiny
102net-books.
103
104This package contains the NX plugin for the Remmina remote desktop
105client.
106
107%package plugins-rdp
108Summary: RDP plugin for Remmina Remote Desktop Client
109Requires: %{name} = %{version}-%{release}
d8865dbe 110Requires: freerdp2-libs >= 2.0.0-0.20190320
bff36d36
AG
111
112%description plugins-rdp
113Remmina is a remote desktop client written in GTK+, aiming to be
114useful for system administrators and travelers, who need to work with
115lots of remote computers in front of either large monitors or tiny
116net-books.
117
118This package contains the Remote Desktop Protocol (RDP) plugin for the
119Remmina remote desktop client.
120
c64abc6f
AG
121%package plugins-secret
122Summary: Keyring integration for Remmina Remote Desktop Client
bff36d36 123Requires: %{name} = %{version}-%{release}
c64abc6f
AG
124Provides: %{name}-plugins-gnome%{?_isa} = %{version}-%{release}
125Obsoletes: remmina-plugins-gnome < %{version}-%{release}
bff36d36 126
c64abc6f 127%description plugins-secret
bff36d36
AG
128Remmina is a remote desktop client written in GTK+, aiming to be
129useful for system administrators and travelers, who need to work with
130lots of remote computers in front of either large monitors or tiny
131net-books.
132
c64abc6f
AG
133This package contains the plugin with keyring support for the Remmina
134remote desktop client.
135
136%package plugins-spice
137Summary: SPICE plugin for Remmina Remote Desktop Client
138Requires: %{name} = %{version}-%{release}
139
140%description plugins-spice
141Remmina is a remote desktop client written in GTK+, aiming to be
142useful for system administrators and travelers, who need to work with
143lots of remote computers in front of either large monitors or tiny
144net-books.
145
146This package contains the SPICE plugin for the Remmina remote desktop
bff36d36
AG
147client.
148
6f8d7930
AG
149%package plugins-telepathy
150Summary: Telepathy plugin for Remmina Remote Desktop Client
151Requires: %{name} = %{version}-%{release}
152
153%description plugins-telepathy
154Remmina is a remote desktop client written in GTK+, aiming to be
155useful for system administrators and travelers, who need to work with
156lots of remote computers in front of either large monitors or tiny
157net-books.
158
159This package contains the Telepathy plugin for the Remmina remote
160desktop client.
161
c64abc6f
AG
162%package plugins-vnc
163Summary: VNC plugin for Remmina Remote Desktop Client
bff36d36 164Requires: %{name} = %{version}-%{release}
bff36d36 165
c64abc6f 166%description plugins-vnc
bff36d36
AG
167Remmina is a remote desktop client written in GTK+, aiming to be
168useful for system administrators and travelers, who need to work with
169lots of remote computers in front of either large monitors or tiny
170net-books.
171
c64abc6f 172This package contains the VNC plugin for the Remmina remote desktop
bff36d36
AG
173client.
174
2cd7a1fc
KM
175%package plugins-www
176Summary: Browser plugin for Remmina Remote Desktop Client
177Requires: %{name} = %{version}-%{release}
178
179%description plugins-www
180Remmina is a remote desktop client written in GTK+, aiming to be
181useful for system administrators and travelers, who need to work with
182lots of remote computers in front of either large monitors or tiny
183net-books.
184
185This package contains the www plugin for the Remmina remote desktop
186client.
187
c64abc6f
AG
188%package plugins-xdmcp
189Summary: XDMCP plugin for Remmina Remote Desktop Client
bff36d36 190Requires: %{name} = %{version}-%{release}
c64abc6f 191Requires: xorg-xserver-Xephyr
bff36d36 192
c64abc6f 193%description plugins-xdmcp
bff36d36
AG
194Remmina is a remote desktop client written in GTK+, aiming to be
195useful for system administrators and travelers, who need to work with
196lots of remote computers in front of either large monitors or tiny
197net-books.
198
c64abc6f 199This package contains the XDMCP plugin for the Remmina remote desktop
bff36d36
AG
200client.
201
202%prep
203%setup -qn Remmina-v%{version}
762693bc
AG
204%{__sed} -i s/^pt_PT$// po/LINGUAS
205%{__rm} -f po/pt_PT.po
2cd7a1fc 206%patch0 -p1
bff36d36
AG
207
208%build
209mkdir -p build
210
211%cmake --build=build \
212 -DCMAKE_INSTALL_LIBDIR=%{_lib} \
213 -DCMAKE_INSTALL_PREFIX=%{_prefix} \
214 -DWITH_APPINDICATOR=ON \
215 -DWITH_AVAHI=ON \
1c5458ab 216 %{cmake_on_off rdp FREERDP} \
bff36d36
AG
217 -DWITH_GCRYPT=ON \
218 -DWITH_GETTEXT=ON \
7fc1103f
KM
219 -DWITH_LIBSSH=OFF \
220 %{cmake_on_off nx WITH_LIBSSH} \
52965156 221 %{cmake_on_off vnc LIBVNCSERVER} \
1c5458ab 222 %{cmake_on_off spice SPICE} \
6f8d7930 223 %{cmake_on_off telepathy TELEPATHY} \
1c5458ab 224 %{cmake_on_off vte VTE} \
bff36d36
AG
225 .
226
227%{__make}
228
229%install
230rm -rf $RPM_BUILD_ROOT
231%{__make} install \
232 DESTDIR=$RPM_BUILD_ROOT
233
234install -d $RPM_BUILD_ROOT/%{_libdir}/cmake/%{name}/
235cp -pr cmake/*.cmake $RPM_BUILD_ROOT/%{_libdir}/cmake/%{name}/
236cp -pr config.h.in $RPM_BUILD_ROOT/%{_includedir}/%{name}/
237cp -p %{SOURCE1} $RPM_BUILD_ROOT/%{_includedir}/%{name}/
238
2cd7a1fc
KM
239# not supported by glibc yet
240%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/{br,ckb,eo,ie,hi,shn}
241
bff36d36
AG
242%find_lang %{name}
243
244%clean
245rm -rf $RPM_BUILD_ROOT
246
791ee4d2
JP
247%post
248%update_icon_cache hicolor
249
250%postun
251%update_icon_cache hicolor
252
bff36d36
AG
253%files -f %{name}.lang
254%defattr(644,root,root,755)
255%doc LICENSE AUTHORS ChangeLog README.md
2cd7a1fc 256%attr(755,root,root) %{_bindir}/remmina-file-wrapper
bff36d36
AG
257%attr(755,root,root) %{_bindir}/remmina
258%{_datadir}/metainfo/*.appdata.xml
259%{_desktopdir}/*.desktop
260%{_iconsdir}/hicolor/*/actions/*.*
261%{_iconsdir}/hicolor/*/apps/*.*
c2acb0d6
AG
262%{_iconsdir}/hicolor/*/emblems/remmina-sftp-symbolic.svg
263%{_iconsdir}/hicolor/*/emblems/remmina-ssh-symbolic.svg
264%{_iconsdir}/hicolor/*/emblems/remmina-tool-symbolic.svg
2cd7a1fc
KM
265%dir %{_iconsdir}/hicolor/apps
266%{_iconsdir}/hicolor/apps/*.*
267%dir %{_iconsdir}/hicolor/scalable/panel
268%{_iconsdir}/hicolor/scalable/panel/*.*
bff36d36
AG
269%{_datadir}/mime/packages/*.xml
270%{_datadir}/%{name}/
271%dir %{_libdir}/remmina/
272%dir %{_libdir}/remmina/plugins/
2cd7a1fc 273%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-st.so
c2acb0d6 274%{_mandir}/man1/remmina.1*
2cd7a1fc 275%{_mandir}/man1/remmina-file-wrapper.1*
bff36d36
AG
276
277%files devel
278%defattr(644,root,root,755)
279%{_includedir}/%{name}/
280%{_pkgconfigdir}/%{name}.pc
762693bc 281%dir %{_libdir}/cmake/%{name}
bff36d36
AG
282%{_libdir}/cmake/%{name}/*.cmake
283
7c4bd58c 284%if %{with exec}
bff36d36
AG
285%files plugins-exec
286%defattr(644,root,root,755)
2cd7a1fc 287%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-exec.so
7c4bd58c 288%endif
bff36d36 289
7c4bd58c 290%if %{with nx}
bff36d36
AG
291%files plugins-nx
292%defattr(644,root,root,755)
2cd7a1fc 293%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-nx.so
bff36d36 294%{_iconsdir}/hicolor/*/emblems/remmina-nx-symbolic.svg
7c4bd58c 295%endif
bff36d36 296
7c4bd58c 297%if %{with rdp}
bff36d36
AG
298%files plugins-rdp
299%defattr(644,root,root,755)
2cd7a1fc 300%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-rdp.so
bff36d36
AG
301%{_iconsdir}/hicolor/*/emblems/remmina-rdp-ssh-symbolic.svg
302%{_iconsdir}/hicolor/*/emblems/remmina-rdp-symbolic.svg
7c4bd58c 303%endif
bff36d36 304
7c4bd58c 305%if %{with secret}
c64abc6f
AG
306%files plugins-secret
307%defattr(644,root,root,755)
2cd7a1fc 308%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-secret.so
7c4bd58c 309%endif
c64abc6f 310
7c4bd58c 311%if %{with spice}
c64abc6f
AG
312%files plugins-spice
313%defattr(644,root,root,755)
2cd7a1fc 314%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-spice.so
c64abc6f
AG
315%{_iconsdir}/hicolor/*/emblems/remmina-spice-symbolic.svg
316%{_iconsdir}/hicolor/*/emblems/remmina-spice-ssh-symbolic.svg
7c4bd58c 317%endif
c64abc6f 318
6f8d7930
AG
319%if %{with telepathy}
320%files plugins-telepathy
321%defattr(644,root,root,755)
2cd7a1fc 322%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-telepathy.so
6f8d7930
AG
323%{_datadir}/dbus-1/services/org.freedesktop.Telepathy.Client.Remmina.service
324%{_datadir}/telepathy/clients/Remmina.client
325%endif
326
7c4bd58c 327%if %{with vnc}
bff36d36
AG
328%files plugins-vnc
329%defattr(644,root,root,755)
2cd7a1fc 330%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-vnc.so
bff36d36
AG
331%{_iconsdir}/hicolor/*/emblems/remmina-vnc-ssh-symbolic.svg
332%{_iconsdir}/hicolor/*/emblems/remmina-vnc-symbolic.svg
7c4bd58c 333%endif
bff36d36 334
2cd7a1fc
KM
335%if %{with www}
336%files plugins-www
337%defattr(644,root,root,755)
338%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-www.so
339%{_iconsdir}/hicolor/*/emblems/remmina-www-symbolic.svg
340%endif
341
7c4bd58c 342%if %{with xdmcp}
bff36d36
AG
343%files plugins-xdmcp
344%defattr(644,root,root,755)
2cd7a1fc 345%attr(755,root,root) %{_libdir}/remmina/plugins/remmina-plugin-xdmcp.so
bff36d36
AG
346%{_iconsdir}/hicolor/*/emblems/remmina-xdmcp-ssh-symbolic.svg
347%{_iconsdir}/hicolor/*/emblems/remmina-xdmcp-symbolic.svg
7c4bd58c 348%endif
bff36d36 349
bff36d36 350%changelog
This page took 0.116292 seconds and 4 git commands to generate.