]> git.pld-linux.org Git - packages/rclone.git/commitdiff
up to 1.66.0 master auto/th/rclone-1.66.0-1
authorJan Palus <atler@pld-linux.org>
Mon, 11 Mar 2024 10:31:01 +0000 (11:31 +0100)
committerJan Palus <atler@pld-linux.org>
Mon, 11 Mar 2024 10:31:01 +0000 (11:31 +0100)
rclone.spec
webdav-modtime.patch

index adc67ac0821eff86186cdb9ccccc429c37835b04..f343ac0e3b50a9a3df13a9f672f7e4e1ec779931 100644 (file)
@@ -1,22 +1,23 @@
-%define                vendor_ver      1.65.2
+%define                vendor_ver      1.66.0
+
 Summary:       rsync for cloud storage
 Name:          rclone
-Version:       1.65.2
+Version:       1.66.0
 Release:       1
 License:       MIT
 Group:         Networking/Utilities
 #Source0Download: https://github.com/rclone/rclone/releases
 Source0:       https://github.com/rclone/rclone/releases/download/v%{version}/%{name}-v%{version}.tar.gz
-# Source0-md5: a69c661fec93b84e508d31a8dc1ceddb
+# Source0-md5: ae301cfeecf0675209d0acbfd8eaf05a
 # cd rclone-%{version}
 # go mod vendor
 # cd ..
 # tar cJf rclone-vendor-%{version}.tar.xz rclone-v%{version}/vendor
 Source1:       %{name}-vendor-%{vendor_ver}.tar.xz
-# Source1-md5: 59c4f447060c9ccd7111933267c7c316
+# Source1-md5: acca3f3203821e5623497bccce73de75
 Patch0:                webdav-modtime.patch
 URL:           https://rclone.org/
-BuildRequires: golang >= 1.19
+BuildRequires: golang >= 1.20
 BuildRequires: rpm-build >= 4.6
 BuildRequires: rpmbuild(macros) >= 2.009
 BuildRequires: tar >= 1:1.22
index 1254315d7195a950b95a2da6c1025bb4733046fe..ac61ec0d7bcb5e7afd973ac86b03f88b2018dfef 100644 (file)
@@ -96,9 +96,9 @@ index c91e4950c..a8c7ffce8 100644
 --- a/backend/webdav/webdav.go
 +++ b/backend/webdav/webdav.go
 @@ -146,6 +146,14 @@ Set to 0 to disable chunked uploading.
`,
                      Help:     "Exclude ownCloud shares",
                        Advanced: true,
-                       Default:  10 * fs.Mebi, // Default NextCloud `max_chunk_size` is `10 MiB`. See https://github.com/nextcloud/server/blob/0447b53bda9fe95ea0cbed765aa332584605d652/apps/files/lib/App.php#L57
+                       Default:  false,
 +              }, {
 +                      Name: "update_modtime",
 +                      Help: `Adjust modification time on servers which allow DAV:getlastmodified property update.
@@ -111,9 +111,9 @@ index c91e4950c..a8c7ffce8 100644
        })
  }
 @@ -162,6 +170,7 @@ type Options struct {
-       Headers            fs.CommaSepList      `config:"headers"`
        PacerMinSleep      fs.Duration          `config:"pacer_min_sleep"`
        ChunkSize          fs.SizeSuffix        `config:"nextcloud_chunk_size"`
+       ExcludeShares      bool                 `config:"owncloud_exclude_shares"`
 +      UpdateModTime      fs.Tristate          `config:"update_modtime"`
  }
  
This page took 0.225215 seconds and 4 git commands to generate.