]> git.pld-linux.org Git - packages/rclone.git/blob - rclone.spec
new (version 1.53.3)
[packages/rclone.git] / rclone.spec
1 Summary:        rsync for cloud storage
2 Name:           rclone
3 Version:        1.53.3
4 Release:        1
5 License:        MIT
6 Group:          Networking/Utilities
7 #Source0Download: https://github.com/rclone/rclone/releases
8 Source0:        https://github.com/rclone/rclone/releases/download/v%{version}/%{name}-v%{version}.tar.gz
9 # Source0-md5:  76bb7a543b04ea243d611bd0f934e351
10 # cd rclone-%{version}
11 # go mod vendor
12 # cd ..
13 # tar cJf rclonevendor-%{version}.tar.xz rclone-%{version}/vendor
14 Source1:        %{name}-vendor-%{version}.tar.xz
15 # Source1-md5:  eb0153a39af5cd5e7bf40a69b6ae2542
16 URL:            https://rclone.org/
17 BuildRequires:  golang >= 1.12
18 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Rclone is a command line program to sync files and directories to and
23 from different cloud storage providers.
24
25 %prep
26 %setup -q -b1 -n %{name}-v%{version}
27
28 %{__mkdir_p} .go-cache
29
30 %build
31 GOCACHE="$(pwd)/.go-cache" go build -v -mod=vendor --ldflags "-s -X github.com/rclone/rclone/fs.Version=%{version}" -o bin/rclone
32
33 %install
34 rm -rf $RPM_BUILD_ROOT
35
36 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
37
38 cp -p bin/rclone $RPM_BUILD_ROOT%{_bindir}
39 cp -p rclone.1 $RPM_BUILD_ROOT%{_mandir}/man1
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(644,root,root,755)
46 %doc CONTRIBUTING.md MAINTAINERS.md MANUAL.md README.md
47 %attr(755,root,root) %{_bindir}/rclone
48 %{_mandir}/man1/rclone.1*
This page took 0.122317 seconds and 4 git commands to generate.