]> git.pld-linux.org Git - packages/rclone.git/blob - rclone.spec
d648e253fba5cea9a8342a03ab09af12ab936252
[packages/rclone.git] / rclone.spec
1 Summary:        rsync for cloud storage
2 Name:           rclone
3 Version:        1.55.0
4 Release:        1
5 License:        MIT
6 Group:          Networking/Utilities
7 #Source0Download: https://github.com/rclone/rclone/releases
8 Source0:        https://github.com/rclone/rclone/releases/download/v%{version}/%{name}-v%{version}.tar.gz
9 # Source0-md5:  16389b8398ecf5c0b9942dbfc956ff88
10 # cd rclone-%{version}
11 # go mod vendor
12 # cd ..
13 # tar cJf rclone-vendor-%{version}.tar.xz rclone-v%{version}/vendor
14 Source1:        %{name}-vendor-%{version}.tar.xz
15 # Source1-md5:  9de5b2c00f12d4f082c0c24f7e3e01d4
16 URL:            https://rclone.org/
17 BuildRequires:  golang >= 1.14
18 BuildRequires:  tar >= 1:1.22
19 BuildRequires:  xz
20 ExclusiveArch:  %{ix86} %{x8664} %{arm} aarch64 mips64 mips64le ppc64 ppc64le s390x
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Rclone is a command line program to sync files and directories to and
25 from different cloud storage providers.
26
27 %prep
28 %setup -q -b1 -n %{name}-v%{version}
29
30 %{__mkdir_p} .go-cache
31
32 %build
33 GOCACHE="$(pwd)/.go-cache" go build -v -mod=vendor --ldflags "-s -X github.com/rclone/rclone/fs.Version=%{version}" -o bin/rclone
34
35 %install
36 rm -rf $RPM_BUILD_ROOT
37
38 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
39
40 cp -p bin/rclone $RPM_BUILD_ROOT%{_bindir}
41 cp -p rclone.1 $RPM_BUILD_ROOT%{_mandir}/man1
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc CONTRIBUTING.md MAINTAINERS.md MANUAL.md README.md
49 %attr(755,root,root) %{_bindir}/rclone
50 %{_mandir}/man1/rclone.1*
This page took 0.055407 seconds and 3 git commands to generate.