]> git.pld-linux.org Git - packages/ragel.git/blob - ragel.spec
4656fe4f292dc4fa0b0a8ea8e51e9fee735d099e
[packages/ragel.git] / ragel.spec
1 Summary:        Ragel State Machine Compiler
2 Summary(pl):    Ragel State Machine Compiler - kompilator automatów
3 Name:           ragel
4 Version:        5.16
5 Release:        1
6 License:        GPL
7 Group:          Development/Tools
8 Source0:        http://www.cs.queensu.ca/home/thurston/ragel/%{name}-%{version}.tar.gz
9 # Source0-md5:  0c19b9fe68dd54efa64009dc85a08325
10 URL:            http://www.cs.queensu.ca/home/thurston/ragel/
11 BuildRequires:  bison
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 %description
15 Ragel compiles finite state machines from regular languages into
16 runnable C code. Ragel state machines can not only recognize byte
17 sequences as regular expression machines do, but can also execute code
18 at arbitrary points in the recognition of a regular language. When you
19 wish to write down a regular language you start with some simple
20 regular language and build a bigger one using the regular language
21 operators union, concatenation, Kleene star, intersection and
22 subtraction. This is precisely the way you describe to Ragel how to
23 compile your finite state machines. Ragel also understands operators
24 that insert function calls into machines and operators that control
25 any non-determinism in machines.
26
27 %description -l pl
28 Ragel kompiluje automaty skoñczone z jêzyków regularnych do
29 dzia³aj±cego kodu w C. Automaty Ragela nie tylko rozpoznaj± sekwencje
30 bajtów, jak robi± to automaty wyra¿eñ regularnych, ale tak¿e wykonuj±
31 kod w dowolnych miejscach podczas rozpoznawania jêzyka regularnego.
32 Aby napisaæ jêzyk regularny zaczyna siê od prostego jêzyka regularnego
33 i buduje wiêkszy przy u¿yciu operatorów sumy, z³±czenia, dope³nienia
34 Kleene'a, przeciêcia i odejmowania. Jest to dok³adnie taki sposób, w
35 jaki opisuje siê Ragelowi jak kompilowaæ automaty skoñczone. Ragel
36 rozumie tak¿e operatory wstawiaj±ce wywo³ania funkcji do automatów i
37 operatory steruj±ce niedeterminizmem w automatach.
38
39 %prep
40 %setup -q
41
42 %build
43 %configure
44 %{__make}
45 %{__make} -C doc ragel.1 rlcodegen.1
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49 install -d $RPM_BUILD_ROOT%{_bindir}
50 install -s ragel/ragel $RPM_BUILD_ROOT%{_bindir}/ragel
51 install -s rlcodegen/rlcodegen $RPM_BUILD_ROOT%{_bindir}/rlcodegen
52 install -d $RPM_BUILD_ROOT%{_mandir}/man1
53 install doc/ragel.1 $RPM_BUILD_ROOT%{_mandir}/man1/ragel.1
54 install doc/rlcodegen.1 $RPM_BUILD_ROOT%{_mandir}/man1/rlcodegen.1
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_bindir}/*
62 %{_mandir}/man1/*
This page took 0.068054 seconds and 2 git commands to generate.