]> git.pld-linux.org Git - packages/r8168.git/commitdiff
- up to 8.048.02 auto/th/r8168-8.048.02-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 4 Apr 2020 21:05:10 +0000 (23:05 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 4 Apr 2020 21:05:10 +0000 (23:05 +0200)
kernel-5.4.patch [deleted file]
kernel-5.6.patch [new file with mode: 0644]
r8168.spec

diff --git a/kernel-5.4.patch b/kernel-5.4.patch
deleted file mode 100644 (file)
index 4dfb03c..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- r8168-8.047.01/src/r8168_n.c~      2019-04-01 17:58:10.000000000 +0200
-+++ r8168-8.047.01/src/r8168_n.c       2019-11-30 23:52:41.804500848 +0100
-@@ -56,7 +56,7 @@
- #include <linux/rtnetlink.h>
- #include <linux/completion.h>
--#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)
-+#if (LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,26)) && (LINUX_VERSION_CODE < KERNEL_VERSION(5,4,0))
- #include <linux/pci-aspm.h>
- #endif
- #if LINUX_VERSION_CODE >= KERNEL_VERSION(2,4,37)
diff --git a/kernel-5.6.patch b/kernel-5.6.patch
new file mode 100644 (file)
index 0000000..925148a
--- /dev/null
@@ -0,0 +1,50 @@
+--- r8168-8.048.02/src/r8168_n.c~      2020-02-12 15:43:44.000000000 +0100
++++ r8168-8.048.02/src/r8168_n.c       2020-04-04 22:52:03.066746887 +0200
+@@ -1616,12 +1616,21 @@
+         return single_open(file, show, dev);
+ }
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,6,0)
+ static const struct file_operations rtl8168_proc_fops = {
+         .open           = rtl8168_proc_open,
+         .read           = seq_read,
+         .llseek         = seq_lseek,
+         .release        = single_release,
+ };
++#else
++static const struct proc_ops rtl8168_proc_fops = {
++        .proc_open          = rtl8168_proc_open,
++        .proc_read          = seq_read,
++        .proc_lseek         = seq_lseek,
++        .proc_release       = single_release,
++};
++#endif
+ #endif
+ /*
+--- r8168-8.048.02/src/r8168_n.c~      2020-04-04 22:53:42.000000000 +0200
++++ r8168-8.048.02/src/r8168_n.c       2020-04-04 22:58:05.263418678 +0200
+@@ -456,7 +456,11 @@
+ static void rtl8168_hw_start(struct net_device *dev);
+ static int rtl8168_close(struct net_device *dev);
+ static void rtl8168_set_rx_mode(struct net_device *dev);
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,6,0)
+ static void rtl8168_tx_timeout(struct net_device *dev);
++#else
++static void rtl8168_tx_timeout(struct net_device *dev, unsigned int txqueue);
++#endif
+ static struct net_device_stats *rtl8168_get_stats(struct net_device *dev);
+ static int rtl8168_rx_interrupt(struct net_device *, struct rtl8168_private *, napi_budget);
+ static int rtl8168_change_mtu(struct net_device *dev, int new_mtu);
+@@ -27858,7 +27858,11 @@
+ }
+ static void
++#if LINUX_VERSION_CODE < KERNEL_VERSION(5,6,0)
+ rtl8168_tx_timeout(struct net_device *dev)
++#else
++rtl8168_tx_timeout(struct net_device *dev, unsigned int txqueue)
++#endif
+ {
+         struct rtl8168_private *tp = netdev_priv(dev);
+         unsigned long flags;
index e83b2865bb9e8d352b8dfb4a7dacf27264b8d3ff..2d0e5fe33fdc08b5422844a9fc0e938f1cebd1e9 100644 (file)
@@ -9,7 +9,7 @@
 Summary:       Linux driver for RTL8111/8168B PCI Express Gigabit Ethernet controllers
 Summary(pl.UTF-8):     Linuksowy sterownik dla kart sieciowych RTL8111/8168B PCI Express Gigabit Ethernet
 Name:          %{pname}%{_alt_kernel}
-Version:       8.047.05
+Version:       8.048.02
 Release:       %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
 License:       GPL
 Group:         Base/Kernel
@@ -18,8 +18,8 @@ URL:          http://www.realtek.com.tw/
 # https://www.realtek.com/en/component/zoo/category/network-interface-controllers-10-100-1000m-gigabit-ethernet-pci-express-software
 # unfortunately this download is not DF-friendly.
 Source0:       %{pname}-%{version}.tar.bz2
-# Source0-md5: d239300e229061c449848707819c1d0d
-Patch0:                kernel-5.4.patch
+# Source0-md5: 45370f7630da1ff6e3a9996e445a94af
+Patch0:                kernel-5.6.patch
 BuildRequires: rpmbuild(macros) >= 1.701
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
This page took 0.092673 seconds and 4 git commands to generate.