]> git.pld-linux.org Git - packages/r8168.git/commitdiff
- up to 8.041.01 auto/th/r8168-8.041.01-1
authorJan Rękorajski <baggins@pld-linux.org>
Tue, 26 Apr 2016 05:49:27 +0000 (07:49 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Tue, 26 Apr 2016 05:49:27 +0000 (07:49 +0200)
- fix building with linux 4.5

linux-4.0.patch [deleted file]
linux-4.5.patch [new file with mode: 0644]
r8168.spec

diff --git a/linux-4.0.patch b/linux-4.0.patch
deleted file mode 100644 (file)
index 652e27c..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- r8168-8.039.00/src/r8168_n.c.orig  2015-04-19 13:32:19.399796241 +0200
-+++ r8168-8.039.00/src/r8168_n.c       2015-04-19 13:34:01.866459293 +0200
-@@ -3291,9 +3291,12 @@
- #if LINUX_VERSION_CODE < KERNEL_VERSION(3,0,0)
-         tag = (tp->vlgrp && vlan_tx_tag_present(skb)) ?
-               TxVlanTag | swab16(vlan_tx_tag_get(skb)) : 0x00;
--#else
-+#elif LINUX_VERSION_CODE < KERNEL_VERSION(4,0,0)
-         tag = (vlan_tx_tag_present(skb)) ?
-               TxVlanTag | swab16(vlan_tx_tag_get(skb)) : 0x00;
-+#else
-+        tag = (tp->vlgrp && skb_vlan_tag_present(skb)) ?
-+              TxVlanTag | swab16(skb_vlan_tag_get(skb)) : 0x00;
- #endif
-         return tag;
diff --git a/linux-4.5.patch b/linux-4.5.patch
new file mode 100644 (file)
index 0000000..3dd8df1
--- /dev/null
@@ -0,0 +1,14 @@
+--- r8168-8.041.01/src/r8168_n.c~      2015-10-06 08:33:04.000000000 +0200
++++ r8168-8.041.01/src/r8168_n.c       2016-04-26 07:48:15.696296115 +0200
+@@ -4209,7 +4209,11 @@
+         spin_lock_irqsave(&tp->lock, flags);
+         if (dev->mtu > ETH_DATA_LEN) {
+                 features &= ~NETIF_F_ALL_TSO;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4,5,0)
+                 features &= ~NETIF_F_ALL_CSUM;
++#else
++                features &= ~NETIF_F_CSUM_MASK;
++#endif
+         }
+         spin_unlock_irqrestore(&tp->lock, flags);
index 83f058ed4cbcb04d89d914e6fcee955bf8452654..3498aac6a0b7dc7ec296d2172f4b8517fecb488f 100644 (file)
@@ -4,12 +4,12 @@
 # nothing to be placed to debuginfo package
 %define                _enable_debug_packages  0
 
-%define                rel     2
+%define                rel     1
 %define                pname   r8168
 Summary:       Linux driver for RTL8111/8168B PCI Express Gigabit Ethernet controllers
 Summary(pl.UTF-8):     Linuksowy sterownik dla kart sieciowych RTL8111/8168B PCI Express Gigabit Ethernet
 Name:          %{pname}%{_alt_kernel}
-Version:       8.039.00
+Version:       8.041.01
 Release:       %{rel}%{?_pld_builder:@%{_kernel_ver_str}}
 License:       GPL
 Group:         Base/Kernel
@@ -18,8 +18,8 @@ URL:          http://www.realtek.com.tw/
 # http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=13&PFid=5&Level=5&Conn=4&DownTypeID=3&GetDown=false
 # unfortunately this download is not DF-friendly.
 Source0:       %{pname}-%{version}.tar.bz2
-# Source0-md5: 98314a558a4c667d7652d5dbdd0f0579
-Patch0:                linux-4.0.patch
+# Source0-md5: 38adfd88b76ec33dcd716fb28ee30057
+Patch0:                linux-4.5.patch
 BuildRequires: rpmbuild(macros) >= 1.701
 %{expand:%buildrequires_kernel kernel%%{_alt_kernel}-module-build >= 3:2.6.20.2}
 BuildRoot:     %{tmpdir}/%{pname}-%{version}-root-%(id -u -n)
This page took 0.108456 seconds and 4 git commands to generate.