]> git.pld-linux.org Git - packages/qutebrowser.git/blob - qutebrowser.spec
ac4e5144df9a03d0b255e726b632b64f2fe3a08c
[packages/qutebrowser.git] / qutebrowser.spec
1 %define         qtver   5.7.1
2 Summary:        A keyboard-driven, vim-like browser based on PyQt5
3 Name:           qutebrowser
4 Version:        1.10.0
5 Release:        1
6 License:        GPL v3+
7 Group:          X11/Applications/Networking
8 Source0:        https://github.com/qutebrowser/qutebrowser/archive/v%{version}.tar.gz
9 # Source0-md5:  296e3be923b9c4956e0a1070bb6b24b9
10 URL:            https://www.qutebrowser.org/
11 BuildRequires:  asciidoc
12 BuildRequires:  python3 >= 3.6
13 BuildRequires:  python3-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       Qt5Core >= %{qtver}
17 Requires:       Qt5OpenGL >= %{qtver}
18 Requires:       Qt5Sql >= %{qtver}
19 Requires:       Qt5Sql-sqldriver-sqlite3 >= %{qtver}
20 Requires:       Qt5WebEngine >= %{qtver}
21 Requires:       bash
22 Requires:       hicolor-icon-theme
23 Requires:       python3 >= 3.6
24 Requires:       python3-PyQt5 >= 5.7.0
25 Requires:       python3-PyYAML
26 Requires:       python3-attrs
27 Requires:       python3-jinja2
28 Requires:       python3-pyPEG2
29 Requires:       python3-pygments
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 qutebrowser is a keyboard-focused browser with a minimal GUI. It’s
35 based on Python, PyQt5 and QtWebEngine and free software, licensed
36 under the GPL. It was inspired by other browsers/addons like dwb and
37 Vimperator/Pentadactyl.
38
39 %prep
40 %setup -q
41
42 grep -r '#!.*env bash' -l . | xargs %{__sed} -i -e '1 s,#!.*env bash.*,#!/bin/bash,'
43 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python.*,#!%{__python3},'
44 grep -r '#!.*env node' -l . | xargs %{__sed} -i -e '1 s,#!.*env node.*,#!/usr/bin/node,'
45
46 %build
47 %py3_build
48
49 %{__python3} scripts/asciidoc2html.py
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %py3_install
55
56 %{__make} -f misc/Makefile install PYTHON=/bin/true DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %post
62 %update_desktop_database_post
63 %update_icon_cache hicolor
64
65 %postun
66 %update_desktop_database_postun
67 %update_icon_cache hicolor
68
69 %files
70 %defattr(644,root,root,755)
71 %doc README.asciidoc
72 %attr(755,root,root) %{_bindir}/qutebrowser
73 %{py3_sitescriptdir}/qutebrowser
74 %{py3_sitescriptdir}/qutebrowser-%{version}-py*.egg-info
75 %{_desktopdir}/org.qutebrowser.qutebrowser.desktop
76 %{_iconsdir}/hicolor/*x*/apps/qutebrowser.png
77 %{_iconsdir}/hicolor/scalable/apps/qutebrowser.svg
78 %{_mandir}/man1/qutebrowser.1*
79 %{_datadir}/metainfo/org.qutebrowser.qutebrowser.appdata.xml
80 %dir %{_datadir}/qutebrowser
81 %dir %{_datadir}/qutebrowser/scripts
82 %{_datadir}/qutebrowser/scripts/*.js
83 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.py
84 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.sh
85 %dir %{_datadir}/qutebrowser/userscripts
86 %attr(755,root,root) %{_datadir}/qutebrowser/userscripts/*
This page took 0.048708 seconds and 2 git commands to generate.