]> git.pld-linux.org Git - packages/qutebrowser.git/blob - qutebrowser.spec
7379b2ff3b739a37a74b3bb413e83c9af759931f
[packages/qutebrowser.git] / qutebrowser.spec
1 %define         qtver   5.7.1
2 Summary:        A keyboard-driven, vim-like browser based on PyQt5
3 Name:           qutebrowser
4 Version:        1.11.0
5 Release:        1
6 License:        GPL v3+
7 Group:          X11/Applications/Networking
8 Source0:        https://github.com/qutebrowser/qutebrowser/archive/v%{version}.tar.gz
9 # Source0-md5:  ee0277d9ec871a63050e6396d9a6b8d4
10 URL:            https://www.qutebrowser.org/
11 BuildRequires:  asciidoc
12 BuildRequires:  python3 >= 3.6
13 BuildRequires:  python3-setuptools
14 BuildRequires:  rpm-pythonprov
15 BuildRequires:  rpmbuild(macros) >= 1.714
16 Requires:       Qt5Core >= %{qtver}
17 Requires:       Qt5OpenGL >= %{qtver}
18 Requires:       Qt5Sql >= %{qtver}
19 Requires:       Qt5Sql-sqldriver-sqlite3 >= %{qtver}
20 Requires:       Qt5WebEngine >= %{qtver}
21 Requires:       bash
22 Requires:       hicolor-icon-theme
23 Requires:       python3 >= 3.6
24 Requires:       python3-PyQt5 >= 5.7.0
25 Requires:       python3-PyYAML
26 Requires:       python3-attrs
27 Requires:       python3-jinja2
28 Requires:       python3-pyPEG2
29 Requires:       python3-pygments
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 qutebrowser is a keyboard-focused browser with a minimal GUI. It’s
35 based on Python, PyQt5 and QtWebEngine and free software, licensed
36 under the GPL. It was inspired by other browsers/addons like dwb and
37 Vimperator/Pentadactyl.
38
39 %package userscripts
40 Summary:        User scripts for qutebrowser
41 Group:          X11/Applications/Networking
42 Requires:       %{name} = %{version}-%{release}
43
44 %description userscripts
45 User scripts for qutebrowser.
46
47 %prep
48 %setup -q
49
50 grep -r '#!.*env bash' -l . | xargs %{__sed} -i -e '1 s,#!.*env bash.*,#!/bin/bash,'
51 grep -r '#!.*env python' -l . | xargs %{__sed} -i -e '1 s,#!.*env python.*,#!%{__python3},'
52 grep -r '#!.*env node' -l . | xargs %{__sed} -i -e '1 s,#!.*env node.*,#!/usr/bin/node,'
53
54 %build
55 %py3_build
56
57 %{__python3} scripts/asciidoc2html.py
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %py3_install
63
64 %{__make} -f misc/Makefile install PYTHON=/bin/true DESTDIR=$RPM_BUILD_ROOT PREFIX=%{_prefix}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %post
70 %update_desktop_database_post
71 %update_icon_cache hicolor
72
73 %postun
74 %update_desktop_database_postun
75 %update_icon_cache hicolor
76
77 %files
78 %defattr(644,root,root,755)
79 %doc README.asciidoc
80 %attr(755,root,root) %{_bindir}/qutebrowser
81 %{py3_sitescriptdir}/qutebrowser
82 %{py3_sitescriptdir}/qutebrowser-%{version}-py*.egg-info
83 %{_desktopdir}/org.qutebrowser.qutebrowser.desktop
84 %{_iconsdir}/hicolor/*x*/apps/qutebrowser.png
85 %{_iconsdir}/hicolor/scalable/apps/qutebrowser.svg
86 %{_mandir}/man1/qutebrowser.1*
87 %{_datadir}/metainfo/org.qutebrowser.qutebrowser.appdata.xml
88 %dir %{_datadir}/qutebrowser
89 %dir %{_datadir}/qutebrowser/scripts
90 %{_datadir}/qutebrowser/scripts/*.js
91 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.py
92 %attr(755,root,root) %{_datadir}/qutebrowser/scripts/*.sh
93
94 %files userscripts
95 %defattr(644,root,root,755)
96 %dir %{_datadir}/qutebrowser/userscripts
97 %attr(755,root,root) %{_datadir}/qutebrowser/userscripts/*
This page took 0.031427 seconds and 2 git commands to generate.