]> git.pld-linux.org Git - packages/qt5-qtwebkit.git/commitdiff
adjusted upstream patch to fix build with icu 65
authorJan Palus <atler@pld-linux.org>
Tue, 8 Oct 2019 08:03:25 +0000 (10:03 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 8 Oct 2019 08:03:25 +0000 (10:03 +0200)
icu65.patch [new file with mode: 0644]
qt5-qtwebkit.spec

diff --git a/icu65.patch b/icu65.patch
new file mode 100644 (file)
index 0000000..e3b7d07
--- /dev/null
@@ -0,0 +1,50 @@
+------------------------------------------------------------------------
+r250747 | commit-queue@webkit.org | 2019-10-04 23:51:37 +0200 (pią, 04 paź 2019) | 16 lines
+
+Fix build with icu 65.1
+https://bugs.webkit.org/show_bug.cgi?id=202600
+
+Patch by Heiko Becker <heirecka@exherbo.org> on 2019-10-04
+Reviewed by Konstantin Tokarev.
+
+Source/WebCore:
+
+* dom/Document.cpp:
+(WebCore::isValidNameNonASCII):
+(WebCore::Document::parseQualifiedName):
+
+Source/WTF:
+
+* wtf/URLHelpers.cpp:
+(WTF::URLHelpers::allCharactersInIDNScriptWhiteList):
+
+Index: Source/WebCore/dom/Document.cpp
+===================================================================
+--- Source/WebCore/dom/Document.cpp    (revision 250746)
++++ Source/WebCore/dom/Document.cpp    (revision 250747)
+@@ -4954,12 +4954,12 @@
+     unsigned i = 0;
+     UChar32 c;
+-    U16_NEXT(characters, i, length, c)
++    U16_NEXT(characters, i, length, c);
+     if (!isValidNameStart(c))
+         return false;
+     while (i < length) {
+-        U16_NEXT(characters, i, length, c)
++        U16_NEXT(characters, i, length, c);
+         if (!isValidNamePart(c))
+             return false;
+     }
+@@ -5019,7 +5019,7 @@
+     for (unsigned i = 0; i < length; ) {
+         UChar32 c;
+-        U16_NEXT(qualifiedName, i, length, c)
++        U16_NEXT(qualifiedName, i, length, c);
+         if (c == ':') {
+             if (sawColon)
+                 return Exception { InvalidCharacterError };
+
+------------------------------------------------------------------------
index 4d26220197b6859500a054c6564f3fc040764afa..2cf70145dbb03db050dc9222700863c3bed2ba21 100644 (file)
@@ -42,6 +42,7 @@ License:      LGPL v2+
 Group:         X11/Libraries
 Source0:       https://github.com/qtwebkit/qtwebkit/releases/download/qtwebkit-%{version}-%{snap}/qtwebkit-%{version}-%{snap}.tar.xz
 # Source0-md5: 5e7ade75ad0df9047826e625e4f262fc
+Patch0:                icu65.patch
 # from FC
 Patch102:      qtwebkit-5.212.0_cmake_cmp0071.patch
 Patch108:      x32.patch
@@ -185,6 +186,7 @@ Dokumentacja do bibliotek Qt5 WebKit w formacie QCH.
 
 %prep
 %setup -q -n qtwebkit-%{version}-%{snap}
+%patch0 -p0
 %patch102 -p1
 %patch108 -p1
 
This page took 0.167156 seconds and 4 git commands to generate.