]> git.pld-linux.org Git - packages/qt5-qtwebengine.git/commitdiff
another debian patch to fix 32bit build with new binutils; rel 6 auto/th/qt5-qtwebengine-5.15.0-6
authorJan Palus <atler@pld-linux.org>
Wed, 5 Aug 2020 15:52:09 +0000 (17:52 +0200)
committerJan Palus <atler@pld-linux.org>
Wed, 5 Aug 2020 15:52:09 +0000 (17:52 +0200)
binutils-2.35.patch [new file with mode: 0644]
qt5-qtwebengine.spec

diff --git a/binutils-2.35.patch b/binutils-2.35.patch
new file mode 100644 (file)
index 0000000..dedb0f2
--- /dev/null
@@ -0,0 +1,35 @@
+Description: build openh264 with -DX86_32_PICASM on x86
+ To fix linker errors with new binutils, see #965328.
+Author: Dmitry Shachnev <mitya57@debian.org>
+Forwarded: not-yet
+Last-Update: 2020-07-20
+
+--- a/src/3rdparty/chromium/third_party/openh264/BUILD.gn
++++ b/src/3rdparty/chromium/third_party/openh264/BUILD.gn
+@@ -67,7 +67,7 @@ if (use_assembler) {
+     sources = openh264_common_sources_asm_x86
+     defines = yasm_defines
+     if (target_cpu == "x86") {
+-      defines += [ "X86_32" ]
++      defines += [ "X86_32", "X86_32_PICASM" ]
+     } else {  # x64
+       if (is_mac) {
+         defines += [
+@@ -88,7 +88,7 @@ if (use_assembler) {
+     sources = openh264_processing_sources_asm_x86
+     defines = yasm_defines
+     if (target_cpu == "x86") {
+-      defines += [ "X86_32" ]
++      defines += [ "X86_32", "X86_32_PICASM" ]
+     } else {  # x64
+       if (is_mac) {
+         defines += [
+@@ -109,7 +109,7 @@ if (use_assembler) {
+     sources = openh264_encoder_sources_asm_x86
+     defines = yasm_defines
+     if (target_cpu == "x86") {
+-      defines += [ "X86_32" ]
++      defines += [ "X86_32", "X86_32_PICASM" ]
+     } else {  # x64
+       if (is_mac) {
+         defines += [
index 26690c09f3e4ec94b034333aee20b05d44c03272..b48dd564b52e7e05f26aa8f18d53a12613959084 100644 (file)
@@ -8,7 +8,7 @@ Summary:        The Qt5 WebEngine library
 Summary(pl.UTF-8):     Biblioteka Qt5 WebEngine
 Name:          qt5-%{orgname}
 Version:       5.15.0
-Release:       5
+Release:       6
 License:       LGPL v3 or GPL v2+ or commercial
 Group:         X11/Libraries
 Source0:       http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
@@ -16,7 +16,8 @@ Source0:      http://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%
 Patch0:                x32.patch
 Patch1:                webauthn.patch
 Patch2:                bison-3.7.patch
-Patch3:                icu67.patch
+Patch3:                binutils-2.35.patch
+Patch4:                icu67.patch
 URL:           http://www.qt.io/
 BuildRequires: Mesa-khrplatform-devel
 BuildRequires: Qt5Core-devel >= %{version}
@@ -228,8 +229,9 @@ Biblioteka Qt5 Pdf - pliki programistyczne.
 %endif
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
 cd ./src/3rdparty/chromium
-%patch3 -p2
+%patch4 -p2
 
 %build
 %ifarch x32
This page took 0.509159 seconds and 4 git commands to generate.