]> git.pld-linux.org Git - packages/qt5-qtwebengine.git/blobdiff - qt5-qtwebengine.spec
- remove compiler check that's not needed and doesn't work because we set QMAKE_COMPI...
[packages/qt5-qtwebengine.git] / qt5-qtwebengine.spec
index 54e2079e91aad7e9bb55e0d6634e7fa0eb63919d..a042de67cd958a56349d7563217031a540adbf14 100644 (file)
@@ -1,6 +1,6 @@
 #
 # Conditional build:
-%bcond_without qch     # documentation in QCH format
+%bcond_without doc     # Documentation
 
 %define                orgname         qtwebengine
 %define                qtbase_ver              %{version}
 Summary:       The Qt5 WebEngine library
 Summary(pl.UTF-8):     Biblioteka Qt5 WebEngine
 Name:          qt5-%{orgname}
-Version:       5.5.1
+Version:       5.11.1
 Release:       0.1
 License:       LGPL v3 or GPL v2+ or commercial
 Group:         X11/Libraries
-Source0:       http://download.qt.io/official_releases/qt/5.5/%{version}/submodules/%{orgname}-opensource-src-%{version}.tar.xz
-# Source0-md5: 2a548bde706e8639cdec2cbe31d85545
+Source0:       http://download.qt.io/official_releases/qt/5.11/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
+# Source0-md5: 75d2ff31addba4ec41981b0f459cc587
+Patch0:                remove-compiler-check.patch
 URL:           http://www.qt.io/
 BuildRequires: Qt5Core-devel >= %{qtbase_ver}
 BuildRequires: Qt5Gui-devel >= %{qtbase_ver}
@@ -24,7 +25,7 @@ BuildRequires:        Qt5Qml-devel >= %{qtdeclarative_ver}
 BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
 BuildRequires: Qt5WebChannel-devel >= %{qtwebchannel_ver}
 BuildRequires: Qt5Widgets-devel >= %{qtbase_ver}
-%if %{with qch}
+%if %{with doc}
 BuildRequires: qt5-assistant >= %{qttools_ver}
 %endif
 BuildRequires: qt5-build >= %{qtbase_ver}
@@ -128,23 +129,27 @@ Qt5 WebEngine examples.
 PrzykĹ‚ady do biblioteki Qt5 WebEngine.
 
 %prep
-%setup -q -n %{orgname}-opensource-src-%{version}
+%setup -q -n %{orgname}-everywhere-src-%{version}
+%patch0 -p1
 
 %build
 qmake-qt5
-%{__make}
-%{__make} %{!?with_qch:html_}docs
+%{__make} \
+       QMAKE_CXX="g++"
+%{?with_doc:%{__make} docs}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        INSTALL_ROOT=$RPM_BUILD_ROOT
 
-%{__make} install_%{!?with_qch:html_}docs \
+%if %{with doc}
+%{__make} install_docs \
        INSTALL_ROOT=$RPM_BUILD_ROOT
+%endif
 
 # useless symlinks
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.?
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
 # actually drop *.la, follow policy of not packaging them when *.pc exist
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
 
@@ -199,11 +204,11 @@ rm -rf $RPM_BUILD_ROOT
 %{qt5dir}/mkspecs/modules/qt_lib_webengine.pri
 %{qt5dir}/mkspecs/modules/qt_lib_webengine_private.pri
 
+%if %{with doc}
 %files doc
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebengine
 
-%if %{with qch}
 %files doc-qch
 %defattr(644,root,root,755)
 %{_docdir}/qt5-doc/qtwebengine.qch
This page took 0.094333 seconds and 4 git commands to generate.