]> git.pld-linux.org Git - packages/qt5-qtwebengine.git/blame - qt5-qtwebengine.spec
manually adjust artificial qt version deps in cmake files; rel 2
[packages/qt5-qtwebengine.git] / qt5-qtwebengine.spec
CommitLineData
daa4415e
JB
1#
2# Conditional build:
3acb2706 3%bcond_without doc # documentation
37b97c17 4%bcond_without system_libvpx # Build with system libvpx
daa4415e 5
4f7be6a6
JP
6%define base_version 5.15
7
daa4415e 8%define orgname qtwebengine
b1b877d1
JP
9%define qtbase_ver 5.15
10%define qtdeclarative_ver 5.15
11%define qtlocation_ver 5.15
12%define qtsvg_ver 5.15
13%define qttools_ver 5.15
14%define qtwebchannel_ver 5.15
daa4415e
JB
15Summary: The Qt5 WebEngine library
16Summary(pl.UTF-8): Biblioteka Qt5 WebEngine
17Name: qt5-%{orgname}
4f7be6a6
JP
18Version: %{base_version}.6
19Release: 2
3acb2706 20License: LGPL v3 or GPL v2 or GPL v3 or commercial
daa4415e 21Group: X11/Libraries
3b5e88b8 22Source0: qtwebengine-%{version}.tar.xz
815f1910 23# Source0-md5: 61a4fa3e98149543c08172c99993c844
6b0906cb 24Patch0: x32.patch
3acb2706 25Patch1: %{name}-gn-dynamic.patch
3b5e88b8
JP
26Patch2: icu.patch
27Patch3: glibc-2.33.patch
7b92ae8b 28Patch4: glibc2.34.patch
ed0134ce 29URL: https://www.qt.io/
3acb2706
JB
30BuildRequires: Qt5Core-devel >= %{qtbase_ver}
31BuildRequires: Qt5Designer-devel >= %{qttools_ver}
32BuildRequires: Qt5Gui-devel >= %{qtbase_ver}
33BuildRequires: Qt5Network-devel >= %{qtbase_ver}
34BuildRequires: Qt5Positioning-devel >= %{qtlocation_ver}
35BuildRequires: Qt5PrintSupport-devel >= %{qtbase_ver}
36BuildRequires: Qt5Qml-devel >= %{qtdeclarative_ver}
37BuildRequires: Qt5Quick-devel >= %{qtdeclarative_ver}
38BuildRequires: Qt5Svg-devel >= %{qtsvg_ver}
39BuildRequires: Qt5UiTools-devel >= %{qttools_ver}
40BuildRequires: Qt5WebChannel-devel >= %{qtwebchannel_ver}
41BuildRequires: Qt5Widgets-devel >= %{qtbase_ver}
ce64a084
JP
42BuildRequires: alsa-lib-devel >= 1.0.10
43BuildRequires: bison
44BuildRequires: dbus-devel
3acb2706
JB
45BuildRequires: expat-devel
46# libavcodec libavformat libavutil
ce64a084
JP
47BuildRequires: ffmpeg-devel
48BuildRequires: flex
49BuildRequires: fontconfig-devel
3acb2706 50BuildRequires: freetype-devel >= 1:2.4.2
ce64a084 51BuildRequires: glib2-devel >= 1:2.32.0
3acb2706
JB
52BuildRequires: glibc-misc >= 6:2.17
53BuildRequires: glibc-devel >= 6:2.17
ce64a084 54BuildRequires: gperf
c91e1c7d 55BuildRequires: harfbuzz-devel >= 2.2.0
3acb2706
JB
56# webengine-system-jsoncpp disabled in src/core/config/linux.pri
57#BuildRequires: jsoncpp-devel
09943e8d 58BuildRequires: khrplatform-devel
ce64a084
JP
59BuildRequires: lcms2-devel
60BuildRequires: libdrm-devel
61BuildRequires: libevent-devel
c91e1c7d 62BuildRequires: libicu-devel >= 64
ce64a084 63BuildRequires: libjpeg-devel
3acb2706
JB
64BuildRequires: libpng-devel >= 2:1.6.0
65BuildRequires: libstdc++-devel >= 6:5
ce64a084
JP
66%{?with_system_libvpx:BuildRequires: libvpx-devel >= 1.8.0}
67BuildRequires: libwebp-devel
3acb2706
JB
68BuildRequires: libxcb-devel
69# need icu enabled to be accepted
70#BuildRequires: libxml2-devel >= 2
71#BuildRequires: libxslt-devel
ce64a084
JP
72BuildRequires: minizip-devel
73BuildRequires: ninja
e5ae5bcf 74BuildRequires: nodejs
3acb2706 75BuildRequires: nspr-devel
ce64a084 76BuildRequires: nss-devel >= 3.26
c91e1c7d 77BuildRequires: opus-devel >= 1.3.1
ce64a084 78BuildRequires: pkgconfig
3acb2706
JB
79# checked by qt part, but no longer used by current chromium
80#BuildRequires: poppler-cpp-devel
81# webengine-system-protobuf disabled in src/core/config/linux.pri
82#BuildRequires: protobuf-devel
ce64a084 83BuildRequires: pulseaudio-devel >= 0.9.10
3acb2706 84BuildRequires: python >= 1:2.7.5
de8a9faa 85%if %{with doc}
b1b877d1 86BuildRequires: qt5-assistant >= 5.15
daa4415e 87%endif
b1b877d1
JP
88BuildRequires: qt5-build >= 5.15
89BuildRequires: qt5-qmake >= 5.15
7c8e5cfd 90BuildRequires: qt5-qtdoc
26cfb426 91BuildRequires: qt5-qttools
3acb2706
JB
92BuildRequires: re2-devel
93BuildRequires: rpmbuild(macros) >= 1.752
94BuildRequires: snappy-devel
daa4415e 95BuildRequires: tar >= 1:1.22
ce64a084 96BuildRequires: xorg-lib-libX11-devel
3acb2706 97BuildRequires: xorg-lib-libXScrnSaver-devel
ce64a084
JP
98BuildRequires: xorg-lib-libXcomposite-devel
99BuildRequires: xorg-lib-libXcursor-devel
3acb2706
JB
100BuildRequires: xorg-lib-libXdamage-devel
101BuildRequires: xorg-lib-libXext-devel
102BuildRequires: xorg-lib-libXfixes-devel
ce64a084 103BuildRequires: xorg-lib-libXi-devel
3acb2706 104BuildRequires: xorg-lib-libXrender-devel
ce64a084
JP
105BuildRequires: xorg-lib-libXrandr-devel
106BuildRequires: xorg-lib-libXtst-devel
c91e1c7d 107BuildRequires: xorg-lib-libxkbcommon-devel
daa4415e 108BuildRequires: xz
ce64a084 109BuildRequires: zlib-devel
2d29c405 110BuildConflicts: Qt5WebEngine-devel
daa4415e
JB
111BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113%define specflags -fno-strict-aliasing
114%define qt5dir %{_libdir}/qt5
115
3b5e88b8
JP
116%define qt5bindir %(qtpaths-qt5 --binaries-dir)
117
daa4415e
JB
118%description
119Qt is a cross-platform application and UI framework. Using Qt, you can
120write web-enabled applications once and deploy them across desktop,
121mobile and embedded systems without rewriting the source code.
122
123This package contains Qt5 WebEngine library.
124
125%description -l pl.UTF-8
126Qt to wieloplatformowy szkielet aplikacji i interfejsów użytkownika.
127Przy użyciu Qt można pisać aplikacje powiązane z WWW i wdrażać je w
128systemach biurkowych, przenośnych i wbudowanych bez przepisywania kodu
129źródłowego.
130
131Ten pakiet zawiera bibliotekę Qt5 WebEngine.
132
133%package -n Qt5WebEngine
134Summary: The Qt5 WebEngine library
135Summary(pl.UTF-8): Biblioteka Qt5 WebEngine
136Group: Libraries
b1b877d1
JP
137%requires_ge_to Qt5Core Qt5Core-devel
138%requires_ge_to Qt5Gui Qt5Gui-devel
139%requires_ge_to Qt5Network Qt5Network-devel
140%requires_ge_to Qt5Positioning Qt5Positioning-devel
141%requires_ge_to Qt5Qml Qt5Qml-devel
142%requires_ge_to Qt5Quick Qt5Quick-devel
143%requires_ge_to Qt5WebChannel Qt5WebChannel-devel
3acb2706
JB
144Requires: alsa-lib >= 1.0.10
145Requires: freetype >= 1:2.4.2
146Requires: harfbuzz >= 2.2.0
147Requires: libicu >= 64
148Requires: libpng >= 2:1.6.0
149%{?with_system_libvpx:Requires: libvpx >= 1.8.0}
150Requires: nss >= 3.26
151Requires: opus >= 1.3.1
152Requires: pulseaudio-libs >= 0.9.10
daa4415e
JB
153
154%description -n Qt5WebEngine
155Qt5 WebEngine library provides seamless integration of C++ and QML
156applications with HTML/JavaScript clients.
157
158%description -n Qt5WebEngine -l pl.UTF-8
159Biblioteka Qt5 WebEngine udostępnia integrację aplikacji C++ i QML z
160klientami w HTML-u/JavaScripcie.
161
162%package -n Qt5WebEngine-devel
163Summary: Qt5 WebEngine library - development files
164Summary(pl.UTF-8): Biblioteka Qt5 WebEngine - pliki programistyczne
165Group: Development/Libraries
b1b877d1
JP
166%requires_ge Qt5Core-devel
167%requires_ge Qt5Gui-devel
168%requires_ge Qt5Network-devel
169%requires_ge Qt5Positioning-devel
170%requires_ge Qt5PrintSupport-devel
171%requires_ge Qt5Qml-devel
172%requires_ge Qt5Quick-devel
173%requires_ge Qt5WebChannel-devel
daa4415e 174Requires: Qt5WebEngine = %{version}-%{release}
b1b877d1 175%requires_ge Qt5Widgets-devel
daa4415e
JB
176
177%description -n Qt5WebEngine-devel
178Qt5 WebEngine library - development files.
179
180%description -n Qt5WebEngine-devel -l pl.UTF-8
181Biblioteka Qt5 WebEngine - pliki programistyczne.
182
3acb2706
JB
183%package -n Qt5Pdf
184Summary: The Qt5 Pdf library
185Summary(pl.UTF-8): Biblioteka Qt5 Pdf
186Group: Libraries
b1b877d1
JP
187%requires_ge_to Qt5Core Qt5Core-devel
188%requires_ge_to Qt5Gui Qt5Gui-devel
189%requires_ge_to Qt5Network Qt5Network-devel
190%requires_ge_to Qt5Qml Qt5Qml-devel
191%requires_ge_to Qt5Quick Qt5Quick-devel
192%requires_ge_to Qt5Widgets Qt5Widgets-devel
3acb2706
JB
193
194%description -n Qt5Pdf
195Qt5 Pdf module contains classes and functions for rendering PDF
196documents.
197
198%description -n Qt5Pdf -l pl.UTF-8
199Moduł Qt5 Pdf zawiera klasy i funkcje do renderowania dokumentów PDF.
200
201%package -n Qt5Pdf-devel
202Summary: Qt5 Pdf library - development files
203Summary(pl.UTF-8): Biblioteka Qt5 Pdf - pliki programistyczne
204Group: Development/Libraries
b1b877d1
JP
205%requires_ge Qt5Core-devel
206%requires_ge Qt5Gui-devel
3acb2706 207Requires: Qt5Pdf = %{version}-%{release}
b1b877d1 208%requires_ge Qt5Widgets-devel
3acb2706
JB
209
210%description -n Qt5Pdf-devel
211Qt5 Pdf library - development files.
212
213%description -n Qt5Pdf-devel -l pl.UTF-8
214Biblioteka Qt5 Pdf - pliki programistyczne.
215
ed0134ce
JB
216%package -n Qt5Designer-plugin-qwebengineview
217Summary: QWebEngineView plugin for Qt5 Designer
218Summary(pl.UTF-8): Wtyczka QWebEngineView dla Qt5 Designera
219Group: X11/Libraries
b1b877d1
JP
220%requires_ge_to Qt5Core Qt5Core-devel
221%requires_ge_to Qt5Gui Qt5Gui-devel
222%requires_ge_to Qt5Designer Qt5Designer-devel
ed0134ce 223Requires: Qt5WebEngine = %{version}-%{release}
b1b877d1 224%requires_ge_to Qt5Widgets Qt5Widgets-devel
ed0134ce
JB
225
226%description -n Qt5Designer-plugin-qwebengineview
227QWebEngineView plugin for Qt5 Designer.
228
229%description -n Qt5Designer-plugin-qwebengineview -l pl.UTF-8
230Wtyczka QWebEngineView dla Qt5 Designera.
231
daa4415e
JB
232%package doc
233Summary: Qt5 WebEngine documentation in HTML format
234Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 WebEngine w formacie HTML
3acb2706 235License: FDL v1.3
daa4415e 236Group: Documentation
b1b877d1 237%requires_ge_to qt5-doc-common Qt5Core-devel
eaae791a 238BuildArch: noarch
daa4415e
JB
239
240%description doc
241Qt5 WebEngine documentation in HTML format.
242
243%description doc -l pl.UTF-8
244Dokumentacja do biblioteki Qt5 WebEngine w formacie HTML.
245
246%package doc-qch
247Summary: Qt5 WebEngine documentation in QCH format
248Summary(pl.UTF-8): Dokumentacja do biblioteki Qt5 WebEngine w formacie QCH
3acb2706 249License: FDL v1.3
daa4415e 250Group: Documentation
b1b877d1 251%requires_ge_to qt5-doc-common Qt5Core-devel
eaae791a 252BuildArch: noarch
daa4415e
JB
253
254%description doc-qch
255Qt5 WebEngine documentation in QCH format.
256
257%description doc-qch -l pl.UTF-8
258Dokumentacja do biblioteki Qt5 WebEngine w formacie QCH.
259
260%package examples
261Summary: Qt5 WebEngine examples
262Summary(pl.UTF-8): Przykłady do biblioteki Qt5 WebEngine
3acb2706 263License: BSD or commercial
daa4415e 264Group: X11/Development/Libraries
eaae791a 265BuildArch: noarch
daa4415e
JB
266
267%description examples
268Qt5 WebEngine examples.
269
270%description examples -l pl.UTF-8
271Przykłady do biblioteki Qt5 WebEngine.
272
273%prep
3b5e88b8 274%setup -q -n qtwebengine
06e41866 275%ifarch x32
6b0906cb 276%patch0 -p1
06e41866 277%endif
3acb2706 278%patch1 -p1
3b5e88b8
JP
279%patch2 -p1
280%patch3 -p1
7b92ae8b
JP
281cd src/3rdparty/chromium
282%patch4 -p1
283cd ../../..
3b5e88b8
JP
284
285%{qt5bindir}/syncqt.pl -version %{version}
1abc1d3c 286
daa4415e 287%build
06e41866
JR
288%ifarch x32
289export V8_TARGET_ARCH="x32"
290%endif
3b5e88b8 291qmake-qt5 CONFIG+=use_gold_linker -- \
ce64a084 292 -webengine-ffmpeg \
2d011345 293 -webengine-icu \
e5ae5bcf
JP
294 -webengine-opus \
295 -webengine-proprietary-codecs \
296 -webengine-webp \
297 -webengine-webrtc
3acb2706 298
0a1dd662 299%{?__jobs:NINJAJOBS="-j %__jobs"} \
1abc1d3c 300%{__make}
de8a9faa 301%{?with_doc:%{__make} docs}
daa4415e
JB
302
303%install
304rm -rf $RPM_BUILD_ROOT
3acb2706 305
daa4415e
JB
306%{__make} install \
307 INSTALL_ROOT=$RPM_BUILD_ROOT
308
de8a9faa
JR
309%if %{with doc}
310%{__make} install_docs \
daa4415e 311 INSTALL_ROOT=$RPM_BUILD_ROOT
de8a9faa 312%endif
daa4415e
JB
313
314# useless symlinks
7ed59526 315%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.so.5.??
daa4415e
JB
316# actually drop *.la, follow policy of not packaging them when *.pc exist
317%{__rm} $RPM_BUILD_ROOT%{_libdir}/libQt5*.la
3acb2706
JB
318# misnamed?
319%{__rm} $RPM_BUILD_ROOT%{_libdir}/Qt5WebEngineCore.la
daa4415e
JB
320
321# Prepare some files list
322ifecho() {
323 r="$RPM_BUILD_ROOT$2"
324 if [ -d "$r" ]; then
325 echo "%%dir $2" >> $1.files
326 elif [ -x "$r" ] ; then
327 echo "%%attr(755,root,root) $2" >> $1.files
328 elif [ -f "$r" ]; then
329 echo "$2" >> $1.files
330 else
331 echo "Error generation $1 files list!"
332 echo "$r: no such file or directory!"
333 return 1
334 fi
335}
336ifecho_tree() {
337 ifecho $1 $2
338 for f in `find $RPM_BUILD_ROOT$2 -printf "%%P "`; do
339 ifecho $1 $2/$f
340 done
341}
342
343echo "%defattr(644,root,root,755)" > examples.files
3acb2706
JB
344ifecho_tree examples %{_examplesdir}/qt5/pdf
345ifecho_tree examples %{_examplesdir}/qt5/pdfwidgets
daa4415e 346ifecho_tree examples %{_examplesdir}/qt5/webengine
1abc1d3c 347ifecho_tree examples %{_examplesdir}/qt5/webenginewidgets
daa4415e 348
4f7be6a6
JP
349# fixup artificial Qt version dependency
350sed -i -e 's/%{version} ${_Qt5WebEngine[^_]*_FIND_VERSION_EXACT}/%{base_version}/' \
351 $RPM_BUILD_ROOT%{_libdir}/cmake/Qt5WebEngine*/Qt5WebEngine*Config.cmake
352
daa4415e
JB
353%clean
354rm -rf $RPM_BUILD_ROOT
355
356%post -n Qt5WebEngine -p /sbin/ldconfig
357%postun -n Qt5WebEngine -p /sbin/ldconfig
358
c91e1c7d
JP
359%post -n Qt5Pdf -p /sbin/ldconfig
360%postun -n Qt5Pdf -p /sbin/ldconfig
361
daa4415e
JB
362%files -n Qt5WebEngine
363%defattr(644,root,root,755)
3acb2706
JB
364%doc LICENSE.Chromium LICENSE.GPL3-EXCEPT dist/changes-*
365# R: Qt5Core Qt5Gui Qt5Network Qt5Qml Qt5Quick Qt5WebChannel Qt5WebEngineCore
daa4415e
JB
366%attr(755,root,root) %{_libdir}/libQt5WebEngine.so.*.*.*
367%attr(755,root,root) %ghost %{_libdir}/libQt5WebEngine.so.5
3acb2706 368# R: Qt5Core Qt5Gui Qt5Network Qt5Positioning Qt5Qml Qt5Quick Qt5WebChannel alsa-lib dbus-libs expat fontconfig freetype harfbuzz lcms2 libX11 libXcomposite libXcursor libXdamage libXext libXfixes libXi libXrender libXrandr libXss libavcodec libavformat libavutil libevent libjpeg libicu libpng libvpx libwebp libxcb minizip nspr nss opus re2 snappy zlib
1abc1d3c
AM
369%attr(755,root,root) %{_libdir}/libQt5WebEngineCore.so.*.*.*
370%attr(755,root,root) %ghost %{_libdir}/libQt5WebEngineCore.so.5
3acb2706 371# R: Qt5Core Qt5Gui Qt5Network Qt5PrintSupport Qt5Quick Qt5QuickWidgets Qt5WebEngineCore Qt5Widgets
1abc1d3c
AM
372%attr(755,root,root) %{_libdir}/libQt5WebEngineWidgets.so.*.*.*
373%attr(755,root,root) %ghost %{_libdir}/libQt5WebEngineWidgets.so.5
daa4415e 374%dir %{qt5dir}/qml/QtWebEngine
daa4415e
JB
375%{qt5dir}/qml/QtWebEngine/plugins.qmltypes
376%{qt5dir}/qml/QtWebEngine/qmldir
1abc1d3c
AM
377%{qt5dir}/qml/QtWebEngine/Controls1Delegates
378%{qt5dir}/qml/QtWebEngine/Controls2Delegates
3acb2706 379# R: Qt5Core Qt5Qml Qt5Quick Qt5WebEngine Qt5WebEngineCore
1abc1d3c 380%attr(755,root,root) %{qt5dir}/qml/QtWebEngine/libqtwebengineplugin.so
cdd0ffa8 381%dir %{_datadir}/qt5/resources
1abc1d3c 382%{_datadir}/qt5/resources/qtwebengine*.pak
3acb2706
JB
383%dir %{_datadir}/qt5/translations/qtwebengine_locales
384%lang(am) %{_datadir}/qt5/translations/qtwebengine_locales/am.pak
385%lang(ar) %{_datadir}/qt5/translations/qtwebengine_locales/ar.pak
386%lang(bg) %{_datadir}/qt5/translations/qtwebengine_locales/bg.pak
387%lang(bn) %{_datadir}/qt5/translations/qtwebengine_locales/bn.pak
388%lang(ca) %{_datadir}/qt5/translations/qtwebengine_locales/ca.pak
389%lang(cs) %{_datadir}/qt5/translations/qtwebengine_locales/cs.pak
390%lang(da) %{_datadir}/qt5/translations/qtwebengine_locales/da.pak
391%lang(de) %{_datadir}/qt5/translations/qtwebengine_locales/de.pak
392%lang(el) %{_datadir}/qt5/translations/qtwebengine_locales/el.pak
393%lang(en) %{_datadir}/qt5/translations/qtwebengine_locales/en-GB.pak
394%lang(en) %{_datadir}/qt5/translations/qtwebengine_locales/en-US.pak
395%lang(es) %{_datadir}/qt5/translations/qtwebengine_locales/es.pak
396%lang(es_AR,es_BO,es_CL,es_CO,es_CR,es_CU,es_DO,es_EC,es_GT,es_HN,es_MX,es_NI,es_PA,es_PE,es_PR,es_PY,es_SV,es_UY,es_VE) %{_datadir}/qt5/translations/qtwebengine_locales/es-419.pak
397%lang(et) %{_datadir}/qt5/translations/qtwebengine_locales/et.pak
398%lang(fa) %{_datadir}/qt5/translations/qtwebengine_locales/fa.pak
399%lang(fi) %{_datadir}/qt5/translations/qtwebengine_locales/fi.pak
400%lang(fil) %{_datadir}/qt5/translations/qtwebengine_locales/fil.pak
401%lang(fr) %{_datadir}/qt5/translations/qtwebengine_locales/fr.pak
402%lang(gu) %{_datadir}/qt5/translations/qtwebengine_locales/gu.pak
403%lang(he) %{_datadir}/qt5/translations/qtwebengine_locales/he.pak
404%lang(hi) %{_datadir}/qt5/translations/qtwebengine_locales/hi.pak
405%lang(hr) %{_datadir}/qt5/translations/qtwebengine_locales/hr.pak
406%lang(hu) %{_datadir}/qt5/translations/qtwebengine_locales/hu.pak
407%lang(id) %{_datadir}/qt5/translations/qtwebengine_locales/id.pak
408%lang(it) %{_datadir}/qt5/translations/qtwebengine_locales/it.pak
409%lang(ja) %{_datadir}/qt5/translations/qtwebengine_locales/ja.pak
410%lang(kn) %{_datadir}/qt5/translations/qtwebengine_locales/kn.pak
411%lang(ko) %{_datadir}/qt5/translations/qtwebengine_locales/ko.pak
412%lang(lt) %{_datadir}/qt5/translations/qtwebengine_locales/lt.pak
413%lang(lv) %{_datadir}/qt5/translations/qtwebengine_locales/lv.pak
414%lang(ml) %{_datadir}/qt5/translations/qtwebengine_locales/ml.pak
415%lang(mr) %{_datadir}/qt5/translations/qtwebengine_locales/mr.pak
416%lang(ms) %{_datadir}/qt5/translations/qtwebengine_locales/ms.pak
417%lang(nb) %{_datadir}/qt5/translations/qtwebengine_locales/nb.pak
418%lang(nl) %{_datadir}/qt5/translations/qtwebengine_locales/nl.pak
419%lang(pl) %{_datadir}/qt5/translations/qtwebengine_locales/pl.pak
420%lang(pt_BR) %{_datadir}/qt5/translations/qtwebengine_locales/pt-BR.pak
421%lang(pt) %{_datadir}/qt5/translations/qtwebengine_locales/pt-PT.pak
422%lang(ro) %{_datadir}/qt5/translations/qtwebengine_locales/ro.pak
423%lang(ru) %{_datadir}/qt5/translations/qtwebengine_locales/ru.pak
424%lang(sk) %{_datadir}/qt5/translations/qtwebengine_locales/sk.pak
425%lang(sl) %{_datadir}/qt5/translations/qtwebengine_locales/sl.pak
426%lang(sr) %{_datadir}/qt5/translations/qtwebengine_locales/sr.pak
427%lang(sv) %{_datadir}/qt5/translations/qtwebengine_locales/sv.pak
428%lang(sw) %{_datadir}/qt5/translations/qtwebengine_locales/sw.pak
429%lang(ta) %{_datadir}/qt5/translations/qtwebengine_locales/ta.pak
430%lang(te) %{_datadir}/qt5/translations/qtwebengine_locales/te.pak
431%lang(th) %{_datadir}/qt5/translations/qtwebengine_locales/th.pak
432%lang(tr) %{_datadir}/qt5/translations/qtwebengine_locales/tr.pak
433%lang(uk) %{_datadir}/qt5/translations/qtwebengine_locales/uk.pak
434%lang(vi) %{_datadir}/qt5/translations/qtwebengine_locales/vi.pak
435%lang(zh_CN) %{_datadir}/qt5/translations/qtwebengine_locales/zh-CN.pak
436%lang(zh_TW) %{_datadir}/qt5/translations/qtwebengine_locales/zh-TW.pak
437# R: Qt5Core libevent libicu
1abc1d3c 438%attr(755,root,root) %{_libdir}/qt5/bin/qwebengine_convert_dict
3acb2706 439# R: Qt5Core Qt5WebEngineCore
1abc1d3c 440%attr(755,root,root) %{_libdir}/qt5/libexec/QtWebEngineProcess
daa4415e
JB
441
442%files -n Qt5WebEngine-devel
443%defattr(644,root,root,755)
444%attr(755,root,root) %{_libdir}/libQt5WebEngine.so
1abc1d3c
AM
445%attr(755,root,root) %{_libdir}/libQt5WebEngineCore.so
446%attr(755,root,root) %{_libdir}/libQt5WebEngineWidgets.so
daa4415e 447%{_libdir}/libQt5WebEngine.prl
1abc1d3c
AM
448%{_libdir}/libQt5WebEngineCore.prl
449%{_libdir}/libQt5WebEngineWidgets.prl
daa4415e 450%{_includedir}/qt5/QtWebEngine
1abc1d3c
AM
451%{_includedir}/qt5/QtWebEngineCore
452%{_includedir}/qt5/QtWebEngineWidgets
daa4415e 453%{_pkgconfigdir}/Qt5WebEngine.pc
1abc1d3c
AM
454%{_pkgconfigdir}/Qt5WebEngineCore.pc
455%{_pkgconfigdir}/Qt5WebEngineWidgets.pc
daa4415e 456%{_libdir}/cmake/Qt5WebEngine
1abc1d3c
AM
457%{_libdir}/cmake/Qt5WebEngineCore
458%{_libdir}/cmake/Qt5WebEngineWidgets
daa4415e
JB
459%{qt5dir}/mkspecs/modules/qt_lib_webengine.pri
460%{qt5dir}/mkspecs/modules/qt_lib_webengine_private.pri
1abc1d3c
AM
461%{_libdir}/qt5/mkspecs/modules/qt_lib_webenginecore.pri
462%{_libdir}/qt5/mkspecs/modules/qt_lib_webenginecore_private.pri
463%{_libdir}/qt5/mkspecs/modules/qt_lib_webenginecoreheaders_private.pri
464%{_libdir}/qt5/mkspecs/modules/qt_lib_webenginewidgets.pri
465%{_libdir}/qt5/mkspecs/modules/qt_lib_webenginewidgets_private.pri
daa4415e 466
ed0134ce
JB
467%files -n Qt5Designer-plugin-qwebengineview
468%defattr(644,root,root,755)
469# R: Qt5Core Qt5Gui Qt5WebEngineWidgets Qt5Widgets [+Qt5Designer by dir]
470%attr(755,root,root) %{_libdir}/qt5/plugins/designer/libqwebengineview.so
471%{_libdir}/cmake/Qt5Designer/Qt5Designer_QWebEngineViewPlugin.cmake
472
c91e1c7d
JP
473%files -n Qt5Pdf
474%defattr(644,root,root,755)
3acb2706 475# R: Qt5Core Qt5Gui Qt5Network freetype libjpeg zlib
c91e1c7d
JP
476%attr(755,root,root) %{_libdir}/libQt5Pdf.so.*.*.*
477%attr(755,root,root) %ghost %{_libdir}/libQt5Pdf.so.5
3acb2706 478# R: Qt5Core Qt5Gui Qt5Pdf Qt5Widgets
c91e1c7d
JP
479%attr(755,root,root) %{_libdir}/libQt5PdfWidgets.so.*.*.*
480%attr(755,root,root) %ghost %{_libdir}/libQt5PdfWidgets.so.5
481%dir %{qt5dir}/qml/QtQuick/Pdf
482%{qt5dir}/qml/QtQuick/Pdf/plugins.qmltypes
483%{qt5dir}/qml/QtQuick/Pdf/qmldir
484%{qt5dir}/qml/QtQuick/Pdf/qml
3acb2706 485# R: Qt5Core Qt5Gui Qt5Pdf Qt5Qml Qt5Quick
c91e1c7d 486%attr(755,root,root) %{qt5dir}/qml/QtQuick/Pdf/libpdfplugin.so
3acb2706 487# R: Qt5Core Qt5Gui Qt5Pdf
c91e1c7d
JP
488%attr(755,root,root) %{_libdir}/qt5/plugins/imageformats/libqpdf.so
489
490%files -n Qt5Pdf-devel
491%defattr(644,root,root,755)
492%attr(755,root,root) %{_libdir}/libQt5Pdf.so
493%attr(755,root,root) %{_libdir}/libQt5PdfWidgets.so
494%{_libdir}/libQt5Pdf.prl
495%{_libdir}/libQt5PdfWidgets.prl
496%{_includedir}/qt5/QtPdf
497%{_includedir}/qt5/QtPdfWidgets
498%{_pkgconfigdir}/Qt5Pdf.pc
499%{_pkgconfigdir}/Qt5PdfWidgets.pc
500%{_libdir}/cmake/Qt5Gui/Qt5Gui_QPdfPlugin.cmake
501%{_libdir}/cmake/Qt5Pdf
502%{_libdir}/cmake/Qt5PdfWidgets
503%{qt5dir}/mkspecs/modules/qt_lib_pdf.pri
504%{qt5dir}/mkspecs/modules/qt_lib_pdf_private.pri
505%{qt5dir}/mkspecs/modules/qt_lib_pdfwidgets.pri
506%{qt5dir}/mkspecs/modules/qt_lib_pdfwidgets_private.pri
3acb2706
JB
507
508%if %{with doc}
509%files doc
510%defattr(644,root,root,755)
511%{_docdir}/qt5-doc/qtpdf
512%{_docdir}/qt5-doc/qtwebengine
513
514%files doc-qch
515%defattr(644,root,root,755)
516%{_docdir}/qt5-doc/qtpdf.qch
517%{_docdir}/qt5-doc/qtwebengine.qch
518%endif
519
520%files examples -f examples.files
521%defattr(644,root,root,755)
522# XXX: dir shared with qt5-qtbase-examples
523%dir %{_examplesdir}/qt5
This page took 0.160741 seconds and 4 git commands to generate.