]> git.pld-linux.org Git - packages/qt5-qtbase.git/commitdiff
patch to fix missing includes in header files; rel 4 auto/th/qt5-qtbase-5.15.2-4
authorJan Palus <atler@pld-linux.org>
Tue, 25 May 2021 11:07:10 +0000 (13:07 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 25 May 2021 11:07:10 +0000 (13:07 +0200)
gcc11.patch [new file with mode: 0644]
qt5-qtbase.spec

diff --git a/gcc11.patch b/gcc11.patch
new file mode 100644 (file)
index 0000000..9d39131
--- /dev/null
@@ -0,0 +1,38 @@
+Description: include <limits> to fix some GCC 11 build issues
+Origin: upstream, commits:
+ https://code.qt.io/cgit/qt/qtbase.git/commit/?id=813a928c7c3cf986
+ https://code.qt.io/cgit/qt/qtbase.git/commit/?id=9c56d4da2ff631a8
+Last-Update: 2021-01-26
+
+--- a/src/corelib/global/qendian.h
++++ b/src/corelib/global/qendian.h
+@@ -44,6 +44,8 @@
+ #include <QtCore/qfloat16.h>
+ #include <QtCore/qglobal.h>
++#include <limits>
++
+ // include stdlib.h and hope that it defines __GLIBC__ for glibc-based systems
+ #include <stdlib.h>
+ #include <string.h>
+--- a/src/corelib/global/qfloat16.h
++++ b/src/corelib/global/qfloat16.h
+@@ -43,6 +43,7 @@
+ #include <QtCore/qglobal.h>
+ #include <QtCore/qmetatype.h>
++#include <limits>
+ #include <string.h>
+ #if defined(QT_COMPILER_SUPPORTS_F16C) && defined(__AVX2__) && !defined(__F16C__)
+--- a/src/corelib/text/qbytearraymatcher.h
++++ b/src/corelib/text/qbytearraymatcher.h
+@@ -42,6 +42,8 @@
+ #include <QtCore/qbytearray.h>
++#include <limits>
++
+ QT_BEGIN_NAMESPACE
index fd76d2b10bc5fca3a5267d41046c23cc8ac63ecd..0fd51d28a414d0e29ce71a56190c4d0e4f823334 100644 (file)
@@ -71,7 +71,7 @@ Summary:      Qt5 - base components
 Summary(pl.UTF-8):     Biblioteka Qt5 - podstawowe komponenty
 Name:          qt5-%{orgname}
 Version:       5.15.2
-Release:       3
+Release:       4
 License:       LGPL v3 or GPL v2 or GPL v3 or commercial
 Group:         X11/Libraries
 Source0:       https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/%{orgname}-everywhere-src-%{version}.tar.xz
@@ -79,6 +79,7 @@ Source0:      https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/
 Source1:       https://download.qt.io/official_releases/qt/5.15/%{version}/submodules/qttranslations-everywhere-src-%{version}.tar.xz
 # Source1-md5: 9b66cdb64402e8fd9e843f8a7120abb1
 Patch0:                %{name}-system_cacerts.patch
+Patch1:                gcc11.patch
 URL:           https://www.qt.io/
 %{?with_directfb:BuildRequires:        DirectFB-devel}
 BuildRequires: EGL-devel
@@ -1170,6 +1171,7 @@ Generator plików makefile dla aplikacji Qt5.
 %prep
 %setup -q -n %{orgname}-everywhere-src-%{version} %{?with_qm:-a1}
 %patch0 -p1
+%patch1 -p1
 
 %{__sed} -i -e 's,usr/X11R6/,usr/,g' mkspecs/linux-g++-64/qmake.conf
 
This page took 0.317913 seconds and 4 git commands to generate.