]> git.pld-linux.org Git - packages/qt4.git/blame - qt4.spec
- Cosmetics
[packages/qt4.git] / qt4.spec
CommitLineData
bc7da990 1#
ef04429e 2# TODO:
bc7da990 3# - build system recheck (most make -C are to be changed)
4# - redo subpackages (qt-core,qt-xml,qt-network,qt-opengl, etc.)
5# - bconds for IBM db2, oracle and tds sql drivers
ef04429e 6# - fix install
bc7da990 7# - remove obsolete patches
8
9# Conditional build:
10%bcond_with nas # enable NAS audio support
11%bcond_with nvidia # prelink Qt/KDE and depend on NVIDIA binaries
bc7da990 12%bcond_without static_libs # don't build static libraries
13%bcond_without cups # disable CUPS support
14%bcond_without mysql # don't build MySQL plugin
15%bcond_without odbc # don't build unixODBC plugin
16%bcond_without pgsql # don't build PostgreSQL plugin
17%bcond_without designer # don't build designer (it takes long)
18%bcond_without sqlite # don't build SQLite plugin
19%bcond_without ibase # build ibase (InterBase/Firebird) plugin
20%bcond_with pch # enable pch in qmake
21%bcond_with pch_devel # enable experimental boost (for developers only!)
ef04429e 22%bcond_with dont_enable # a bcond for missing features
23
24%undefine with_dont_enable
25
bc7da990 26%ifnarch %{ix86} sparc sparcv9 ppc
27%undefine with_ibase
28%endif
29%define _withsql 1
30%{!?with_sqlite:%{!?with_ibase:%{!?with_mysql:%{!?with_pgsql:%{!?with_odbc:%undefine _withsql}}}}}
31
32%define _snap 040422
33%define _ver 4.0.0
34%define _packager djurban
35%define _name qt
36
37Summary: The Qt GUI application framework
38Summary(es): Biblioteca para ejecutar aplicaciones GUI Qt
39Summary(pl): Biblioteka Qt do tworzenia GUI
40