]> git.pld-linux.org Git - packages/qt-creator.git/commitdiff
- updated to 3.6.1
authorBartek Szady <bszx@bszx.eu>
Wed, 28 Sep 2016 09:06:12 +0000 (11:06 +0200)
committerBartek Szady <bszx@bszx.eu>
Wed, 28 Sep 2016 09:06:12 +0000 (11:06 +0200)
- libexec.patch fixed. Design mode works for qml files.

qt-creator-libexec.patch
qt-creator.spec

index 25ded8eb96b851438da2ef38897b7f83f25a0042..d06f2e4f2316617e3032cf35c4b3b447108f3142 100644 (file)
      INSTALL_DATA_PATH    = $$QTC_PREFIX/share/qtcreator
      INSTALL_DOC_PATH     = $$QTC_PREFIX/share/doc/qtcreator
      INSTALL_BIN_PATH     = $$QTC_PREFIX/bin
+--- qt-creator-opensource-src-3.6.1/src/plugins/coreplugin/icore.cpp.orig      2016-03-08 12:30:19.000000000 +0100
++++ qt-creator-opensource-src-3.6.1/src/plugins/coreplugin/icore.cpp   2016-09-27 22:33:01.376312984 +0200
+@@ -435,21 +435,7 @@
+  */
+ QString ICore::libexecPath()
+ {
+-    QString path;
+-    switch (Utils::HostOsInfo::hostOs()) {
+-    case Utils::OsTypeWindows:
+-        path = QCoreApplication::applicationDirPath();
+-        break;
+-    case Utils::OsTypeMac:
+-        path = QCoreApplication::applicationDirPath() + QLatin1String("/../Resources");
+-        break;
+-    case Utils::OsTypeLinux:
+-    case Utils::OsTypeOtherUnix:
+-    case Utils::OsTypeOther:
+-        path = QCoreApplication::applicationDirPath() + QLatin1String("/../libexec/qtcreator");
+-        break;
+-    }
+-    return QDir::cleanPath(path);
++    return QDir::cleanPath(QLatin1String("/usr/" IDE_LIBRARY_BASENAME "/qtcreator"));
+ }
+ static QString compilerString()
index 002a5f5fce6497bfb14299cb7b4ba5e1bda15609..b804264297e08f540c170637a92fcb116987d6aa 100644 (file)
@@ -1,13 +1,13 @@
 Summary:       An IDE tailored to the needs of Qt developers
 Summary(pl.UTF-8):     IDE dostosowane do potrzeb developerow Qt
 Name:          qt-creator
-Version:       3.6.0
+Version:       3.6.1
 Release:       1
 Epoch:         1
 License:       LGPL v2.1
 Group:         X11/Development/Tools
 Source0:       http://download.qt.io/official_releases/qtcreator/3.6/%{version}/%{name}-opensource-src-%{version}.tar.gz
-# Source0-md5: 6b0052a6d671318fca540a190cacd97d
+# Source0-md5: 3b6631cf6ff00bb2a2146553ea6864bf
 Source1:       %{name}.desktop
 Patch0:                %{name}-libexec.patch
 URL:           http://qt.digia.com/Product/Developer-Tools
This page took 0.2373 seconds and 4 git commands to generate.