]> git.pld-linux.org Git - packages/qt-creator.git/blame - qt-creator.spec
- BR s/QtSql-sqlite/QtSql-sqlite3/
[packages/qt-creator.git] / qt-creator.spec
CommitLineData
2aefa737 1#
2
3Summary: An IDE tailored to the needs of Qt developers
4Summary(pl.UTF-8): IDE dostosowane do potrzeb developerow Qt
5Name: qt-creator
6Version: 1.0.0
2b26ffea 7Release: 2
2aefa737 8Epoch: 1
9License: LGPL v2.1
10Group: Libraries
11Source0: http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
12# Source0-md5: 5478124035d80a90e66a3db67ab4477a
2b26ffea 13Patch0: %{name}-pluginpath64.patch
2aefa737 14URL: http://www.qtsoftware.com/developer/qt-creator
a2bb26e4 15BuildRequires: QtDBus-devel
2aefa737 16BuildRequires: QtGui-devel
a2bb26e4
KK
17BuildRequires: QtHelp-devel
18BuildRequires: QtNetwork-devel
19BuildRequires: QtScript-devel
5eafeef8 20BuildRequires: QtSql-sqlite3
a2bb26e4
KK
21BuildRequires: QtSvg-devel
22BuildRequires: QtWebKit-devel
23BuildRequires: QtXml-devel
24BuildRequires: qt4-build >= 4.5.0-3
25BuildRequires: qt4-qmake >= 4.5.0-3
26BuildRequires: unzip
2aefa737 27BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29%description
30Qt Creator is a cross-platform integrated development environment (IDE)
31tailored to the needs of Qt developers.
32
33%description -l pl.UTF-8
34Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
35
36%prep
37%setup -q -n %{name}-%{version}-src
38
2b26ffea 39%if "%{_lib}" == "lib64"
40%patch0 -p1
41%endif
42
2aefa737 43%build
44export QTDIR=%{_libdir}/qt4
45# the qmakespec in qt4 is somewhat broken, need to look at this
46#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
47
48qmake-qt4 qtcreator.pro \
49 QMAKE_CXX="%{__cxx}" \
50 QMAKE_LINK="%{__cxx}" \
51 QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
52 QMAKE_RPATH=
53
54%{__make}
55
56%install
57rm -rf $RPM_BUILD_ROOT
58
59export QTDIR=%{_libdir}/qt4
2aefa737 60%{__make} install \
61 INSTALL_ROOT=$RPM_BUILD_ROOT/%{_prefix}
62
5eafeef8 63%if "%{_lib}" == "lib64"
2aefa737 64mv -f $RPM_BUILD_ROOT/{%{_prefix}/lib,%{_libdir}}
5eafeef8 65%endif
2aefa737 66
2b26ffea 67install -d $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d
68echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
69
2aefa737 70%clean
71rm -rf $RPM_BUILD_ROOT
72
73%files
74%defattr(644,root,root,755)
75%attr(755,root,root) %{_bindir}/*
2b26ffea 76%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2aefa737 77%dir %{_libdir}/qtcreator
2b26ffea 78%attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
79%attr(755,root,root) %{_libdir}/qtcreator/lib*.so
5eafeef8 80%attr(755,root,root) %ghost %{_libdir}/qtcreator/lib*.so.1
2aefa737 81%dir %{_libdir}/qtcreator/plugins
82%dir %{_libdir}/qtcreator/plugins/Nokia
a2bb26e4 83%{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
2aefa737 84%attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
85%{_datadir}/qtcreator
2b26ffea 86%{_defaultdocdir}/qtcreator
2aefa737 87%{_pixmapsdir}/qtcreator_logo*.png
2b26ffea 88
89%post -p /sbin/ldconfig
90%postun -p /sbin/ldconfig
This page took 0.351334 seconds and 4 git commands to generate.