]> git.pld-linux.org Git - packages/qt-creator.git/blame - qt-creator.spec
- fix ldconfig locations, add 64bit plugin search path fixes
[packages/qt-creator.git] / qt-creator.spec
CommitLineData
2aefa737 1#
2
3Summary: An IDE tailored to the needs of Qt developers
4Summary(pl.UTF-8): IDE dostosowane do potrzeb developerow Qt
5Name: qt-creator
6Version: 1.0.0
2b26ffea 7Release: 2
2aefa737 8Epoch: 1
9License: LGPL v2.1
10Group: Libraries
11Source0: http://download.qtsoftware.com/qtcreator/%{name}-%{version}-src.zip
12# Source0-md5: 5478124035d80a90e66a3db67ab4477a
2b26ffea 13Patch0: %{name}-pluginpath64.patch
2aefa737 14URL: http://www.qtsoftware.com/developer/qt-creator
15BuildRequires: libstdc++-devel
16BuildRequires: qt4-qmake >= 4.5.0-3
17BuildRequires: QtSql-sqlite
18BuildRequires: QtGui-devel
19BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21%description
22Qt Creator is a cross-platform integrated development environment (IDE)
23tailored to the needs of Qt developers.
24
25%description -l pl.UTF-8
26Qt Creator to wieloplatformowe IDE dostosowane do potrzeb developerow Qt.
27
28%prep
29%setup -q -n %{name}-%{version}-src
30
2b26ffea 31%if "%{_lib}" == "lib64"
32%patch0 -p1
33%endif
34
2aefa737 35%build
36export QTDIR=%{_libdir}/qt4
37# the qmakespec in qt4 is somewhat broken, need to look at this
38#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
39
40qmake-qt4 qtcreator.pro \
41 QMAKE_CXX="%{__cxx}" \
42 QMAKE_LINK="%{__cxx}" \
43 QMAKE_CXXFLAGS_RELEASE="%{rpmcflags}" \
44 QMAKE_RPATH=
45
46%{__make}
47
48%install
49rm -rf $RPM_BUILD_ROOT
50
51export QTDIR=%{_libdir}/qt4
52#export QMAKESPEC=%{_datadir}/qt4/mkspecs/linux-g++/
53%{__make} install \
54 INSTALL_ROOT=$RPM_BUILD_ROOT/%{_prefix}
55
56mv -f $RPM_BUILD_ROOT/{%{_prefix}/lib,%{_libdir}}
57
2b26ffea 58install -d $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d
59echo "%{_libdir}/qtcreator" > $RPM_BUILD_ROOT/%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
60
2aefa737 61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%files
65%defattr(644,root,root,755)
66%attr(755,root,root) %{_bindir}/*
2b26ffea 67%{_sysconfdir}/ld.so.conf.d/qtcreator.conf
2aefa737 68%dir %{_libdir}/qtcreator
2b26ffea 69%attr(755,root,root) %{_libdir}/qtcreator/lib*.so.*.*
70%attr(755,root,root) %{_libdir}/qtcreator/lib*.so
2aefa737 71%dir %{_libdir}/qtcreator/plugins
72%dir %{_libdir}/qtcreator/plugins/Nokia
73%{_libdir}/qtcreator/plugins/Nokia/*.pluginspec
74%attr(755,root,root) %{_libdir}/qtcreator/plugins/Nokia/*.so
75%{_datadir}/qtcreator
2b26ffea 76%{_defaultdocdir}/qtcreator
2aefa737 77%{_pixmapsdir}/qtcreator_logo*.png
2b26ffea 78
79%post -p /sbin/ldconfig
80%postun -p /sbin/ldconfig
This page took 0.078455 seconds and 4 git commands to generate.