]> git.pld-linux.org Git - packages/qpid-proton.git/blobdiff - qpid-proton-format.patch
- unconditional noarch subpackages
[packages/qpid-proton.git] / qpid-proton-format.patch
index a3a894d59cbb4cdf4085ebf607323b41d9e4aac2..7746caec701e84c05cda5b329ef0ec2f1ad7f54d 100644 (file)
@@ -1,11 +1,11 @@
---- qpid-proton-0.31.0/CMakeLists.txt.orig     2020-05-07 16:57:23.000000000 +0200
-+++ qpid-proton-0.31.0/CMakeLists.txt  2020-05-26 22:29:21.525675340 +0200
-@@ -140,7 +140,7 @@
-   endif (ENABLE_WARNING_ERROR)
-   set (COMPILE_WARNING_FLAGS "${WERROR} -Wall -pedantic-errors")
-   # C++ allow "%z" format specifier and variadic macros
--  set (CXX_WARNING_FLAGS "${COMPILE_WARNING_FLAGS} -Wno-format -Wno-variadic-macros")
-+  set (CXX_WARNING_FLAGS "${COMPILE_WARNING_FLAGS} -Wno-variadic-macros")
-   if (NOT BUILD_WITH_CXX)
-     set (COMPILE_WARNING_FLAGS "${COMPILE_WARNING_FLAGS} -Wstrict-prototypes -Wc++-compat -Wvla -Wsign-compare -Wwrite-strings")
-     set (COMPILE_LANGUAGE_FLAGS "-std=c99")
+--- qpid-proton-0.32.0/c/tests/threaderciser.c.orig    2020-10-13 19:03:31.807418794 +0200
++++ qpid-proton-0.32.0/c/tests/threaderciser.c 2020-10-13 19:03:34.654070039 +0200
+@@ -94,7 +94,7 @@
+   char msg[256];
+   char *i = msg;
+   char *end = i + sizeof(msg);
+-  i += assert_no_err(snprintf(i, end-i, "(%lx) ", (uintptr_t) pthread_self()));
++  i += assert_no_err(snprintf(i, end-i, "(%tx) ", (uintptr_t) pthread_self()));
+   if (i < end) {
+     va_list ap;
+     va_start(ap, fmt);
This page took 0.066164 seconds and 4 git commands to generate.