]> git.pld-linux.org Git - packages/qpid-proton.git/blob - qpid-proton.spec
10e4198374acc93a67f27bb1afdaf8ac23813bba
[packages/qpid-proton.git] / qpid-proton.spec
1 # TODO
2 # - bindings and bconds for them
3 Summary:        A high performance, lightweight messaging library
4 Name:           qpid-proton
5 Version:        0.8
6 Release:        0.1
7 License:        Apache v2.0
8 Group:          Libraries
9 Source0:        http://www.apache.org/dist/qpid/proton/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  48bfbd7ba5a639760bb28380f4d68208
11 Patch0001:      0001-PROTON-731-Installing-Python-requires-Proton-be-inst.patch
12 URL:            http://qpid.apache.org/proton/
13 BuildRequires:  cmake >= 2.6
14 BuildRequires:  doxygen
15 BuildRequires:  epydoc
16 BuildRequires:  libuuid-devel
17 BuildRequires:  openssl-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  python
20 BuildRequires:  python-devel
21 BuildRequires:  swig
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define proton_datadir %{_datadir}/proton-%{version}
25
26 %description
27 Proton is a high performance, lightweight messaging library. It can be
28 used in the widest range of messaging applications including brokers,
29 client libraries, routers, bridges, proxies, and more. Proton is based
30 on the AMQP 1.0 messaging standard. Using Proton it is trivial to
31 integrate with the AMQP 1.0 ecosystem from any platform, environment,
32 or language.
33
34 %package c
35 Summary:        C libraries for Qpid Proton
36 Group:          Libraries
37
38 %description c
39 %{summary}.
40
41 %package c-devel
42 Summary:        Development libraries for writing messaging apps with Qpid Proton
43 Group:          Development/Libraries
44 Requires:       qpid-proton-c = %{version}-%{release}
45
46 %description c-devel
47 %{summary}.
48
49 %package c-devel-doc
50 Summary:        Documentation for the C development libraries for Qpid Proton
51 Group:          Documentation
52 %if "%{_rpmversion}" >= "5"
53 BuildArch:      noarch
54 %endif
55
56 %description c-devel-doc
57 %{summary}.
58
59 %package -n python-%{name}
60 Summary:        Python language bindings for the Qpid Proton messaging framework
61 Group:          Libraries/Python
62 Requires:       %{name}-c = %{version}-%{release}
63
64 %description -n python-%{name}
65 %{summary}.
66
67 %package -n python-%{name}-doc
68 Summary:        Documentation for the Python language bindings for Qpid Proton
69 Group:          Documentation
70 %if "%{_rpmversion}" >= "5"
71 BuildArch:      noarch
72 %endif
73
74 %description -n python-%{name}-doc
75 %{summary}.
76
77 %prep
78 %setup -q
79 %patch0001 -p1
80
81 %build
82 %cmake \
83         -DPROTON_DISABLE_RPATH=true \
84         -DPYTHON_SITEARCH_PACKAGES=%{python_sitearch} \
85         -DBINDING_LANGS="%{?with_perl:PERL} %{?with_php:PHP} %{?with_python:PYTHON} %{?with_ruby:RUBY}" \
86         -DNOBUILD_RUBY=1 \
87         -DNOBUILD_PHP=1 \
88         -DNOBUILD_JAVA=1 \
89         -DBUILD_PYTHON=0 \
90         -DBUILD_PERL=0 \
91         -DSYSINSTALL_PYTHON=1 \
92         -DSYSINSTALL_PERL=0 \
93         -DCHECK_SYSINSTALL_PYTHON=0 \
94         .
95
96 %{__make} all docs
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 %{__make} install \
101         DESTDIR=$RPM_BUILD_ROOT
102
103 %if %{with python}
104 chmod +x $RPM_BUILD_ROOT%{py_sitedir}/_cproton.so
105 %endif
106
107 # clean up files that are not shipped
108 rm -rf $RPM_BUILD_ROOT%{_exec_prefix}/bindings
109 rm -rf $RPM_BUILD_ROOT%{_libdir}/java
110 rm -rf $RPM_BUILD_ROOT%{_libdir}/libproton-jni.so
111 rm -rf $RPM_BUILD_ROOT%{_datarootdir}/java
112 rm -rf $RPM_BUILD_ROOT%{_libdir}/proton.cmake
113
114 %clean
115 rm -rf $RPM_BUILD_ROOT
116
117 %post   c -p /sbin/ldconfig
118 %postun c -p /sbin/ldconfig
119
120 %files c
121 %defattr(644,root,root,755)
122 %dir %{proton_datadir}
123 %doc %{proton_datadir}/LICENSE
124 %doc %{proton_datadir}/README
125 %doc %{proton_datadir}/TODO
126 %attr(755,root,root) %{_libdir}/libqpid-proton.so.*.*.*
127 %ghost %{_libdir}/libqpid-proton.so.2
128 %attr(755,root,root) %{_bindir}/proton
129 %attr(755,root,root) %{_bindir}/proton-dump
130 %{_mandir}/man1/proton-dump.1*
131 %{_mandir}/man1/proton.1*
132
133 %files c-devel
134 %defattr(644,root,root,755)
135 %{_includedir}/proton
136 %{_libdir}/libqpid-proton.so
137 %{_pkgconfigdir}/libqpid-proton.pc
138 %{_libdir}/cmake/Proton
139 %{_datadir}/proton/examples
140
141 %files c-devel-doc
142 %defattr(644,root,root,755)
143 %doc %{proton_datadir}/docs/api-c
144
145 %if %{with python}
146 %files -n python-%{name}
147 %defattr(644,root,root,755)
148 %{py_sitedir}/_cproton.so
149 %{py_sitedir}/cproton.*
150 %{py_sitedir}/proton.*
151
152 %files -n python-%{name}-doc
153 %defattr(644,root,root,755)
154 %doc %{proton_datadir}/docs/api-py
155 %endif
This page took 0.088806 seconds and 3 git commands to generate.