]> git.pld-linux.org Git - packages/qemu.git/commitdiff
- partial update to 2.5.0 (TODO: few new unpackages files left) auto/th/qemu-2.5.0-0.1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 21 Dec 2015 22:00:05 +0000 (23:00 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 21 Dec 2015 22:00:05 +0000 (23:00 +0100)
qemu-cflags.patch
qemu-sh.patch
qemu-system-libcacard.patch [deleted file]
qemu.spec
x32.patch

index f9a9ecad341702a9536cc8b162cbe11234b66774..bdc711253c8571e0134aab02260b99915573b84e 100644 (file)
@@ -1,22 +1,16 @@
---- qemu-1.7.0/configure.orig  2013-11-27 23:15:55.000000000 +0100
-+++ qemu-1.7.0/configure       2013-12-15 08:37:16.187664605 +0100
-@@ -332,10 +332,6 @@
- QEMU_CFLAGS="-Wstrict-prototypes -Wredundant-decls $QEMU_CFLAGS"
- QEMU_CFLAGS="-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE $QEMU_CFLAGS"
- QEMU_INCLUDES="-I. -I\$(SRC_PATH) -I\$(SRC_PATH)/include"
--if test "$debug_info" = "yes"; then
--    CFLAGS="-g $CFLAGS"
--    LDFLAGS="-g $LDFLAGS"
--fi
+--- qemu-2.5.0/configure~      2015-12-21 22:27:18.000000000 +0100
++++ qemu-2.5.0/configure       2015-12-21 22:29:00.990327069 +0100
+@@ -4494,12 +4494,8 @@
+ # After here, no more $cc or $ld runs
  
- # make source path absolute
- source_path=`cd "$source_path"; pwd`
-@@ -3549,8 +3545,6 @@
  if test "$gcov" = "yes" ; then
-   CFLAGS="-fprofile-arcs -ftest-coverage -g $CFLAGS"
+-  CFLAGS="-fprofile-arcs -ftest-coverage -g $CFLAGS"
++  CFLAGS="-fprofile-arcs -ftest-coverage $CFLAGS"
    LDFLAGS="-fprofile-arcs -ftest-coverage $LDFLAGS"
--elif test "$debug" = "no" ; then
+-elif test "$fortify_source" = "yes" ; then
 -  CFLAGS="-O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 $CFLAGS"
+-elif test "$debug" = "no"; then
+-  CFLAGS="-O2 $CFLAGS"
  fi
  
+ ##########################################
index a2272eb02e23be33c614324bd513225bc3945462..daee83823380a814d32e3a892270e7b9a631c490 100644 (file)
@@ -1,11 +1,11 @@
---- qemu-2.4.0.1/configure.orig        2015-10-05 21:43:29.245561041 +0200
-+++ qemu-2.4.0.1/configure     2015-10-05 21:49:36.392212179 +0200
-@@ -4501,7 +4501,7 @@
+--- qemu-2.5.0/configure~      2015-12-21 22:39:21.000000000 +0100
++++ qemu-2.5.0/configure       2015-12-21 22:39:58.952714685 +0100
+@@ -4754,7 +4754,7 @@
  echo "GNUTLS support    $gnutls"
  echo "GNUTLS hash       $gnutls_hash"
- echo "GNUTLS gcrypt     $gnutls_gcrypt"
--echo "GNUTLS nettle     $gnutls_nettle ${gnutls_nettle+($nettle_version)}"
-+echo "GNUTLS nettle     $gnutls_nettle ${gnutls_nettle:+\($nettle_version)}"
+ echo "libgcrypt         $gcrypt"
+-echo "nettle            $nettle ${nettle+($nettle_version)}"
++echo "nettle            $nettle ${nettle+\($nettle_version)}"
+ echo "libtasn1          $tasn1"
  echo "VTE support       $vte"
  echo "curses support    $curses"
- echo "curl support      $curl"
diff --git a/qemu-system-libcacard.patch b/qemu-system-libcacard.patch
deleted file mode 100644 (file)
index 7034b44..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-diff -urN qemu-2.1.2.org/configure qemu-2.1.2/configure
---- qemu-2.1.2.org/configure   2014-09-25 21:54:52.000000000 +0200
-+++ qemu-2.1.2/configure       2014-11-08 13:52:27.205351822 +0100
-@@ -3546,9 +3546,10 @@
- #include <pk11pub.h>
- int main(void) { PK11_FreeSlot(0); return 0; }
- EOF
--    # FIXME: do not include $glib_* in here
--    nss_libs="$($pkg_config --libs nss 2>/dev/null) $glib_libs"
--    nss_cflags="$($pkg_config --cflags nss 2>/dev/null) $glib_cflags"
-+    libcacard_libs="$($pkg_config --libs libcacard 2>/dev/null)"
-+    libcacard_cflags="$($pkg_config --cflags libcacard 2>/dev/null)"
-+    nss_libs="$($pkg_config --libs nss 2>/dev/null)"
-+    nss_cflags="$($pkg_config --cflags nss 2>/dev/null)"
-     test_cflags="$nss_cflags"
-     # The header files in nss < 3.13.3 have a bug which causes them to
-     # emit a warning. If we're going to compile QEMU with -Werror, then
-@@ -4582,6 +4583,8 @@
-   echo "CONFIG_SMARTCARD_NSS=y" >> $config_host_mak
-   echo "NSS_LIBS=$nss_libs" >> $config_host_mak
-   echo "NSS_CFLAGS=$nss_cflags" >> $config_host_mak
-+  echo "LIBCACARD_LIBS=$libcacard_libs" >> $config_host_mak
-+  echo "LIBCACARD_CFLAGS=$libcacard_cflags" >> $config_host_mak
- fi
- if test "$libusb" = "yes" ; then
-diff -urN qemu-2.1.2.org/hw/usb/ccid-card-passthru.c qemu-2.1.2/hw/usb/ccid-card-passthru.c
---- qemu-2.1.2.org/hw/usb/ccid-card-passthru.c 2014-09-25 21:54:52.000000000 +0200
-+++ qemu-2.1.2/hw/usb/ccid-card-passthru.c     2014-11-08 13:52:56.156055395 +0100
-@@ -12,7 +12,7 @@
- #include "qemu/sockets.h"
- #include "monitor/monitor.h"
- #include "ccid.h"
--#include "libcacard/vscard_common.h"
-+#include "cacard/vscard_common.h"
- #define DPRINTF(card, lvl, fmt, ...)                    \
- do {                                                    \
-diff -urN qemu-2.1.2.org/hw/usb/Makefile.objs qemu-2.1.2/hw/usb/Makefile.objs
---- qemu-2.1.2.org/hw/usb/Makefile.objs        2014-09-25 21:54:52.000000000 +0200
-+++ qemu-2.1.2/hw/usb/Makefile.objs    2014-11-08 13:55:50.056948226 +0100
-@@ -24,7 +24,8 @@
- common-obj-y                          += dev-smartcard-reader.o
- common-obj-y                          += ccid-card-passthru.o
- common-obj-$(CONFIG_SMARTCARD_NSS)    += ccid-card-emulated.o
--ccid-card-emulated.o-cflags := -I$(SRC_PATH)/libcacard
-+ccid-card-emulated.o-cflags := $(LIBCACARD_CFLAGS)
-+ccid-card-emulated.o-libs := $(LIBCACARD_LIBS)
- endif
- ifeq ($(CONFIG_POSIX),y)
-diff -urN qemu-2.1.2.org/Makefile qemu-2.1.2/Makefile
---- qemu-2.1.2.org/Makefile    2014-09-25 21:54:52.000000000 +0200
-+++ qemu-2.1.2/Makefile        2014-11-08 13:48:43.709920110 +0100
-@@ -142,9 +142,6 @@
- ifneq ($(wildcard config-host.mak),)
- include $(SRC_PATH)/tests/Makefile
- endif
--ifeq ($(CONFIG_SMARTCARD_NSS),y)
--include $(SRC_PATH)/libcacard/Makefile
--endif
- all: $(DOCS) $(TOOLS) $(HELPERS-y) recurse-all modules
-diff -urN qemu-2.1.2.org/Makefile.objs qemu-2.1.2/Makefile.objs
---- qemu-2.1.2.org/Makefile.objs       2014-09-25 21:54:52.000000000 +0200
-+++ qemu-2.1.2/Makefile.objs   2014-11-08 13:49:29.161024919 +0100
-@@ -75,8 +75,6 @@ common-obj-y += backends/
- common-obj-$(CONFIG_SECCOMP) += qemu-seccomp.o
--common-obj-$(CONFIG_SMARTCARD_NSS) += $(libcacard-y)
--
- common-obj-$(CONFIG_FDT) += device_tree.o
- ######################################################################
-
index 30e7d454fa99a769600ad9bdcb8b0131bc53c09f..a435c44e9072d5a6167c09639211bab0d2995588 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.4.1
-Release:       1
+Version:       2.5.0
+Release:       0.1
 License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: a895e93ec1dafc34bc64ed676f0d55a6
+# Source0-md5: f469f2330bbe76e3e39db10e9ac4f8db
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
@@ -59,7 +59,7 @@ Source12:     99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-system-libcacard.patch
+
 Patch4:                %{name}-xattr.patch
 Patch5:                libjpeg-boolean.patch
 Patch6:                x32.patch
@@ -748,14 +748,12 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
-%patch3 -p1
+
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
 
-%{__mv} libcacard libcacard-use-system-lib
-
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
@@ -787,7 +785,7 @@ ln -s ../error.h qapi/error.h
        --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       %{__enable_disable smartcard smartcard-nss} \
+       %{__enable_disable smartcard smartcard} \
        --enable-tpm \
        --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}" \
        %{__enable_disable usbredir usb-redir} \
@@ -797,7 +795,6 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       --enable-vnc-tls \
        %{!?with_vte:--disable-vte} \
        --enable-kvm \
        %{__enable_disable xen} \
index 07aa9153b2e83487637f0061f26b3ae43c696713..2efe351a490260cedccfe7e68210df724a6d0270 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -1,14 +1,14 @@
 --- qemu-2.2.0/configure~      2015-03-26 19:52:14.000000000 +0100
 +++ qemu-2.2.0/configure       2015-03-26 19:56:34.255072716 +0100
-@@ -1819,7 +1819,7 @@
- # libseccomp check
+@@ -1904,7 +1904,7 @@
  
  if test "$seccomp" != "no" ; then
--    if test "$cpu" = "i386" || test "$cpu" = "x86_64" &&
-+    if test "$cpu" = "i386" || test "$cpu" = "x86_64" || test "$cpu" = "x32" &&
-         $pkg_config --atleast-version=2.1.1 libseccomp; then
-         libs_softmmu="$libs_softmmu `$pkg_config --libs libseccomp`"
-         QEMU_CFLAGS="$QEMU_CFLAGS `$pkg_config --cflags libseccomp`"
+     case "$cpu" in
+-    i386|x86_64)
++    i386|x86_64|x32)
+         libseccomp_minver="2.1.0"
+         ;;
+     arm|aarch64)
 @@ -2932,7 +2932,7 @@
  ##########################################
  # TPM passthrough is only on x86 Linux
This page took 0.051313 seconds and 4 git commands to generate.