]> git.pld-linux.org Git - packages/qemu.git/commitdiff
start upgrading to 5.2.0 (rel 0.1)
authorJan Palus <atler@pld-linux.org>
Wed, 10 Mar 2021 00:00:32 +0000 (01:00 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 10 Mar 2021 00:00:32 +0000 (01:00 +0100)
- vxhs code dropped completely
- remove lm32 unicore32 platforms (deprecated and scheduled for removal)
- drop pie from build flags (breaks build)
- new system: avr

binutils-2.36.patch
qemu-cflags.patch
qemu-user-execve.patch
qemu-vxhs.patch [deleted file]
qemu-whitelist.patch [deleted file]
qemu.spec
x32.patch

index 0bd9eed1964f9d63ed903c28174489df93700a1f..5b3a436693e0227cde1ef5d17bf5c356b05fbaf6 100644 (file)
@@ -45,31 +45,28 @@ index cb21108d34c..c228f7c21e7 100755
 @@ -2153,7 +2152,6 @@ if test "$static" = "yes"; then
    fi
  elif test "$pie" = "no"; then
-   QEMU_CFLAGS="$CFLAGS_NOPIE $QEMU_CFLAGS"
--  QEMU_LDFLAGS="$LDFLAGS_NOPIE $QEMU_LDFLAGS"
+   CONFIGURE_CFLAGS="$CFLAGS_NOPIE $CONFIGURE_CFLAGS"
+-  CONFIGURE_LDFLAGS="$LDFLAGS_NOPIE $CONFIGURE_LDFLAGS"
  elif compile_prog "-Werror -fPIE -DPIE" "-pie"; then
-   QEMU_CFLAGS="-fPIE -DPIE $QEMU_CFLAGS"
-   QEMU_LDFLAGS="-pie $QEMU_LDFLAGS"
+   CONFIGURE_CFLAGS="-fPIE -DPIE $CONFIGURE_CFLAGS"
+   CONFIGURE_LDFLAGS="-pie $CONFIGURE_LDFLAGS"
 @@ -6714,7 +6712,6 @@ echo "QEMU_CXXFLAGS=$QEMU_CXXFLAGS" >> $config_host_mak
  echo "QEMU_CFLAGS  += -Wbitwise -Wno-transparent-union -Wno-old-initializer -Wno-non-pointer-null" >> $config_host_mak
- fi
echo "GLIB_CFLAGS=$glib_cflags" >> $config_host_mak
+ echo "GLIB_LIBS=$glib_libs" >> $config_host_mak
  echo "QEMU_LDFLAGS=$QEMU_LDFLAGS" >> $config_host_mak
 -echo "LDFLAGS_NOPIE=$LDFLAGS_NOPIE" >> $config_host_mak
- echo "LD_REL_FLAGS=$LD_REL_FLAGS" >> $config_host_mak
  echo "LD_I386_EMULATION=$ld_i386_emulation" >> $config_host_mak
- echo "LIBS+=$LIBS" >> $config_host_mak
---- qemu-5.0.0/pc-bios/optionrom/Makefile.orig 2020-04-28 18:49:25.000000000 +0200
-+++ qemu-5.0.0/pc-bios/optionrom/Makefile      2021-03-09 12:33:41.049922063 +0100
-@@ -47,10 +47,10 @@
-       $(call quiet-command,$(CPP) $(QEMU_INCLUDES) $(QEMU_DGFLAGS) -c -o - $< | $(AS) $(ASFLAGS) -o $@,"AS","$(TARGET_DIR)$@")
+ echo "EXESUF=$EXESUF" >> $config_host_mak
+ echo "HOST_DSOSUF=$HOST_DSOSUF" >> $config_host_mak
+diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
+index 084fc10f054..30771f8d17c 100644
+--- a/pc-bios/optionrom/Makefile
++++ b/pc-bios/optionrom/Makefile
+@@ -41,7 +41,6 @@ override CFLAGS += $(call cc-option, $(Wa)-32)
  
- pvh.img: pvh.o pvh_main.o
--      $(call quiet-command,$(LD) $(LDFLAGS_NOPIE) -m $(LD_I386_EMULATION) -T $(SRC_PATH)/pc-bios/optionrom/flat.lds -s -o $@ $^,"BUILD","$(TARGET_DIR)$@")
-+      $(call quiet-command,$(LD) -m $(LD_I386_EMULATION) -T $(SRC_PATH)/pc-bios/optionrom/flat.lds -s -o $@ $^,"BUILD","$(TARGET_DIR)$@")
+ LD_I386_EMULATION ?= elf_i386
+ override LDFLAGS = -m $(LD_I386_EMULATION) -T $(SRC_DIR)/flat.lds
+-override LDFLAGS += $(LDFLAGS_NOPIE)
  
- %.img: %.o
--      $(call quiet-command,$(LD) $(LDFLAGS_NOPIE) -m $(LD_I386_EMULATION) -T $(SRC_PATH)/pc-bios/optionrom/flat.lds -s -o $@ $<,"BUILD","$(TARGET_DIR)$@")
-+      $(call quiet-command,$(LD) -m $(LD_I386_EMULATION) -T $(SRC_PATH)/pc-bios/optionrom/flat.lds -s -o $@ $<,"BUILD","$(TARGET_DIR)$@")
+ all: multiboot.bin linuxboot.bin linuxboot_dma.bin kvmvapic.bin pvh.bin
  
- %.raw: %.img
-       $(call quiet-command,$(OBJCOPY) -O binary -j .text $< $@,"BUILD","$(TARGET_DIR)$@")
index ed5ce2a7a2e81a4f946a2450910d5e70e7812de0..b1e4ead0609f06905f0ee1dcc9b173303fdd0998 100644 (file)
@@ -1,16 +1,12 @@
---- qemu-5.0.0/configure.orig  2020-05-25 07:18:02.653298508 +0200
-+++ qemu-5.0.0/configure       2020-05-25 07:23:20.044912383 +0200
-@@ -6258,12 +6258,8 @@
- write_c_skeleton
+--- qemu-5.2.0/configure.orig  2021-03-09 22:06:14.087491054 +0100
++++ qemu-5.2.0/configure       2021-03-09 22:07:10.121515560 +0100
+@@ -5666,9 +5666,6 @@
  
  if test "$gcov" = "yes" ; then
--  QEMU_CFLAGS="-fprofile-arcs -ftest-coverage -g $QEMU_CFLAGS"
-+  QEMU_CFLAGS="-fprofile-arcs -ftest-coverage $QEMU_CFLAGS"
-   QEMU_LDFLAGS="-fprofile-arcs -ftest-coverage $QEMU_LDFLAGS"
+   :
 -elif test "$fortify_source" = "yes" ; then
--  CFLAGS="-O2 -U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 $CFLAGS"
--elif test "$debug" = "no"; then
--  CFLAGS="-O2 $CFLAGS"
+-  QEMU_CFLAGS="-U_FORTIFY_SOURCE -D_FORTIFY_SOURCE=2 $QEMU_CFLAGS"
+-  debug=no
  fi
  
if test "$have_asan" = "yes"; then
case "$ARCH" in
index 3f538a95d61878e894c14319f245ca967b66a3ba..8a0cf71c293893ab1f9d95c3f93fdfe577e3725f 100644 (file)
@@ -58,7 +58,7 @@ index ee12035..5951279 100644
  /* XXX: on x86 MAP_GROWSDOWN only works if ESP <= address + 32, so
     we allocate a bigger stack. Need a better solution, for example
 @@ -3828,6 +3829,11 @@ static void handle_arg_guest_base(const char *arg)
-     have_guest_base = 1;
+     have_guest_base = true;
  }
  
 +static void handle_arg_execve(const char *arg)
diff --git a/qemu-vxhs.patch b/qemu-vxhs.patch
deleted file mode 100644 (file)
index 00a50b7..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- qemu-4.2.0/block/vxhs.c.orig       2019-12-12 19:20:47.000000000 +0100
-+++ qemu-4.2.0/block/vxhs.c    2020-05-23 22:56:39.361009319 +0200
-@@ -18,6 +18,7 @@
- #include "qapi/qmp/qstring.h"
- #include "trace.h"
- #include "qemu/module.h"
-+#include "qemu/option.h"
- #include "qemu/uri.h"
- #include "qapi/error.h"
- #include "qemu/uuid.h"
diff --git a/qemu-whitelist.patch b/qemu-whitelist.patch
deleted file mode 100644 (file)
index f267a2c..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- qemu-5.0.0/scripts/create_config.orig      2021-03-09 12:06:01.531473021 +0100
-+++ qemu-5.0.0/scripts/create_config   2021-03-09 12:08:49.823397889 +0100
-@@ -43,14 +43,18 @@
-  CONFIG_BDRV_RW_WHITELIST=*)
-     echo "#define CONFIG_BDRV_RW_WHITELIST\\"
-     for drv in ${line#*=}; do
--      echo "    \"${drv}\",\\"
-+      if [ ! -z "$drv" ]; then
-+        echo "    \"${drv}\",\\"
-+      fi
-     done
-     echo "    NULL"
-     ;;
-  CONFIG_BDRV_RO_WHITELIST=*)
-     echo "#define CONFIG_BDRV_RO_WHITELIST\\"
-     for drv in ${line#*=}; do
--      echo "    \"${drv}\",\\"
-+      if [ ! -z "$drv" ]; then
-+        echo "    \"${drv}\",\\"
-+      fi
-     done
-     echo "    NULL"
-     ;;
index 291ff9c4751452542aee044f43f5ee5ec981abd7..445936be34c41268c084c8301089e6be86b5b498 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -27,7 +27,6 @@
 %bcond_with    lttng           # lttng-ust trace backend support [needs update]
 %bcond_without systemtap       # SystemTap/dtrace trace backend support
 %bcond_without virgl           # build virgl support
-%bcond_with    vxhs            # Veritas HyperScale vDisk backend support (builtin; module not supported)
 %bcond_without xkbcommon       # xkbcommon support
 
 %if %{without gtk}
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       5.0.0
-Release:       5
+Version:       5.2.0
+Release:       0.1
 License:       GPL v2, BSD (edk2 firmware files)
 Group:         Applications/Emulators
 Source0:       https://download.qemu.org/%{name}-%{version}.tar.xz
-# Source0-md5: ede6005d7143fe994dd089d31dc2cf6c
+# Source0-md5: 179f86928835da857c237b42f4b2df73
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -67,13 +66,11 @@ Source14:   %{name}-guest-agent.logrotate
 Source15:      %{name}-pr-helper.service
 Source16:      %{name}-pr-helper.socket
 Patch0:                %{name}-cflags.patch
-Patch1:                %{name}-whitelist.patch
-Patch2:                %{name}-user-execve.patch
-Patch3:                %{name}-xattr.patch
-Patch4:                libjpeg-boolean.patch
-Patch5:                x32.patch
-Patch6:                %{name}-vxhs.patch
-Patch7:                binutils-2.36.patch
+Patch1:                %{name}-user-execve.patch
+Patch2:                %{name}-xattr.patch
+Patch3:                libjpeg-boolean.patch
+Patch4:                x32.patch
+Patch5:                binutils-2.36.patch
 URL:           https://www.qemu.org/
 %{?with_opengl:BuildRequires:  Mesa-libgbm-devel}
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
@@ -113,15 +110,16 @@ BuildRequires:    libslirp-devel >= 4.0.0
 BuildRequires: libusb-devel >= 1.0.22
 BuildRequires: liburing-devel
 BuildRequires: libuuid-devel
-%{?with_vxhs:BuildRequires:    libvxhs-devel}
 BuildRequires: libxml2-devel >= 2.0
 %{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: lzfse-devel
 BuildRequires: lzo-devel >= 2
+BuildRequires: meson
 %{?with_multipath:BuildRequires:       multipath-tools-devel}
 BuildRequires: ncurses-devel
 # also libgcrypt-devel >= 1.5.0 possible, but gnutls already pulls nettle
 BuildRequires: nettle-devel >= 2.7.1
+BuildRequires: ninja
 %{?with_smartcard:BuildRequires:       nss-devel >= 1:3.12.8}
 BuildRequires: numactl-devel
 BuildRequires: pam-devel
@@ -171,9 +169,9 @@ Requires:   %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-aarch64 = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
 Requires:      %{name}-system-arm = %{version}-%{release}
+Requires:      %{name}-system-avr = %{version}-%{release}
 Requires:      %{name}-system-cris = %{version}-%{release}
 Requires:      %{name}-system-hppa = %{version}-%{release}
-Requires:      %{name}-system-lm32 = %{version}-%{release}
 Requires:      %{name}-system-m68k = %{version}-%{release}
 Requires:      %{name}-system-microblaze = %{version}-%{release}
 Requires:      %{name}-system-mips = %{version}-%{release}
@@ -188,7 +186,6 @@ Requires:   %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
 Requires:      %{name}-system-sparc = %{version}-%{release}
 Requires:      %{name}-system-tricore = %{version}-%{release}
-Requires:      %{name}-system-unicore32 = %{version}-%{release}
 Requires:      %{name}-system-x86 = %{version}-%{release}
 Requires:      %{name}-system-xtensa = %{version}-%{release}
 Requires:      %{name}-user = %{version}-%{release}
@@ -402,6 +399,26 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z 32-bitowym procesorem ARM.
 
+%package system-avr
+Summary:       QEMU system emulator for AVR
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem AVR
+Group:         Applications/Emulators
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+Obsoletes:     qemu-kvm-system-avr
+
+%description system-avr
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for AVR.
+
+%description system-avr -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem AVR.
+
 %package system-cris
 Summary:       QEMU system emulator for CRIS
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem CRIS
@@ -441,26 +458,6 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem HP/PA (PA-RISC).
 
-%package system-lm32
-Summary:       QEMU system emulator for LM32
-Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem LM32
-Group:         Applications/Emulators
-Requires:      %{name}-common = %{version}-%{release}
-%systempkg_req
-Obsoletes:     qemu-kvm-system-lm32
-
-%description system-lm32
-QEMU is a generic and open source processor emulator which achieves a
-good emulation speed by using dynamic translation.
-
-This package provides the system emulator with LM32 CPU.
-
-%description system-lm32 -l pl.UTF-8
-QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
-dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
-
-Ten pakiet zawiera emulator systemu z procesorem LM32.
-
 %package system-m68k
 Summary:       QEMU system emulator for m68k
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem m68k
@@ -738,26 +735,6 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem TriCore.
 
-%package system-unicore32
-Summary:       QEMU system emulator for UniCore32
-Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem UniCore32
-Group:         Applications/Emulators
-Requires:      %{name}-common = %{version}-%{release}
-%systempkg_req
-Obsoletes:     qemu-kvm-system-unicore32
-
-%description system-unicore32
-QEMU is a generic and open source processor emulator which achieves a
-good emulation speed by using dynamic translation.
-
-This package provides the system emulator with UniCore32 CPU.
-
-%description system-unicore32 -l pl.UTF-8
-QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
-dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
-
-Ten pakiet zawiera emulator systemu z procesorem UniCore32.
-
 %package system-x86
 Summary:       QEMU system emulator for x86
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem x86
@@ -959,8 +936,6 @@ Sondy systemtap/dtrace dla QEMU.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
-%patch7 -p1
 
 %{__sed} -i '1s,/usr/bin/env python3,%{__python3},' scripts/qemu-trace-stap
 
@@ -1000,8 +975,8 @@ build() {
 }
 
 build dynamic \
-       --extra-cflags="%{rpmcflags} %{rpmcppflags} -fPIE -DPIE" \
-       --extra-ldflags="%{rpmldflags} -pie -Wl,-z,relro -Wl,-z,now" \
+       --extra-cflags="%{rpmcflags} %{rpmcppflags}" \
+       --extra-ldflags="%{rpmldflags} -Wl,-z,relro -Wl,-z,now" \
        --audio-drv-list="alsa%{?with_oss:,oss}%{?with_sdl:,sdl}%{?with_pulseaudio:,pa}" \
        --enable-attr \
        %{__enable_disable brlapi} \
@@ -1037,7 +1012,6 @@ build dynamic \
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
-       %{__enable_disable vxhs} \
        %{!?with_vte:--disable-vte} \
        %{__enable_disable xen} \
        %{__enable_disable xkbcommon}
@@ -1065,7 +1039,6 @@ build static \
        --disable-system \
        --disable-tcmalloc \
        --disable-tools \
-       --disable-vxhs \
        --enable-user \
        --disable-xkbcommon \
        --disable-zstd \
@@ -1221,8 +1194,6 @@ done
 
 # cleanup Sphinx files
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/{interop,specs,system,tools,user}/{.buildinfo,objects.inv}
-# leave just HTML version
-%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{ga,qmp}-ref.txt
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -1297,8 +1268,8 @@ fi
 %{systemdunitdir}/qemu-pr-helper.service
 %{systemdunitdir}/qemu-pr-helper.socket
 %attr(755,root,root) %{_bindir}/elf2dmp
-%attr(755,root,root) %{_bindir}/ivshmem-client
-%attr(755,root,root) %{_bindir}/ivshmem-server
+#%attr(755,root,root) %{_bindir}/ivshmem-client
+#%attr(755,root,root) %{_bindir}/ivshmem-server
 %attr(755,root,root) %{_bindir}/qemu-edid
 %if %{with xkbcommon}
 %attr(755,root,root) %{_bindir}/qemu-keymap
@@ -1306,13 +1277,13 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_bindir}/qemu-pr-helper
 %attr(755,root,root) %{_bindir}/qemu-storage-daemon
-%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_sbindir}/ksmctl
 %attr(755,root,root) %{_sbindir}/ksmtuned
 %attr(755,root,root) %{_libexecdir}/qemu-bridge-helper
 %if %{with virgl}
 %attr(755,root,root) %{_libexecdir}/vhost-user-gpu
 %endif
+%attr(755,root,root) %{_libexecdir}/virtfs-proxy-helper
 %attr(755,root,root) %{_libexecdir}/virtiofsd
 %dir %{_libdir}/%{name}
 # modules without too many external dependencies
@@ -1325,9 +1296,27 @@ fi
 %if %{with pulseaudio}
 %attr(755,root,root) %{_libdir}/%{name}/audio-pa.so
 %endif
+%attr(755,root,root) %{_libdir}/%{name}/chardev-baum.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-qxl.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-virtio-gpu-pci.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-virtio-gpu.so
+%attr(755,root,root) %{_libdir}/%{name}/hw-display-virtio-vga.so
 %attr(755,root,root) %{_libdir}/%{name}/ui-curses.so
+%if %{with usbredir}
+%attr(755,root,root) %{_libdir}/%{name}/hw-usb-redirect.so
+%endif
+%if %{with smartcard}
+%attr(755,root,root) %{_libdir}/%{name}/hw-usb-smartcard.so
+%endif
+%if %{with opengl}
+%attr(755,root,root) %{_libdir}/%{name}/ui-egl-headless.so
+%attr(755,root,root) %{_libdir}/%{name}/ui-opengl.so
+%endif
 %if %{with spice}
+%attr(755,root,root) %{_libdir}/%{name}/audio-spice.so
+%attr(755,root,root) %{_libdir}/%{name}/chardev-spice.so
 %attr(755,root,root) %{_libdir}/%{name}/ui-spice-app.so
+%attr(755,root,root) %{_libdir}/%{name}/ui-spice-core.so
 %endif
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/firmware
@@ -1349,6 +1338,7 @@ fi
 %{_mandir}/man7/qemu-cpu-models.7*
 %{_mandir}/man7/qemu-qmp-ref.7*
 %{_mandir}/man8/qemu-nbd.8*
+%{_mandir}/man8/qemu-pr-helper.8*
 %{_docdir}/qemu
 
 %files img
@@ -1381,7 +1371,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-or1k
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
-%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
 %attr(755,root,root) %{_bindir}/qemu-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-riscv32
 %attr(755,root,root) %{_bindir}/qemu-riscv64
@@ -1391,7 +1380,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
-%attr(755,root,root) %{_bindir}/qemu-tilegx
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 %attr(755,root,root) %{_bindir}/qemu-xtensa
 %attr(755,root,root) %{_bindir}/qemu-xtensaeb
@@ -1421,7 +1409,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-or1k-static
 %attr(755,root,root) %{_bindir}/qemu-ppc-static
 %attr(755,root,root) %{_bindir}/qemu-ppc64-static
-%attr(755,root,root) %{_bindir}/qemu-ppc64abi32-static
 %attr(755,root,root) %{_bindir}/qemu-ppc64le-static
 %attr(755,root,root) %{_bindir}/qemu-riscv32-static
 %attr(755,root,root) %{_bindir}/qemu-riscv64-static
@@ -1431,7 +1418,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc-static
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus-static
 %attr(755,root,root) %{_bindir}/qemu-sparc64-static
-%attr(755,root,root) %{_bindir}/qemu-tilegx-static
 %attr(755,root,root) %{_bindir}/qemu-x86_64-static
 %attr(755,root,root) %{_bindir}/qemu-xtensa-static
 %attr(755,root,root) %{_bindir}/qemu-xtensaeb-static
@@ -1455,6 +1441,11 @@ fi
 %{_datadir}/%{name}/edk2-arm-code.fd
 %{_datadir}/%{name}/edk2-arm-vars.fd
 %{_datadir}/%{name}/firmware/60-edk2-arm.json
+%{_datadir}/%{name}/npcm7xx_bootrom.bin
+
+%files system-avr
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-avr
 
 %files system-cris
 %defattr(644,root,root,755)
@@ -1465,10 +1456,6 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-system-hppa
 %{_datadir}/%{name}/hppa-firmware.img
 
-%files system-lm32
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/qemu-system-lm32
-
 %files system-m68k
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-m68k
@@ -1515,14 +1502,14 @@ fi
 %files system-riscv32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-riscv32
-%{_datadir}/%{name}/opensbi-riscv32-sifive_u-fw_jump.bin
-%{_datadir}/%{name}/opensbi-riscv32-virt-fw_jump.bin
+%{_datadir}/%{name}/opensbi-riscv32-generic-fw_dynamic.bin
+%{_datadir}/%{name}/opensbi-riscv32-generic-fw_dynamic.elf
 
 %files system-riscv64
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-riscv64
-%{_datadir}/%{name}/opensbi-riscv64-sifive_u-fw_jump.bin
-%{_datadir}/%{name}/opensbi-riscv64-virt-fw_jump.bin
+%{_datadir}/%{name}/opensbi-riscv64-generic-fw_dynamic.bin
+%{_datadir}/%{name}/opensbi-riscv64-generic-fw_dynamic.elf
 
 %files system-rx
 %defattr(644,root,root,755)
@@ -1552,10 +1539,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-tricore
 
-%files system-unicore32
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/qemu-system-unicore32
-
 %files system-x86
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-i386
@@ -1591,6 +1574,7 @@ fi
 %{_datadir}/%{name}/pxe-pcnet.rom
 %{_datadir}/%{name}/pxe-rtl8139.rom
 %{_datadir}/%{name}/pxe-virtio.rom
+%{_datadir}/%{name}/qboot.rom
 %{_datadir}/%{name}/sgabios.bin
 %{_datadir}/%{name}/vgabios.bin
 %{_datadir}/%{name}/vgabios-ati.bin
index 00b573046e1f949159e03dcc72e05f545c4e1e90..342bb07320aa0c3a97bbeba9303cf1646f024678 100644 (file)
--- a/x32.patch
+++ b/x32.patch
@@ -7,7 +7,7 @@
 -if { test "$cpu" = "i386" || test "$cpu" = "x86_64"; } && \
 +if { test "$cpu" = "i386" || test "$cpu" = "x86_64" || test "$cpu" = "x32"; } && \
          test "$targetos" != "Darwin" && test "$targetos" != "SunOS" && \
-         test "$softmmu" = yes ; then
+         test "$targetos" != "Haiku" && test "$softmmu" = yes ; then
      # Different host OS linkers have different ideas about the name of the ELF
 --- qemu-2.6.0/include/qemu/atomic.h~  2016-07-17 18:37:57.000000000 +0200
 +++ qemu-2.6.0/include/qemu/atomic.h   2016-07-17 18:38:33.485893530 +0200
This page took 0.256964 seconds and 4 git commands to generate.