]> git.pld-linux.org Git - packages/qemu.git/commitdiff
- started update to 1.3.0; 1.2.x left on qemu-1.2 branch
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 16 Dec 2012 13:35:03 +0000 (14:35 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 16 Dec 2012 13:35:03 +0000 (14:35 +0100)
- updated system-libcacard patch

qemu-system-libcacard.patch
qemu.spec

index 31499086c60a21483642371e2f2b3013753a5c2f..a8774bc8718b68586206248591ee649f6fde0c27 100644 (file)
@@ -1,6 +1,6 @@
---- qemu-1.2.1/configure.orig  2012-11-25 13:26:46.638846657 +0100
-+++ qemu-1.2.1/configure       2012-11-25 13:31:17.258841016 +0100
-@@ -2710,9 +2710,10 @@
+--- qemu-1.3.0/configure.orig  2012-12-16 11:06:51.151203881 +0100
++++ qemu-1.3.0/configure       2012-12-16 11:07:56.571202516 +0100
+@@ -2767,9 +2767,10 @@
  #include <pk11pub.h>
  int main(void) { PK11_FreeSlot(0); return 0; }
  EOF
@@ -14,7 +14,7 @@
          test_cflags="$libcacard_cflags"
          # The header files in nss < 3.13.3 have a bug which causes them to
          # emit a warning. If we're going to compile QEMU with -Werror, then
-@@ -2722,11 +2723,10 @@
+@@ -2779,11 +2780,10 @@
              test_cflags="-Werror $test_cflags"
          fi
          if $pkg_config --atleast-version=3.12.8 nss >/dev/null 2>&1 && \
@@ -29,7 +29,7 @@
          else
              if test "$smartcard_nss" = "yes"; then
                  feature_not_found "nss"
-@@ -3058,9 +3058,6 @@
+@@ -3133,9 +3133,6 @@
        tools="qemu-ga\$(EXESUF) $tools"
      fi
    fi
@@ -39,7 +39,7 @@
  fi
  
  # Mac OS X ships with a broken assembler
-@@ -3449,6 +3446,8 @@
+@@ -3532,6 +3529,8 @@
    echo "CONFIG_SMARTCARD_NSS=y" >> $config_host_mak
    echo "libcacard_libs=$libcacard_libs" >> $config_host_mak
    echo "libcacard_cflags=$libcacard_cflags" >> $config_host_mak
  fi
  
  if test "$usb_redir" = "yes" ; then
-@@ -3895,9 +3894,6 @@
+@@ -3970,9 +3969,6 @@
+ if test "$target_softmmu" = "yes" ; then
+   echo "CONFIG_SOFTMMU=y" >> $config_target_mak
    echo "LIBS+=$libs_softmmu $target_libs_softmmu" >> $config_target_mak
-   echo "HWDIR=../libhw$target_phys_bits" >> $config_target_mak
-   echo "subdir-$target: subdir-libhw$target_phys_bits" >> $config_host_mak
 -  if test "$smartcard_nss" = "yes" ; then
 -    echo "subdir-$target: subdir-libcacard" >> $config_host_mak
 -  fi
    case "$target_arch2" in
      i386|x86_64)
        echo "CONFIG_HAVE_CORE_DUMP=y" >> $config_target_mak
-@@ -4100,10 +4096,9 @@
+@@ -4179,10 +4175,9 @@
  DIRS="$DIRS pc-bios/optionrom pc-bios/spapr-rtas"
  DIRS="$DIRS roms/seabios roms/vgabios"
  DIRS="$DIRS qapi-generated"
@@ -82,23 +82,21 @@ diff -ur qemu-kvm-1.2.0/hw/ccid-card-passthru.c qemu-kvm-1.2.0-system-libcacard/
  
  #define DPRINTF(card, lvl, fmt, ...)                    \
  do {                                                    \
-diff -ur qemu-kvm-1.2.0/Makefile qemu-kvm-1.2.0-system-libcacard/Makefile
---- qemu-kvm-1.2.0/Makefile    2012-09-06 10:31:27.000000000 +0200
-+++ qemu-kvm-1.2.0-system-libcacard/Makefile   2012-11-09 07:42:39.346751378 +0100
-@@ -98,8 +98,6 @@
+--- qemu-1.3.0/Makefile.orig   2012-12-03 20:37:05.000000000 +0100
++++ qemu-1.3.0/Makefile        2012-12-16 11:08:58.001201236 +0100
+@@ -116,8 +116,6 @@
  include $(SRC_PATH)/Makefile.objs
  endif
  
 -subdir-libcacard: $(oslib-obj-y) $(trace-obj-y) qemu-timer-common.o
 -
- $(filter %-softmmu,$(SUBDIR_RULES)): $(universal-obj-y) $(trace-obj-y) $(common-obj-y) $(extra-obj-y) subdir-libdis
+ subdir-pixman: pixman/Makefile
+       $(call quiet-command,$(MAKE) $(SUBDIR_MAKEFLAGS) -C pixman V="$(V)" all,)
  
- $(filter %-user,$(SUBDIR_RULES)): $(universal-obj-y) $(trace-obj-y) subdir-libdis-user subdir-libuser
-@@ -130,25 +128,6 @@
-       $(call quiet-command,$(WINDRES) -I. -o $@ $<,"  RC    $(TARGET_DIR)$@")
+@@ -166,24 +164,6 @@
+ libqemustub.a: $(stub-obj-y)
  
- version-obj-$(CONFIG_WIN32) += version.o
--######################################################################
+ ######################################################################
 -# Support building shared library libcacard
 -
 -.PHONY: libcacard.la install-libcacard
@@ -120,17 +118,17 @@ diff -ur qemu-kvm-1.2.0/Makefile qemu-kvm-1.2.0-system-libcacard/Makefile
  
  qemu-img.o: qemu-img-cmds.h
  
-@@ -163,9 +142,6 @@
+@@ -197,9 +177,6 @@
  
  qemu-bridge-helper$(EXESUF): qemu-bridge-helper.o
  
--vscclient$(EXESUF): $(libcacard-y) $(oslib-obj-y) $(trace-obj-y) $(tools-obj-y) qemu-timer-common.o libcacard/vscclient.o
+-vscclient$(EXESUF): $(libcacard-y) $(oslib-obj-y) $(trace-obj-y) libcacard/vscclient.o libqemustub.a
 -      $(call quiet-command,$(CC) $(LDFLAGS) -o $@ $^ $(libcacard_libs) $(LIBS),"  LINK  $@")
 -
  fsdev/virtfs-proxy-helper$(EXESUF): fsdev/virtfs-proxy-helper.o fsdev/virtio-9p-marshal.o oslib-posix.o $(trace-obj-y)
  fsdev/virtfs-proxy-helper$(EXESUF): LIBS += -lcap
  
-@@ -226,7 +202,7 @@
+@@ -260,7 +237,7 @@
        rm -rf qapi-generated
        rm -rf qga/qapi-generated
        $(MAKE) -C tests/tcg clean
index 6578d71b6d0d1610a8178b5d7fcfb034ed87c1b1..b6e7fbe0960228ff70a04d4fa06e585979c66c4c 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.2.2
-Release:       1
+Version:       1.3.0
+Release:       0.1
 License:       GPL v2+
 Group:         Applications/Emulators
-Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: ea9f290266ef26b48bf4d68f810fd4ec
+Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: a4030ddd2ba324152a97d65d3c0b247d
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-usbredir.patch
@@ -563,7 +563,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/qemu-nbd.8*
 
 %dir %{_datadir}/qemu
-%{_datadir}/%{name}/cpus-*.conf
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
 # various bios images
This page took 0.072534 seconds and 4 git commands to generate.