]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- packaged remaining files, added -system-moxie subpackage
[packages/qemu.git] / qemu.spec
index 2c6bd956a20c23e5e8686446076cfa00e43e6760..cee340b665dbd150ab9c9cf6190d555ea9ce1a62 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
-#
 # TODO:
-# - update patches
+# - merge missing bits from qemu-kvm
+# - --enable-glusterfs when glusterfs 3.4 is out
+# - qemu-system-ppc -hda ac-ppc.img says:
+#   qemu: could not open disk image ac-ppc.img: error "Success"
+#   qemu-0.12.2-2.x86_64.rpm - broken
+#   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
+#   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
+#   qemu-0.11.1-*.x86_64.rpm - OK
 #
 # Conditional build:
-%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
-%bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
-%bcond_with    dosguest                # add special patch when use with DOS as guest os
-%bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_without dist_kernel             # without distribution kernel
-%bcond_without kernel                  # build kqemu KERNEL MODULES
-%bcond_without userspace               # don't build userspace utilities
-
-# no kernel kqemu module for ppc
-%ifarch ppc
-%undefine      with_kqemu
-%undefine      with_kernel
-%endif
-
-%if %{without kernel}
-%undefine      with_dist_kernel
-%endif
-%if "%{_alt_kernel}" != "%{nil}"
-%undefine      with_userspace
-%endif
-%if %{without userspace}
-# nothing to be placed to debuginfo package
-%define                _enable_debug_packages  0
-%endif
-
-%define                rel     3
+%bcond_without sdl             # SDL UI and audio support
+%bcond_without glx             # OpenGL support
+%bcond_without ceph            # Ceph/RBD support
+%bcond_with    glusterfs       # GlusterFS backend
+%bcond_without spice           # SPICE support
+%bcond_with    esd             # EsounD audio support
+%bcond_without oss             # OSS audio support
+%bcond_without pulseaudio      # PulseAudio audio support
+%bcond_without xen             # Xen backend driver support
 
-%define                kqemu_version   1.4.0pre1
-%define                qemu_version    0.11.0
-%define                pname   qemu
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
-Name:          %{pname}%{_alt_kernel}
-Version:       %{qemu_version}
-Release:       %{rel}%{?with_kqemu:k}
-License:       GPL
+Name:          qemu
+Version:       1.5.0
+Release:       0.1
+License:       GPL v2+
 Group:         Applications/Emulators
-# Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://download.savannah.gnu.org/releases/qemu/%{pname}-%{version}.tar.gz
-# Source0-md5: 4da6a3e926a0260902f0dee342a59c23
-Source1:       http://www.nongnu.org/qemu/k%{pname}-%{kqemu_version}.tar.gz
-# Source1-md5: d738d8ca7332211ab716ec3213d82ee1
-Patch0:                %{pname}-ncurses.patch
-Patch6:                %{pname}-nosdlgui.patch
+Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: b6f3265b8ed39d77e8f354f35cc26e16
+Patch0:                %{name}-cflags.patch
+Patch1:                vgabios-widescreens.patch
+Patch2:                %{name}-whitelist.patch
+Patch3:                %{name}-system-libcacard.patch
 # Proof of concept, for reference, do not remove
-Patch8:                %{pname}-kde_virtual_workspaces_hack.patch
-#Patch12:      %{pname}-0.7.2-dyngen-check-stack-clobbers.patch
-Patch13:       %{pname}-dosguest.patch
-Patch14:       %{pname}-ppc_old_binutils.patch
-Patch15:       %{pname}-isa-bios-ram.patch
-# below one fixes problems with passing ram size to bios/bootloader
-# which affects coreboot/linuxbios
-Patch16:       %{pname}-piix-ram-size.patch
-URL:           http://www.nongnu.org/qemu/
-%if %{with kernel} && %{with dist_kernel}
-BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
-BuildRequires: rpmbuild(macros) >= 1.379
-%endif
-%if %{with userspace}
-BuildRequires: SDL-devel >= 1.2.1
+Patch4:                %{name}-kde_virtual_workspaces_hack.patch
+URL:           http://www.qemu-project.org/
+%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
+%{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
 BuildRequires: alsa-lib-devel
+BuildRequires:  bcc
 BuildRequires: bluez-libs-devel
+BuildRequires: brlapi-devel
+%{?with_ceph:BuildRequires:    ceph-devel}
+BuildRequires: curl-devel
+BuildRequires: cyrus-sasl-devel >= 2
+%{?with_esd:BuildRequires:     esound-devel}
+BuildRequires: glib2-devel >= 1:2.12
+%{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
 BuildRequires: gnutls-devel
+BuildRequires: libaio-devel
+BuildRequires: libcacard-devel
+BuildRequires: libcap-devel
+BuildRequires: libcap-ng-devel
+BuildRequires: libfdt-devel
+BuildRequires: libiscsi-devel
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
+BuildRequires: libseccomp-devel
+BuildRequires: libuuid-devel
 BuildRequires: ncurses-devel
+BuildRequires: nss-devel >= 3.12.8
+BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
+%{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
+BuildRequires: rpmbuild(macros) >= 1.202
 BuildRequires: sed >= 4.0
+%if %{with spice}
+BuildRequires: spice-protocol >= 0.12.0
+BuildRequires: spice-server-devel >= 0.12.0
+%endif
 BuildRequires: texi2html
-BuildRequires: texinfo-texi2dvi
+BuildRequires: texinfo
+BuildRequires: usbredir-devel >= 0.6
+BuildRequires: vde2-devel
 BuildRequires: which
+%{?with_xen:BuildRequires:     xen-devel >= 3.4}
+BuildRequires: xfsprogs-devel
 BuildRequires: xorg-lib-libX11-devel
-%endif
-Requires:      SDL >= 1.2.1
-# sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
-ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
+BuildRequires: zlib-devel
+Requires:      %{name}-img = %{version}-%{release}
+Requires:      %{name}-system-alpha = %{version}-%{release}
+Requires:      %{name}-system-arm = %{version}-%{release}
+Requires:      %{name}-system-cris = %{version}-%{release}
+Requires:      %{name}-system-lm32 = %{version}-%{release}
+Requires:      %{name}-system-m68k = %{version}-%{release}
+Requires:      %{name}-system-microblaze = %{version}-%{release}
+Requires:      %{name}-system-mips = %{version}-%{release}
+Requires:      %{name}-system-moxie = %{version}-%{release}
+Requires:      %{name}-system-or32 = %{version}-%{release}
+Requires:      %{name}-system-ppc = %{version}-%{release}
+Requires:      %{name}-system-s390x = %{version}-%{release}
+Requires:      %{name}-system-sh4 = %{version}-%{release}
+Requires:      %{name}-system-sparc = %{version}-%{release}
+Requires:      %{name}-system-unicore32 = %{version}-%{release}
+Requires:      %{name}-system-x86 = %{version}-%{release}
+Requires:      %{name}-system-xtensa = %{version}-%{release}
+Requires:      %{name}-user = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define        systempkg_req \
+Requires:      SDL >= 1.2.1 \
+Requires:      usbredir >= 0.6
+
 # some PPC/SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/openbios-.*
+%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -114,173 +137,596 @@ aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
   używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
-%package -n kernel%{_alt_kernel}-misc-kqemu
-Summary:       kqemu - kernel module
-Summary(pl.UTF-8):     kqemu - moduł jądra
-Version:       %{kqemu_version}
-Release:       %{rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel}
-License:       GPL v2
-Obsoletes:     kernel%{_alt_kernel}-smp-misc-kqemu
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
+%package common
+Summary:       QEMU common files needed by all QEMU targets
+Summary(pl.UTF-8):     Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
+Group:         Development/Tools
+Requires:      glib2 >= 1:2.12
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Provides:      group(qemu)
+Provides:      user(qemu)
+Conflicts:     qemu < 1.0-2
+
+%description common
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the common files needed by all QEMU targets.
+
+%description common -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
+środowiska QEMU.
+
+%package img
+Summary:       QEMU command line tool for manipulating disk images
+Summary(pl.UTF-8):     Narzędzie QEMU do operacji na obrazach dysków
+Group:         Development/Tools
+Conflicts:     qemu < 1.0-2
 
-%description -n kernel%{_alt_kernel}-misc-kqemu
-kqemu - kernel module.
+%description img
+This package provides a command line tool for manipulating disk
+images.
 
-%description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
-kqemu - moduł jądra.
+%description img -l pl.UTF-8
+Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
+na obrazach dysków.
+
+%package user
+Summary:       QEMU user mode emulation of qemu targets
+Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description user
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the user mode emulation of QEMU targets.
 
-%prep
-%setup -q -n %{pname}-%{qemu_version} %{?with_kernel:-a1}
-%patch0 -p0
-%{?with_nosdlgui:%patch6 -p1}
-#%patch8 -p1
-
-%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
-%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
-
-# cannot use optflags on x86 - they cause "no register to spill" errors
-%if %{with cflags_passing}
-%{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
-%else
-%{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
-%endif
+%description user -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
-%if %{with kernel}
-echo -n > kqemu-%{kqemu_version}/install.sh
+Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
+
+%package system-alpha
+Summary:       QEMU system emulator for Alpha
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Alpha
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-alpha
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with Alpha CPU.
 
-cat <<'EOF' > modprobe.conf
-# enable dynamic major
-options kqemu major=0
-# for autoloading from static dev
-#alias char-major-250 kqemu
-EOF
+%description system-alpha -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
-cat <<'EOF' > udev.conf
-KERNEL=="kqemu", NAME="%k", MODE="0666"
-EOF
+Ten pakiet zawiera emulator systemu z procesorem Alpha.
+
+%package system-arm
+Summary:       QEMU system emulator for ARM
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem ARM
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
 
-%if %{with dosguest}
-%patch13 -p1
-%endif
-%patch14 -p1
-#%patch15 -p1
-%patch16 -p1
-
-cd kqemu-%{kqemu_version}
-%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
-%ifarch %{x8664}
-%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
-%{__make} -C common -j1
-mv -f kqemu-mod-x86_64.o{,.bin}
-%else
-%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
-%{__make} -C common -j1
-mv -f kqemu-mod-i386.o{,.bin}
-%endif
+%description system-arm
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
 
-mv -f kqemu-linux.c{,.orig}
-cat > Makefile <<'EOF'
-obj-m := kqemu.o
-kqemu-objs:= kqemu-linux.o kqemu-mod.o
+This package provides the system emulator for ARM.
 
-$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
-       cp $< $@
-EOF
-cd -
-%endif
+%description system-arm -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
-%build
-%if %{with kernel}
-cd kqemu-%{kqemu_version}
-%build_kernel_modules -m kqemu <<'EOF'
-if grep -q "CONFIG_PREEMPT_RT" o/.config; then
-       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
-               kqemu-linux.c.orig > kqemu-linux.c
-else
-       cat kqemu-linux.c.orig > kqemu-linux.c
-fi
-EOF
-cd -
-%endif
+Ten pakiet zawiera emulator systemu z procesorem ARM.
+
+%package system-cris
+Summary:       QEMU system emulator for CRIS
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem CRIS
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-cris
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with CRIS CPU.
+
+%description system-cris -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem CRIS.
+
+%package system-lm32
+Summary:       QEMU system emulator for LM32
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem LM32
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-lm32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with LM32 CPU.
+
+%description system-lm32 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem LM32.
+
+%package system-m68k
+Summary:       QEMU system emulator for m68k
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem m68k
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-m68k
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with m68k CPU.
+
+%description system-m68k -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem m68k.
+
+%package system-microblaze
+Summary:       QEMU system emulator for MicroBlaze
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem MicroBlaze
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-microblaze
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with MicroBlaze CPU.
+
+%description system-microblaze -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
+
+%package system-mips
+Summary:       QEMU system emulator for MIPS
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem MIPS
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-mips
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with MIPS CPU.
+
+%description system-mips -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem MIPS.
+
+%package system-moxie
+Summary:       QEMU system emulator for Moxie
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Moxie
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-moxie
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with Moxie CPU.
+
+%description system-moxie -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem Moxie.
+
+%package system-or32
+Summary:       QEMU system emulator for OpenRISC
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem OpenRISC
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-or32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with OpenRISC CPU.
+
+%description system-or32 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
+
+%package system-ppc
+Summary:       QEMU system emulator for PowerPC
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem PowerPC
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-ppc
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with PowerPC CPU.
+
+%description system-ppc -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem PowerPC.
+
+%package system-s390x
+Summary:       QEMU system emulator for S390
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem S390
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-s390x
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with S390 CPU.
+
+%description system-s390x -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem S390.
+
+%package system-sh4
+Summary:       QEMU system emulator for SH4
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem SH4
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-sh4
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with SH4 CPU.
+
+%description system-sh4 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem SH4.
 
-%if %{with userspace}
-# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
-# they can be passed if the cflags_passing bcond is used
+%package system-sparc
+Summary:       QEMU system emulator for SPARC
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem SPARC
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-sparc
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with SPARC/SPARC64 CPU.
+
+%description system-sparc -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
+
+%package system-unicore32
+Summary:       QEMU system emulator for UniCore32
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem UniCore32
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-unicore32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with UniCore32 CPU.
+
+%description system-unicore32 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem UniCore32.
+
+%package system-x86
+Summary:       QEMU system emulator for x86
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem x86
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-x86
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+%description system-x86 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+%package system-xtensa
+Summary:       QEMU system emulator for Xtensa
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Xtensa
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-xtensa
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with Xtensa CPU.
+
+%description system-xtensa -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem Xtensa.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p0
+%patch3 -p1
+
+%{__mv} libcacard libcacard-use-system-lib
+
+# workaround for conflict with alsa/error.h
+ln -s ../error.h qapi/error.h
+
+%build
 ./configure \
+       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
+       --extra-ldflags="%{rpmldflags}" \
        --prefix=%{_prefix} \
+       --sysconfdir=%{_sysconfdir} \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
-       --make="%{__make}" \
-%if %{without kqemu}
-       --disable-kqemu \
-%endif
+       --disable-strip \
+       --enable-attr \
+       --enable-bluez \
+       --enable-brlapi \
+       --enable-cap-ng \
+       --enable-curl \
+       --enable-curses \
+       --enable-docs \
+       --enable-fdt \
+       %{__enable_disable glusterfs} \
+       --enable-libiscsi \
        --enable-mixemu \
-       --audio-drv-list="alsa" \
-       --interp-prefix=%{_libdir}/%{pname}
-%{__make}
-%endif
+       %{__enable_disable glx} \
+       %{__enable_disable ceph rbd} \
+       %{__enable_disable sdl} \
+       --enable-seccomp \
+       %{__enable_disable spice} \
+       --enable-smartcard-nss \
+       --enable-usb-redir \
+       --enable-uuid \
+       --enable-vde \
+       --enable-virtfs \
+       --enable-vnc-jpeg \
+       --enable-vnc-png \
+       --enable-vnc-sasl \
+       --enable-vnc-tls \
+       %{__enable_disable xen} \
+       --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
+       --interp-prefix=%{_libdir}/qemu/lib-%%M
+# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
+# --libexecdir in configure is nop
+%{__make} \
+       V=1 \
+       CONFIG_QEMU_HELPERDIR="%{_libdir}"
+
+# rebuild patched vesa tables with additional widescreen modes.
+%{__make} -C roms/vgabios stdvga-bios
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with userspace}
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       libexecdir=%{_libdir}
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
 
 EOF
-%endif
-
-%if %{with kernel}
-%install_kernel_modules -m kqemu-%{kqemu_version}/kqemu -d misc
-install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
-install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
-%endif
 
 # already packaged
-rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
+
+# install patched vesa tables with additional widescreen modes.
+cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
+
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
+%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kernel}
-%post
-%banner %{pname} -e <<EOF
-To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
-modprobe kqemu
-EOF
-%endif
-
-%post  -n kernel%{_alt_kernel}-misc-kqemu
-%depmod %{_kernel_ver}
+%pre common
+%groupadd -g 276 qemu
+%useradd -u 276 -g qemu -c "QEMU User" qemu
 
-%postun -n kernel%{_alt_kernel}-misc-kqemu
-%depmod %{_kernel_ver}
+%postun common
+if [ "$1" = "0" ]; then
+       %userremove qemu
+       %groupremove qemu
+fi
 
-%if %{with userspace}
 %files
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html
+
+%files common -f %{name}.lang
+%defattr(644,root,root,755)
+%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
-%attr(755,root,root) %{_bindir}/*
-%{_datadir}/qemu
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
+%dir %{_sysconfdir}/qemu
+%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
+%attr(755,root,root) %{_bindir}/qemu-nbd
+%attr(755,root,root) %{_libdir}/qemu-bridge-helper
 %{_mandir}/man1/qemu.1*
-%{_mandir}/man1/qemu-img.1*
+%{_mandir}/man1/virtfs-proxy-helper.1*
 %{_mandir}/man8/qemu-nbd.8*
-%endif
 
-%if %{with kernel}
-%files -n kernel%{_alt_kernel}-misc-kqemu
+%dir %{_datadir}/qemu
+%{_datadir}/%{name}/keymaps
+%{_datadir}/%{name}/qemu-icon.bmp
+# various bios images
+%{_datadir}/%{name}/*.aml
+%{_datadir}/%{name}/*.bin
+%{_datadir}/%{name}/*.rom
+%{_datadir}/%{name}/*.dtb
+%{_datadir}/%{name}/openbios-ppc
+%{_datadir}/%{name}/openbios-sparc*
+%{_datadir}/%{name}/palcode-clipper
+%{_datadir}/%{name}/s390-ccw.img
+
+%files img
 %defattr(644,root,root,755)
-%doc kqemu-%{kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-/lib/modules/%{_kernel_ver}/misc/kqemu.ko*
-%endif
+%attr(755,root,root) %{_bindir}/qemu-img
+%{_mandir}/man1/qemu-img.1*
+
+%files user
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-alpha
+%attr(755,root,root) %{_bindir}/qemu-arm
+%attr(755,root,root) %{_bindir}/qemu-armeb
+%attr(755,root,root) %{_bindir}/qemu-cris
+%attr(755,root,root) %{_bindir}/qemu-ga
+%attr(755,root,root) %{_bindir}/qemu-i386
+%attr(755,root,root) %{_bindir}/qemu-io
+%attr(755,root,root) %{_bindir}/qemu-m68k
+%attr(755,root,root) %{_bindir}/qemu-microblaze
+%attr(755,root,root) %{_bindir}/qemu-microblazeel
+%attr(755,root,root) %{_bindir}/qemu-mips
+%attr(755,root,root) %{_bindir}/qemu-mipsel
+%attr(755,root,root) %{_bindir}/qemu-mips64
+%attr(755,root,root) %{_bindir}/qemu-mips64el
+%attr(755,root,root) %{_bindir}/qemu-mipsn32
+%attr(755,root,root) %{_bindir}/qemu-mipsn32el
+%attr(755,root,root) %{_bindir}/qemu-or32
+%attr(755,root,root) %{_bindir}/qemu-ppc
+%attr(755,root,root) %{_bindir}/qemu-ppc64
+%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
+%attr(755,root,root) %{_bindir}/qemu-s390x
+%attr(755,root,root) %{_bindir}/qemu-sh4
+%attr(755,root,root) %{_bindir}/qemu-sh4eb
+%attr(755,root,root) %{_bindir}/qemu-sparc
+%attr(755,root,root) %{_bindir}/qemu-sparc32plus
+%attr(755,root,root) %{_bindir}/qemu-sparc64
+%attr(755,root,root) %{_bindir}/qemu-unicore32
+%attr(755,root,root) %{_bindir}/qemu-x86_64
+
+%files system-alpha
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-alpha
+
+%files system-arm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-arm
+
+%files system-cris
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-cris
+
+%files system-lm32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-lm32
+
+%files system-m68k
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-m68k
+
+%files system-microblaze
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-microblaze
+%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
+
+%files system-mips
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-mips
+%attr(755,root,root) %{_bindir}/qemu-system-mipsel
+%attr(755,root,root) %{_bindir}/qemu-system-mips64
+%attr(755,root,root) %{_bindir}/qemu-system-mips64el
+
+%files system-moxie
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-moxie
+
+%files system-or32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-or32
+
+%files system-ppc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-ppc
+%attr(755,root,root) %{_bindir}/qemu-system-ppc64
+%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
+
+%files system-s390x
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-s390x
+
+%files system-sh4
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-sh4
+%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
+
+%files system-sparc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-sparc
+%attr(755,root,root) %{_bindir}/qemu-system-sparc64
+
+%files system-unicore32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-unicore32
+
+%files system-x86
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-i386
+%attr(755,root,root) %{_bindir}/qemu-system-x86_64
+
+%files system-xtensa
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-xtensa
+%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.087824 seconds and 4 git commands to generate.