]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- updated to 2.0.2
[packages/qemu.git] / qemu.spec
index 57c511b55a7f36e08f8f55f8d102cde700a4d1b7..c3513a9a6e18024fa33732ff87667279d4faa4cf 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -6,21 +6,35 @@
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
+%bcond_without gtk3            # Do not build GTK UI
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
 %bcond_without oss             # OSS audio support
 %bcond_without pulseaudio      # PulseAudio audio support
 %bcond_without xen             # Xen backend driver support
+%bcond_without bluetooth       # bluetooth support
+%bcond_without brlapi          # brlapi support
+%bcond_without smartcard       # smartcard-nss support
+%bcond_without iscsi           # iscsi support
+%bcond_without libnfs          # NFS support
+%bcond_without seccomp         # seccomp support
+%bcond_without usbredir        # usb network redirection support
+%bcond_without system_seabios  # system seabios binary
+%bcond_without snappy          # snappy compression library
+
+%if %{with gtk2}
+%undefine with_gtk3
+%endif
 
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.7.1
+Version:       2.0.2
 Release:       1
 License:       GPL v2+
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 9541063d999cf9659ed7fdce71314f31
+# Source0-md5: 6d7379054b17d8fd3c47955d0a018851
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
@@ -39,55 +53,57 @@ Patch0:             %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
 Patch3:                %{name}-system-libcacard.patch
-Patch4:                vmdk3ro.patch
-Patch5:                %{name}-xattr.patch
-Patch6:                libjpeg-boolean.patch
+Patch4:                %{name}-xattr.patch
+Patch5:                libjpeg-boolean.patch
 # Proof of concept, for reference, do not remove
 Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
-%{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
+%{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
 BuildRequires: bcc
-BuildRequires: bluez-libs-devel
-BuildRequires: brlapi-devel
+%{?with_bluetooth:BuildRequires:       bluez-libs-devel}
+%{?with_brlapi:BuildRequires:  brlapi-devel}
 %{?with_ceph:BuildRequires:    ceph-devel}
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: glib2-devel >= 1:2.12
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
-BuildRequires: gnutls-devel
+BuildRequires: gnutls-devel > 2.10.0
 BuildRequires: libaio-devel
-BuildRequires: libcacard-devel
+%{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
 BuildRequires: libfdt-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
-BuildRequires: libiscsi-devel
+%{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.4.0}
 BuildRequires: libjpeg-devel
+%{?with_libnfs:BuildRequires:  libnfs-devel >= 1.9.3}
 BuildRequires: libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
-BuildRequires: libseccomp-devel
+%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.1.0}
 BuildRequires: libssh2-devel >= 1.2.8
-# for usb passthrough, when available
-#BuildRequires:        libusb-devel >= 1.0.13
+BuildRequires: libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
+BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
-BuildRequires: nss-devel >= 3.12.8
+%{?with_smartcard:BuildRequires:       nss-devel >= 3.12.8}
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: rpmbuild(macros) >= 1.644
+%{?with_system_seabios:BuildRequires:  seabios}
 BuildRequires: sed >= 4.0
+%{?with_snappy:BuildRequires:  snappy-devel}
 %if %{with spice}
-BuildRequires: spice-protocol >= 0.12.0
+BuildRequires: spice-protocol >= 0.12.3
 BuildRequires: spice-server-devel >= 0.12.0
 %endif
 BuildRequires: texi2html
 BuildRequires: texinfo
-BuildRequires: usbredir-devel >= 0.6
+%{?with_usbredir:BuildRequires:        usbredir-devel >= 0.6}
 BuildRequires: vde2-devel
 BuildRequires: which
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
@@ -97,11 +113,13 @@ BuildRequires:     zlib-devel
 %if %{with gtk2}
 BuildRequires: gtk+2-devel >= 2:2.18.0
 BuildRequires: vte0-devel >= 0.24.0
-%else
+%endif
+%if %{with gtk3}
 BuildRequires: gtk+3-devel >= 3.0.0
 BuildRequires: vte-devel >= 0.32.0
 %endif
 Requires:      %{name}-img = %{version}-%{release}
+Requires:      %{name}-system-aarch64 = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
 Requires:      %{name}-system-arm = %{version}-%{release}
 Requires:      %{name}-system-cris = %{version}-%{release}
@@ -123,12 +141,21 @@ Obsoletes:        qemu-kvm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        systempkg_req \
-Requires:      SDL >= 1.2.1 \
+%if %{with sdl} \
+Requires:      SDL2 \
+%endif \
+%if %{with seccomp} \
+Requires:      libseccomp >= 2.1.0 \
+%endif \
+Requires:      libusb >= 1.0.13 \
+%if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
+%endif \
 %if %{with gtk2} \
 Requires:      gtk+2 >= 2:2.18.0 \
 Requires:      vte0 >= 0.24.0 \
-%else \
+%endif \
+%if %{with gtk3} \
 Requires:      gtk+3 >= 3.0.0 \
 Requires:      vte >= 0.32.0 \
 %endif
@@ -179,6 +206,7 @@ Requires(pre):      /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      glib2 >= 1:2.12
+%{?with_libnfs:Requires:       libnfs >= 1.9.3}
 Requires:      libssh2 >= 1.2.8
 Requires:      systemd-units >= 38
 Provides:      group(qemu)
@@ -235,6 +263,26 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
 
+%package system-aarch64
+Summary:       QEMU system emulator for AArch64
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem AArch64
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+Obsoletes:     qemu-kvm-system-aarch64
+
+%description system-aarch64
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with AArch64 CPU.
+
+%description system-aarch64 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem AArch64.
+
 %package system-alpha
 Summary:       QEMU system emulator for Alpha
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Alpha
@@ -519,6 +567,7 @@ Summary:    QEMU system emulator for x86
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem x86
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
+%{?with_system_seabios:Requires:       seabios}
 %systempkg_req
 Obsoletes:     kvm
 Obsoletes:     qemu-kvm-system-x86
@@ -580,6 +629,68 @@ systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
 
 Ten pakiet nie musi być zainstalowany w systemie hosta.
 
+%package module-block-curl
+Summary:       QEMU module for 'curl' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'curl'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-curl
+'curl' block device support for QEMU.
+
+%description module-block-curl -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'curl'.
+
+%package module-block-gluster
+Summary:       QEMU module for 'gluster' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'gluster'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+Requires:      glusterfs-libs >= 3.4
+
+%description module-block-gluster
+'gluster' block device support for QEMU.
+
+%description module-block-gluster -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'gluster'.
+
+%package module-block-iscsi
+Summary:       QEMU module for 'iscsi' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'iscsi'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+Requires:      libiscsi >= 1.4.0
+
+%description module-block-iscsi
+'iscsi' block device support for QEMU.
+
+%description module-block-iscsi -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'iscsi'.
+
+%package module-block-rbd
+Summary:       QEMU module for 'rbd' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'rbd'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-rbd
+'rbd' block device support for QEMU.
+
+%description module-block-rbd -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'rbd'.
+
+%package module-block-ssh
+Summary:       QEMU module for 'ssh' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'ssh'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-ssh
+'ssh' block device support for QEMU.
+
+%description module-block-ssh -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'ssh'.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -588,7 +699,6 @@ Ten pakiet nie musi być zainstalowany w systemie hosta.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 %{__mv} libcacard libcacard-use-system-lib
 
@@ -600,29 +710,32 @@ ln -s ../error.h qapi/error.h
        --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
        --extra-ldflags="%{rpmldflags}" \
        --prefix=%{_prefix} \
+       --libdir=%{_libdir} \
+       --libexecdir=%{_libexecdir} \
        --sysconfdir=%{_sysconfdir} \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --disable-strip \
        --enable-attr \
-       --enable-bluez \
-       --enable-brlapi \
+       %{__enable_disable bluetooth bluez} \
+       %{__enable_disable brlapi} \
        --enable-cap-ng \
        --enable-curl \
        --enable-curses \
        --enable-docs \
        --enable-fdt \
        %{__enable_disable glusterfs} \
-       --enable-libiscsi \
+       %{__enable_disable iscsi libiscsi} \
        %{__enable_disable glx} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
-       --enable-seccomp \
+       --with-sdlabi=2.0 \
+       %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       --enable-smartcard-nss \
+       %{__enable_disable smartcard smartcard-nss} \
        --enable-tpm \
-       --enable-usb-redir \
+       %{__enable_disable usbredir usb-redir} \
        --enable-uuid \
        --enable-vde \
        --enable-virtfs \
@@ -632,15 +745,23 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-tls \
        --enable-kvm \
        %{__enable_disable xen} \
+       --enable-modules \
+       --disable-netmap \
+       %{__enable_disable libnfs} \
+       --enable-lzo \
+       %{__enable_disable snappy} \
+       --enable-quorum \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
        --interp-prefix=%{_libdir}/qemu/lib-%%M \
+%if %{without gtk2} && %{without gtk3}
+       --disable-gtk
+%else
        --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
+%endif
 
-# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
-# --libexecdir in configure is nop
 %{__make} \
        V=1 \
-       CONFIG_QEMU_HELPERDIR="%{_libdir}"
+       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n}
 
 # rebuild patched vesa tables with additional widescreen modes.
 %{__make} -C roms/vgabios stdvga-bios
@@ -654,8 +775,8 @@ install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       libexecdir=%{_libdir}
+       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
@@ -712,9 +833,24 @@ done < %{SOURCE2}
 # install patched vesa tables with additional widescreen modes.
 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
+%if %{with system_seabios}
+ln -sf /usr/share/seabios/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios-256k.bin
+# bios.bin provided by qemu is stripped to 128k, with no Xen support, keep it
+for f in $RPM_BUILD_ROOT%{_datadir}/%{name}/*.aml ; do
+       bn="$(basename $f)"
+       if [ -e "/usr/share/seabios/$bn" ] ; then
+               ln -sf "/usr/share/seabios/$bn" "$f"
+       fi
+done
+%endif
+
+%if %{with gtk2} || %{with gtk3}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
 %find_lang %{name}
+%else
+: > qemu.lang
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -785,16 +921,46 @@ fi
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
+
 # various bios images
-%{_datadir}/%{name}/*.aml
-%{_datadir}/%{name}/*.bin
-%{_datadir}/%{name}/*.rom
-%{_datadir}/%{name}/*.dtb
-%{_datadir}/%{name}/qemu_logo_no_text.svg
+# all should be probably moved to the right system subpackage
+%{_datadir}/%{name}/QEMU,cgthree.bin
+%{_datadir}/%{name}/QEMU,tcx.bin
+%{_datadir}/%{name}/bamboo.dtb
+%{_datadir}/%{name}/efi-e1000.rom
+%{_datadir}/%{name}/efi-eepro100.rom
+%{_datadir}/%{name}/efi-ne2k_pci.rom
+%{_datadir}/%{name}/efi-pcnet.rom
+%{_datadir}/%{name}/efi-rtl8139.rom
+%{_datadir}/%{name}/efi-virtio.rom
+%{_datadir}/%{name}/kvmvapic.bin
+%{_datadir}/%{name}/linuxboot.bin
+%{_datadir}/%{name}/multiboot.bin
 %{_datadir}/%{name}/openbios-ppc
 %{_datadir}/%{name}/openbios-sparc*
 %{_datadir}/%{name}/palcode-clipper
+%{_datadir}/%{name}/petalogix-ml605.dtb
+%{_datadir}/%{name}/petalogix-s3adsp1800.dtb
+%{_datadir}/%{name}/ppc_rom.bin
+%{_datadir}/%{name}/pxe-e1000.rom
+%{_datadir}/%{name}/pxe-eepro100.rom
+%{_datadir}/%{name}/pxe-ne2k_pci.rom
+%{_datadir}/%{name}/pxe-pcnet.rom
+%{_datadir}/%{name}/pxe-rtl8139.rom
+%{_datadir}/%{name}/pxe-virtio.rom
+%{_datadir}/%{name}/qemu_logo_no_text.svg
 %{_datadir}/%{name}/s390-ccw.img
+%{_datadir}/%{name}/s390-zipl.rom
+%{_datadir}/%{name}/sgabios.bin
+%{_datadir}/%{name}/slof.bin
+%{_datadir}/%{name}/spapr-rtas.bin
+%{_datadir}/%{name}/vgabios-cirrus.bin
+%{_datadir}/%{name}/vgabios-qxl.bin
+%{_datadir}/%{name}/vgabios-stdvga.bin
+%{_datadir}/%{name}/vgabios-vmware.bin
+%{_datadir}/%{name}/vgabios.bin
+
+%dir %{_libdir}/%{name}
 
 %files img
 %defattr(644,root,root,755)
@@ -804,6 +970,7 @@ fi
 %files user
 %defattr(644,root,root,755)
 /usr/lib/binfmt.d/qemu-*.conf
+%attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
 %attr(755,root,root) %{_bindir}/qemu-armeb
@@ -832,6 +999,10 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-unicore32
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 
+%files system-aarch64
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-aarch64
+
 %files system-alpha
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-alpha
@@ -905,6 +1076,10 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
 %attr(755,root,root) %{_bindir}/kvm_stat
 %endif
+%{_datadir}/%{name}/bios.bin
+%{_datadir}/%{name}/bios-256k.bin
+%{_datadir}/%{name}/acpi-dsdt.aml
+%{_datadir}/%{name}/q35-acpi-dsdt.aml
 
 %files system-xtensa
 %defattr(644,root,root,755)
@@ -916,3 +1091,29 @@ fi
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
 %{systemdunitdir}/qemu-guest-agent.service
 %attr(755,root,root) %{_bindir}/qemu-ga
+
+%files module-block-curl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-curl.so
+
+%if %{with glusterfs}
+%files module-block-gluster
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-gluster.so
+%endif
+
+%if %{with iscsi}
+%files module-block-iscsi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-iscsi.so
+%endif
+
+%if %{with ceph}
+%files module-block-rbd
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-rbd.so
+%endif
+
+%files module-block-ssh
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-ssh.so
This page took 0.654517 seconds and 4 git commands to generate.