]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
updated R: libusb version - libusb_set_option
[packages/qemu.git] / qemu.spec
index 2719297614381009ceba5db125a28f7d6c0f362e..c18cbb79bd7c03d60c042292e4ce8a51397346a0 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -5,8 +5,6 @@
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
-%bcond_with    xseg            # Archipelago backend [non-distributable: GPLv3+ vs GPLv2-only]
-%bcond_with    gtk2            # GTK+ 2.x instead of 3.x
 %bcond_without gtk3            # Do not build GTK+ UI
 %bcond_without vte             # VTE support in GTK+ UI
 %bcond_without spice           # SPICE support
 %bcond_without user_static     # build linux-user static packages
 %bcond_with    lttng           # lttng-ust trace backend support
 %bcond_with    systemtap       # SystemTap/dtrace trace backend support
-
-%if %{with gtk2}
-%undefine with_gtk3
-%endif
+%bcond_with    virgl           # build virgl support
+%bcond_without xkbcommon       # xkbcommon support
 
 %ifarch x32
 %undefine      with_xen
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       2.8.0
-Release:       4
-License:       GPL v2
+Version:       4.1.1
+Release:       1
+License:       GPL v2, BSD (edk2 firmware files)
 Group:         Applications/Emulators
-Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 17940dce063b6ce450a12e719a6c9c43
+Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.xz
+# Source0-md5: 53879f792ef2675c6c5e6cbf5cc1ac6c
 Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
@@ -58,13 +54,14 @@ Source9:    ksmtuned
 Source10:      ksmtuned.conf
 Source11:      %{name}-guest-agent.service
 Source12:      99-%{name}-guest-agent.rules
+Source13:      %{name}-guest-agent.init
+Source14:      %{name}-guest-agent.logrotate
 Patch0:                %{name}-cflags.patch
-Patch1:                vgabios-widescreens.patch
-Patch2:                %{name}-whitelist.patch
-Patch3:                %{name}-user-execve.patch
-Patch4:                %{name}-xattr.patch
-Patch5:                libjpeg-boolean.patch
-Patch6:                x32.patch
+Patch1:                %{name}-whitelist.patch
+Patch2:                %{name}-user-execve.patch
+Patch3:                %{name}-xattr.patch
+Patch4:                libjpeg-boolean.patch
+Patch5:                x32.patch
 URL:           http://www.qemu-project.org/
 %{?with_gl:BuildRequires:      OpenGL-GLX-devel}
 %{?with_gl:BuildRequires:      OpenGL-devel}
@@ -80,24 +77,24 @@ BuildRequires:      cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: glib2-devel >= 1:2.22
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
-BuildRequires: gnutls-devel > 2.10.0
+BuildRequires: gnutls-devel >= 3.1.18
 BuildRequires: libaio-devel
 %{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
 %{?with_gl:BuildRequires:      libepoxy-devel}
-BuildRequires: libfdt-devel
+BuildRequires: libfdt-devel >= 1.4.2
 %{?with_rdma:BuildRequires:    libibverbs-devel}
 %{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
+%{?with_rdma:BuildRequires:    libibumad-devel}
 BuildRequires: libjpeg-devel
 %{?with_libnfs:BuildRequires:  libnfs-devel >= 1.9.3}
 BuildRequires: libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
-%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.1.1}
+%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.3.0}
 BuildRequires: libssh2-devel >= 1.2.8
 BuildRequires: libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
-%{?with_xseg:BuildRequires:    libxseg-devel}
 %{?with_lttng:BuildRequires:   lttng-ust-devel}
 BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
@@ -123,16 +120,14 @@ BuildRequires:    texinfo
 %{?with_lttng:BuildRequires:   userspace-rcu-devel}
 BuildRequires: vde2-devel
 BuildRequires: which
+%{?with_virgl:BuildRequires:   virglrenderer-devel}
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
 BuildRequires: xfsprogs-devel
+%{?with_xkbcommon:BuildRequires:       xorg-lib-libxkbcommon-devel}
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: zlib-devel
-%if %{with gtk2}
-BuildRequires: gtk+2-devel >= 2:2.18.0
-%{?with_vte:BuildRequires:     vte0-devel >= 0.24.0}
-%endif
 %if %{with gtk3}
-BuildRequires: gtk+3-devel >= 3.0.0
+BuildRequires: gtk+3-devel >= 3.14.0
 %{?with_vte:BuildRequires:     vte2.90-devel >= 0.32.0}
 %endif
 %if %{with user_static}
@@ -141,18 +136,23 @@ BuildRequires:    glibc-static
 BuildRequires: pcre-static
 BuildRequires: zlib-static
 %endif
+BuildConflicts:        libslirp-devel
 Requires:      %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-aarch64 = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
 Requires:      %{name}-system-arm = %{version}-%{release}
 Requires:      %{name}-system-cris = %{version}-%{release}
+Requires:      %{name}-system-hppa = %{version}-%{release}
 Requires:      %{name}-system-lm32 = %{version}-%{release}
 Requires:      %{name}-system-m68k = %{version}-%{release}
 Requires:      %{name}-system-microblaze = %{version}-%{release}
 Requires:      %{name}-system-mips = %{version}-%{release}
 Requires:      %{name}-system-moxie = %{version}-%{release}
-Requires:      %{name}-system-or32 = %{version}-%{release}
+Requires:      %{name}-system-nios2 = %{version}-%{release}
+Requires:      %{name}-system-or1k = %{version}-%{release}
 Requires:      %{name}-system-ppc = %{version}-%{release}
+Requires:      %{name}-system-riscv32 = %{version}-%{release}
+Requires:      %{name}-system-riscv64 = %{version}-%{release}
 Requires:      %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
 Requires:      %{name}-system-sparc = %{version}-%{release}
@@ -168,20 +168,17 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %if %{with sdl} \
 Requires:      SDL2 \
 %endif \
+Requires:      libfdt >= 1.4.2 \
 %if %{with seccomp} \
-Requires:      libseccomp >= 2.1.0 \
+Requires:      libseccomp >= 2.3.0 \
 %endif \
-Requires:      libusb >= 1.0.13 \
+Requires:      libusb >= 1.0.22 \
 Requires:      pixman >= 0.21.8 \
 %if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
 %endif \
-%if %{with gtk2} \
-Requires:      gtk+2 >= 2:2.18.0 \
-%{?with_vte:Requires:  vte0 >= 0.24.0} \
-%endif \
 %if %{with gtk3} \
-Requires:      gtk+3 >= 3.0.0 \
+Requires:      gtk+3 >= 3.14.0 \
 %{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
@@ -382,6 +379,25 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem CRIS.
 
+%package system-hppa
+Summary:       QEMU system emulator for HP/PA
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem HP/PA
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-hppa
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with HP/PA CPU.
+
+%description system-hppa -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem HP/PA.
+
 %package system-lm32
 Summary:       QEMU system emulator for LM32
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem LM32
@@ -481,21 +497,41 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem Moxie.
 
-%package system-or32
+%package system-nios2
+Summary:       QEMU system emulator for Nios II
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Nios II
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-nios2
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with Nios II CPU.
+
+%description system-nios2 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem Nios II.
+
+%package system-or1k
 Summary:       QEMU system emulator for OpenRISC
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem OpenRISC
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
-Obsoletes:     qemu-kvm-system-or32
+Obsoletes:     qemu-kvm-system-or1k
+Obsoletes:     qemu-system-or32
 
-%description system-or32
+%description system-or1k
 QEMU is a generic and open source processor emulator which achieves a
 good emulation speed by using dynamic translation.
 
 This package provides the system emulator with OpenRISC CPU.
 
-%description system-or32 -l pl.UTF-8
+%description system-or1k -l pl.UTF-8
 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
@@ -521,6 +557,44 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
 
+%package system-riscv32
+Summary:       QEMU system emulator for RISC-V (32 bit)
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem RISC-V (32 bit)
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-riscv32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with RISC-V (32 bit) CPU.
+
+%description system-riscv32 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem RISC-V (32 bit).
+
+%package system-riscv64
+Summary:       QEMU system emulator for RISC-V (64 bit)
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem RISC-V (64 bit)
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-riscv64
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with RISC-V (64 bit) CPU.
+
+%description system-riscv64 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem RISC-V (64 bit).
+
 %package system-s390x
 Summary:       QEMU system emulator for S390
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem S390
@@ -634,10 +708,14 @@ Obsoletes:        qemu-kvm-system-x86
 QEMU is a generic and open source processor emulator which achieves a
 good emulation speed by using dynamic translation.
 
+This package provides the system emulator with x86 CPU.
+
 %description system-x86 -l pl.UTF-8
 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
+Ten pakiet zawiera emulator systemu z procesorem x86.
+
 %package system-xtensa
 Summary:       QEMU system emulator for Xtensa
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Xtensa
@@ -687,18 +765,6 @@ systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
 
 Ten pakiet nie musi być zainstalowany w systemie hosta.
 
-%package module-block-archipelago
-Summary:       QEMU module for Archipelago block devices
-Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych Archipelago
-Group:         Development/Tools
-Requires:      %{name}-common = %{version}-%{release}
-
-%description module-block-archipelago
-Archipelago block device support for QEMU.
-
-%description module-block-archipelago -l pl.UTF-8
-Moduł QEMU dla urządeń blokowych Archipelago.
-
 %package module-block-curl
 Summary:       QEMU module for 'curl' block devices
 Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'curl'
@@ -764,12 +830,11 @@ Moduł QEMU dla urządeń blokowych typu 'ssh'.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
-%patch2 -p0
+%patch1 -p0
+%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
@@ -807,7 +872,6 @@ build() {
 build dynamic \
        --extra-cflags="%{rpmcflags} %{rpmcppflags} -fPIE -DPIE" \
        --extra-ldflags="%{rpmldflags} -pie -Wl,-z,relro -Wl,-z,now" \
-       %{__enable_disable xseg archipelago} \
        --enable-attr \
        %{__enable_disable bluetooth bluez} \
        %{__enable_disable brlapi} \
@@ -821,19 +885,18 @@ build dynamic \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
-       --with-sdlabi=2.0 \
        %{__enable_disable seccomp} \
        %{__enable_disable spice} \
        %{__enable_disable smartcard smartcard} \
        --enable-tpm \
        %{__enable_disable usbredir usb-redir} \
-       --enable-uuid \
        --enable-vde \
        --enable-virtfs \
        --enable-vnc-jpeg \
        --enable-vnc-png \
        --enable-vnc-sasl \
        %{!?with_vte:--disable-vte} \
+       %{__enable_disable virgl virglrenderer} \
        %{__enable_disable xen} \
        --enable-modules \
        --disable-netmap \
@@ -841,10 +904,8 @@ build dynamic \
        --enable-lzo \
        %{__enable_disable snappy} \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
-%if %{without gtk2} && %{without gtk3}
+%if %{without gtk3}
        --disable-gtk
-%else
-       --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
 %endif
 
 %if %{with user_static}
@@ -865,22 +926,18 @@ build static \
        --disable-spice \
        --disable-tcmalloc \
        --disable-tools \
-       --disable-uuid \
        --enable-user \
        --disable-system \
        --static
 
 %endif
 
-# rebuild patched vesa tables with additional widescreen modes.
-%{__make} -C roms/vgabios stdvga-bios
-
 %{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
-       $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d} \
+       $RPM_BUILD_ROOT/etc/{qemu,sysconfig,udev/rules.d,modules-load.d,rc.d/init.d,logrotate.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
 %if %{with user_static}
@@ -927,6 +984,9 @@ install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
 install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 
+install -p %{SOURCE13} $RPM_BUILD_ROOT/etc/rc.d/init.d/qemu-ga
+install -p %{SOURCE14} $RPM_BUILD_ROOT/etc/logrotate.d/qemu-ga
+
 # Install binfmt
 for i in dummy \
 %ifnarch %{ix86} %{x8664} x32
@@ -981,10 +1041,6 @@ done < %{SOURCE2}
 
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-doc.html
-%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
-
-# install patched vesa tables with additional widescreen modes.
-cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
 %if %{with system_seabios}
 ln -sf /usr/share/seabios/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios-256k.bin
@@ -997,7 +1053,7 @@ for f in $RPM_BUILD_ROOT%{_datadir}/%{name}/*.aml ; do
 done
 %endif
 
-%if %{with gtk2} || %{with gtk3}
+%if %{with gtk3}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
 %{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
 %find_lang %{name}
@@ -1005,6 +1061,8 @@ done
 : > qemu.lang
 %endif
 
+%{__rm} -r $RPM_BUILD_ROOT%{_docdir}/qemu
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -1046,9 +1104,15 @@ fi
 %systemd_service_restart systemd-binfmt.service
 
 %post guest-agent
+/sbin/chkconfig --add qemu-ga
+%service qemu-ga restart "qemu-ga"
 %systemd_reload
 
 %preun guest-agent
+if [ "$1" = "0" ]; then
+       %service qemu-ga stop
+       /sbin/chkconfig --del qemu-ga
+fi
 %systemd_preun qemu-guest-agent.service
 
 %postun guest-agent
@@ -1069,21 +1133,27 @@ fi
 %attr(640,root,qemu) %config(noreplace) %verify(not md5 mtime size) /etc/qemu/bridge.conf
 %{systemdunitdir}/ksm.service
 %{systemdunitdir}/ksmtuned.service
+%attr(755,root,root) %{_bindir}/elf2dmp
 %attr(755,root,root) %{_bindir}/ivshmem-client
 %attr(755,root,root) %{_bindir}/ivshmem-server
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
+%attr(755,root,root) %{_bindir}/qemu-edid
+%{?with_xkbcommon:%attr(755,root,root) %{_bindir}/qemu-keymap}
 %attr(755,root,root) %{_bindir}/qemu-nbd
+%attr(755,root,root) %{_bindir}/qemu-pr-helper
 %attr(755,root,root) %{_bindir}/qemu-tilegx
-%attr(755,root,root) %{_libdir}/qemu-bridge-helper
+%attr(755,root,root) %{_libexecdir}/qemu-bridge-helper
 %attr(755,root,root) %{_sbindir}/ksmctl
 %attr(755,root,root) %{_sbindir}/ksmtuned
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/virtfs-proxy-helper.1*
+%{_mandir}/man7/qemu-cpu-models.7*
+%{_mandir}/man7/qemu-block-drivers.7*
 %{_mandir}/man8/qemu-nbd.8*
 
 %dir %{_datadir}/qemu
+%dir %{_datadir}/%{name}/firmware
 %{_datadir}/%{name}/keymaps
-%{_datadir}/%{name}/qemu-icon.bmp
 %{_datadir}/%{name}/trace-events-all
 
 # various bios images
@@ -1107,6 +1177,7 @@ fi
 %{_datadir}/%{name}/petalogix-ml605.dtb
 %{_datadir}/%{name}/petalogix-s3adsp1800.dtb
 %{_datadir}/%{name}/ppc_rom.bin
+%{_datadir}/%{name}/pvh.bin
 %{_datadir}/%{name}/pxe-e1000.rom
 %{_datadir}/%{name}/pxe-eepro100.rom
 %{_datadir}/%{name}/pxe-ne2k_pci.rom
@@ -1114,7 +1185,6 @@ fi
 %{_datadir}/%{name}/pxe-rtl8139.rom
 %{_datadir}/%{name}/pxe-virtio.rom
 %{_datadir}/%{name}/QEMU,cgthree.bin
-%{_datadir}/%{name}/qemu_logo_no_text.svg
 %{_datadir}/%{name}/QEMU,tcx.bin
 %{_datadir}/%{name}/s390-ccw.img
 %{_datadir}/%{name}/sgabios.bin
@@ -1122,8 +1192,11 @@ fi
 %{_datadir}/%{name}/slof.bin
 %{_datadir}/%{name}/spapr-rtas.bin
 %{_datadir}/%{name}/vgabios.bin
+%{_datadir}/%{name}/vgabios-ati.bin
+%{_datadir}/%{name}/vgabios-bochs-display.bin
 %{_datadir}/%{name}/vgabios-cirrus.bin
 %{_datadir}/%{name}/vgabios-qxl.bin
+%{_datadir}/%{name}/vgabios-ramfb.bin
 %{_datadir}/%{name}/vgabios-stdvga.bin
 %{_datadir}/%{name}/vgabios-virtio.bin
 %{_datadir}/%{name}/vgabios-vmware.bin
@@ -1132,7 +1205,16 @@ fi
 
 # modules without too many external dependencies
 %attr(755,root,root) %{_libdir}/%{name}/block-dmg-bz2.so
-%attr(755,root,root) %{_libdir}/%{name}/block-nfs.so
+%{?with_libnfs:%attr(755,root,root) %{_libdir}/%{name}/block-nfs.so}
+
+%attr(755,root,root) %{_libdir}/%{name}/audio-alsa.so
+%{?with_pulseaudio:%attr(755,root,root) %{_libdir}/%{name}/audio-pa.so}
+%{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/audio-sdl.so}
+%attr(755,root,root) %{_libdir}/%{name}/ui-curses.so
+%if %{with gtk3}
+%attr(755,root,root) %{_libdir}/%{name}/ui-gtk.so
+%endif
+%{?with_sdl:%attr(755,root,root) %{_libdir}/%{name}/ui-sdl.so}
 
 %files img
 %defattr(644,root,root,755)
@@ -1143,10 +1225,12 @@ fi
 %defattr(644,root,root,755)
 /usr/lib/binfmt.d/qemu-*-dynamic.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64
+%attr(755,root,root) %{_bindir}/qemu-aarch64_be
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
 %attr(755,root,root) %{_bindir}/qemu-armeb
 %attr(755,root,root) %{_bindir}/qemu-cris
+%attr(755,root,root) %{_bindir}/qemu-hppa
 %attr(755,root,root) %{_bindir}/qemu-i386
 %attr(755,root,root) %{_bindir}/qemu-io
 %attr(755,root,root) %{_bindir}/qemu-m68k
@@ -1158,11 +1242,14 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-mips64el
 %attr(755,root,root) %{_bindir}/qemu-mipsn32
 %attr(755,root,root) %{_bindir}/qemu-mipsn32el
-%attr(755,root,root) %{_bindir}/qemu-or32
+%attr(755,root,root) %{_bindir}/qemu-nios2
+%attr(755,root,root) %{_bindir}/qemu-or1k
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
 %attr(755,root,root) %{_bindir}/qemu-ppc64le
+%attr(755,root,root) %{_bindir}/qemu-riscv32
+%attr(755,root,root) %{_bindir}/qemu-riscv64
 %attr(755,root,root) %{_bindir}/qemu-s390x
 %attr(755,root,root) %{_bindir}/qemu-sh4
 %attr(755,root,root) %{_bindir}/qemu-sh4eb
@@ -1170,16 +1257,20 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
 %attr(755,root,root) %{_bindir}/qemu-sparc64
 %attr(755,root,root) %{_bindir}/qemu-x86_64
+%attr(755,root,root) %{_bindir}/qemu-xtensa
+%attr(755,root,root) %{_bindir}/qemu-xtensaeb
 
 %if %{with user_static}
 %files user-static
 %defattr(644,root,root,755)
 /usr/lib/binfmt.d/qemu-*-static.conf
 %attr(755,root,root) %{_bindir}/qemu-aarch64-static
+%attr(755,root,root) %{_bindir}/qemu-aarch64_be-static
 %attr(755,root,root) %{_bindir}/qemu-alpha-static
 %attr(755,root,root) %{_bindir}/qemu-arm-static
 %attr(755,root,root) %{_bindir}/qemu-armeb-static
 %attr(755,root,root) %{_bindir}/qemu-cris-static
+%attr(755,root,root) %{_bindir}/qemu-hppa-static
 %attr(755,root,root) %{_bindir}/qemu-i386-static
 %attr(755,root,root) %{_bindir}/qemu-m68k-static
 %attr(755,root,root) %{_bindir}/qemu-microblaze-static
@@ -1190,11 +1281,14 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-mipsel-static
 %attr(755,root,root) %{_bindir}/qemu-mipsn32-static
 %attr(755,root,root) %{_bindir}/qemu-mipsn32el-static
-%attr(755,root,root) %{_bindir}/qemu-or32-static
+%attr(755,root,root) %{_bindir}/qemu-nios2-static
+%attr(755,root,root) %{_bindir}/qemu-or1k-static
 %attr(755,root,root) %{_bindir}/qemu-ppc-static
 %attr(755,root,root) %{_bindir}/qemu-ppc64-static
 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32-static
 %attr(755,root,root) %{_bindir}/qemu-ppc64le-static
+%attr(755,root,root) %{_bindir}/qemu-riscv32-static
+%attr(755,root,root) %{_bindir}/qemu-riscv64-static
 %attr(755,root,root) %{_bindir}/qemu-s390x-static
 %attr(755,root,root) %{_bindir}/qemu-sh4-static
 %attr(755,root,root) %{_bindir}/qemu-sh4eb-static
@@ -1203,11 +1297,15 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-sparc64-static
 %attr(755,root,root) %{_bindir}/qemu-tilegx-static
 %attr(755,root,root) %{_bindir}/qemu-x86_64-static
+%attr(755,root,root) %{_bindir}/qemu-xtensa-static
+%attr(755,root,root) %{_bindir}/qemu-xtensaeb-static
 %endif
 
 %files system-aarch64
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-aarch64
+%{_datadir}/%{name}/edk2-aarch64-code.fd
+%{_datadir}/%{name}/firmware/60-edk2-aarch64.json
 
 %files system-alpha
 %defattr(644,root,root,755)
@@ -1216,11 +1314,19 @@ fi
 %files system-arm
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-arm
+%{_datadir}/%{name}/edk2-arm-code.fd
+%{_datadir}/%{name}/edk2-arm-vars.fd
+%{_datadir}/%{name}/firmware/60-edk2-arm.json
 
 %files system-cris
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-cris
 
+%files system-hppa
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-hppa
+%{_datadir}/%{name}/hppa-firmware.img
+
 %files system-lm32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-lm32
@@ -1245,21 +1351,38 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-moxie
 
-%files system-or32
+%files system-nios2
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-nios2
+
+%files system-or1k
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/qemu-system-or32
+%attr(755,root,root) %{_bindir}/qemu-system-or1k
 
 %files system-ppc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-ppc
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
-#%attr(755,root,root) %{_bindir}/qemu-system-ppc64le
-%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
+%{_datadir}/%{name}/canyonlands.dtb
+%{_datadir}/%{name}/qemu_vga.ndrv
 %{_datadir}/%{name}/u-boot.e500
+%{_datadir}/%{name}/u-boot-sam460-20100605.bin
+
+%files system-riscv32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-riscv32
+%{_datadir}/%{name}/opensbi-riscv32-virt-fw_jump.bin
+
+%files system-riscv64
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-riscv64
+%{_datadir}/%{name}/opensbi-riscv64-sifive_u-fw_jump.bin
+%{_datadir}/%{name}/opensbi-riscv64-virt-fw_jump.bin
 
 %files system-s390x
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-s390x
+%{_datadir}/%{name}/s390-netboot.img
 
 %files system-sh4
 %defattr(644,root,root,755)
@@ -1289,7 +1412,15 @@ fi
 %endif
 %{_datadir}/%{name}/bios.bin
 %{_datadir}/%{name}/bios-256k.bin
-%{_datadir}/%{name}/acpi-dsdt.aml
+%{_datadir}/%{name}/edk2-i386-code.fd
+%{_datadir}/%{name}/edk2-i386-secure-code.fd
+%{_datadir}/%{name}/edk2-i386-vars.fd
+%{_datadir}/%{name}/edk2-x86_64-code.fd
+%{_datadir}/%{name}/edk2-x86_64-secure-code.fd
+%{_datadir}/%{name}/firmware/50-edk2-i386-secure.json
+%{_datadir}/%{name}/firmware/50-edk2-x86_64-secure.json
+%{_datadir}/%{name}/firmware/60-edk2-i386.json
+%{_datadir}/%{name}/firmware/60-edk2-x86_64.json
 
 %files system-xtensa
 %defattr(644,root,root,755)
@@ -1300,15 +1431,12 @@ fi
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
 %{systemdunitdir}/qemu-guest-agent.service
+%attr(754,root,root) /etc/rc.d/init.d/qemu-ga
+%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/qemu-ga
 %attr(755,root,root) %{_bindir}/qemu-ga
+%{_mandir}/man7/qemu-ga-ref.7*
 %{_mandir}/man8/qemu-ga.8*
 
-%if %{with xseg}
-%files module-block-archipelago
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/%{name}/block-archipelago.so
-%endif
-
 %files module-block-curl
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/%{name}/block-curl.so
This page took 0.066142 seconds and 4 git commands to generate.