]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
Use seabios binary from the seabios package
[packages/qemu.git] / qemu.spec
index 8b09c4f09b84919fea104e60d75b6d9a124dc037..924f3e00a6ccdf411822aee093fe8ce24e47aa48 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,11 +1,3 @@
-# TODO:
-# - merge missing bits from qemu-kvm
-# - qemu-system-ppc -hda ac-ppc.img says:
-#   qemu: could not open disk image ac-ppc.img: error "Success"
-#   qemu-0.12.2-2.x86_64.rpm - broken
-#   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
-#   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
-#   qemu-0.11.1-*.x86_64.rpm - OK
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
+%bcond_without gtk3            # Do not build GTK UI
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
 %bcond_without oss             # OSS audio support
 %bcond_without pulseaudio      # PulseAudio audio support
 %bcond_without xen             # Xen backend driver support
+%bcond_without bluetooth       # bluetooth support
+%bcond_without brlapi          # brlapi support
+%bcond_without smartcard       # smartcard-nss support
+%bcond_without iscsi           # iscsi support
+%bcond_without seccomp         # seccomp support
+%bcond_without usbredir        # usb network redirection support
+%bcond_without system_seabios  # system seabios binary
+
+%if %{with gtk2}
+%undefine with_gtk3
+%endif
 
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.6.1
+Version:       1.7.1
 Release:       2
 License:       GPL v2+
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 3a897d722457c5a895cd6ac79a28fda0
+# Source0-md5: 9541063d999cf9659ed7fdce71314f31
+Source2:       %{name}.binfmt
+# Loads kvm kernel modules at boot
+Source3:       kvm-modules-load.conf
+# Creates /dev/kvm
+Source4:       80-kvm.rules
+# KSM control scripts
+Source5:       ksm.service
+Source6:       ksm.sysconfig
+Source7:       ksmctl.c
+Source8:       ksmtuned.service
+Source9:       ksmtuned
+Source10:      ksmtuned.conf
+Source11:      %{name}-guest-agent.service
+Source12:      99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
 Patch3:                %{name}-system-libcacard.patch
+Patch4:                vmdk3ro.patch
+Patch5:                %{name}-xattr.patch
+Patch6:                libjpeg-boolean.patch
 # Proof of concept, for reference, do not remove
-Patch4:                %{name}-kde_virtual_workspaces_hack.patch
+Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
 BuildRequires: alsa-lib-devel
-BuildRequires:  bcc
-BuildRequires: bluez-libs-devel
-BuildRequires: brlapi-devel
+BuildRequires: bcc
+%{?with_bluetooth:BuildRequires:       bluez-libs-devel}
+%{?with_brlapi:BuildRequires:  brlapi-devel}
 %{?with_ceph:BuildRequires:    ceph-devel}
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
@@ -50,27 +71,28 @@ BuildRequires:      glib2-devel >= 1:2.12
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
 BuildRequires: gnutls-devel
 BuildRequires: libaio-devel
-BuildRequires: libcacard-devel
+%{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
 BuildRequires: libfdt-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
-BuildRequires: libiscsi-devel
+%{?with_iscsi:BuildRequires:   libiscsi-devel}
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
-BuildRequires: libseccomp-devel
+%{?with_seccomp:BuildRequires: libseccomp-devel}
 BuildRequires: libssh2-devel >= 1.2.8
 # for usb passthrough, when available
 #BuildRequires:        libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
 BuildRequires: ncurses-devel
-BuildRequires: nss-devel >= 3.12.8
+%{?with_smartcard:BuildRequires:       nss-devel >= 3.12.8}
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
-BuildRequires: rpmbuild(macros) >= 1.202
+BuildRequires: rpmbuild(macros) >= 1.644
+%{?with_system_seabios:BuildRequires:  seabios}
 BuildRequires: sed >= 4.0
 %if %{with spice}
 BuildRequires: spice-protocol >= 0.12.0
@@ -78,7 +100,7 @@ BuildRequires:       spice-server-devel >= 0.12.0
 %endif
 BuildRequires: texi2html
 BuildRequires: texinfo
-BuildRequires: usbredir-devel >= 0.6
+%{?with_usbredir:BuildRequires:        usbredir-devel >= 0.6}
 BuildRequires: vde2-devel
 BuildRequires: which
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
@@ -88,7 +110,8 @@ BuildRequires:       zlib-devel
 %if %{with gtk2}
 BuildRequires: gtk+2-devel >= 2:2.18.0
 BuildRequires: vte0-devel >= 0.24.0
-%else
+%endif
+%if %{with gtk3}
 BuildRequires: gtk+3-devel >= 3.0.0
 BuildRequires: vte-devel >= 0.32.0
 %endif
@@ -110,15 +133,21 @@ Requires: %{name}-system-unicore32 = %{version}-%{release}
 Requires:      %{name}-system-x86 = %{version}-%{release}
 Requires:      %{name}-system-xtensa = %{version}-%{release}
 Requires:      %{name}-user = %{version}-%{release}
+Obsoletes:     qemu-kvm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        systempkg_req \
+%if %{with sdl} \
 Requires:      SDL >= 1.2.1 \
+%endif \
+%if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
+%endif \
 %if %{with gtk2} \
 Requires:      gtk+2 >= 2:2.18.0 \
 Requires:      vte0 >= 0.24.0 \
-%else \
+%endif \
+%if %{with gtk3} \
 Requires:      gtk+3 >= 3.0.0 \
 Requires:      vte >= 0.32.0 \
 %endif
@@ -161,6 +190,7 @@ aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 Summary:       QEMU common files needed by all QEMU targets
 Summary(pl.UTF-8):     Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
 Group:         Development/Tools
+Requires(post,preun,postun):   systemd-units >= 38
 Requires(postun):      /usr/sbin/groupdel
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
@@ -169,8 +199,10 @@ Requires(pre):     /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
 Requires:      glib2 >= 1:2.12
 Requires:      libssh2 >= 1.2.8
+Requires:      systemd-units >= 38
 Provides:      group(qemu)
 Provides:      user(qemu)
+Obsoletes:     qemu-kvm-common
 Conflicts:     qemu < 1.0-2
 
 %description common
@@ -190,6 +222,7 @@ Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
 Summary:       QEMU command line tool for manipulating disk images
 Summary(pl.UTF-8):     Narzędzie QEMU do operacji na obrazach dysków
 Group:         Development/Tools
+Obsoletes:     qemu-kvm-img
 Conflicts:     qemu < 1.0-2
 
 %description img
@@ -205,6 +238,9 @@ Summary:    QEMU user mode emulation of qemu targets
 Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
+Requires(post,postun): systemd-units >= 38
+Requires:      systemd-units >= 38
+Obsoletes:     qemu-kvm-user
 
 %description user
 QEMU is a generic and open source processor emulator which achieves a
@@ -224,6 +260,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem Alpha
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-alpha
 
 %description system-alpha
 QEMU is a generic and open source processor emulator which achieves a
@@ -243,6 +280,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem ARM
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-arm
 
 %description system-arm
 QEMU is a generic and open source processor emulator which achieves a
@@ -262,6 +300,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem CRIS
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-cris
 
 %description system-cris
 QEMU is a generic and open source processor emulator which achieves a
@@ -281,6 +320,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem LM32
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-lm32
 
 %description system-lm32
 QEMU is a generic and open source processor emulator which achieves a
@@ -300,6 +340,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem m68k
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-m68k
 
 %description system-m68k
 QEMU is a generic and open source processor emulator which achieves a
@@ -319,6 +360,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem MicroBlaze
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-microblaze
 
 %description system-microblaze
 QEMU is a generic and open source processor emulator which achieves a
@@ -338,6 +380,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem MIPS
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-mips
 
 %description system-mips
 QEMU is a generic and open source processor emulator which achieves a
@@ -376,6 +419,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem OpenRISC
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-or32
 
 %description system-or32
 QEMU is a generic and open source processor emulator which achieves a
@@ -395,6 +439,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem PowerPC
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-ppc
 
 %description system-ppc
 QEMU is a generic and open source processor emulator which achieves a
@@ -414,6 +459,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem S390
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-s390x
 
 %description system-s390x
 QEMU is a generic and open source processor emulator which achieves a
@@ -433,6 +479,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem SH4
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-sh4
 
 %description system-sh4
 QEMU is a generic and open source processor emulator which achieves a
@@ -452,6 +499,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem SPARC
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-sparc
 
 %description system-sparc
 QEMU is a generic and open source processor emulator which achieves a
@@ -471,6 +519,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem UniCore32
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-unicore32
 
 %description system-unicore32
 QEMU is a generic and open source processor emulator which achieves a
@@ -489,7 +538,10 @@ Summary:   QEMU system emulator for x86
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem x86
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
+%{?with_system_seabios:Requires:       seabios}
 %systempkg_req
+Obsoletes:     kvm
+Obsoletes:     qemu-kvm-system-x86
 
 %description system-x86
 QEMU is a generic and open source processor emulator which achieves a
@@ -505,6 +557,7 @@ Summary(pl.UTF-8):  QEMU - emulator systemu z procesorem Xtensa
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
 %systempkg_req
+Obsoletes:     qemu-kvm-system-xtensa
 
 %description system-xtensa
 QEMU is a generic and open source processor emulator which achieves a
@@ -518,12 +571,44 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
 
+%package guest-agent
+Summary:       QEMU guest agent
+Summary(pl.UTF-8):     Agent gościa QEMU
+Group:         Daemons
+Requires(post,preun,postun):   systemd-units >= 38
+Requires:      glib2 >= 1:2.12
+Requires:      systemd-units >= 38
+Obsoletes:     qemu-kvm-guest-agent
+
+%description guest-agent
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides an agent to run inside guests, which
+communicates with the host over a virtio-serial channel named
+"org.qemu.guest_agent.0".
+
+This package does not need to be installed on the host OS.
+
+%description guest-agent -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet udostępnia agenta przeznaczonego do uruchomienia w
+systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
+"org.qemu.guest_agent.0".
+
+Ten pakiet nie musi być zainstalowany w systemie hosta.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
 
 %{__mv} libcacard libcacard-use-system-lib
 
@@ -540,25 +625,24 @@ ln -s ../error.h qapi/error.h
        --host-cc="%{__cc}" \
        --disable-strip \
        --enable-attr \
-       --enable-bluez \
-       --enable-brlapi \
+       %{__enable_disable bluetooth bluez} \
+       %{__enable_disable brlapi} \
        --enable-cap-ng \
        --enable-curl \
        --enable-curses \
        --enable-docs \
        --enable-fdt \
        %{__enable_disable glusterfs} \
-       --enable-libiscsi \
-       --enable-mixemu \
+       %{__enable_disable iscsi libiscsi} \
        %{__enable_disable glx} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
-       --enable-seccomp \
+       %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       --enable-smartcard-nss \
+       %{__enable_disable smartcard smartcard-nss} \
        --enable-tpm \
-       --enable-usb-redir \
+       %{__enable_disable usbredir usb-redir} \
        --enable-uuid \
        --enable-vde \
        --enable-virtfs \
@@ -566,24 +650,36 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-png \
        --enable-vnc-sasl \
        --enable-vnc-tls \
+       --enable-kvm \
        %{__enable_disable xen} \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
        --interp-prefix=%{_libdir}/qemu/lib-%%M \
+%if %{without gtk2} && %{without gtk3}
+       --disable-gtk
+%else
        --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
+%endif
 
 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
 # --libexecdir in configure is nop
 %{__make} \
        V=1 \
-       CONFIG_QEMU_HELPERDIR="%{_libdir}"
+       CONFIG_QEMU_HELPERDIR="%{_libdir}" \
+       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n}
 
 # rebuild patched vesa tables with additional widescreen modes.
 %{__make} -C roms/vgabios stdvga-bios
 
+%{__cc} %{SOURCE7} %{rpmcflags} -o ksmctl
+
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
+       $RPM_BUILD_ROOT/etc/{sysconfig,udev/rules.d,modules-load.d} \
+       $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
 %{__make} install \
+       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
        DESTDIR=$RPM_BUILD_ROOT \
        libexecdir=%{_libdir}
 
@@ -593,42 +689,135 @@ cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 
 EOF
 
-# already packaged
+install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
+
+%ifarch %{ix86} %{x8664}
+install -p scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
+install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
+install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
+%endif
+
+install -p %{SOURCE5} $RPM_BUILD_ROOT%{systemdunitdir}/ksm.service
+install -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/ksm
+install -p ksmctl $RPM_BUILD_ROOT%{_sbindir}
+
+install -p %{SOURCE8} $RPM_BUILD_ROOT%{systemdunitdir}/ksmtuned.service
+install -p %{SOURCE9} $RPM_BUILD_ROOT%{_sbindir}/ksmtuned
+install -p %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/ksmtuned.conf
+
+# For the qemu-guest-agent subpackage install the systemd
+# service and udev rules.
+install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
+install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
+
+for i in dummy \
+%ifnarch %{ix86} %{x8664}
+       qemu-i386 \
+%endif
+%ifnarch arm
+       qemu-arm \
+%endif
+%ifnarch ppc ppc64
+       qemu-ppc \
+%endif
+%ifnarch sparc sparc64
+       qemu-sparc \
+%endif
+%ifnarch sh4
+       qemu-sh4 \
+%endif
+; do
+       test $i = dummy && continue
+       grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
+done < %{SOURCE2}
+
+# packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
 
 # install patched vesa tables with additional widescreen modes.
 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
-%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
-%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
+%if %{with system_seabios}
+ln -sf /usr/share/seabios/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios.bin
+for f in $RPM_BUILD_ROOT%{_datadir}/%{name}/*.aml ; do
+       bn="$(basename $f)"
+       if [ -e "/usr/share/seabios/$bn" ] ; then
+               ln -sf "/usr/share/seabios/$bn" "$f"
+       fi
+done
+%endif
+
+%if %{with gtk2} || %{with gtk3}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
 %find_lang %{name}
+%else
+: > qemu.lang
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre common
+%groupadd -g 160 kvm
 %groupadd -g 276 qemu
-%useradd -u 276 -g qemu -c "QEMU User" qemu
+%useradd -u 276 -g qemu -G kvm -c "QEMU User" qemu
+
+%post common
+%systemd_post ksm.service
+%systemd_post ksmtuned.service
+
+%preun common
+%systemd_preun ksm.service
+%systemd_preun ksmtuned.service
 
 %postun common
 if [ "$1" = "0" ]; then
        %userremove qemu
        %groupremove qemu
+       %groupremove kvm
 fi
+%systemd_reload
+
+%triggerpostun common -- qemu-common < 1.6.1-4
+%systemd_trigger ksm.service
+%systemd_trigger ksmtuned.service
+
+%post user
+%systemd_service_restart systemd-binfmt.service
+
+%postun user
+%systemd_service_restart systemd-binfmt.service
+
+%post guest-agent
+%systemd_reload
+
+%preun guest-agent
+%systemd_preun qemu-guest-agent.service
+
+%postun guest-agent
+%systemd_reload
 
 %files
 %defattr(644,root,root,755)
 
 %files common -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
+%doc README qemu-doc.html qemu-tech.html qmp-commands.txt
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
+%{systemdunitdir}/ksm.service
+%{systemdunitdir}/ksmtuned.service
 %dir %{_sysconfdir}/qemu
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
+%attr(755,root,root) %{_sbindir}/ksmctl
+%attr(755,root,root) %{_sbindir}/ksmtuned
 %{_mandir}/man1/qemu.1*
 %{_mandir}/man1/virtfs-proxy-helper.1*
 %{_mandir}/man8/qemu-nbd.8*
@@ -636,16 +825,43 @@ fi
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
+
 # various bios images
-%{_datadir}/%{name}/*.aml
-%{_datadir}/%{name}/*.bin
-%{_datadir}/%{name}/*.rom
-%{_datadir}/%{name}/*.dtb
-%{_datadir}/%{name}/qemu_logo_no_text.svg
+# all should be probably moved to the right system subpackage
+%{_datadir}/%{name}/QEMU,tcx.bin
+%{_datadir}/%{name}/bamboo.dtb
+%{_datadir}/%{name}/efi-e1000.rom
+%{_datadir}/%{name}/efi-eepro100.rom
+%{_datadir}/%{name}/efi-ne2k_pci.rom
+%{_datadir}/%{name}/efi-pcnet.rom
+%{_datadir}/%{name}/efi-rtl8139.rom
+%{_datadir}/%{name}/efi-virtio.rom
+%{_datadir}/%{name}/kvmvapic.bin
+%{_datadir}/%{name}/linuxboot.bin
+%{_datadir}/%{name}/multiboot.bin
 %{_datadir}/%{name}/openbios-ppc
 %{_datadir}/%{name}/openbios-sparc*
 %{_datadir}/%{name}/palcode-clipper
+%{_datadir}/%{name}/petalogix-ml605.dtb
+%{_datadir}/%{name}/petalogix-s3adsp1800.dtb
+%{_datadir}/%{name}/ppc_rom.bin
+%{_datadir}/%{name}/pxe-e1000.rom
+%{_datadir}/%{name}/pxe-eepro100.rom
+%{_datadir}/%{name}/pxe-ne2k_pci.rom
+%{_datadir}/%{name}/pxe-pcnet.rom
+%{_datadir}/%{name}/pxe-rtl8139.rom
+%{_datadir}/%{name}/pxe-virtio.rom
+%{_datadir}/%{name}/qemu_logo_no_text.svg
 %{_datadir}/%{name}/s390-ccw.img
+%{_datadir}/%{name}/s390-zipl.rom
+%{_datadir}/%{name}/sgabios.bin
+%{_datadir}/%{name}/slof.bin
+%{_datadir}/%{name}/spapr-rtas.bin
+%{_datadir}/%{name}/vgabios-cirrus.bin
+%{_datadir}/%{name}/vgabios-qxl.bin
+%{_datadir}/%{name}/vgabios-stdvga.bin
+%{_datadir}/%{name}/vgabios-vmware.bin
+%{_datadir}/%{name}/vgabios.bin
 
 %files img
 %defattr(644,root,root,755)
@@ -654,11 +870,11 @@ fi
 
 %files user
 %defattr(644,root,root,755)
+/usr/lib/binfmt.d/qemu-*.conf
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
 %attr(755,root,root) %{_bindir}/qemu-armeb
 %attr(755,root,root) %{_bindir}/qemu-cris
-%attr(755,root,root) %{_bindir}/qemu-ga
 %attr(755,root,root) %{_bindir}/qemu-i386
 %attr(755,root,root) %{_bindir}/qemu-io
 %attr(755,root,root) %{_bindir}/qemu-m68k
@@ -751,8 +967,22 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-i386
 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
+%ifarch %{ix86} %{x8664}
+%config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
+%attr(755,root,root) %{_bindir}/kvm_stat
+%endif
+%{_datadir}/%{name}/bios.bin
+%{_datadir}/%{name}/acpi-dsdt.aml
+%{_datadir}/%{name}/q35-acpi-dsdt.aml
 
 %files system-xtensa
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
+
+%files guest-agent
+%defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
+%{systemdunitdir}/qemu-guest-agent.service
+%attr(755,root,root) %{_bindir}/qemu-ga
This page took 0.064968 seconds and 4 git commands to generate.