]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
Merge branch 'master' of git://git.pld-linux.org/packages/qemu
[packages/qemu.git] / qemu.spec
index bf122c26536bdf4a538ee7a6d2b62a740615d783..63781bfa52bb30315ab50a6a0422245ef88cf1f2 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -8,30 +8,22 @@
 #   qemu-0.11.1-*.x86_64.rpm - OK
 #
 # Conditional build:
-%bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
-%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.0
-Release:       5
+Version:       1.2.0
+Release:       4
 License:       GPL
 Group:         Applications/Emulators
-Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.gz
-# Source0-md5: a64b36067a191451323b0d34ebb44954
-Patch0:                %{name}-ncurses.patch
+Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
+Patch0:                %{name}-cflags.patch
+Patch1:                vgabios-widescreens.patch
 Patch6:                %{name}-nosdlgui.patch
 # Proof of concept, for reference, do not remove
 Patch8:                %{name}-kde_virtual_workspaces_hack.patch
-#Patch12: %{name}-0.7.2-dyngen-check-stack-clobbers.patch
-Patch13:       %{name}-dosguest.patch
-Patch14:       %{name}-ppc_old_binutils.patch
-Patch15:       %{name}-isa-bios-ram.patch
-# below one fixes problems with passing ram size to bios/bootloader
-# which affects coreboot/linuxbios
-Patch16:       %{name}-piix-ram-size.patch
 Patch17:       %{name}-whitelist.patch
 URL:           http://wiki.qemu.org/Index.html
 BuildRequires: SDL-devel >= 1.2.1
@@ -44,7 +36,9 @@ BuildRequires:        perl-tools-pod
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
 BuildRequires: texi2html
+BuildRequires: texinfo
 BuildRequires: which
+BuildRequires: xen-devel
 BuildRequires: xorg-lib-libX11-devel
 Requires:      %{name}-img = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
@@ -55,9 +49,11 @@ Requires:    %{name}-system-m68k = %{version}-%{release}
 Requires:      %{name}-system-microblaze = %{version}-%{release}
 Requires:      %{name}-system-mips = %{version}-%{release}
 Requires:      %{name}-system-ppc = %{version}-%{release}
+Requires:      %{name}-system-or32 = %{version}-%{release}
 Requires:      %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
 Requires:      %{name}-system-sparc = %{version}-%{release}
+Requires:      %{name}-system-unicore32 = %{version}-%{release}
 Requires:      %{name}-system-x86 = %{version}-%{release}
 Requires:      %{name}-system-xtensa = %{version}-%{release}
 Requires:      %{name}-user = %{version}-%{release}
@@ -66,7 +62,7 @@ ExclusiveArch:        %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some PPC/SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/.*-.* .*%{_datadir}/qemu/bios.bin
+%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -207,6 +203,17 @@ good emulation speed by using dynamic translation.
 
 This package provides the system emulator for mips.
 
+%package system-or32
+Summary:       QEMU system emulator for or32
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-or32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for or32.
+
 %package system-ppc
 Summary:       QEMU system emulator for ppc
 Group:         Development/Tools
@@ -251,11 +258,21 @@ good emulation speed by using dynamic translation.
 
 This package provides the system emulator for sparc/sparc64.
 
+%package system-unicore32
+Summary:       QEMU system emulator for unicore32
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description system-unicore32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for unicore32.
+
 %package system-x86
 Summary:       QEMU system emulator for x86
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
-Obsoletes:     qemu-kvm
 
 %description system-x86
 QEMU is a generic and open source processor emulator which achieves a
@@ -279,41 +296,41 @@ This package provides the system emulator for xtensa.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 %{?with_nosdlgui:%patch6 -p1}
 #patch8 -p1
 %patch17 -p0
 
-%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
-%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
-
-# cannot use optflags on x86 - they cause "no register to spill" errors
-%if %{with cflags_passing}
-%{__sed} -i -e 's/-g $CFLAGS/-Wall %{rpmcflags}/' configure
-%else
-%{__sed} -i 's/-g $CFLAGS/-Wall -fno-var-tracking-assignments/' configure
-%endif
-
 # workaround for conflict with alsa/error.h
 ln -s ../error.h qapi/error.h
 
 %build
-# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
-# they can be passed if the cflags_passing bcond is used
 ./configure \
+       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
+       --extra-ldflags="%{rpmldflags}" \
        --sysconfdir=%{_sysconfdir} \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
+       --disable-strip \
        --enable-mixemu \
        --audio-drv-list="alsa" \
        --interp-prefix=%{_libdir}/%{name}
-%{__make} V=1
+# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
+# --libexecdir in configure is nop
+%{__make} \
+       V=1 \
+       CONFIG_QEMU_HELPERDIR="%{_libdir}"
+
+# rebuild patched vesa tables with additional widescreen modes.
+%{__make} -C roms/vgabios stdvga-bios
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       libexecdir=%{_libdir}
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
@@ -322,7 +339,11 @@ cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 EOF
 
 # already packaged
-rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
+
+# install patched vesa tables with additional widescreen modes.
+install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -332,16 +353,22 @@ rm -rf $RPM_BUILD_ROOT
 
 %files common
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html
+%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
 %dir %{_sysconfdir}/qemu
+%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
+%attr(755,root,root) %{_bindir}/vscclient
 %attr(755,root,root) %{_bindir}/qemu-nbd
+%attr(755,root,root) %{_libdir}/qemu-bridge-helper
 %{_mandir}/man1/qemu.1*
+%{_mandir}/man1/virtfs-proxy-helper.1*
 %{_mandir}/man8/qemu-nbd.8*
 
 %dir %{_datadir}/qemu
+%{_datadir}/%{name}/cpus-*.conf
 %{_datadir}/%{name}/keymaps
+%{_datadir}/%{name}/qemu-icon.bmp
 # various bios images
 %{_datadir}/%{name}/*.bin
 %{_datadir}/%{name}/*.rom
@@ -370,6 +397,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/qemu-microblazeel
 %attr(755,root,root) %{_bindir}/qemu-mips
 %attr(755,root,root) %{_bindir}/qemu-mipsel
+%attr(755,root,root) %{_bindir}/qemu-or32
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
@@ -413,6 +441,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/qemu-system-mips64
 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
 
+%files system-or32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-or32
+
 %files system-ppc
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-ppc
@@ -433,6 +465,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/qemu-system-sparc
 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
 
+%files system-unicore32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-unicore32
+
 %files system-x86
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-i386
This page took 0.410266 seconds and 4 git commands to generate.