]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- removed outdated gcc33,parallel patches
[packages/qemu.git] / qemu.spec
index 807dae9745b478addcb5088ede469e6aa6a93ebf..618458754a9b5267710dadb1e9768bb520cc996d 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
 %bcond_with    kernel                  # build kqemu kernel modules
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
-
-%if %{with dist_kernel}
-%define        with_kernel     1
-%endif
 #
-%define        _kqemu_version  1.3.0pre7
+%define        _kqemu_version  1.3.0pre9
 %define                _rel    0.4
 Summary:       QEMU CPU Emulator
 Summary(pl):   QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.1
+Version:       0.8.2
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 67d924324a5ab79d017bd97a1e767285
+# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
 Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# NoSource1-md5:       3b77edbada790f924456aa4675edd0be
-NoSource:      1
+# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
 Patch0:                %{name}-nostatic.patch
 Patch1:                %{name}-cc.patch
 Patch2:                %{name}-longjmp.patch
 Patch3:                %{name}-dot.patch
-
-Patch5:                %{name}-gcc4_x86.patch
-Patch6:                %{name}-gcc4_ppc.patch
-Patch7:                %{name}-parallel.patch
-Patch8:                %{name}-nosdlgui.patch
-Patch9:                %{name}-ifup.patch
-Patch10:       %{name}-gcc33.patch
-
+Patch4:                %{name}-gcc4_x86.patch
+Patch5:                %{name}-gcc4_ppc.patch
+Patch6:                %{name}-nosdlgui.patch
+Patch7:                %{name}-ifup.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -52,7 +43,9 @@ BuildRequires:        alsa-lib-devel
 %if %{with kqemu} && %{with dist_kernel}
 BuildRequires: kernel-module-build >= 3:2.6.7
 %endif
+BuildRequires: perl-tools-pod
 BuildRequires: rpmbuild(macros) >= 1.217
+BuildRequires: tetex
 BuildRequires: sed >= 4.0
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
@@ -60,7 +53,7 @@ ExclusiveArch:        %{ix86} %{x8664} %{!?with_kqemu:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/proll.elf
+%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -133,16 +126,12 @@ kqemu - modu
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-
 %if %{with gcc4}
-%patch5 -p0
-%patch6 -p1
+%patch4 -p0
+%patch5 -p1
 %endif
-# probably not needed
-# %patch7 -p1
-%{?with_nosdlgui:%patch8 -p1}
-%patch9 -p1
-%patch10 -p1
+%{?with_nosdlgui:%patch6 -p1}
+%patch7 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -212,8 +201,12 @@ cd -
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --make="%{__make}" \
+%if %{with kqemu}
+       --kernel-path=%{_kernelsrcdir} \
+%else
+       --disable-kqemu \
+%endif
        %{?with_gcc4:--disable-gcc-check} \
-       %{!?with_kqemu:--disable-kqemu} \
        --enable-alsa \
        --interp-prefix=%{_libdir}/%{name}
 %{__make}
This page took 0.032427 seconds and 4 git commands to generate.