]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- release 5 (by relup.sh)
[packages/qemu.git] / qemu.spec
index 6a8ee9e4b8c32917995a2b53ba46bdbe6efd991d..211543a3d52b6f5b8bce2962409805a7488d0d74 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
-#
 # TODO:
-# - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - kqemu could be distributable if somebody bothers to contact qemu
-#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
+# - qemu-system-ppc -hda ac-ppc.img says:
+#   qemu: could not open disk image ac-ppc.img: error "Success"
+#   qemu-0.12.2-2.x86_64.rpm - broken
+#   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
+#   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
+#   qemu-0.11.1-*.x86_64.rpm - OK
 #
 # Conditional build:
-%bcond_without kqemu                   # disable QEMU accelerator support
-%bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
-%bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
-%bcond_without dist_kernel             # without distribution kernel
-%bcond_with    kernel                  # build kqemu kernel modules
-%bcond_without smp                     # don't build SMP module
-%bcond_without userspace               # don't build userspace utilities
+%bcond_without sdl             # SDL UI and audio support
+%bcond_without opengl          # OpenGL support
+%bcond_without ceph            # Ceph/RBD support
+%bcond_without spice           # SPICE support
+%bcond_with    esd             # EsounD audio support
+%bcond_without oss             # OSS audio support
+%bcond_without pulseaudio      # PulseAudio audio support
+%bcond_without xen             # Xen backend driver support
 #
-%define        _kqemu_version  1.3.0pre9
-%define                _rel    0.4
 Summary:       QEMU CPU Emulator
-Summary(pl):   QEMU - emulator procesora
+Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.2
-Release:       %{_rel}%{?with_kqemu:k}
-License:       GPL
+Version:       1.2.0
+Release:       5
+License:       GPL v2+
 Group:         Applications/Emulators
-#Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
-Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
-Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
-Patch0:                %{name}-nostatic.patch
-Patch1:                %{name}-cc.patch
-Patch2:                %{name}-longjmp.patch
-Patch3:                %{name}-dot.patch
-Patch4:                %{name}-gcc4_x86.patch
-Patch5:                %{name}-gcc4_ppc.patch
-Patch6:                %{name}-nosdlgui.patch
-Patch7:                %{name}-ifup.patch
-URL:           http://fabrice.bellard.free.fr/qemu/
-BuildRequires: SDL-devel >= 1.2.1
+Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 78eb1e984f4532aa9f2bdd3c127b5b61
+Patch0:                %{name}-cflags.patch
+Patch1:                vgabios-widescreens.patch
+Patch2:                %{name}-usbredir.patch
+Patch3:                %{name}-whitelist.patch
+# Proof of concept, for reference, do not remove
+Patch4:                %{name}-kde_virtual_workspaces_hack.patch
+URL:           http://wiki.qemu.org/Index.html
+%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
+%{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
 BuildRequires: alsa-lib-devel
-%{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
-%if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
-%endif
+BuildRequires: bluez-libs-devel
+BuildRequires: brlapi-devel
+%{?with_ceph:BuildRequires:    ceph-devel}
+BuildRequires: curl-devel
+BuildRequires: cyrus-sasl-devel >= 2
+%{?with_esd:BuildRequires:     esound-devel}
+BuildRequires: glib2-devel >= 1:2.12
+BuildRequires: gnutls-devel
+BuildRequires: libcap-devel
+BuildRequires: libcap-ng-devel
+BuildRequires: libfdt-devel
+BuildRequires: libiscsi-devel
+BuildRequires: libjpeg-devel
+BuildRequires: libpng-devel
+BuildRequires: libseccomp-devel
+BuildRequires: libuuid-devel
+BuildRequires: ncurses-devel
+BuildRequires: nss-devel >= 3.12.8
+BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.326
-BuildRequires: tetex
+BuildRequires: pkgconfig
+%{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
 BuildRequires: sed >= 4.0
-Requires:      SDL >= 1.2.1
+%if %{with spice}
+BuildRequires: spice-protocol >= 0.8.0
+BuildRequires: spice-server-devel >= 0.8.2
+%endif
+BuildRequires: texi2html
+BuildRequires: texinfo
+BuildRequires: usbredir-devel >= 0.3.4
+BuildRequires: vde2-devel
+BuildRequires: which
+%{?with_xen:BuildRequires:     xen-devel >= 3.4}
+BuildRequires: xfsprogs-devel
+BuildRequires: xorg-lib-libX11-devel
+BuildRequires: zlib-devel
+Requires:      %{name}-img = %{version}-%{release}
+Requires:      %{name}-system-alpha = %{version}-%{release}
+Requires:      %{name}-system-arm = %{version}-%{release}
+Requires:      %{name}-system-cris = %{version}-%{release}
+Requires:      %{name}-system-lm32 = %{version}-%{release}
+Requires:      %{name}-system-m68k = %{version}-%{release}
+Requires:      %{name}-system-microblaze = %{version}-%{release}
+Requires:      %{name}-system-mips = %{version}-%{release}
+Requires:      %{name}-system-ppc = %{version}-%{release}
+Requires:      %{name}-system-or32 = %{version}-%{release}
+Requires:      %{name}-system-s390x = %{version}-%{release}
+Requires:      %{name}-system-sh4 = %{version}-%{release}
+Requires:      %{name}-system-sparc = %{version}-%{release}
+Requires:      %{name}-system-unicore32 = %{version}-%{release}
+Requires:      %{name}-system-x86 = %{version}-%{release}
+Requires:      %{name}-system-xtensa = %{version}-%{release}
+Requires:      %{name}-user = %{version}-%{release}
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
-ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
+ExclusiveArch: %{ix86} %{x8664} %{?with_userspace:ppc}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# some SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/openbios-sparc32
+%define        systempkg_req \
+Requires:      SDL >= 1.2.1
+
+# some PPC/SPARC boot image in ELF format
+%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -69,219 +112,561 @@ CPUs. QEMU has two operating modes:
   including a processor and various peripherials. It can also be used to
   provide virtual hosting of several virtual PC on a single server.
 
-%description -l pl
-QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
-t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
-aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
+%description -l pl.UTF-8
+QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
+tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
+aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
-- Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
+- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
-  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
-  s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
+  procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
+  niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
+  słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
   cele QEMU.
 
-- Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
-  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
+  włączając w to procesor i różne urządzenia peryferyjne. Może być także
+  używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
-%package -n kernel%{_alt_kernel}-misc-kqemu
-Summary:       kqemu - kernel module
-Summary(pl):   kqemu - modu³ j±dra
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
-
-%description -n kernel%{_alt_kernel}-misc-kqemu
-kqemu - kernel module.
-
-%description -n kernel%{_alt_kernel}-misc-kqemu -l pl
-kqemu - modu³ j±dra.
-
-%package -n kernel%{_alt_kernel}-smp-misc-kqemu
-Summary:       kqemu - SMP kernel module
-Summary(pl):   kqemu - modu³ j±dra SMP
-Version:       %{_kqemu_version}
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-%{?with_dist_kernel:%requires_releq_kernel_smp}
-License:       Free to use, non-distributable
-Requires(post,postun): /sbin/depmod
-Requires:      module-init-tools >= 3.2.2-2
-
-%description -n kernel%{_alt_kernel}-smp-misc-kqemu
-kqemu - SMP kernel module.
-
-%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
-kqemu - modu³ j±dra SMP.
+%package common
+Summary:       QEMU common files needed by all QEMU targets
+Summary(pl.UTF-8):     Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
+Group:         Development/Tools
+Requires:      glib2 >= 1:2.12
+Conflicts:     qemu < 1.0-2
 
-%prep
-%setup -q %{?with_kernel:-a1}
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%if %{with gcc4}
-%patch4 -p0
-%patch5 -p1
-%endif
-%{?with_nosdlgui:%patch6 -p1}
-%patch7 -p1
+%description common
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
 
-%{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
-%{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
+This package provides the common files needed by all QEMU targets.
 
-# cannot use optflags on x86 - they cause "no register to spill" errors
-%if %{with cflags_passing}
-%{__sed} -i -e 's/-Wall -O2 -g/-Wall %{rpmcflags}/' Makefile Makefile.target
-%else
-%{__sed} -i 's/-Wall -O2 -g/-Wall -O2/' Makefile Makefile.target
-%endif
+%description common -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
-%if %{with kernel}
-echo -n > kqemu-%{_kqemu_version}/install.sh
+Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
+środowiska QEMU.
 
-cat <<'EOF' > modprobe.conf
-# enable dynamic major
-options kqemu major=0
-# for autoloading from static dev
-#alias char-major-250 kqemu
-EOF
+%package img
+Summary:       QEMU command line tool for manipulating disk images
+Summary(pl.UTF-8):     Narzędzie QEMU do operacji na obrazach dysków
+Group:         Development/Tools
+Conflicts:     qemu < 1.0-2
 
-cat <<'EOF' > udev.conf
-KERNEL=="kqemu", NAME="%k", MODE="0666"
-EOF
-%endif
+%description img
+This package provides a command line tool for manipulating disk
+images.
 
-%build
-%if %{with kernel}
-cd kqemu-%{_kqemu_version}
-
-mv -f kqemu-mod-i386.o{,.bin}
-mv -f kqemu-mod-x86_64.o{,.bin}
-mv -f kqemu-linux.c{,.orig}
-cat > Makefile <<'EOF'
-obj-m := kqemu.o
-kqemu-objs:= kqemu-linux.o kqemu-mod.o
-
-$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
-       cp $< $@
-EOF
+%description img -l pl.UTF-8
+Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
+na obrazach dysków.
 
-%build_kernel_modules -m kqemu <<'EOF'
-if grep -q "CONFIG_PREEMPT_RT" o/.config; then
-       sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
-               kqemu-linux.c.orig > kqemu-linux.c
-else
-       cat kqemu-linux.c.orig > kqemu-linux.c
-fi
-EOF
-cd -
-%endif
+%package user
+Summary:       QEMU user mode emulation of qemu targets
+Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description user
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the user mode emulation of QEMU targets.
+
+%description user -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
+
+%package system-alpha
+Summary:       QEMU system emulator for Alpha
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Alpha
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-alpha
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with Alpha CPU.
+
+%description system-alpha -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem Alpha.
+
+%package system-arm
+Summary:       QEMU system emulator for ARM
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem ARM
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-arm
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator for ARM.
+
+%description system-arm -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem ARM.
+
+%package system-cris
+Summary:       QEMU system emulator for CRIS
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem CRIS
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-cris
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with CRIS CPU.
+
+%description system-cris -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem CRIS.
+
+%package system-lm32
+Summary:       QEMU system emulator for LM32
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem LM32
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-lm32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with LM32 CPU.
+
+%description system-lm32 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem LM32.
+
+%package system-m68k
+Summary:       QEMU system emulator for m68k
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem m68k
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-m68k
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with m68k CPU.
+
+%description system-m68k -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem m68k.
+
+%package system-microblaze
+Summary:       QEMU system emulator for MicroBlaze
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem MicroBlaze
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-microblaze
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with MicroBlaze CPU.
+
+%description system-microblaze -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
+
+%package system-mips
+Summary:       QEMU system emulator for MIPS
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem MIPS
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-mips
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with MIPS CPU.
+
+%description system-mips -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem MIPS.
+
+%package system-or32
+Summary:       QEMU system emulator for OpenRISC
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem OpenRISC
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-or32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with OpenRISC CPU.
+
+%description system-or32 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
+
+%package system-ppc
+Summary:       QEMU system emulator for PowerPC
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem PowerPC
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-ppc
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with PowerPC CPU.
+
+%description system-ppc -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem PowerPC.
+
+%package system-s390x
+Summary:       QEMU system emulator for S390
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem S390
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-s390x
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with S390 CPU.
+
+%description system-s390x -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem S390.
+
+%package system-sh4
+Summary:       QEMU system emulator for SH4
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem SH4
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
 
-%if %{with userspace}
-# --extra-cflags don't work (overridden by CFLAGS in Makefile*)
-# they can be passed if the cflags_passing bcond is used
+%description system-sh4
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with SH4 CPU.
+
+%description system-sh4 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem SH4.
+
+%package system-sparc
+Summary:       QEMU system emulator for SPARC
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem SPARC
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-sparc
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with SPARC/SPARC64 CPU.
+
+%description system-sparc -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
+
+%package system-unicore32
+Summary:       QEMU system emulator for UniCore32
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem UniCore32
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-unicore32
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with UniCore32 CPU.
+
+%description system-unicore32 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem UniCore32.
+
+%package system-x86
+Summary:       QEMU system emulator for x86
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem x86
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-x86
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+%description system-x86 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+%package system-xtensa
+Summary:       QEMU system emulator for Xtensa
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Xtensa
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-xtensa
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with Xtensa CPU.
+
+%description system-xtensa -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem Xtensa.
+
+%prep
+%setup -q
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p0
+#patch4 -p1
+
+# workaround for conflict with alsa/error.h
+ln -s ../error.h qapi/error.h
+
+%build
 ./configure \
+       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
+       --extra-ldflags="%{rpmldflags}" \
+       --sysconfdir=%{_sysconfdir} \
        --prefix=%{_prefix} \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
-       --make="%{__make}" \
-%if %{with kqemu}
-       --kernel-path=%{_kernelsrcdir} \
-%else
-       --disable-kqemu \
-%endif
-       %{?with_gcc4:--disable-gcc-check} \
-       --enable-alsa \
+       --disable-strip \
+       --enable-attr \
+       --enable-bluez \
+       --enable-brlapi \
+       --enable-cap-ng \
+       --enable-curl \
+       --enable-curses \
+       --enable-fdt \
+       --enable-libiscsi \
+       --enable-mixemu \
+       %{__enable_disable opengl} \
+       %{__enable_disable ceph rbd} \
+       %{__enable_disable sdl} \
+       --enable-seccomp \
+       %{__enable_disable spice} \
+       --enable-smartcard \
+       --enable-smartcard-nss \
+       --enable-usb-redir \
+       --enable-uuid \
+       --enable-vde \
+       --enable-virtfs \
+       --enable-vnc-jpeg \
+       --enable-vnc-sasl \
+       --enable-vnc-tls \
+       %{__enable_disable xen} \
+       --audio-drv-list="alsa oss%{?with_sdl: sdl}%{?with_esd: esd}%{?with_pulseaudio: pa}" \
        --interp-prefix=%{_libdir}/%{name}
-%{__make}
-%endif
+# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
+# --libexecdir in configure is nop
+%{__make} \
+       V=1 \
+       CONFIG_QEMU_HELPERDIR="%{_libdir}"
+
+# rebuild patched vesa tables with additional widescreen modes.
+%{__make} -C roms/vgabios stdvga-bios
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with userspace}
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       libexecdir=%{_libdir}
 
-install -d $RPM_BUILD_ROOT/sbin
-cat <<'EOF' > $RPM_BUILD_ROOT/sbin/qemu-ifup
+install -d $RPM_BUILD_ROOT%{_sysconfdir}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 #!/bin/sh
-if [ -f /etc/sysconfig/qemu ]; then
-       . /etc/sysconfig/qemu
-fi
-# of course this will work only for one interface. a lot possible to involve
-sudo /sbin/ifconfig $1 ${INTERFACE_ADDR:-172.20.0.1}
-EOF
-%endif
 
-%if %{with kernel}
-%install_kernel_modules -m kqemu-%{_kqemu_version}/kqemu -d misc
-install -d $RPM_BUILD_ROOT/etc/{modprobe.d/%{_kernel_ver}{,smp},udev/rules.d}
-install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-%if %{with smp} && %{with dist_kernel}
-install modprobe.conf $RPM_BUILD_ROOT/etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
-%endif
-install udev.conf $RPM_BUILD_ROOT/etc/udev/rules.d/kqemu.rules
-%endif
+EOF
 
 # already packaged
-rm -rf $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
+%{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
+
+# install patched vesa tables with additional widescreen modes.
+install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if %{with kernel}
-%post
-%banner %{name} -e <<EOF
-To enable qemu accelerator (kqemu), the kqemu kernel module must be loaded:
-modprobe kqemu
-EOF
-%endif
+%files
+%defattr(644,root,root,755)
 
-%post  -n kernel%{_alt_kernel}-misc-kqemu
-%depmod %{_kernel_ver}
+%files common
+%defattr(644,root,root,755)
+%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
+%attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
+%dir %{_sysconfdir}/qemu
+%attr(755,root,root) %{_bindir}/virtfs-proxy-helper
+%attr(755,root,root) %{_bindir}/vscclient
+%attr(755,root,root) %{_bindir}/qemu-nbd
+%attr(755,root,root) %{_libdir}/qemu-bridge-helper
+%{_mandir}/man1/qemu.1*
+%{_mandir}/man1/virtfs-proxy-helper.1*
+%{_mandir}/man8/qemu-nbd.8*
+
+%dir %{_datadir}/qemu
+%{_datadir}/%{name}/cpus-*.conf
+%{_datadir}/%{name}/keymaps
+%{_datadir}/%{name}/qemu-icon.bmp
+# various bios images
+%{_datadir}/%{name}/*.bin
+%{_datadir}/%{name}/*.rom
+%{_datadir}/%{name}/*.dtb
+%{_datadir}/%{name}/openbios-ppc
+%{_datadir}/%{name}/openbios-sparc*
+%{_datadir}/%{name}/palcode-clipper
+
+%files img
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-img
+%{_mandir}/man1/qemu-img.1*
 
-%postun -n kernel%{_alt_kernel}-misc-kqemu
-%depmod %{_kernel_ver}
+%files user
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-alpha
+%attr(755,root,root) %{_bindir}/qemu-arm
+%attr(755,root,root) %{_bindir}/qemu-armeb
+%attr(755,root,root) %{_bindir}/qemu-cris
+%attr(755,root,root) %{_bindir}/qemu-ga
+%attr(755,root,root) %{_bindir}/qemu-i386
+%attr(755,root,root) %{_bindir}/qemu-io
+%attr(755,root,root) %{_bindir}/qemu-m68k
+%attr(755,root,root) %{_bindir}/qemu-microblaze
+%attr(755,root,root) %{_bindir}/qemu-microblazeel
+%attr(755,root,root) %{_bindir}/qemu-mips
+%attr(755,root,root) %{_bindir}/qemu-mipsel
+%attr(755,root,root) %{_bindir}/qemu-or32
+%attr(755,root,root) %{_bindir}/qemu-ppc
+%attr(755,root,root) %{_bindir}/qemu-ppc64
+%attr(755,root,root) %{_bindir}/qemu-ppc64abi32
+%attr(755,root,root) %{_bindir}/qemu-s390x
+%attr(755,root,root) %{_bindir}/qemu-sh4
+%attr(755,root,root) %{_bindir}/qemu-sh4eb
+%attr(755,root,root) %{_bindir}/qemu-sparc
+%attr(755,root,root) %{_bindir}/qemu-sparc32plus
+%attr(755,root,root) %{_bindir}/qemu-sparc64
+%attr(755,root,root) %{_bindir}/qemu-unicore32
+%attr(755,root,root) %{_bindir}/qemu-x86_64
+
+%files system-alpha
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-alpha
 
-%post  -n kernel%{_alt_kernel}-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
+%files system-arm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-arm
 
-%postun -n kernel%{_alt_kernel}-smp-misc-kqemu
-%depmod %{_kernel_ver}smp
+%files system-cris
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-cris
 
-%if %{with userspace}
-%files
+%files system-lm32
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html
-%attr(755,root,root) /sbin/qemu-ifup
-%attr(755,root,root) %{_bindir}/*
-%{_datadir}/qemu
-%{_mandir}/man1/qemu.1*
-%{_mandir}/man1/qemu-img.1*
-%endif
+%attr(755,root,root) %{_bindir}/qemu-system-lm32
 
-%if %{with kernel}
-%files -n kernel%{_alt_kernel}-misc-kqemu
+%files system-m68k
 %defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}/kqemu.conf
-/lib/modules/%{_kernel_ver}/misc/kqemu.ko*
+%attr(755,root,root) %{_bindir}/qemu-system-m68k
 
-%if %{with smp} && %{with dist_kernel}
-%files -n kernel%{_alt_kernel}-smp-misc-kqemu
+%files system-microblaze
 %defattr(644,root,root,755)
-%doc kqemu-%{_kqemu_version}/LICENSE
-%config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/kqemu.rules
-%config(noreplace) %verify(not md5 mtime size) /etc/modprobe.d/%{_kernel_ver}smp/kqemu.conf
-/lib/modules/%{_kernel_ver}smp/misc/kqemu.ko*
-%endif
-%endif
+%attr(755,root,root) %{_bindir}/qemu-system-microblaze
+%attr(755,root,root) %{_bindir}/qemu-system-microblazeel
+
+%files system-mips
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-mips
+%attr(755,root,root) %{_bindir}/qemu-system-mipsel
+%attr(755,root,root) %{_bindir}/qemu-system-mips64
+%attr(755,root,root) %{_bindir}/qemu-system-mips64el
+
+%files system-or32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-or32
+
+%files system-ppc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-ppc
+%attr(755,root,root) %{_bindir}/qemu-system-ppc64
+%attr(755,root,root) %{_bindir}/qemu-system-ppcemb
+
+%files system-s390x
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-s390x
+
+%files system-sh4
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-sh4
+%attr(755,root,root) %{_bindir}/qemu-system-sh4eb
+
+%files system-sparc
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-sparc
+%attr(755,root,root) %{_bindir}/qemu-system-sparc64
+
+%files system-unicore32
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-unicore32
+
+%files system-x86
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-i386
+%attr(755,root,root) %{_bindir}/qemu-system-x86_64
+
+%files system-xtensa
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-xtensa
+%attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.063189 seconds and 4 git commands to generate.