]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- updated to 1.4.0; 1.3.0 left on qemu-1.3 branch
[packages/qemu.git] / qemu.spec
index 7f574110335d8be58d492a86b436205738e19370..2ffeba6f1725ea7d122c53d34afb514596572eee 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,4 +1,6 @@
 # TODO:
+# - merge missing bits from qemu-kvm
+# - --enable-glusterfs when glusterfs 3.4 is out
 # - qemu-system-ppc -hda ac-ppc.img says:
 #   qemu: could not open disk image ac-ppc.img: error "Success"
 #   qemu-0.12.2-2.x86_64.rpm - broken
@@ -10,6 +12,7 @@
 %bcond_without sdl             # SDL UI and audio support
 %bcond_without opengl          # OpenGL support
 %bcond_without ceph            # Ceph/RBD support
+%bcond_with    glusterfs       # GlusterFS backend
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
 %bcond_without oss             # OSS audio support
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.2.1
-Release:       1
+Version:       1.4.0
+Release:       0.1
 License:       GPL v2+
 Group:         Applications/Emulators
-Source0:       http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 189bc5b87281a72f8c72a0f7ebaa6d00
+Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
+# Source0-md5: 78f13b774814b6b7ebcaf4f9b9204318
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
-Patch2:                %{name}-usbredir.patch
-Patch3:                %{name}-whitelist.patch
-Patch4:                %{name}-system-libcacard.patch
+Patch2:                %{name}-whitelist.patch
+Patch3:                %{name}-system-libcacard.patch
 # Proof of concept, for reference, do not remove
-Patch5:                %{name}-kde_virtual_workspaces_hack.patch
+Patch4:                %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
 %{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
 BuildRequires: alsa-lib-devel
+BuildRequires:  bcc
 BuildRequires: bluez-libs-devel
 BuildRequires: brlapi-devel
 %{?with_ceph:BuildRequires:    ceph-devel}
@@ -43,6 +46,7 @@ BuildRequires:        curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
 BuildRequires: glib2-devel >= 1:2.12
+%{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
 BuildRequires: gnutls-devel
 BuildRequires: libaio-devel
 BuildRequires: libcacard-devel
@@ -60,14 +64,15 @@ BuildRequires:      perl-Encode
 BuildRequires: perl-tools-pod
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
+BuildRequires: rpmbuild(macros) >= 1.202
 BuildRequires: sed >= 4.0
 %if %{with spice}
-BuildRequires: spice-protocol >= 0.8.0
-BuildRequires: spice-server-devel >= 0.8.2
+BuildRequires: spice-protocol >= 0.12.0
+BuildRequires: spice-server-devel >= 0.12.0
 %endif
 BuildRequires: texi2html
 BuildRequires: texinfo
-BuildRequires: usbredir-devel >= 0.3.4
+BuildRequires: usbredir-devel >= 0.5.3
 BuildRequires: vde2-devel
 BuildRequires: which
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
@@ -94,7 +99,8 @@ Requires:     %{name}-user = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        systempkg_req \
-Requires:      SDL >= 1.2.1
+Requires:      SDL >= 1.2.1 \
+Requires:      usbredir >= 0.5.3
 
 # some PPC/SPARC boot image in ELF format
 %define                _noautostrip    .*%{_datadir}/qemu/.*-.*
@@ -135,6 +141,14 @@ Summary:   QEMU common files needed by all QEMU targets
 Summary(pl.UTF-8):     Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
 Group:         Development/Tools
 Requires:      glib2 >= 1:2.12
+Requires(postun):      /usr/sbin/groupdel
+Requires(postun):      /usr/sbin/userdel
+Requires(pre): /bin/id
+Requires(pre): /usr/bin/getgid
+Requires(pre): /usr/sbin/groupadd
+Requires(pre): /usr/sbin/useradd
+Provides:      group(qemu)
+Provides:      user(qemu)
 Conflicts:     qemu < 1.0-2
 
 %description common
@@ -467,9 +481,8 @@ Ten pakiet zawiera emulator systemu z procesorem Xtensa.
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p0
-%patch4 -p1
+%patch2 -p0
+%patch3 -p1
 
 %{__mv} libcacard libcacard-use-system-lib
 
@@ -493,6 +506,7 @@ ln -s ../error.h qapi/error.h
        --enable-curses \
        --enable-docs \
        --enable-fdt \
+       %{__enable_disable glusterfs} \
        --enable-libiscsi \
        --enable-mixemu \
        %{__enable_disable opengl} \
@@ -500,7 +514,6 @@ ln -s ../error.h qapi/error.h
        %{__enable_disable sdl} \
        --enable-seccomp \
        %{__enable_disable spice} \
-       --enable-smartcard \
        --enable-smartcard-nss \
        --enable-usb-redir \
        --enable-uuid \
@@ -546,6 +559,16 @@ cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{n
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%pre common
+%groupadd -g 276 qemu
+%useradd -u 276 -g qemu -c "QEMU User" qemu
+
+%postun common
+if [ "$1" = "0" ]; then
+       %userremove qemu
+       %groupremove qemu
+fi
+
 %files
 %defattr(644,root,root,755)
 
@@ -563,10 +586,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man8/qemu-nbd.8*
 
 %dir %{_datadir}/qemu
-%{_datadir}/%{name}/cpus-*.conf
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
 # various bios images
+%{_datadir}/%{name}/*.aml
 %{_datadir}/%{name}/*.bin
 %{_datadir}/%{name}/*.rom
 %{_datadir}/%{name}/*.dtb
This page took 0.125012 seconds and 4 git commands to generate.