]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- use gcc4 by default (HEAD if for Th)
[packages/qemu.git] / qemu.spec
index ebdf9ea475dd28901a224bb22cac2215e39f2fd5..1522e8fc8a9d47f6e7797b584cc0dfe3503c680c 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -5,18 +5,21 @@
 # Conditional build:
 %bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
 # Note that gcc4 build is very problematic and not supported by qemu team
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
+%bcond_without gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
 %bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without up                      # don't build up module
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
+
 %define        _kqemu_version  1.3.0pre11
 %define                _rel    1
 Summary:       QEMU CPU Emulator
-Summary(pl.UTF-8):   QEMU - emulator procesora
+Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
 Version:       0.9.0
 Release:       %{_rel}%{?with_kqemu:k}
@@ -40,6 +43,7 @@ Patch8:               %{name}-kde_virtual_workspaces_hack.patch
 Patch9:                %{name}-0.8.0-gcc4-hacks.patch
 Patch11:       %{name}-0.7.2-gcc4-opts.patch
 #Patch12:      %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
 %if %{with kernel} && %{with dist_kernel}
 BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
@@ -94,7 +98,7 @@ aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
 %package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
-Summary(pl.UTF-8):   kqemu - moduł jądra
+Summary(pl.UTF-8):     kqemu - moduł jądra
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
@@ -111,7 +115,7 @@ kqemu - moduł jądra.
 
 %package -n kernel%{_alt_kernel}-smp-misc-kqemu
 Summary:       kqemu - SMP kernel module
-Summary(pl.UTF-8):   kqemu - moduł jądra SMP
+Summary(pl.UTF-8):     kqemu - moduł jądra SMP
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
@@ -127,6 +131,13 @@ kqemu - SMP kernel module.
 kqemu - moduł jądra SMP.
 
 %prep
+%if %{with kernel}
+%if %{with dist_kernel} && %{without up} && %{without smp}
+%{error:%{name}: If building kernel module You need to enable at least one of up or smp}
+exit 1
+%endif
+%endif
+
 %setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
@@ -167,12 +178,25 @@ KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 %endif
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
 
-mv -f kqemu-mod-i386.o{,.bin}
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common
 mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-i386.o{,.bin}
+%endif
+
 mv -f kqemu-linux.c{,.orig}
 cat > Makefile <<'EOF'
 obj-m := kqemu.o
This page took 0.07669 seconds and 4 git commands to generate.