]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- use gcc4 by default (HEAD if for Th)
[packages/qemu.git] / qemu.spec
index 4e338ff404cf31db7f741aaf50bb9cb111728a8f..1522e8fc8a9d47f6e7797b584cc0dfe3503c680c 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,52 +1,62 @@
 #
 # TODO:
 # - wait till the gcc bug http://gcc.gnu.org/PR16185 is fixed.
-# - kqemu could be distributable if somebody bothers to contact qemu
-#   author http://fabrice.bellard.free.fr/qemu/qemu-accel.html
 #
 # Conditional build:
-%bcond_without kqemu                   # disable QEMU accelerator support
+%bcond_without kqemu                   # disable KQEMU ACCELERATOR support in QEMU
 %bcond_with    cflags_passing          # with passing rpmcflags to Makefiles
+%bcond_with    dosguest                # add special patch when use with DOS as guest os
 %bcond_with    nosdlgui                # do not use SDL gui (use X11 instead)
-%bcond_with    gcc4                    # use gcc4 patches (broke build on gcc33)
+# Note that gcc4 build is very problematic and not supported by qemu team
+%bcond_without gcc4                    # use gcc4 patches (broke build on gcc33)
 %bcond_without dist_kernel             # without distribution kernel
-%bcond_with    kernel                  # build kqemu kernel modules
+%bcond_without kernel                  # build kqemu KERNEL MODULES
+%bcond_without up                      # don't build up module
 %bcond_without smp                     # don't build SMP module
 %bcond_without userspace               # don't build userspace utilities
 #
-%define        _kqemu_version  1.3.0pre9
-%define                _rel    0.4
+
+%define        _kqemu_version  1.3.0pre11
+%define                _rel    1
 Summary:       QEMU CPU Emulator
-Summary(pl):   QEMU - emulator procesora
+Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       0.8.2
+Version:       0.9.0
 Release:       %{_rel}%{?with_kqemu:k}
 License:       GPL
 Group:         Applications/Emulators
 #Source0Download: http://fabrice.bellard.free.fr/qemu/download.html
 Source0:       http://fabrice.bellard.free.fr/qemu/%{name}-%{version}.tar.gz
-# Source0-md5: 5b3a89eb2f256a8a6f3bb07f7b3f1b07
+# Source0-md5: ab11a03ba30cf4a70641f0f170473d69
 Source1:       http://fabrice.bellard.free.fr/qemu/k%{name}-%{_kqemu_version}.tar.gz
-# Source1-md5: 27888c3220844ad360a6a23345fa1bcb
+# Source1-md5: 970521874ef8b1ba4598925ace5936c3
 Patch0:                %{name}-nostatic.patch
 Patch1:                %{name}-cc.patch
-Patch2:                %{name}-longjmp.patch
 Patch3:                %{name}-dot.patch
 Patch4:                %{name}-gcc4_x86.patch
 Patch5:                %{name}-gcc4_ppc.patch
 Patch6:                %{name}-nosdlgui.patch
 Patch7:                %{name}-ifup.patch
+# Proof of concept, for reference, do not remove
+Patch8:                %{name}-kde_virtual_workspaces_hack.patch
+# http://gwenole.beauchesne.info/en/projects/qemu
+Patch9:                %{name}-0.8.0-gcc4-hacks.patch
+Patch11:       %{name}-0.7.2-gcc4-opts.patch
+#Patch12:      %{name}-0.7.2-dyngen-check-stack-clobbers.patch
+Patch13:       %{name}-dosguest.patch
 URL:           http://fabrice.bellard.free.fr/qemu/
+%if %{with kernel} && %{with dist_kernel}
+BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
+BuildRequires: rpmbuild(macros) >= 1.330
+%endif
+%if %{with userspace}
 BuildRequires: SDL-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 %{!?with_gcc4:BuildRequires:   gcc < 5:4.0}
-%if %{with kqemu} && %{with dist_kernel}
-BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6.7
-%endif
 BuildRequires: perl-tools-pod
-BuildRequires: rpmbuild(macros) >= 1.326
 BuildRequires: tetex
 BuildRequires: sed >= 4.0
+%endif
 Requires:      SDL >= 1.2.1
 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
 ExclusiveArch: %{ix86} %{x8664} %{!?with_kqemu:ppc}
@@ -69,69 +79,79 @@ CPUs. QEMU has two operating modes:
   including a processor and various peripherials. It can also be used to
   provide virtual hosting of several virtual PC on a single server.
 
-%description -l pl
-QEMU to szybki(!) emulator procesora. Poprzez u¿ycie dynamicznego
-t³umaczenia osi±ga rozs±dn± szybko¶æ i jest ³atwy do przeportowania,
-aby dzia³a³ na kolejnych procesorach. QEMU ma dwa tryby pracy:
+%description -l pl.UTF-8
+QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
+tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
+aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
 
-- Emulacja trybu u¿ytkownika. W tym trybie QEMU mo¿e uruchamiaæ
+- Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
   procesy linuksowe skompilowane dla jednego procesora na innym
-  procesorze. Linuksowe wywo³ania systemowe s± t³umaczone ze wzglêdu na
-  niezgodno¶æ kolejno¶ci bajtów w s³owie i 32/64-bitowego rozmiaru
-  s³owa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to g³ówne
+  procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
+  niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
+  słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
   cele QEMU.
 
-- Pe³na emulacja systemu. W tym trybie QEMU emuluje ca³y system,
-  w³±czaj±c w to procesor i ró¿ne urz±dzenia peryferyjne. Mo¿e byæ tak¿e
-  u¿ywane do wirtualnego hostowania kilku wirtualnych pecetów na
+- Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
+  włączając w to procesor i różne urządzenia peryferyjne. Może być także
+  używane do wirtualnego hostowania kilku wirtualnych pecetów na
   pojedynczym serwerze.
 
 %package -n kernel%{_alt_kernel}-misc-kqemu
 Summary:       kqemu - kernel module
-Summary(pl):   kqemu - modu³ j±dra
+Summary(pl.UTF-8):     kqemu - moduł jądra
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_up}
-License:       Free to use, non-distributable
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
 %description -n kernel%{_alt_kernel}-misc-kqemu
 kqemu - kernel module.
 
-%description -n kernel%{_alt_kernel}-misc-kqemu -l pl
-kqemu - modu³ j±dra.
+%description -n kernel%{_alt_kernel}-misc-kqemu -l pl.UTF-8
+kqemu - moduł jądra.
 
 %package -n kernel%{_alt_kernel}-smp-misc-kqemu
 Summary:       kqemu - SMP kernel module
-Summary(pl):   kqemu - modu³ j±dra SMP
+Summary(pl.UTF-8):     kqemu - moduł jądra SMP
 Version:       %{_kqemu_version}
 Release:       %{_rel}@%{_kernel_ver_str}
 Group:         Base/Kernel
 %{?with_dist_kernel:%requires_releq_kernel_smp}
-License:       Free to use, non-distributable
+License:       GPL v2
 Requires(post,postun): /sbin/depmod
 Requires:      module-init-tools >= 3.2.2-2
 
 %description -n kernel%{_alt_kernel}-smp-misc-kqemu
 kqemu - SMP kernel module.
 
-%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl
-kqemu - modu³ j±dra SMP.
+%description -n kernel%{_alt_kernel}-smp-misc-kqemu -l pl.UTF-8
+kqemu - moduł jądra SMP.
 
 %prep
+%if %{with kernel}
+%if %{with dist_kernel} && %{without up} && %{without smp}
+%{error:%{name}: If building kernel module You need to enable at least one of up or smp}
+exit 1
+%endif
+%endif
+
 %setup -q %{?with_kernel:-a1}
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
 %if %{with gcc4}
-%patch4 -p0
+%patch9 -p1
+%patch11 -p1
+#%patch12 -p1
+#%patch4 -p0
 %patch5 -p1
 %endif
 %{?with_nosdlgui:%patch6 -p1}
 %patch7 -p1
+#%patch8 -p1
 
 %{__sed} -i -e 's/sdl_static=yes/sdl_static=no/' configure
 %{__sed} -i 's/.*MAKE) -C kqemu$//' Makefile
@@ -158,10 +178,34 @@ KERNEL=="kqemu", NAME="%k", MODE="0666"
 EOF
 %endif
 
+%if %{with dosguest}
+%patch13 -p1
+%endif
+
 %build
 %if %{with kernel}
 cd kqemu-%{_kqemu_version}
+
+%{__sed} -i 's#include ../config-host.mak##' ./common/Makefile
+%ifarch %{x8664}
+%{__sed} -i 's/^#ARCH=x86_64/ARCH=x86_64/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-x86_64.o{,.bin}
+%else
+%{__sed} -i 's/^#ARCH=i386/ARCH=i386/' ./common/Makefile
+%{__make} -C common
+mv -f kqemu-mod-i386.o{,.bin}
+%endif
+
 mv -f kqemu-linux.c{,.orig}
+cat > Makefile <<'EOF'
+obj-m := kqemu.o
+kqemu-objs:= kqemu-linux.o kqemu-mod.o
+
+$(obj)/kqemu-mod.o: $(src)/kqemu-mod-$(ARCH).o.bin
+       cp $< $@
+EOF
+
 %build_kernel_modules -m kqemu <<'EOF'
 if grep -q "CONFIG_PREEMPT_RT" o/.config; then
        sed 's/SPIN_LOCK_UNLOCKED/SPIN_LOCK_UNLOCKED(kqemu_lock)/' \
This page took 0.176197 seconds and 4 git commands to generate.