]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu.spec
- added xseg/archipelago support (disabled by default, produces non-distributable...
[packages/qemu.git] / qemu.spec
index 526e4a7ee2f149cf50de22e540597ef638f46896..070660ca3214571249be9ce825de15f63e12f8d6 100644 (file)
--- a/qemu.spec
+++ b/qemu.spec
@@ -1,29 +1,49 @@
-# TODO:
-# - merge missing bits from qemu-kvm
+# TODO: archipelago (libxseg) on bcond (GPL v3 vs v2-only conflict)
 #
 # Conditional build:
 %bcond_without sdl             # SDL UI and audio support
-%bcond_without glx             # OpenGL/GLX support
 %bcond_without ceph            # Ceph/RBD support
 %bcond_without glusterfs       # GlusterFS backend
 %bcond_without rdma            # RDMA-based migration support
+%bcond_with    xseg            # Archipelago backend [non-distributable: GPLv3+ vs GPLv2-only]
 %bcond_with    gtk2            # GTK+ 2.x instead of 3.x
+%bcond_without gtk3            # Do not build GTK+ UI
+%bcond_without vte             # VTE support in GTK+ UI
 %bcond_without spice           # SPICE support
 %bcond_with    esd             # EsounD audio support
 %bcond_without oss             # OSS audio support
 %bcond_without pulseaudio      # PulseAudio audio support
 %bcond_without xen             # Xen backend driver support
+%bcond_without bluetooth       # bluetooth support
+%bcond_without brlapi          # brlapi support
+%bcond_without smartcard       # smartcard-nss support
+%bcond_without iscsi           # iscsi support
+%bcond_without libnfs          # NFS support
+%bcond_without seccomp         # seccomp support
+%bcond_without usbredir        # usb network redirection support
+%bcond_without system_seabios  # system seabios binary
+%bcond_without snappy          # snappy compression library
+%bcond_with    lttng           # lttng-ust trace backend support
+%bcond_with    systemtap       # SystemTap/dtrace trace backend support
+
+%if %{with gtk2}
+%undefine with_gtk3
+%endif
+
+%ifarch x32
+%undefine      with_xen
+%endif
 
 Summary:       QEMU CPU Emulator
 Summary(pl.UTF-8):     QEMU - emulator procesora
 Name:          qemu
-Version:       1.6.1
-Release:       3
-License:       GPL v2+
+Version:       2.4.0.1
+Release:       1
+License:       GPL v2
 Group:         Applications/Emulators
 Source0:       http://wiki.qemu-project.org/download/%{name}-%{version}.tar.bz2
-# Source0-md5: 3a897d722457c5a895cd6ac79a28fda0
-Source2:       qemu.binfmt
+# Source0-md5: c99445164e77184a9ba2e7dbf7ed5c29
+Source2:       %{name}.binfmt
 # Loads kvm kernel modules at boot
 Source3:       kvm-modules-load.conf
 # Creates /dev/kvm
@@ -35,58 +55,74 @@ Source7:    ksmctl.c
 Source8:       ksmtuned.service
 Source9:       ksmtuned
 Source10:      ksmtuned.conf
-Source11:      qemu-guest-agent.service
-Source12:      99-qemu-guest-agent.rules
+Source11:      %{name}-guest-agent.service
+Source12:      99-%{name}-guest-agent.rules
 Patch0:                %{name}-cflags.patch
 Patch1:                vgabios-widescreens.patch
 Patch2:                %{name}-whitelist.patch
 Patch3:                %{name}-system-libcacard.patch
+Patch4:                %{name}-xattr.patch
+Patch5:                libjpeg-boolean.patch
+Patch6:                x32.patch
+Patch7:                %{name}-sh.patch
 # Proof of concept, for reference, do not remove
-Patch4:                %{name}-kde_virtual_workspaces_hack.patch
+Patch400:      %{name}-kde_virtual_workspaces_hack.patch
 URL:           http://www.qemu-project.org/
-%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
-%{?with_sdl:BuildRequires:     SDL-devel >= 1.2.1}
+BuildRequires: OpenGL-devel
+BuildRequires: OpenGL-GLX-devel
+%{?with_sdl:BuildRequires:     SDL2-devel >= 2.0}
 BuildRequires: alsa-lib-devel
-BuildRequires:  bcc
-BuildRequires: bluez-libs-devel
-BuildRequires: brlapi-devel
+BuildRequires: bcc >= 0.16.21-2
+%{?with_bluetooth:BuildRequires:       bluez-libs-devel}
+%{?with_brlapi:BuildRequires:  brlapi-devel}
+BuildRequires: bzip2-devel
 %{?with_ceph:BuildRequires:    ceph-devel}
 BuildRequires: curl-devel
 BuildRequires: cyrus-sasl-devel >= 2
 %{?with_esd:BuildRequires:     esound-devel}
-BuildRequires: glib2-devel >= 1:2.12
+BuildRequires: glib2-devel >= 1:2.22
 %{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4}
-BuildRequires: gnutls-devel
+BuildRequires: gnutls-devel > 2.10.0
 BuildRequires: libaio-devel
-BuildRequires: libcacard-devel
+%{?with_smartcard:BuildRequires:       libcacard-devel}
 BuildRequires: libcap-devel
 BuildRequires: libcap-ng-devel
+BuildRequires: libepoxy-devel
 BuildRequires: libfdt-devel
 %{?with_rdma:BuildRequires:    libibverbs-devel}
-BuildRequires: libiscsi-devel
+%{?with_iscsi:BuildRequires:   libiscsi-devel >= 1.9.0}
 BuildRequires: libjpeg-devel
+%{?with_libnfs:BuildRequires:  libnfs-devel >= 1.9.3}
 BuildRequires: libpng-devel
 %{?with_rdma:BuildRequires:    librdmacm-devel}
-BuildRequires: libseccomp-devel
+%{?with_seccomp:BuildRequires: libseccomp-devel >= 2.1.1}
 BuildRequires: libssh2-devel >= 1.2.8
-# for usb passthrough, when available
-#BuildRequires:        libusb-devel >= 1.0.13
+BuildRequires: libusb-devel >= 1.0.13
 BuildRequires: libuuid-devel
+%{?with_xseg:BuildRequires:    libxseg-devel}
+%{?with_lttng:BuildRequires:   lttng-ust-devel}
+BuildRequires: lzo-devel >= 2
 BuildRequires: ncurses-devel
-BuildRequires: nss-devel >= 3.12.8
+%{?with_smartcard:BuildRequires:       nss-devel >= 1:3.12.8}
+BuildRequires: numactl-devel
 BuildRequires: perl-Encode
 BuildRequires: perl-tools-pod
+BuildRequires: pixman-devel >= 0.21.8
 BuildRequires: pkgconfig
 %{?with_pulseaudio:BuildRequires:      pulseaudio-devel}
-BuildRequires: rpmbuild(macros) >= 1.202
+BuildRequires: rpmbuild(macros) >= 1.644
+%{?with_system_seabios:BuildRequires:  seabios}
 BuildRequires: sed >= 4.0
+%{?with_snappy:BuildRequires:  snappy-devel}
 %if %{with spice}
-BuildRequires: spice-protocol >= 0.12.0
+BuildRequires: spice-protocol >= 0.12.3
 BuildRequires: spice-server-devel >= 0.12.0
 %endif
+%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
 BuildRequires: texi2html
 BuildRequires: texinfo
-BuildRequires: usbredir-devel >= 0.6
+%{?with_usbredir:BuildRequires:        usbredir-devel >= 0.6}
+%{?with_lttng:BuildRequires:   userspace-rcu-devel}
 BuildRequires: vde2-devel
 BuildRequires: which
 %{?with_xen:BuildRequires:     xen-devel >= 3.4}
@@ -95,12 +131,14 @@ BuildRequires:     xorg-lib-libX11-devel
 BuildRequires: zlib-devel
 %if %{with gtk2}
 BuildRequires: gtk+2-devel >= 2:2.18.0
-BuildRequires: vte0-devel >= 0.24.0
-%else
+%{?with_vte:BuildRequires:     vte0-devel >= 0.24.0}
+%endif
+%if %{with gtk3}
 BuildRequires: gtk+3-devel >= 3.0.0
-BuildRequires: vte-devel >= 0.32.0
+%{?with_vte:BuildRequires:     vte2.90-devel >= 0.32.0}
 %endif
 Requires:      %{name}-img = %{version}-%{release}
+Requires:      %{name}-system-aarch64 = %{version}-%{release}
 Requires:      %{name}-system-alpha = %{version}-%{release}
 Requires:      %{name}-system-arm = %{version}-%{release}
 Requires:      %{name}-system-cris = %{version}-%{release}
@@ -114,6 +152,7 @@ Requires:   %{name}-system-ppc = %{version}-%{release}
 Requires:      %{name}-system-s390x = %{version}-%{release}
 Requires:      %{name}-system-sh4 = %{version}-%{release}
 Requires:      %{name}-system-sparc = %{version}-%{release}
+Requires:      %{name}-system-tricore = %{version}-%{release}
 Requires:      %{name}-system-unicore32 = %{version}-%{release}
 Requires:      %{name}-system-x86 = %{version}-%{release}
 Requires:      %{name}-system-xtensa = %{version}-%{release}
@@ -122,18 +161,29 @@ Obsoletes:        qemu-kvm
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define        systempkg_req \
-Requires:      SDL >= 1.2.1 \
+%if %{with sdl} \
+Requires:      SDL2 \
+%endif \
+%if %{with seccomp} \
+Requires:      libseccomp >= 2.1.0 \
+%endif \
+Requires:      libusb >= 1.0.13 \
+Requires:      pixman >= 0.21.8 \
+%if %{with usbredir} \
 Requires:      usbredir >= 0.6 \
+%endif \
 %if %{with gtk2} \
 Requires:      gtk+2 >= 2:2.18.0 \
-Requires:      vte0 >= 0.24.0 \
-%else \
+%{?with_vte:Requires:  vte0 >= 0.24.0} \
+%endif \
+%if %{with gtk3} \
 Requires:      gtk+3 >= 3.0.0 \
-Requires:      vte >= 0.32.0 \
+%{?with_vte:Requires:  vte2.90 >= 0.32.0} \
 %endif
 
-# some PPC/SPARC boot image in ELF format
-%define                _noautostrip    .*%{_datadir}/qemu/.*-.*
+# don't strip/chrpath anything in there; these are boot images, roms etc
+%define                _noautostrip    .*%{_datadir}/qemu/.*
+%define                _noautochrpath  .*%{_datadir}/qemu/.*
 
 %description
 QEMU is a FAST! processor emulator. By using dynamic translation it
@@ -177,7 +227,8 @@ Requires(pre):      /bin/id
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
 Requires(pre): /usr/sbin/useradd
-Requires:      glib2 >= 1:2.12
+Requires:      glib2 >= 1:2.22
+%{?with_libnfs:Requires:       libnfs >= 1.9.3}
 Requires:      libssh2 >= 1.2.8
 Requires:      systemd-units >= 38
 Provides:      group(qemu)
@@ -202,8 +253,8 @@ Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
 Summary:       QEMU command line tool for manipulating disk images
 Summary(pl.UTF-8):     Narzędzie QEMU do operacji na obrazach dysków
 Group:         Development/Tools
-Conflicts:     qemu < 1.0-2
 Obsoletes:     qemu-kvm-img
+Conflicts:     qemu < 1.0-2
 
 %description img
 This package provides a command line tool for manipulating disk
@@ -218,6 +269,8 @@ Summary:    QEMU user mode emulation of qemu targets
 Summary(pl.UTF-8):     QEMU - emulacja trybu użytkownika środowisk qemu
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
+Requires(post,postun): systemd-units >= 38
+Requires:      systemd-units >= 38
 Obsoletes:     qemu-kvm-user
 
 %description user
@@ -232,6 +285,26 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
 
+%package system-aarch64
+Summary:       QEMU system emulator for AArch64
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem AArch64
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+Obsoletes:     qemu-kvm-system-aarch64
+
+%description system-aarch64
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with AArch64 CPU.
+
+%description system-aarch64 -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem AArch64.
+
 %package system-alpha
 Summary:       QEMU system emulator for Alpha
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem Alpha
@@ -491,6 +564,25 @@ dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
 
 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
 
+%package system-tricore
+Summary:       QEMU system emulator for TriCore
+Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem TriCore
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+%systempkg_req
+
+%description system-tricore
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
+
+This package provides the system emulator with TriCore CPU.
+
+%description system-sparc -l pl.UTF-8
+QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
+dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
+
+Ten pakiet zawiera emulator systemu z procesorem TriCore.
+
 %package system-unicore32
 Summary:       QEMU system emulator for UniCore32
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem UniCore32
@@ -516,7 +608,9 @@ Summary:    QEMU system emulator for x86
 Summary(pl.UTF-8):     QEMU - emulator systemu z procesorem x86
 Group:         Development/Tools
 Requires:      %{name}-common = %{version}-%{release}
+%{?with_system_seabios:Requires:       seabios}
 %systempkg_req
+Obsoletes:     kvm
 Obsoletes:     qemu-kvm-system-x86
 
 %description system-x86
@@ -552,13 +646,13 @@ Summary:  QEMU guest agent
 Summary(pl.UTF-8):     Agent gościa QEMU
 Group:         Daemons
 Requires(post,preun,postun):   systemd-units >= 38
-Requires:      glib2 >= 1:2.12
+Requires:      glib2 >= 1:2.22
 Requires:      systemd-units >= 38
 Obsoletes:     qemu-kvm-guest-agent
 
 %description guest-agent
-QEMU is a generic and open source processor emulator which achieves
-good emulation speed by using dynamic translation.
+QEMU is a generic and open source processor emulator which achieves a
+good emulation speed by using dynamic translation.
 
 This package provides an agent to run inside guests, which
 communicates with the host over a virtio-serial channel named
@@ -576,12 +670,90 @@ systemach-gościach, komunikującego się kanałem virtio-serial o nazwie
 
 Ten pakiet nie musi być zainstalowany w systemie hosta.
 
+%package module-block-archipelago
+Summary:       QEMU module for Archipelago block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych Archipelago
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-archipelago
+Archipelago block device support for QEMU.
+
+%description module-block-archipelago -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych Archipelago.
+
+%package module-block-curl
+Summary:       QEMU module for 'curl' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'curl'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-curl
+'curl' block device support for QEMU.
+
+%description module-block-curl -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'curl'.
+
+%package module-block-gluster
+Summary:       QEMU module for 'gluster' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'gluster'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+Requires:      glusterfs-libs >= 3.4
+
+%description module-block-gluster
+'gluster' block device support for QEMU.
+
+%description module-block-gluster -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'gluster'.
+
+%package module-block-iscsi
+Summary:       QEMU module for 'iscsi' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'iscsi'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+Requires:      libiscsi >= 1.9.0
+
+%description module-block-iscsi
+'iscsi' block device support for QEMU.
+
+%description module-block-iscsi -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'iscsi'.
+
+%package module-block-rbd
+Summary:       QEMU module for 'rbd' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'rbd'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-rbd
+'rbd' block device support for QEMU.
+
+%description module-block-rbd -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'rbd'.
+
+%package module-block-ssh
+Summary:       QEMU module for 'ssh' block devices
+Summary(pl.UTF-8):     Moduł QEMU dla urządeń blokowych typu 'ssh'
+Group:         Development/Tools
+Requires:      %{name}-common = %{version}-%{release}
+
+%description module-block-ssh
+'ssh' block device support for QEMU.
+
+%description module-block-ssh -l pl.UTF-8
+Moduł QEMU dla urządeń blokowych typu 'ssh'.
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p0
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+%patch7 -p1
 
 %{__mv} libcacard libcacard-use-system-lib
 
@@ -590,33 +762,36 @@ ln -s ../error.h qapi/error.h
 
 %build
 ./configure \
-       --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
-       --extra-ldflags="%{rpmldflags}" \
+       --extra-cflags="%{rpmcflags} %{rpmcppflags} -fPIE -DPIE" \
+       --extra-ldflags="%{rpmldflags} -pie -Wl,-z,relro -Wl,-z,now" \
        --prefix=%{_prefix} \
+       --libdir=%{_libdir} \
+       --libexecdir=%{_libexecdir} \
        --sysconfdir=%{_sysconfdir} \
        --cc="%{__cc}" \
        --host-cc="%{__cc}" \
        --disable-strip \
+       %{__enable_disable xseg archipelago} \
        --enable-attr \
-       --enable-bluez \
-       --enable-brlapi \
+       %{__enable_disable bluetooth bluez} \
+       %{__enable_disable brlapi} \
        --enable-cap-ng \
        --enable-curl \
        --enable-curses \
        --enable-docs \
        --enable-fdt \
        %{__enable_disable glusterfs} \
-       --enable-libiscsi \
-       --enable-mixemu \
-       %{__enable_disable glx} \
+       %{__enable_disable iscsi libiscsi} \
        %{__enable_disable ceph rbd} \
        %{__enable_disable rdma} \
        %{__enable_disable sdl} \
-       --enable-seccomp \
+       --with-sdlabi=2.0 \
+       %{__enable_disable seccomp} \
        %{__enable_disable spice} \
-       --enable-smartcard-nss \
+       %{__enable_disable smartcard smartcard-nss} \
        --enable-tpm \
-       --enable-usb-redir \
+       --enable-trace-backends="nop%{?with_systemtap:,dtrace}%{?with_lttng:,ust}" \
+       %{__enable_disable usbredir usb-redir} \
        --enable-uuid \
        --enable-vde \
        --enable-virtfs \
@@ -624,17 +799,25 @@ ln -s ../error.h qapi/error.h
        --enable-vnc-png \
        --enable-vnc-sasl \
        --enable-vnc-tls \
+       %{!?with_vte:--disable-vte} \
        --enable-kvm \
        %{__enable_disable xen} \
+       --enable-modules \
+       --disable-netmap \
+       %{__enable_disable libnfs} \
+       --enable-lzo \
+       %{__enable_disable snappy} \
        --audio-drv-list="alsa%{?with_iss:,oss}%{?with_sdl:,sdl}%{?with_esd:,esd}%{?with_pulseaudio:,pa}" \
        --interp-prefix=%{_libdir}/qemu/lib-%%M \
+%if %{without gtk2} && %{without gtk3}
+       --disable-gtk
+%else
        --with-gtkabi="%{?with_gtk2:2.0}%{!?with_gtk2:3.0}"
+%endif
 
-# note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
-# --libexecdir in configure is nop
 %{__make} \
        V=1 \
-       CONFIG_QEMU_HELPERDIR="%{_libdir}"
+       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n}
 
 # rebuild patched vesa tables with additional widescreen modes.
 %{__make} -C roms/vgabios stdvga-bios
@@ -648,8 +831,8 @@ install -d $RPM_BUILD_ROOT{%{systemdunitdir},/usr/lib/binfmt.d} \
        $RPM_BUILD_ROOT{%{_sysconfdir}/sasl,%{_sbindir}}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       libexecdir=%{_libdir}
+       %{!?with_smartcard:CONFIG_USB_SMARTCARD=n} \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
@@ -657,8 +840,10 @@ cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
 
 EOF
 
-%ifarch %{ix86} %{x8664}
-install scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
+install -p qemu.sasl $RPM_BUILD_ROOT%{_sysconfdir}/sasl/qemu.conf
+
+%ifarch %{ix86} %{x8664} x32
+install -p scripts/kvm/kvm_stat $RPM_BUILD_ROOT%{_bindir}
 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/modules-load.d/kvm.conf
 install -p %{SOURCE4} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 %endif
@@ -677,43 +862,59 @@ install -p %{SOURCE11} $RPM_BUILD_ROOT%{systemdunitdir}
 install -p %{SOURCE12} $RPM_BUILD_ROOT%{_sysconfdir}/udev/rules.d
 
 for i in dummy \
-%ifnarch %{ix86} %{x8664}
-    qemu-i386 \
+%ifnarch %{ix86} %{x8664} x32
+       qemu-i386 \
 %endif
 %ifnarch arm
-    qemu-arm \
+       qemu-arm \
 %endif
 %ifnarch ppc ppc64
-    qemu-ppc \
+       qemu-ppc \
 %endif
 %ifnarch sparc sparc64
-    qemu-sparc \
+       qemu-sparc \
 %endif
 %ifnarch sh4
-    qemu-sh4 \
+       qemu-sh4 \
 %endif
 ; do
        test $i = dummy && continue
        grep /$i:\$ %{SOURCE2} > $RPM_BUILD_ROOT/usr/lib/binfmt.d/$i.conf
 done < %{SOURCE2}
 
-# already packaged
+# packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
 
 # install patched vesa tables with additional widescreen modes.
 cp -p roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
 
-%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{de_DE,de}
-%{__mv} $RPM_BUILD_ROOT%{_datadir}/locale/{fr_FR,fr}
+%if %{with system_seabios}
+ln -sf /usr/share/seabios/bios.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/bios-256k.bin
+# bios.bin provided by qemu is stripped to 128k, with no Xen support, keep it
+for f in $RPM_BUILD_ROOT%{_datadir}/%{name}/*.aml ; do
+       bn="$(basename $f)"
+       if [ -e "/usr/share/seabios/$bn" ] ; then
+               ln -sf "/usr/share/seabios/$bn" "$f"
+       fi
+done
+%endif
+
+%if %{with gtk2} || %{with gtk3}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{de_DE,de}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
 %find_lang %{name}
+%else
+: > qemu.lang
+%endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %pre common
+%groupadd -g 160 kvm
 %groupadd -g 276 qemu
-%useradd -u 276 -g qemu -c "QEMU User" qemu
+%useradd -u 276 -g qemu -G kvm -c "QEMU User" qemu
 
 %post common
 %systemd_post ksm.service
@@ -727,6 +928,7 @@ rm -rf $RPM_BUILD_ROOT
 if [ "$1" = "0" ]; then
        %userremove qemu
        %groupremove qemu
+       %groupremove kvm
 fi
 %systemd_reload
 
@@ -754,14 +956,13 @@ fi
 
 %files common -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
+%doc LICENSE README qemu-doc.html qemu-tech.html qmp-commands.txt
 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/ksmtuned.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/sasl/qemu.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/ksm
 %{systemdunitdir}/ksm.service
 %{systemdunitdir}/ksmtuned.service
-%dir %{_sysconfdir}/qemu
 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
 %attr(755,root,root) %{_bindir}/qemu-nbd
 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
@@ -774,16 +975,51 @@ fi
 %dir %{_datadir}/qemu
 %{_datadir}/%{name}/keymaps
 %{_datadir}/%{name}/qemu-icon.bmp
+%{_datadir}/%{name}/trace-events
+
 # various bios images
-%{_datadir}/%{name}/*.aml
-%{_datadir}/%{name}/*.bin
-%{_datadir}/%{name}/*.rom
-%{_datadir}/%{name}/*.dtb
-%{_datadir}/%{name}/qemu_logo_no_text.svg
+# all should be probably moved to the right system subpackage
+%{_datadir}/%{name}/QEMU,cgthree.bin
+%{_datadir}/%{name}/QEMU,tcx.bin
+%{_datadir}/%{name}/bamboo.dtb
+%{_datadir}/%{name}/efi-e1000.rom
+%{_datadir}/%{name}/efi-eepro100.rom
+%{_datadir}/%{name}/efi-ne2k_pci.rom
+%{_datadir}/%{name}/efi-pcnet.rom
+%{_datadir}/%{name}/efi-rtl8139.rom
+%{_datadir}/%{name}/efi-virtio.rom
+%{_datadir}/%{name}/kvmvapic.bin
+%{_datadir}/%{name}/linuxboot.bin
+%{_datadir}/%{name}/multiboot.bin
 %{_datadir}/%{name}/openbios-ppc
 %{_datadir}/%{name}/openbios-sparc*
 %{_datadir}/%{name}/palcode-clipper
+%{_datadir}/%{name}/petalogix-ml605.dtb
+%{_datadir}/%{name}/petalogix-s3adsp1800.dtb
+%{_datadir}/%{name}/ppc_rom.bin
+%{_datadir}/%{name}/pxe-e1000.rom
+%{_datadir}/%{name}/pxe-eepro100.rom
+%{_datadir}/%{name}/pxe-ne2k_pci.rom
+%{_datadir}/%{name}/pxe-pcnet.rom
+%{_datadir}/%{name}/pxe-rtl8139.rom
+%{_datadir}/%{name}/pxe-virtio.rom
+%{_datadir}/%{name}/qemu_logo_no_text.svg
 %{_datadir}/%{name}/s390-ccw.img
+%{_datadir}/%{name}/s390-zipl.rom
+%{_datadir}/%{name}/sgabios.bin
+%{_datadir}/%{name}/slof.bin
+%{_datadir}/%{name}/spapr-rtas.bin
+%{_datadir}/%{name}/vgabios-cirrus.bin
+%{_datadir}/%{name}/vgabios-qxl.bin
+%{_datadir}/%{name}/vgabios-stdvga.bin
+%{_datadir}/%{name}/vgabios-virtio.bin
+%{_datadir}/%{name}/vgabios-vmware.bin
+%{_datadir}/%{name}/vgabios.bin
+
+%dir %{_libdir}/%{name}
+
+# modules without too many external dependencies
+%attr(755,root,root) %{_libdir}/%{name}/block-dmg.so
 
 %files img
 %defattr(644,root,root,755)
@@ -793,6 +1029,7 @@ fi
 %files user
 %defattr(644,root,root,755)
 /usr/lib/binfmt.d/qemu-*.conf
+%attr(755,root,root) %{_bindir}/qemu-aarch64
 %attr(755,root,root) %{_bindir}/qemu-alpha
 %attr(755,root,root) %{_bindir}/qemu-arm
 %attr(755,root,root) %{_bindir}/qemu-armeb
@@ -812,6 +1049,7 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-ppc
 %attr(755,root,root) %{_bindir}/qemu-ppc64
 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
+%attr(755,root,root) %{_bindir}/qemu-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-s390x
 %attr(755,root,root) %{_bindir}/qemu-sh4
 %attr(755,root,root) %{_bindir}/qemu-sh4eb
@@ -821,6 +1059,10 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-unicore32
 %attr(755,root,root) %{_bindir}/qemu-x86_64
 
+%files system-aarch64
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-aarch64
+
 %files system-alpha
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-alpha
@@ -865,7 +1107,9 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-ppc
 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
+#%attr(755,root,root) %{_bindir}/qemu-system-ppc64le
 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
+%{_datadir}/%{name}/u-boot.e500
 
 %files system-s390x
 %defattr(644,root,root,755)
@@ -881,6 +1125,10 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-system-sparc
 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
 
+%files system-tricore
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/qemu-system-tricore
+
 %files system-unicore32
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
@@ -889,11 +1137,15 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/qemu-system-i386
 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
 %config(noreplace) %verify(not md5 mtime size) /etc/modules-load.d/kvm.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/80-kvm.rules
 %attr(755,root,root) %{_bindir}/kvm_stat
 %endif
+%{_datadir}/%{name}/bios.bin
+%{_datadir}/%{name}/bios-256k.bin
+%{_datadir}/%{name}/acpi-dsdt.aml
+%{_datadir}/%{name}/q35-acpi-dsdt.aml
 
 %files system-xtensa
 %defattr(644,root,root,755)
@@ -901,6 +1153,39 @@ fi
 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
 
 %files guest-agent
+%defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) /etc/udev/rules.d/99-qemu-guest-agent.rules
 %{systemdunitdir}/qemu-guest-agent.service
 %attr(755,root,root) %{_bindir}/qemu-ga
+
+%if %{with xseg}
+%files module-block-archipelago
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-archipelago.so
+%endif
+
+%files module-block-curl
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-curl.so
+
+%if %{with glusterfs}
+%files module-block-gluster
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-gluster.so
+%endif
+
+%if %{with iscsi}
+%files module-block-iscsi
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-iscsi.so
+%endif
+
+%if %{with ceph}
+%files module-block-rbd
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-rbd.so
+%endif
+
+%files module-block-ssh
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/%{name}/block-ssh.so
This page took 0.085045 seconds and 4 git commands to generate.