]> git.pld-linux.org Git - packages/qemu.git/blobdiff - qemu-system-libcacard.patch
- updated some dependencies, added conditions for -module-block-*
[packages/qemu.git] / qemu-system-libcacard.patch
index c20dea5c9f4b85ca201c6e73bb340dfaa5003c5c..98c11b765886b25371e9fc56c41a4490b146995d 100644 (file)
@@ -1,6 +1,6 @@
---- qemu-1.3.0/configure.orig  2012-12-16 11:06:51.151203881 +0100
-+++ qemu-1.3.0/configure       2012-12-16 11:07:56.571202516 +0100
-@@ -2767,9 +2767,10 @@
+--- qemu-1.7.0/configure.orig  2013-12-15 08:38:07.584329114 +0100
++++ qemu-1.7.0/configure       2013-12-15 08:54:19.730954984 +0100
+@@ -3123,9 +3123,10 @@
  #include <pk11pub.h>
  int main(void) { PK11_FreeSlot(0); return 0; }
  EOF
      test_cflags="$libcacard_cflags"
      # The header files in nss < 3.13.3 have a bug which causes them to
      # emit a warning. If we're going to compile QEMU with -Werror, then
-@@ -2779,11 +2780,10 @@
+@@ -3136,11 +3137,10 @@
      fi
      if test -n "$libtool" &&
-             $pkg_config --atleast-version=3.12.8 nss >/dev/null 2>&1 && \
+        $pkg_config --atleast-version=3.12.8 nss && \
 -      compile_prog "$test_cflags" "$libcacard_libs"; then
 +      compile_prog "$test_cflags" "$nss_libs"; then
          smartcard_nss="yes"
@@ -29,7 +29,7 @@
      else
          if test "$smartcard_nss" = "yes"; then
              feature_not_found "nss"
-@@ -3532,6 +3529,8 @@
+@@ -4082,6 +4082,8 @@
    echo "CONFIG_SMARTCARD_NSS=y" >> $config_host_mak
    echo "libcacard_libs=$libcacard_libs" >> $config_host_mak
    echo "libcacard_cflags=$libcacard_cflags" >> $config_host_mak
@@ -37,7 +37,7 @@
 +  echo "nss_cflags=$nss_cflags" >> $config_host_mak
  fi
  
- if test "$usb_redir" = "yes" ; then
+ if test "$libusb" = "yes" ; then
 --- qemu-1.3.0/Makefile.orig   2012-12-03 20:37:05.000000000 +0100
 +++ qemu-1.3.0/Makefile        2012-12-16 11:08:58.001201236 +0100
 @@ -111,9 +111,6 @@
  
  all: $(DOCS) $(TOOLS) $(HELPERS-y) recurse-all
  
+--- qemu-1.5.0/Makefile.objs.orig      2013-05-20 17:34:39.000000000 +0200
++++ qemu-1.5.0/Makefile.objs   2013-05-26 17:46:51.190865264 +0200
+@@ -74,8 +74,6 @@
+ common-obj-$(CONFIG_SECCOMP) += qemu-seccomp.o
+-common-obj-$(CONFIG_SMARTCARD_NSS) += $(libcacard-y)
+-
+ ######################################################################
+ # qapi
+--- qemu-1.5.0/hw/usb/ccid-card-passthru.c.orig        2013-05-20 17:34:39.000000000 +0200
++++ qemu-1.5.0/hw/usb/ccid-card-passthru.c     2013-05-26 17:58:20.660836330 +0200
+@@ -12,7 +12,7 @@
+ #include "qemu/sockets.h"
+ #include "monitor/monitor.h"
+ #include "ccid.h"
+-#include "libcacard/vscard_common.h"
++#include <cacard/vscard_common.h>
+ #define DPRINTF(card, lvl, fmt, ...)                    \
+ do {                                                    \
This page took 0.035816 seconds and 4 git commands to generate.