]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
f4e676eff4cb1cfe18b59fd81c49c6e3b3c678b7
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - qemu-system-ppc -hda ac-ppc.img says:
3 #   qemu: could not open disk image ac-ppc.img: error "Success"
4 #   qemu-0.12.2-2.x86_64.rpm - broken
5 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
6 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7 #   qemu-0.11.1-*.x86_64.rpm - OK
8 #
9 # Conditional build:
10 %bcond_without  sdl             # SDL UI and audio support
11 %bcond_without  opengl          # OpenGL support
12 %bcond_without  ceph            # Ceph/RBD support
13 %bcond_without  spice           # SPICE support
14 %bcond_with     esd             # EsounD audio support
15 %bcond_without  oss             # OSS audio support
16 %bcond_without  pulseaudio      # PulseAudio audio support
17 %bcond_without  xen             # Xen backend driver support
18 #
19 Summary:        QEMU CPU Emulator
20 Summary(pl.UTF-8):      QEMU - emulator procesora
21 Name:           qemu
22 Version:        1.2.0
23 Release:        4
24 License:        GPL v2+
25 Group:          Applications/Emulators
26 Source0:        http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
27 # Source0-md5:  78eb1e984f4532aa9f2bdd3c127b5b61
28 Patch0:         %{name}-cflags.patch
29 Patch1:         vgabios-widescreens.patch
30 Patch2:         %{name}-usbredir.patch
31 Patch3:         %{name}-whitelist.patch
32 # Proof of concept, for reference, do not remove
33 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
34 URL:            http://wiki.qemu.org/Index.html
35 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
36 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
37 BuildRequires:  alsa-lib-devel
38 BuildRequires:  bluez-libs-devel
39 BuildRequires:  brlapi-devel
40 %{?with_ceph:BuildRequires:     ceph-devel}
41 BuildRequires:  curl-devel
42 BuildRequires:  cyrus-sasl-devel >= 2
43 %{?with_esd:BuildRequires:      esound-devel}
44 BuildRequires:  glib2-devel >= 1:2.12
45 BuildRequires:  gnutls-devel
46 BuildRequires:  libcap-devel
47 BuildRequires:  libcap-ng-devel
48 BuildRequires:  libfdt-devel
49 BuildRequires:  libiscsi-devel
50 BuildRequires:  libjpeg-devel
51 BuildRequires:  libpng-devel
52 BuildRequires:  libseccomp-devel
53 BuildRequires:  libuuid-devel
54 BuildRequires:  ncurses-devel
55 BuildRequires:  nss-devel >= 3.12.8
56 BuildRequires:  perl-Encode
57 BuildRequires:  perl-tools-pod
58 BuildRequires:  pkgconfig
59 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
60 BuildRequires:  sed >= 4.0
61 %if %{with spice}
62 BuildRequires:  spice-protocol >= 0.8.0
63 BuildRequires:  spice-server-devel >= 0.8.2
64 %endif
65 BuildRequires:  texi2html
66 BuildRequires:  texinfo
67 BuildRequires:  usbredir-devel >= 0.3.4
68 BuildRequires:  vde2-devel
69 BuildRequires:  which
70 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
71 BuildRequires:  xfsprogs-devel
72 BuildRequires:  xorg-lib-libX11-devel
73 BuildRequires:  zlib-devel
74 Requires:       %{name}-img = %{version}-%{release}
75 Requires:       %{name}-system-alpha = %{version}-%{release}
76 Requires:       %{name}-system-arm = %{version}-%{release}
77 Requires:       %{name}-system-cris = %{version}-%{release}
78 Requires:       %{name}-system-lm32 = %{version}-%{release}
79 Requires:       %{name}-system-m68k = %{version}-%{release}
80 Requires:       %{name}-system-microblaze = %{version}-%{release}
81 Requires:       %{name}-system-mips = %{version}-%{release}
82 Requires:       %{name}-system-ppc = %{version}-%{release}
83 Requires:       %{name}-system-or32 = %{version}-%{release}
84 Requires:       %{name}-system-s390x = %{version}-%{release}
85 Requires:       %{name}-system-sh4 = %{version}-%{release}
86 Requires:       %{name}-system-sparc = %{version}-%{release}
87 Requires:       %{name}-system-unicore32 = %{version}-%{release}
88 Requires:       %{name}-system-x86 = %{version}-%{release}
89 Requires:       %{name}-system-xtensa = %{version}-%{release}
90 Requires:       %{name}-user = %{version}-%{release}
91 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
92 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
93 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
94
95 %define systempkg_req \
96 Requires:       SDL >= 1.2.1
97
98 # some PPC/SPARC boot image in ELF format
99 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
100
101 %description
102 QEMU is a FAST! processor emulator. By using dynamic translation it
103 achieves a reasonnable speed while being easy to port on new host
104 CPUs. QEMU has two operating modes:
105
106 - User mode emulation. In this mode, QEMU can launch Linux processes
107   compiled for one CPU on another CPU. Linux system calls are converted
108   because of endianness and 32/64 bit mismatches. Wine (Windows
109   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
110
111 - Full system emulation. In this mode, QEMU emulates a full system,
112   including a processor and various peripherials. It can also be used to
113   provide virtual hosting of several virtual PC on a single server.
114
115 %description -l pl.UTF-8
116 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
117 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
118 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
119
120 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
121   procesy linuksowe skompilowane dla jednego procesora na innym
122   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
123   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
124   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
125   cele QEMU.
126
127 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
128   włączając w to procesor i różne urządzenia peryferyjne. Może być także
129   używane do wirtualnego hostowania kilku wirtualnych pecetów na
130   pojedynczym serwerze.
131
132 %package common
133 Summary:        QEMU common files needed by all QEMU targets
134 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
135 Group:          Development/Tools
136 Requires:       glib2 >= 1:2.12
137 Conflicts:      qemu < 1.0-2
138
139 %description common
140 QEMU is a generic and open source processor emulator which achieves a
141 good emulation speed by using dynamic translation.
142
143 This package provides the common files needed by all QEMU targets.
144
145 %description common -l pl.UTF-8
146 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
147 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
148
149 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
150 środowiska QEMU.
151
152 %package img
153 Summary:        QEMU command line tool for manipulating disk images
154 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
155 Group:          Development/Tools
156 Conflicts:      qemu < 1.0-2
157
158 %description img
159 This package provides a command line tool for manipulating disk
160 images.
161
162 %description img -l pl.UTF-8
163 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
164 na obrazach dysków.
165
166 %package user
167 Summary:        QEMU user mode emulation of qemu targets
168 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
169 Group:          Development/Tools
170 Requires:       %{name}-common = %{version}-%{release}
171
172 %description user
173 QEMU is a generic and open source processor emulator which achieves a
174 good emulation speed by using dynamic translation.
175
176 This package provides the user mode emulation of QEMU targets.
177
178 %description user -l pl.UTF-8
179 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
180 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
181
182 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
183
184 %package system-alpha
185 Summary:        QEMU system emulator for Alpha
186 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
187 Group:          Development/Tools
188 Requires:       %{name}-common = %{version}-%{release}
189 %systempkg_req
190
191 %description system-alpha
192 QEMU is a generic and open source processor emulator which achieves a
193 good emulation speed by using dynamic translation.
194
195 This package provides the system emulator with Alpha CPU.
196
197 %description system-alpha -l pl.UTF-8
198 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
199 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
200
201 Ten pakiet zawiera emulator systemu z procesorem Alpha.
202
203 %package system-arm
204 Summary:        QEMU system emulator for ARM
205 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
206 Group:          Development/Tools
207 Requires:       %{name}-common = %{version}-%{release}
208 %systempkg_req
209
210 %description system-arm
211 QEMU is a generic and open source processor emulator which achieves a
212 good emulation speed by using dynamic translation.
213
214 This package provides the system emulator for ARM.
215
216 %description system-arm -l pl.UTF-8
217 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
218 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
219
220 Ten pakiet zawiera emulator systemu z procesorem ARM.
221
222 %package system-cris
223 Summary:        QEMU system emulator for CRIS
224 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
225 Group:          Development/Tools
226 Requires:       %{name}-common = %{version}-%{release}
227 %systempkg_req
228
229 %description system-cris
230 QEMU is a generic and open source processor emulator which achieves a
231 good emulation speed by using dynamic translation.
232
233 This package provides the system emulator with CRIS CPU.
234
235 %description system-cris -l pl.UTF-8
236 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
237 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
238
239 Ten pakiet zawiera emulator systemu z procesorem CRIS.
240
241 %package system-lm32
242 Summary:        QEMU system emulator for LM32
243 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
244 Group:          Development/Tools
245 Requires:       %{name}-common = %{version}-%{release}
246 %systempkg_req
247
248 %description system-lm32
249 QEMU is a generic and open source processor emulator which achieves a
250 good emulation speed by using dynamic translation.
251
252 This package provides the system emulator with LM32 CPU.
253
254 %description system-lm32 -l pl.UTF-8
255 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
256 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
257
258 Ten pakiet zawiera emulator systemu z procesorem LM32.
259
260 %package system-m68k
261 Summary:        QEMU system emulator for m68k
262 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
263 Group:          Development/Tools
264 Requires:       %{name}-common = %{version}-%{release}
265 %systempkg_req
266
267 %description system-m68k
268 QEMU is a generic and open source processor emulator which achieves a
269 good emulation speed by using dynamic translation.
270
271 This package provides the system emulator with m68k CPU.
272
273 %description system-m68k -l pl.UTF-8
274 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
275 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
276
277 Ten pakiet zawiera emulator systemu z procesorem m68k.
278
279 %package system-microblaze
280 Summary:        QEMU system emulator for MicroBlaze
281 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
282 Group:          Development/Tools
283 Requires:       %{name}-common = %{version}-%{release}
284 %systempkg_req
285
286 %description system-microblaze
287 QEMU is a generic and open source processor emulator which achieves a
288 good emulation speed by using dynamic translation.
289
290 This package provides the system emulator with MicroBlaze CPU.
291
292 %description system-microblaze -l pl.UTF-8
293 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
294 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
295
296 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
297
298 %package system-mips
299 Summary:        QEMU system emulator for MIPS
300 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
301 Group:          Development/Tools
302 Requires:       %{name}-common = %{version}-%{release}
303 %systempkg_req
304
305 %description system-mips
306 QEMU is a generic and open source processor emulator which achieves a
307 good emulation speed by using dynamic translation.
308
309 This package provides the system emulator with MIPS CPU.
310
311 %description system-mips -l pl.UTF-8
312 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
313 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
314
315 Ten pakiet zawiera emulator systemu z procesorem MIPS.
316
317 %package system-or32
318 Summary:        QEMU system emulator for OpenRISC
319 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
320 Group:          Development/Tools
321 Requires:       %{name}-common = %{version}-%{release}
322 %systempkg_req
323
324 %description system-or32
325 QEMU is a generic and open source processor emulator which achieves a
326 good emulation speed by using dynamic translation.
327
328 This package provides the system emulator with OpenRISC CPU.
329
330 %description system-or32 -l pl.UTF-8
331 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
332 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
333
334 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
335
336 %package system-ppc
337 Summary:        QEMU system emulator for PowerPC
338 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
339 Group:          Development/Tools
340 Requires:       %{name}-common = %{version}-%{release}
341 %systempkg_req
342
343 %description system-ppc
344 QEMU is a generic and open source processor emulator which achieves a
345 good emulation speed by using dynamic translation.
346
347 This package provides the system emulator with PowerPC CPU.
348
349 %description system-ppc -l pl.UTF-8
350 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
351 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
352
353 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
354
355 %package system-s390x
356 Summary:        QEMU system emulator for S390
357 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
358 Group:          Development/Tools
359 Requires:       %{name}-common = %{version}-%{release}
360 %systempkg_req
361
362 %description system-s390x
363 QEMU is a generic and open source processor emulator which achieves a
364 good emulation speed by using dynamic translation.
365
366 This package provides the system emulator with S390 CPU.
367
368 %description system-s390x -l pl.UTF-8
369 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
370 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
371
372 Ten pakiet zawiera emulator systemu z procesorem S390.
373
374 %package system-sh4
375 Summary:        QEMU system emulator for SH4
376 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
377 Group:          Development/Tools
378 Requires:       %{name}-common = %{version}-%{release}
379 %systempkg_req
380
381 %description system-sh4
382 QEMU is a generic and open source processor emulator which achieves a
383 good emulation speed by using dynamic translation.
384
385 This package provides the system emulator with SH4 CPU.
386
387 %description system-sh4 -l pl.UTF-8
388 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
389 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
390
391 Ten pakiet zawiera emulator systemu z procesorem SH4.
392
393 %package system-sparc
394 Summary:        QEMU system emulator for SPARC
395 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
396 Group:          Development/Tools
397 Requires:       %{name}-common = %{version}-%{release}
398 %systempkg_req
399
400 %description system-sparc
401 QEMU is a generic and open source processor emulator which achieves a
402 good emulation speed by using dynamic translation.
403
404 This package provides the system emulator with SPARC/SPARC64 CPU.
405
406 %description system-sparc -l pl.UTF-8
407 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
408 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
409
410 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
411
412 %package system-unicore32
413 Summary:        QEMU system emulator for UniCore32
414 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
415 Group:          Development/Tools
416 Requires:       %{name}-common = %{version}-%{release}
417 %systempkg_req
418
419 %description system-unicore32
420 QEMU is a generic and open source processor emulator which achieves a
421 good emulation speed by using dynamic translation.
422
423 This package provides the system emulator with UniCore32 CPU.
424
425 %description system-unicore32 -l pl.UTF-8
426 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
427 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
428
429 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
430
431 %package system-x86
432 Summary:        QEMU system emulator for x86
433 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
434 Group:          Development/Tools
435 Requires:       %{name}-common = %{version}-%{release}
436 %systempkg_req
437
438 %description system-x86
439 QEMU is a generic and open source processor emulator which achieves a
440 good emulation speed by using dynamic translation.
441
442 This package provides the system emulator with x86 CPU. When being run
443 in a x86 machine that supports it, this package also provides the KVM
444 virtualization platform.
445
446 %description system-x86 -l pl.UTF-8
447 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
448 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
449
450 Ten pakiet zawiera emulator systemu z procesorem x86. W przypadku
451 uruchomienia na maszynie x86 pozwalającej na to, ten pakiet udostępnia
452 także platformę wirtualizacji KVM.
453
454 %package system-xtensa
455 Summary:        QEMU system emulator for Xtensa
456 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
457 Group:          Development/Tools
458 Requires:       %{name}-common = %{version}-%{release}
459 %systempkg_req
460
461 %description system-xtensa
462 QEMU is a generic and open source processor emulator which achieves a
463 good emulation speed by using dynamic translation.
464
465 This package provides the system emulator with Xtensa CPU.
466
467 %description system-xtensa -l pl.UTF-8
468 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
469 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
470
471 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
472
473 %prep
474 %setup -q
475 %patch0 -p1
476 %patch1 -p1
477 %patch2 -p1
478 %patch3 -p0
479 #patch4 -p1
480
481 # workaround for conflict with alsa/error.h
482 ln -s ../error.h qapi/error.h
483
484 %build
485 ./configure \
486         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
487         --extra-ldflags="%{rpmldflags}" \
488         --sysconfdir=%{_sysconfdir} \
489         --prefix=%{_prefix} \
490         --cc="%{__cc}" \
491         --host-cc="%{__cc}" \
492         --disable-strip \
493         --enable-attr \
494         --enable-bluez \
495         --enable-brlapi \
496         --enable-cap-ng \
497         --enable-curl \
498         --enable-curses \
499         --enable-fdt \
500         --enable-libiscsi \
501         --enable-mixemu \
502         %{__enable_disable opengl} \
503         %{__enable_disable ceph rbd} \
504         %{__enable_disable sdl} \
505         --enable-seccomp \
506         %{__enable_disable spice} \
507         --enable-smartcard \
508         --enable-smartcard-nss \
509         --enable-usb-redir \
510         --enable-uuid \
511         --enable-vde \
512         --enable-virtfs \
513         --enable-vnc-jpeg \
514         --enable-vnc-sasl \
515         --enable-vnc-tls \
516         %{__enable_disable xen} \
517         --audio-drv-list="alsa oss%{?with_sdl: sdl}%{?with_esd: esd}%{?with_pulseaudio: pa}" \
518         --interp-prefix=%{_libdir}/%{name}
519 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
520 # --libexecdir in configure is nop
521 %{__make} \
522         V=1 \
523         CONFIG_QEMU_HELPERDIR="%{_libdir}"
524
525 # rebuild patched vesa tables with additional widescreen modes.
526 %{__make} -C roms/vgabios stdvga-bios
527
528 %install
529 rm -rf $RPM_BUILD_ROOT
530
531 %{__make} install \
532         DESTDIR=$RPM_BUILD_ROOT \
533         libexecdir=%{_libdir}
534
535 install -d $RPM_BUILD_ROOT%{_sysconfdir}
536 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
537 #!/bin/sh
538
539 EOF
540
541 # already packaged
542 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
543 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
544
545 # install patched vesa tables with additional widescreen modes.
546 install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
547
548 %clean
549 rm -rf $RPM_BUILD_ROOT
550
551 %files
552 %defattr(644,root,root,755)
553
554 %files common
555 %defattr(644,root,root,755)
556 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
557 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
558 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
559 %dir %{_sysconfdir}/qemu
560 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
561 %attr(755,root,root) %{_bindir}/vscclient
562 %attr(755,root,root) %{_bindir}/qemu-nbd
563 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
564 %{_mandir}/man1/qemu.1*
565 %{_mandir}/man1/virtfs-proxy-helper.1*
566 %{_mandir}/man8/qemu-nbd.8*
567
568 %dir %{_datadir}/qemu
569 %{_datadir}/%{name}/cpus-*.conf
570 %{_datadir}/%{name}/keymaps
571 %{_datadir}/%{name}/qemu-icon.bmp
572 # various bios images
573 %{_datadir}/%{name}/*.bin
574 %{_datadir}/%{name}/*.rom
575 %{_datadir}/%{name}/*.dtb
576 %{_datadir}/%{name}/openbios-ppc
577 %{_datadir}/%{name}/openbios-sparc*
578 %{_datadir}/%{name}/palcode-clipper
579
580 %files img
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_bindir}/qemu-img
583 %{_mandir}/man1/qemu-img.1*
584
585 %files user
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_bindir}/qemu-alpha
588 %attr(755,root,root) %{_bindir}/qemu-arm
589 %attr(755,root,root) %{_bindir}/qemu-armeb
590 %attr(755,root,root) %{_bindir}/qemu-cris
591 %attr(755,root,root) %{_bindir}/qemu-ga
592 %attr(755,root,root) %{_bindir}/qemu-i386
593 %attr(755,root,root) %{_bindir}/qemu-io
594 %attr(755,root,root) %{_bindir}/qemu-m68k
595 %attr(755,root,root) %{_bindir}/qemu-microblaze
596 %attr(755,root,root) %{_bindir}/qemu-microblazeel
597 %attr(755,root,root) %{_bindir}/qemu-mips
598 %attr(755,root,root) %{_bindir}/qemu-mipsel
599 %attr(755,root,root) %{_bindir}/qemu-or32
600 %attr(755,root,root) %{_bindir}/qemu-ppc
601 %attr(755,root,root) %{_bindir}/qemu-ppc64
602 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
603 %attr(755,root,root) %{_bindir}/qemu-s390x
604 %attr(755,root,root) %{_bindir}/qemu-sh4
605 %attr(755,root,root) %{_bindir}/qemu-sh4eb
606 %attr(755,root,root) %{_bindir}/qemu-sparc
607 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
608 %attr(755,root,root) %{_bindir}/qemu-sparc64
609 %attr(755,root,root) %{_bindir}/qemu-unicore32
610 %attr(755,root,root) %{_bindir}/qemu-x86_64
611
612 %files system-alpha
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_bindir}/qemu-system-alpha
615
616 %files system-arm
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/qemu-system-arm
619
620 %files system-cris
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/qemu-system-cris
623
624 %files system-lm32
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/qemu-system-lm32
627
628 %files system-m68k
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_bindir}/qemu-system-m68k
631
632 %files system-microblaze
633 %defattr(644,root,root,755)
634 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
635 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
636
637 %files system-mips
638 %defattr(644,root,root,755)
639 %attr(755,root,root) %{_bindir}/qemu-system-mips
640 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
641 %attr(755,root,root) %{_bindir}/qemu-system-mips64
642 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
643
644 %files system-or32
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_bindir}/qemu-system-or32
647
648 %files system-ppc
649 %defattr(644,root,root,755)
650 %attr(755,root,root) %{_bindir}/qemu-system-ppc
651 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
652 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
653
654 %files system-s390x
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/qemu-system-s390x
657
658 %files system-sh4
659 %defattr(644,root,root,755)
660 %attr(755,root,root) %{_bindir}/qemu-system-sh4
661 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
662
663 %files system-sparc
664 %defattr(644,root,root,755)
665 %attr(755,root,root) %{_bindir}/qemu-system-sparc
666 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
667
668 %files system-unicore32
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
671
672 %files system-x86
673 %defattr(644,root,root,755)
674 %attr(755,root,root) %{_bindir}/qemu-system-i386
675 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
676
677 %files system-xtensa
678 %defattr(644,root,root,755)
679 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
680 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.060406 seconds and 2 git commands to generate.