]> git.pld-linux.org Git - packages/qemu.git/blob - qemu.spec
ddee76f03559da08a13f16fa2944e386278b8f39
[packages/qemu.git] / qemu.spec
1 # TODO:
2 # - qemu-system-ppc -hda ac-ppc.img says:
3 #   qemu: could not open disk image ac-ppc.img: error "Success"
4 #   qemu-0.12.2-2.x86_64.rpm - broken
5 #   qemu-0.12.3-3.x86_64/qemu-0.12.4-1.x86_64 - stops on "returning from prom_init"
6 #   qemu-0.15.0-2.x86_64.rpm - qemu-system-sparc/ppc booting with -kernel, -initrd options stalls in openbios prompt
7 #   qemu-0.11.1-*.x86_64.rpm - OK
8 #
9 # Conditional build:
10 %bcond_without  sdl             # SDL UI and audio support
11 %bcond_without  opengl          # OpenGL support
12 %bcond_without  ceph            # Ceph/RBD support
13 %bcond_with     esd             # EsounD audio support
14 %bcond_without  oss             # OSS audio support
15 %bcond_without  pulseaudio      # PulseAudio audio support
16 %bcond_without  xen             # Xen backend driver support
17 #
18 Summary:        QEMU CPU Emulator
19 Summary(pl.UTF-8):      QEMU - emulator procesora
20 Name:           qemu
21 Version:        1.2.0
22 Release:        4
23 License:        GPL v2+
24 Group:          Applications/Emulators
25 Source0:        http://wiki.qemu.org/download/%{name}-%{version}.tar.bz2
26 # Source0-md5:  78eb1e984f4532aa9f2bdd3c127b5b61
27 Patch0:         %{name}-cflags.patch
28 Patch1:         vgabios-widescreens.patch
29 Patch2:         %{name}-usbredir.patch
30 Patch3:         %{name}-whitelist.patch
31 # Proof of concept, for reference, do not remove
32 Patch4:         %{name}-kde_virtual_workspaces_hack.patch
33 URL:            http://wiki.qemu.org/Index.html
34 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
35 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.1}
36 BuildRequires:  alsa-lib-devel
37 BuildRequires:  bluez-libs-devel
38 BuildRequires:  brlapi-devel
39 %{?with_ceph:BuildRequires:     ceph-devel}
40 BuildRequires:  curl-devel
41 BuildRequires:  cyrus-sasl-devel >= 2
42 %{?with_esd:BuildRequires:      esound-devel}
43 BuildRequires:  glib2-devel >= 1:2.12
44 BuildRequires:  gnutls-devel
45 BuildRequires:  libcap-devel
46 BuildRequires:  libcap-ng-devel
47 BuildRequires:  libfdt-devel
48 BuildRequires:  libiscsi-devel
49 BuildRequires:  libjpeg-devel
50 BuildRequires:  libpng-devel
51 BuildRequires:  libseccomp-devel
52 BuildRequires:  libuuid-devel
53 BuildRequires:  ncurses-devel
54 BuildRequires:  nss-devel >= 3.12.8
55 BuildRequires:  perl-Encode
56 BuildRequires:  perl-tools-pod
57 BuildRequires:  pkgconfig
58 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel}
59 BuildRequires:  sed >= 4.0
60 BuildRequires:  spice-protocol >= 0.8.0
61 BuildRequires:  spice-server-devel >= 0.8.2
62 BuildRequires:  texi2html
63 BuildRequires:  texinfo
64 BuildRequires:  usbredir-devel >= 0.3.4
65 BuildRequires:  vde2-devel
66 BuildRequires:  which
67 %{?with_xen:BuildRequires:      xen-devel >= 3.4}
68 BuildRequires:  xfsprogs-devel
69 BuildRequires:  xorg-lib-libX11-devel
70 BuildRequires:  zlib-devel
71 Requires:       %{name}-img = %{version}-%{release}
72 Requires:       %{name}-system-alpha = %{version}-%{release}
73 Requires:       %{name}-system-arm = %{version}-%{release}
74 Requires:       %{name}-system-cris = %{version}-%{release}
75 Requires:       %{name}-system-lm32 = %{version}-%{release}
76 Requires:       %{name}-system-m68k = %{version}-%{release}
77 Requires:       %{name}-system-microblaze = %{version}-%{release}
78 Requires:       %{name}-system-mips = %{version}-%{release}
79 Requires:       %{name}-system-ppc = %{version}-%{release}
80 Requires:       %{name}-system-or32 = %{version}-%{release}
81 Requires:       %{name}-system-s390x = %{version}-%{release}
82 Requires:       %{name}-system-sh4 = %{version}-%{release}
83 Requires:       %{name}-system-sparc = %{version}-%{release}
84 Requires:       %{name}-system-unicore32 = %{version}-%{release}
85 Requires:       %{name}-system-x86 = %{version}-%{release}
86 Requires:       %{name}-system-xtensa = %{version}-%{release}
87 Requires:       %{name}-user = %{version}-%{release}
88 # sparc is currently unsupported (missing cpu_get_real_ticks() impl in vl.c)
89 ExclusiveArch:  %{ix86} %{x8664} %{?with_userspace:ppc}
90 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
91
92 %define systempkg_req \
93 Requires:       SDL >= 1.2.1
94
95 # some PPC/SPARC boot image in ELF format
96 %define         _noautostrip    .*%{_datadir}/qemu/.*-.*
97
98 %description
99 QEMU is a FAST! processor emulator. By using dynamic translation it
100 achieves a reasonnable speed while being easy to port on new host
101 CPUs. QEMU has two operating modes:
102
103 - User mode emulation. In this mode, QEMU can launch Linux processes
104   compiled for one CPU on another CPU. Linux system calls are converted
105   because of endianness and 32/64 bit mismatches. Wine (Windows
106   emulation) and DOSEMU (DOS emulation) are the main targets for QEMU.
107
108 - Full system emulation. In this mode, QEMU emulates a full system,
109   including a processor and various peripherials. It can also be used to
110   provide virtual hosting of several virtual PC on a single server.
111
112 %description -l pl.UTF-8
113 QEMU to szybki(!) emulator procesora. Poprzez użycie dynamicznego
114 tłumaczenia osiąga rozsądną szybkość i jest łatwy do przeportowania,
115 aby działał na kolejnych procesorach. QEMU ma dwa tryby pracy:
116
117 - Emulacja trybu użytkownika. W tym trybie QEMU może uruchamiać
118   procesy linuksowe skompilowane dla jednego procesora na innym
119   procesorze. Linuksowe wywołania systemowe są tłumaczone ze względu na
120   niezgodność kolejności bajtów w słowie i 32/64-bitowego rozmiaru
121   słowa. Wine (emulacja Windows) i DOSEMU (emulacja DOS-a) to główne
122   cele QEMU.
123
124 - Pełna emulacja systemu. W tym trybie QEMU emuluje cały system,
125   włączając w to procesor i różne urządzenia peryferyjne. Może być także
126   używane do wirtualnego hostowania kilku wirtualnych pecetów na
127   pojedynczym serwerze.
128
129 %package common
130 Summary:        QEMU common files needed by all QEMU targets
131 Summary(pl.UTF-8):      Wspólne pliki QEMU wymagane przez wszystkie środowiska QEMU
132 Group:          Development/Tools
133 Requires:       glib2 >= 1:2.12
134 Conflicts:      qemu < 1.0-2
135
136 %description common
137 QEMU is a generic and open source processor emulator which achieves a
138 good emulation speed by using dynamic translation.
139
140 This package provides the common files needed by all QEMU targets.
141
142 %description common -l pl.UTF-8
143 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
144 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
145
146 Ten pakiet udostępnia wspólne pliki wymagane przez wszystkie
147 środowiska QEMU.
148
149 %package img
150 Summary:        QEMU command line tool for manipulating disk images
151 Summary(pl.UTF-8):      Narzędzie QEMU do operacji na obrazach dysków
152 Group:          Development/Tools
153 Conflicts:      qemu < 1.0-2
154
155 %description img
156 This package provides a command line tool for manipulating disk
157 images.
158
159 %description img -l pl.UTF-8
160 Ten pakiet udostępnia działające z linii poleceń narzędzia do operacji
161 na obrazach dysków.
162
163 %package user
164 Summary:        QEMU user mode emulation of qemu targets
165 Summary(pl.UTF-8):      QEMU - emulacja trybu użytkownika środowisk qemu
166 Group:          Development/Tools
167 Requires:       %{name}-common = %{version}-%{release}
168
169 %description user
170 QEMU is a generic and open source processor emulator which achieves a
171 good emulation speed by using dynamic translation.
172
173 This package provides the user mode emulation of QEMU targets.
174
175 %description user -l pl.UTF-8
176 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
177 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
178
179 Ten pakiet udostępnia emulację trybu użytkownika środowisk QEMU.
180
181 %package system-alpha
182 Summary:        QEMU system emulator for Alpha
183 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Alpha
184 Group:          Development/Tools
185 Requires:       %{name}-common = %{version}-%{release}
186 %systempkg_req
187
188 %description system-alpha
189 QEMU is a generic and open source processor emulator which achieves a
190 good emulation speed by using dynamic translation.
191
192 This package provides the system emulator with Alpha CPU.
193
194 %description system-alpha -l pl.UTF-8
195 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
196 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
197
198 Ten pakiet zawiera emulator systemu z procesorem Alpha.
199
200 %package system-arm
201 Summary:        QEMU system emulator for ARM
202 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem ARM
203 Group:          Development/Tools
204 Requires:       %{name}-common = %{version}-%{release}
205 %systempkg_req
206
207 %description system-arm
208 QEMU is a generic and open source processor emulator which achieves a
209 good emulation speed by using dynamic translation.
210
211 This package provides the system emulator for ARM.
212
213 %description system-arm -l pl.UTF-8
214 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
215 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
216
217 Ten pakiet zawiera emulator systemu z procesorem ARM.
218
219 %package system-cris
220 Summary:        QEMU system emulator for cris
221 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem CRIS
222 Group:          Development/Tools
223 Requires:       %{name}-common = %{version}-%{release}
224 %systempkg_req
225
226 %description system-cris
227 QEMU is a generic and open source processor emulator which achieves a
228 good emulation speed by using dynamic translation.
229
230 This package provides the system emulator with CRIS CPU.
231
232 %description system-cris -l pl.UTF-8
233 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
234 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
235
236 Ten pakiet zawiera emulator systemu z procesorem CRIS.
237
238 %package system-lm32
239 Summary:        QEMU system emulator for LM32
240 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem LM32
241 Group:          Development/Tools
242 Requires:       %{name}-common = %{version}-%{release}
243 %systempkg_req
244
245 %description system-lm32
246 QEMU is a generic and open source processor emulator which achieves a
247 good emulation speed by using dynamic translation.
248
249 This package provides the system emulator with LM32 CPU.
250
251 %description system-lm32 -l pl.UTF-8
252 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
253 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
254
255 Ten pakiet zawiera emulator systemu z procesorem LM32.
256
257 %package system-m68k
258 Summary:        QEMU system emulator for m68k
259 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem m68k
260 Group:          Development/Tools
261 Requires:       %{name}-common = %{version}-%{release}
262 %systempkg_req
263
264 %description system-m68k
265 QEMU is a generic and open source processor emulator which achieves a
266 good emulation speed by using dynamic translation.
267
268 This package provides the system emulator with m68k CPU.
269
270 %description system-m68k -l pl.UTF-8
271 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
272 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
273
274 Ten pakiet zawiera emulator systemu z procesorem m68k.
275
276 %package system-microblaze
277 Summary:        QEMU system emulator for MicroBlaze
278 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MicroBlaze
279 Group:          Development/Tools
280 Requires:       %{name}-common = %{version}-%{release}
281 %systempkg_req
282
283 %description system-microblaze
284 QEMU is a generic and open source processor emulator which achieves a
285 good emulation speed by using dynamic translation.
286
287 This package provides the system emulator with MicroBlaze CPU.
288
289 %description system-microblaze -l pl.UTF-8
290 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
291 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
292
293 Ten pakiet zawiera emulator systemu z procesorem MicroBlaze.
294
295 %package system-mips
296 Summary:        QEMU system emulator for MIPS
297 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem MIPS
298 Group:          Development/Tools
299 Requires:       %{name}-common = %{version}-%{release}
300 %systempkg_req
301
302 %description system-mips
303 QEMU is a generic and open source processor emulator which achieves a
304 good emulation speed by using dynamic translation.
305
306 This package provides the system emulator with MIPS CPU.
307
308 %description system-mips -l pl.UTF-8
309 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
310 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
311
312 Ten pakiet zawiera emulator systemu z procesorem MIPS.
313
314 %package system-or32
315 Summary:        QEMU system emulator for OpenRISC
316 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem OpenRISC
317 Group:          Development/Tools
318 Requires:       %{name}-common = %{version}-%{release}
319 %systempkg_req
320
321 %description system-or32
322 QEMU is a generic and open source processor emulator which achieves a
323 good emulation speed by using dynamic translation.
324
325 This package provides the system emulator with OpenRISC CPU.
326
327 %description system-or32 -l pl.UTF-8
328 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
329 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
330
331 Ten pakiet zawiera emulator systemu z procesorem OpenRISC.
332
333 %package system-ppc
334 Summary:        QEMU system emulator for PowerPC
335 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem PowerPC
336 Group:          Development/Tools
337 Requires:       %{name}-common = %{version}-%{release}
338 %systempkg_req
339
340 %description system-ppc
341 QEMU is a generic and open source processor emulator which achieves a
342 good emulation speed by using dynamic translation.
343
344 This package provides the system emulator with PowerPC CPU.
345
346 %description system-ppc -l pl.UTF-8
347 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
348 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
349
350 Ten pakiet zawiera emulator systemu z procesorem PowerPC.
351
352 %package system-s390x
353 Summary:        QEMU system emulator for S390
354 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem S390
355 Group:          Development/Tools
356 Requires:       %{name}-common = %{version}-%{release}
357 %systempkg_req
358
359 %description system-s390x
360 QEMU is a generic and open source processor emulator which achieves a
361 good emulation speed by using dynamic translation.
362
363 This package provides the system emulator with S390 CPU.
364
365 %description system-s390x -l pl.UTF-8
366 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
367 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
368
369 Ten pakiet zawiera emulator systemu z procesorem S390.
370
371 %package system-sh4
372 Summary:        QEMU system emulator for SH4
373 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SH4
374 Group:          Development/Tools
375 Requires:       %{name}-common = %{version}-%{release}
376 %systempkg_req
377
378 %description system-sh4
379 QEMU is a generic and open source processor emulator which achieves a
380 good emulation speed by using dynamic translation.
381
382 This package provides the system emulator with SH4 CPU.
383
384 %description system-sh4 -l pl.UTF-8
385 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
386 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
387
388 Ten pakiet zawiera emulator systemu z procesorem SH4.
389
390 %package system-sparc
391 Summary:        QEMU system emulator for SPARC
392 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem SPARC
393 Group:          Development/Tools
394 Requires:       %{name}-common = %{version}-%{release}
395 %systempkg_req
396
397 %description system-sparc
398 QEMU is a generic and open source processor emulator which achieves a
399 good emulation speed by using dynamic translation.
400
401 This package provides the system emulator with SPARC/SPARC64 CPU.
402
403 %description system-sparc -l pl.UTF-8
404 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
405 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
406
407 Ten pakiet zawiera emulator systemu z procesorem SPARC/SPARC64.
408
409 %package system-unicore32
410 Summary:        QEMU system emulator for UniCore32
411 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem UniCore32
412 Group:          Development/Tools
413 Requires:       %{name}-common = %{version}-%{release}
414 %systempkg_req
415
416 %description system-unicore32
417 QEMU is a generic and open source processor emulator which achieves a
418 good emulation speed by using dynamic translation.
419
420 This package provides the system emulator with UniCore32 CPU.
421
422 %description system-unicore32 -l pl.UTF-8
423 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
424 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
425
426 Ten pakiet zawiera emulator systemu z procesorem UniCore32.
427
428 %package system-x86
429 Summary:        QEMU system emulator for x86
430 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem x86
431 Group:          Development/Tools
432 Requires:       %{name}-common = %{version}-%{release}
433 %systempkg_req
434
435 %description system-x86
436 QEMU is a generic and open source processor emulator which achieves a
437 good emulation speed by using dynamic translation.
438
439 This package provides the system emulator with x86 CPU. When being run
440 in a x86 machine that supports it, this package also provides the KVM
441 virtualization platform.
442
443 %description system-x86 -l pl.UTF-8
444 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
445 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
446
447 Ten pakiet zawiera emulator systemu z procesorem x86. W przypadku
448 uruchomienia na maszynie x86 pozwalającej na to, ten pakiet udostępnia
449 także platformę wirtualizacji KVM.
450
451 %package system-xtensa
452 Summary:        QEMU system emulator for Xtensa
453 Summary(pl.UTF-8):      QEMU - emulator systemu z procesorem Xtensa
454 Group:          Development/Tools
455 Requires:       %{name}-common = %{version}-%{release}
456 %systempkg_req
457
458 %description system-xtensa
459 QEMU is a generic and open source processor emulator which achieves a
460 good emulation speed by using dynamic translation.
461
462 This package provides the system emulator with Xtensa CPU.
463
464 %description system-xtensa -l pl.UTF-8
465 QEMU to ogólny, mający otwarte źródła emulator procesora, osiągający
466 dobrą szybkość emulacji dzięki użyciu translacji dynamicznej.
467
468 Ten pakiet zawiera emulator systemu z procesorem Xtensa.
469
470 %prep
471 %setup -q
472 %patch0 -p1
473 %patch1 -p1
474 %patch2 -p1
475 %patch3 -p0
476 #patch4 -p1
477
478 # workaround for conflict with alsa/error.h
479 ln -s ../error.h qapi/error.h
480
481 %build
482 ./configure \
483         --extra-cflags="%{rpmcflags} -I/usr/include/ncurses" \
484         --extra-ldflags="%{rpmldflags}" \
485         --sysconfdir=%{_sysconfdir} \
486         --prefix=%{_prefix} \
487         --cc="%{__cc}" \
488         --host-cc="%{__cc}" \
489         --disable-strip \
490         --enable-attr \
491         --enable-bluez \
492         --enable-brlapi \
493         --enable-cap-ng \
494         --enable-curl \
495         --enable-curses \
496         --enable-fdt \
497         --enable-libiscsi \
498         --enable-mixemu \
499         %{__enable_disable opengl} \
500         %{__enable_disable ceph rbd} \
501         %{__enable_disable sdl} \
502         --enable-seccomp \
503         --enable-smartcard \
504         --enable-smartcard-nss \
505         --enable-usb-redir \
506         --enable-uuid \
507         --enable-vde \
508         --enable-virtfs \
509         --enable-vnc-jpeg \
510         --enable-vnc-sasl \
511         --enable-vnc-tls \
512         %{__enable_disable xen} \
513         --audio-drv-list="alsa oss%{?with_sdl: sdl}%{?with_esd: esd}%{?with_pulseaudio: pa}" \
514         --interp-prefix=%{_libdir}/%{name}
515 # note: CONFIG_QEMU_HELPERDIR is used when compiling, libexecdir when installing;
516 # --libexecdir in configure is nop
517 %{__make} \
518         V=1 \
519         CONFIG_QEMU_HELPERDIR="%{_libdir}"
520
521 # rebuild patched vesa tables with additional widescreen modes.
522 %{__make} -C roms/vgabios stdvga-bios
523
524 %install
525 rm -rf $RPM_BUILD_ROOT
526
527 %{__make} install \
528         DESTDIR=$RPM_BUILD_ROOT \
529         libexecdir=%{_libdir}
530
531 install -d $RPM_BUILD_ROOT%{_sysconfdir}
532 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/qemu-ifup
533 #!/bin/sh
534
535 EOF
536
537 # already packaged
538 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qemu-{doc,tech}.html
539 %{__rm} $RPM_BUILD_ROOT%{_docdir}/qemu/qmp-commands.txt
540
541 # install patched vesa tables with additional widescreen modes.
542 install -m 644 roms/vgabios/VGABIOS-lgpl-latest.stdvga.bin $RPM_BUILD_ROOT%{_datadir}/%{name}/vgabios-stdvga.bin
543
544 %clean
545 rm -rf $RPM_BUILD_ROOT
546
547 %files
548 %defattr(644,root,root,755)
549
550 %files common
551 %defattr(644,root,root,755)
552 %doc README qemu-doc.html qemu-tech.html QMP/qmp-commands.txt
553 %attr(755,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu-ifup
554 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/qemu/target-*.conf
555 %dir %{_sysconfdir}/qemu
556 %attr(755,root,root) %{_bindir}/virtfs-proxy-helper
557 %attr(755,root,root) %{_bindir}/vscclient
558 %attr(755,root,root) %{_bindir}/qemu-nbd
559 %attr(755,root,root) %{_libdir}/qemu-bridge-helper
560 %{_mandir}/man1/qemu.1*
561 %{_mandir}/man1/virtfs-proxy-helper.1*
562 %{_mandir}/man8/qemu-nbd.8*
563
564 %dir %{_datadir}/qemu
565 %{_datadir}/%{name}/cpus-*.conf
566 %{_datadir}/%{name}/keymaps
567 %{_datadir}/%{name}/qemu-icon.bmp
568 # various bios images
569 %{_datadir}/%{name}/*.bin
570 %{_datadir}/%{name}/*.rom
571 %{_datadir}/%{name}/*.dtb
572 %{_datadir}/%{name}/openbios-ppc
573 %{_datadir}/%{name}/openbios-sparc*
574 %{_datadir}/%{name}/palcode-clipper
575
576 %files img
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_bindir}/qemu-img
579 %{_mandir}/man1/qemu-img.1*
580
581 %files user
582 %defattr(644,root,root,755)
583 %attr(755,root,root) %{_bindir}/qemu-x86_64
584 %attr(755,root,root) %{_bindir}/qemu-i386
585 %attr(755,root,root) %{_bindir}/qemu-alpha
586 %attr(755,root,root) %{_bindir}/qemu-arm
587 %attr(755,root,root) %{_bindir}/qemu-armeb
588 %attr(755,root,root) %{_bindir}/qemu-cris
589 %attr(755,root,root) %{_bindir}/qemu-ga
590 %attr(755,root,root) %{_bindir}/qemu-io
591 %attr(755,root,root) %{_bindir}/qemu-m68k
592 %attr(755,root,root) %{_bindir}/qemu-microblaze
593 %attr(755,root,root) %{_bindir}/qemu-microblazeel
594 %attr(755,root,root) %{_bindir}/qemu-mips
595 %attr(755,root,root) %{_bindir}/qemu-mipsel
596 %attr(755,root,root) %{_bindir}/qemu-or32
597 %attr(755,root,root) %{_bindir}/qemu-ppc
598 %attr(755,root,root) %{_bindir}/qemu-ppc64
599 %attr(755,root,root) %{_bindir}/qemu-ppc64abi32
600 %attr(755,root,root) %{_bindir}/qemu-s390x
601 %attr(755,root,root) %{_bindir}/qemu-sh4
602 %attr(755,root,root) %{_bindir}/qemu-sh4eb
603 %attr(755,root,root) %{_bindir}/qemu-sparc
604 %attr(755,root,root) %{_bindir}/qemu-sparc32plus
605 %attr(755,root,root) %{_bindir}/qemu-sparc64
606 %attr(755,root,root) %{_bindir}/qemu-unicore32
607
608 %files system-alpha
609 %defattr(644,root,root,755)
610 %attr(755,root,root) %{_bindir}/qemu-system-alpha
611
612 %files system-arm
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_bindir}/qemu-system-arm
615
616 %files system-cris
617 %defattr(644,root,root,755)
618 %attr(755,root,root) %{_bindir}/qemu-system-cris
619
620 %files system-lm32
621 %defattr(644,root,root,755)
622 %attr(755,root,root) %{_bindir}/qemu-system-lm32
623
624 %files system-m68k
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/qemu-system-m68k
627
628 %files system-microblaze
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_bindir}/qemu-system-microblaze
631 %attr(755,root,root) %{_bindir}/qemu-system-microblazeel
632
633 %files system-mips
634 %defattr(644,root,root,755)
635 %attr(755,root,root) %{_bindir}/qemu-system-mips
636 %attr(755,root,root) %{_bindir}/qemu-system-mipsel
637 %attr(755,root,root) %{_bindir}/qemu-system-mips64
638 %attr(755,root,root) %{_bindir}/qemu-system-mips64el
639
640 %files system-or32
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_bindir}/qemu-system-or32
643
644 %files system-ppc
645 %defattr(644,root,root,755)
646 %attr(755,root,root) %{_bindir}/qemu-system-ppc
647 %attr(755,root,root) %{_bindir}/qemu-system-ppc64
648 %attr(755,root,root) %{_bindir}/qemu-system-ppcemb
649
650 %files system-s390x
651 %defattr(644,root,root,755)
652 %attr(755,root,root) %{_bindir}/qemu-system-s390x
653
654 %files system-sh4
655 %defattr(644,root,root,755)
656 %attr(755,root,root) %{_bindir}/qemu-system-sh4
657 %attr(755,root,root) %{_bindir}/qemu-system-sh4eb
658
659 %files system-sparc
660 %defattr(644,root,root,755)
661 %attr(755,root,root) %{_bindir}/qemu-system-sparc
662 %attr(755,root,root) %{_bindir}/qemu-system-sparc64
663
664 %files system-unicore32
665 %defattr(644,root,root,755)
666 %attr(755,root,root) %{_bindir}/qemu-system-unicore32
667
668 %files system-x86
669 %defattr(644,root,root,755)
670 %attr(755,root,root) %{_bindir}/qemu-system-i386
671 %attr(755,root,root) %{_bindir}/qemu-system-x86_64
672
673 %files system-xtensa
674 %defattr(644,root,root,755)
675 %attr(755,root,root) %{_bindir}/qemu-system-xtensa
676 %attr(755,root,root) %{_bindir}/qemu-system-xtensaeb
This page took 0.085775 seconds and 2 git commands to generate.